Add pkg_install, a snapshot of the -CURRENT package installation framework

for use with older versions of FreeBSD.

PR:		54478
Submitted by:	Oliver Eikemeier <eikemeier@fillmore-labs.com>
This commit is contained in:
Joe Marcus Clarke 2003-08-03 21:44:33 +00:00
parent 78163f252f
commit 01a913ae61
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=86245
13 changed files with 185 additions and 0 deletions

View file

@ -0,0 +1,51 @@
# New ports collection makefile for: pkg_install
# Date created: 14 Jul 2003
# Whom: Oliver Eikemeier
#
# $FreeBSD$
#
PORTNAME= pkg_install
PORTVERSION= 20030714
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= marcus
MAINTAINER= portmgr@freebsd.org
COMMENT= FreeBSD 5.x version of the package tools for older system releases
USE_BZIP2= yes
USE_OPENSSL= yes
MANCOMPRESSED= yes
MAN1= pkg_add.1 pkg_create.1 pkg_delete.1 \
pkg_info.1 pkg_sign.1 pkg_version.1
MLINKS= pkg_sign.1 pkg_check.1
MAKE_ARGS= -DNOOBJ
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 460102
check-already-installed:
.if !defined(NO_PKG_REGISTER) && !defined(FORCE_PKG_REGISTER)
@if [ -d ${PKG_DBDIR}/${PKGNAME} ]; then \
${ECHO_CMD} "===> ${PKGNAME} is already installed - perhaps an older version?"; \
${ECHO_CMD} " If so, you may wish to \`\`make deinstall'' and install"; \
${ECHO_CMD} " this port again by \`\`make reinstall'' to upgrade it properly."; \
${ECHO_CMD} " If you really wish to overwrite the old port of ${PKGNAME}"; \
${ECHO_CMD} " without deleting it first, set the variable \"FORCE_PKG_REGISTER\""; \
${ECHO_CMD} " in your environment or the \"make install\" command line."; \
exit 1; \
fi
.else
@${DO_NADA}
.endif
.endif
pre-configure:
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
-e 's,%%MANPREFIX%%,${MANPREFIX},g' \
${FILESDIR}/Makefile.inc > ${WRKDIR}/Makefile.inc
.include <bsd.port.post.mk>

View file

@ -0,0 +1 @@
MD5 (pkg_install-20030714.tar.bz2) = dd98b0275c6bb1e31089e67ea18f22b6

View file

@ -0,0 +1,4 @@
# $FreeBSD$
BINDIR=%%PREFIX%%/sbin
MANDIR=%%MANPREFIX%%/man/man

View file

@ -0,0 +1,20 @@
--- lib/Makefile.orig Fri Jul 25 12:08:43 2003
+++ lib/Makefile Fri Jul 25 12:08:45 2003
@@ -1,12 +1,16 @@
# $FreeBSD: /tmp/pcvs/ports/ports-mgmt/pkg_install/files/patch-lib_Makefile,v 1.1 2003-08-03 21:44:33 marcus Exp $
LIB= install
-INTERNALLIB= YES
SRCS= file.c msg.c plist.c str.c exec.c global.c pen.c match.c \
deps.c version.c pkgwrap.c url.c
+NOPROFILE= yes
+NOPIC= yes
CFLAGS+= ${DEBUG}
WARNS?= 2
+
+install:
+ @echo -n
.include <bsd.lib.mk>

View file

@ -0,0 +1,9 @@
FreeBSD 5.x version of the pkg_install suite of tools for doing
maintainance of software packages.
This is mainly useful on FreeBSD systems <= 4.6.
WWW: http://www.freebsd.org/cgi/cvsweb.cgi/src/usr.sbin/pkg_install/
-- Oliver Eikemeier
eikemeier@fillmore-labs.com

View file

@ -0,0 +1,7 @@
sbin/pkg_add
sbin/pkg_check
sbin/pkg_create
sbin/pkg_delete
sbin/pkg_info
sbin/pkg_sign
sbin/pkg_version

View file

@ -208,6 +208,7 @@
SUBDIR += perf
SUBDIR += personality
SUBDIR += pib
SUBDIR += pkg_install
SUBDIR += pkg_remove
SUBDIR += pkg_tree
SUBDIR += pkill

View file

@ -0,0 +1,51 @@
# New ports collection makefile for: pkg_install
# Date created: 14 Jul 2003
# Whom: Oliver Eikemeier
#
# $FreeBSD$
#
PORTNAME= pkg_install
PORTVERSION= 20030714
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= marcus
MAINTAINER= portmgr@freebsd.org
COMMENT= FreeBSD 5.x version of the package tools for older system releases
USE_BZIP2= yes
USE_OPENSSL= yes
MANCOMPRESSED= yes
MAN1= pkg_add.1 pkg_create.1 pkg_delete.1 \
pkg_info.1 pkg_sign.1 pkg_version.1
MLINKS= pkg_sign.1 pkg_check.1
MAKE_ARGS= -DNOOBJ
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 460102
check-already-installed:
.if !defined(NO_PKG_REGISTER) && !defined(FORCE_PKG_REGISTER)
@if [ -d ${PKG_DBDIR}/${PKGNAME} ]; then \
${ECHO_CMD} "===> ${PKGNAME} is already installed - perhaps an older version?"; \
${ECHO_CMD} " If so, you may wish to \`\`make deinstall'' and install"; \
${ECHO_CMD} " this port again by \`\`make reinstall'' to upgrade it properly."; \
${ECHO_CMD} " If you really wish to overwrite the old port of ${PKGNAME}"; \
${ECHO_CMD} " without deleting it first, set the variable \"FORCE_PKG_REGISTER\""; \
${ECHO_CMD} " in your environment or the \"make install\" command line."; \
exit 1; \
fi
.else
@${DO_NADA}
.endif
.endif
pre-configure:
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
-e 's,%%MANPREFIX%%,${MANPREFIX},g' \
${FILESDIR}/Makefile.inc > ${WRKDIR}/Makefile.inc
.include <bsd.port.post.mk>

View file

@ -0,0 +1 @@
MD5 (pkg_install-20030714.tar.bz2) = dd98b0275c6bb1e31089e67ea18f22b6

View file

@ -0,0 +1,4 @@
# $FreeBSD$
BINDIR=%%PREFIX%%/sbin
MANDIR=%%MANPREFIX%%/man/man

View file

@ -0,0 +1,20 @@
--- lib/Makefile.orig Fri Jul 25 12:08:43 2003
+++ lib/Makefile Fri Jul 25 12:08:45 2003
@@ -1,12 +1,16 @@
# $FreeBSD: /tmp/pcvs/ports/sysutils/pkg_install/files/Attic/patch-lib_Makefile,v 1.1 2003-08-03 21:44:33 marcus Exp $
LIB= install
-INTERNALLIB= YES
SRCS= file.c msg.c plist.c str.c exec.c global.c pen.c match.c \
deps.c version.c pkgwrap.c url.c
+NOPROFILE= yes
+NOPIC= yes
CFLAGS+= ${DEBUG}
WARNS?= 2
+
+install:
+ @echo -n
.include <bsd.lib.mk>

View file

@ -0,0 +1,9 @@
FreeBSD 5.x version of the pkg_install suite of tools for doing
maintainance of software packages.
This is mainly useful on FreeBSD systems <= 4.6.
WWW: http://www.freebsd.org/cgi/cvsweb.cgi/src/usr.sbin/pkg_install/
-- Oliver Eikemeier
eikemeier@fillmore-labs.com

View file

@ -0,0 +1,7 @@
sbin/pkg_add
sbin/pkg_check
sbin/pkg_create
sbin/pkg_delete
sbin/pkg_info
sbin/pkg_sign
sbin/pkg_version