Update to version 3.0.

PR:		51053
Submitted by:	Ports Fury
This commit is contained in:
Christian Weisgerber 2003-04-23 23:54:46 +00:00
parent 703b7fae0f
commit 01baa82fcb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=79545
4 changed files with 11 additions and 85 deletions

View file

@ -6,31 +6,29 @@
# #
PORTNAME= epstool PORTNAME= epstool
PORTVERSION= 2.10 PORTVERSION= 3.0
CATEGORIES= graphics CATEGORIES= graphics
MASTER_SITES= ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/ghostgum/ MASTER_SITES= ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/ghostgum/
DISTNAME= gsv42src
MAINTAINER= ports@FreeBSD.org MAINTAINER= ports@FreeBSD.org
COMMENT= Create or extract preview bitmaps in EPS files COMMENT= Create or extract preview bitmaps in EPS files
RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu
WRKSRC= ${WRKDIR}/${PORTNAME} USE_GMAKE= yes
MAKEFILE= makefile
USE_ZIP= yes MAKE_ARGS= CC="${CC}" CDEBUG="${CFLAGS}" LINK="${CC}" EPSLIB=""
MAKEFILE= makefile.unx ALL_TARGET= ${PORTNAME}
post-extract: post-extract:
.for file in epstool.zip src.zip @${RM} -f ${WRKSRC}/epstool
@cd ${WRKDIR} && unzip -q -aa ${file}
.endfor
post-install: do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/epstool ${PREFIX}/bin
.if !defined(NOPORTDOCS) .if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR} @${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/epstool.htm ${DOCSDIR} ${INSTALL_DATA} ${WRKSRC}/doc/epstool.htm ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/../gsview.css ${DOCSDIR} ${INSTALL_DATA} ${WRKSRC}/doc/gsview.css ${DOCSDIR}
.endif .endif
.include <bsd.port.mk> .include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (gsv42src.zip) = b22a9f76b4741687a5d0bc81c91219d9 MD5 (epstool-3.0.tar.gz) = 5de32de51f41939f9d3a388d0e8ccbcb

View file

@ -1,27 +0,0 @@
--- makefile.unx.orig Mon Nov 6 09:58:48 2000
+++ makefile.unx Thu Jan 11 22:48:17 2001
@@ -20,13 +20,13 @@
RM=/bin/rm -f
SHELL=/bin/sh
-BINDIR=/usr/local/bin
-INCLUDES=-I/usr/openwin/include -I../src -I.
+BINDIR=${PREFIX}/bin
+INCLUDES=-I../src -I.
LIBS=
# if you have a strict ANSI compiler, add -D__STDC__
DEFINES=-DUNIX -DEPSTOOL -DHAVE_UNISTD_H
OBJ=o
-CC=gcc
+#CC=gcc
OBJS=epstool.$(OBJ) gvceps.$(OBJ) dscparse.$(OBJ) dscutil.$(OBJ)
@@ -61,5 +61,5 @@
-$(RM) epstool
install: epstool
- cp epstool $(BINDIR)
- chmod 755 $(BINDIR)/epstool
+ ${BSD_INSTALL_PROGRAM} epstool $(BINDIR)
+

View file

@ -1,45 +0,0 @@
--- epstool.c.orig Fri Nov 23 16:43:50 2001
+++ epstool.c Sun Dec 2 05:05:41 2001
@@ -26,7 +26,7 @@
char gsname[MAXSTR] = GSCOMMAND;
char gsarg[MAXSTR];
char bmpname[MAXSTR];
-char devname[MAXSTR];
+char gsdevname[MAXSTR];
char szScratch[] = "ep";
char szAppName[] = "epstool";
int resolution = 72;
@@ -167,9 +167,9 @@
find_gs(gsname, sizeof(gsname)-1, 550, FALSE);
#endif
#ifdef UNIX
- strcpy(devname, "pbmraw");
+ strcpy(gsdevname, "pbmraw");
#else
- strcpy(devname, "bmpmono");
+ strcpy(gsdevname, "bmpmono");
#endif
if (scan_args(argc, argv))
return 1;
@@ -463,10 +463,10 @@
fclose(tempfile);
#ifdef UNIX
sprintf(gscommand, "\042%s\042 %s -dNOPAUSE -dQUIET -sDEVICE=%s -sOutputFile=\042%s\042 -r%d -g%dx%d %s",
- gsname, gsarg, devname, bmpname, resolution, width, height, tempname);
+ gsname, gsarg, gsdevname, bmpname, resolution, width, height, tempname);
#else
sprintf(gscommand, "-dNOPAUSE\n-dQUIET\n-sDEVICE=%s\n-sOutputFile=\042%s\042\n-r%d\n-g%dx%d\n\042%s\042",
- devname, bmpname, resolution, width, height, tempname);
+ gsdevname, bmpname, resolution, width, height, tempname);
if (!quiet) {
fputs(gscommand, stderr);
fputs("\n", stderr);
@@ -654,7 +654,7 @@
break;
case 'z':
if (argp[2])
- strcpy(devname, argp+2);
+ strcpy(gsdevname, argp+2);
break;
case 'c':
if (got_op) {