- Fix build on CURRENT (change in OpenSSL API)

- While at it, trim Makefile headers and use new LIB_DEPENDS format

Reported by:	pkg-fallout
This commit is contained in:
Pietro Cerutti 2013-09-07 15:45:23 +00:00
parent d56ee54ce6
commit 01c7f63468
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=326642
2 changed files with 48 additions and 9 deletions

View file

@ -1,11 +1,6 @@
# ex: ts=8
# New ports collection makefile for: dclib
# Date created: Wed 10 Jul 2002
# Whom: Sverrir Valgeirsson <e96sv@yahoo.se> and
# Amar Takhar <verm@drunkmonk.net> et al
#
# Created by: Sverrir Valgeirsson <e96sv@yahoo.se> and
# Amar Takhar <verm@drunkmonk.net> et al
# $FreeBSD$
#
PORTNAME= dclib
PORTVERSION= 0.3.23
@ -16,7 +11,7 @@ MASTER_SITES= SF/wxdcgui/${PORTNAME}/${PORTVERSION}
MAINTAINER= gahr@FreeBSD.org
COMMENT= Direct connect interface library for valknut
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg
LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
WRKSRC= ${WRKDIR}/${DISTNAME}
@ -27,6 +22,12 @@ USE_GNOME= libxml2
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 1000015
EXTRA_PATCHES= ${FILESDIR}/extra-dclib-core_cssl.cpp
.endif
post-extract:
${CHMOD} 0755 ${WRKSRC}/admin/install-sh
@ -41,4 +42,4 @@ post-patch:
${REINPLACE_CMD} -e 's|-D_XOPEN_SOURCE=500||g; \
s|-D_BSD_SOURCE||g' ${WRKSRC}/configure ${WRKSRC}/configure.in
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View file

@ -0,0 +1,38 @@
--- dclib/core/cssl.cpp.orig 2013-09-07 16:26:31.000000000 +0200
+++ dclib/core/cssl.cpp 2013-09-07 16:28:11.000000000 +0200
@@ -86,7 +86,7 @@
/** */
SSL_CTX * CSSL::InitClientCTX()
{
- SSL_METHOD *method;
+ const SSL_METHOD *method;
SSL_CTX *ctx = NULL;
method = SSLv23_client_method(); /* Create new client-method instance */
@@ -109,7 +109,7 @@
/** */
SSL_CTX * CSSL::InitServerCTX()
{
- SSL_METHOD *method;
+ const SSL_METHOD *method;
SSL_CTX *ctx = NULL;
method = SSLv23_server_method(); /* Create new client-method instance */
@@ -130,7 +130,7 @@
/** */
SSL_CTX * CSSL::NewTLSv1ClientCTX()
{
- SSL_METHOD * method = TLSv1_client_method();
+ const SSL_METHOD * method = TLSv1_client_method();
SSL_CTX * ctx = NULL;
if ( method != NULL )
@@ -149,7 +149,7 @@
/** */
SSL_CTX * CSSL::NewTLSv1ServerCTX()
{
- SSL_METHOD * method = TLSv1_server_method();
+ const SSL_METHOD * method = TLSv1_server_method();
SSL_CTX * ctx = NULL;
if ( method != NULL )