databases/py-redis: Update to 2.9.1 & modernise
- Update to 2.9.1 - Deprecate easy_install target - Deprecate OPTIONSFILE override - Remove unecessary setup.py patch - Use OPTIONS helpers for HIREDIS RUN_DEPENDS Changes: https://github.com/andymccurdy/redis-py/blob/2.9.1/CHANGES
This commit is contained in:
parent
c2acad1047
commit
01d733c2df
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=343615
3 changed files with 12 additions and 27 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= redis
|
||||
PORTVERSION= 2.8.0
|
||||
PORTVERSION= 2.9.1
|
||||
CATEGORIES= databases python
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
|
@ -11,24 +11,19 @@ COMMENT= Python client for Redis key-value store
|
|||
|
||||
LICENSE= MIT
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= andymccurdy
|
||||
GH_PROJECT= ${PORTNAME}-py
|
||||
GH_COMMIT= 678f353
|
||||
OPTIONS_DEFINE= HIREDIS
|
||||
HIREDIS_DESC= High performance response parser (via hiredis)
|
||||
|
||||
HIREDIS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hiredis>0:${PORTSDIR}/databases/py-hiredis
|
||||
|
||||
USE_PYTHON= yes
|
||||
USE_PYDISTUTILS= easy_install
|
||||
USE_PYDISTUTILS= yes
|
||||
PYDISTUTILS_AUTOPLIST= yes
|
||||
|
||||
OPTIONS_DEFINE= HIREDIS
|
||||
HIREDIS_DESC= High performance response parser (via hiredis)
|
||||
OPTIONSFILE?= ${PORT_DBDIR}/py-${PORTNAME}/options
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MHIREDIS}
|
||||
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}hiredis>0:${PORTSDIR}/databases/py-hiredis
|
||||
.endif
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= andymccurdy
|
||||
GH_PROJECT= ${PORTNAME}-py
|
||||
GH_COMMIT= 91a0b8b
|
||||
|
||||
regression-test: build
|
||||
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (redis-2.8.0.tar.gz) = f92f1b624f3eb5e8ae2aa4f0e1e5e4397512881978bae56fc1824573801afa40
|
||||
SIZE (redis-2.8.0.tar.gz) = 54250
|
||||
SHA256 (redis-2.9.1.tar.gz) = ac67bc0dcfe0ac56626e24ee4bea188d699d9f7ec04483534e1268db9390a2cb
|
||||
SIZE (redis-2.9.1.tar.gz) = 60476
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- ./setup.py.orig 2013-06-16 18:54:43.668848521 +1000
|
||||
+++ ./setup.py 2013-06-16 18:54:57.779885292 +1000
|
||||
@@ -57,5 +57,6 @@
|
||||
'Programming Language :: Python :: 3',
|
||||
'Programming Language :: Python :: 3.2',
|
||||
'Programming Language :: Python :: 3.3',
|
||||
- ]
|
||||
+ ],
|
||||
+ zip_safe=False,
|
||||
)
|
Loading…
Reference in a new issue