databases/puredb: Set of libraries for creating and reading constant databases
PureDB is a portable and tiny set of libraries for creating and reading constant databases. It manages data files that contains text or binary key/data pairs of arbitrary sizes. Lookups are very fast (normally only one disk access to match a hash value), overhead is low (a database is 1028 bytes plus only 16 extra bytes per record), multiple concurrent read access are supported, and databases can be up to 4 Gb long, and they are portable across architectures. PR: ports/48901 Submitted by: Sergei Kolobov <sergei@kolobov.com>
This commit is contained in:
parent
168b1e2955
commit
01f686aad2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=77886
6 changed files with 69 additions and 0 deletions
|
@ -137,6 +137,7 @@
|
|||
SUBDIR += postgresql7
|
||||
SUBDIR += postgresql72
|
||||
SUBDIR += postgresql_autodoc
|
||||
SUBDIR += puredb
|
||||
SUBDIR += pxtools
|
||||
SUBDIR += py-MySQL
|
||||
SUBDIR += py-MySQLdb
|
||||
|
|
28
databases/puredb/Makefile
Normal file
28
databases/puredb/Makefile
Normal file
|
@ -0,0 +1,28 @@
|
|||
# New ports collection makefile for: puredb
|
||||
# Date created: 01 Nov 2002
|
||||
# Whom: Sergei Kolobov <sergei@kolobov.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= puredb
|
||||
PORTVERSION= 2.1
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= http://www.pureftpd.org/puredb/
|
||||
DISTNAME= pure-db-${PORTVERSION}
|
||||
|
||||
MAINTAINER= sergei@kolobov.com
|
||||
COMMENT= Set of libraries for creating and reading constant databases
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
DOCS= AUTHORS FORMAT_DESCR NEWS README
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
post-install:
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
databases/puredb/distinfo
Normal file
1
databases/puredb/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (pure-db-2.1.tar.gz) = 2fdf5771c169877218b1f83852f8cad4
|
12
databases/puredb/files/patch-example_read.c
Normal file
12
databases/puredb/files/patch-example_read.c
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- src/example_read.c.orig Fri Nov 1 23:21:19 2002
|
||||
+++ src/example_read.c Fri Nov 1 23:21:47 2002
|
||||
@@ -3,6 +3,9 @@
|
||||
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
+#ifdef __FreeBSD__
|
||||
+#include <sys/types.h>
|
||||
+#endif
|
||||
#include <puredb_read.h>
|
||||
|
||||
int main(void)
|
10
databases/puredb/pkg-descr
Normal file
10
databases/puredb/pkg-descr
Normal file
|
@ -0,0 +1,10 @@
|
|||
PureDB is a portable and tiny set of libraries for creating and reading
|
||||
constant databases. It manages data files that contains text or binary
|
||||
key/data pairs of arbitrary sizes. Lookups are very fast (normally only one
|
||||
disk access to match a hash value), overhead is low (a database is 1028
|
||||
bytes plus only 16 extra bytes per record), multiple concurrent read access
|
||||
are supported, and databases can be up to 4 Gb long, and they are portable
|
||||
across architectures.
|
||||
|
||||
Author: Frank DENIS <j@4u.net>.
|
||||
WWW: http://www.pureftpd.org/puredb/
|
17
databases/puredb/pkg-plist
Normal file
17
databases/puredb/pkg-plist
Normal file
|
@ -0,0 +1,17 @@
|
|||
bin/example_read
|
||||
bin/example_write
|
||||
include/puredb_read.h
|
||||
include/puredb_write.h
|
||||
lib/libpuredb_read.so.0
|
||||
lib/libpuredb_read.so
|
||||
lib/libpuredb_read.la
|
||||
lib/libpuredb_read.a
|
||||
lib/libpuredb_write.so.0
|
||||
lib/libpuredb_write.so
|
||||
lib/libpuredb_write.la
|
||||
lib/libpuredb_write.a
|
||||
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/FORMAT_DESCR
|
||||
%%PORTDOCS%%%%DOCSDIR%%/NEWS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
Loading…
Reference in a new issue