Toot is a Mastodon CLI client written in Python, which lets you log

into your Mastodon account, search for users and hashtags, display
timelines, post (toot), upload media files and perform account
related actions such us following, muting and blocking.

WWW: https://github.com/ihabunek/toot

PR:		227587
Submitted by:	Mateusz Piotrowski <0mp@FreeBSD.org>
This commit is contained in:
Kirill Ponomarev 2018-04-18 10:50:38 +00:00
parent 13529def80
commit 020f3bd196
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=467702
5 changed files with 61 additions and 0 deletions

View file

@ -205,6 +205,7 @@
SUBDIR += telepathy-sofiasip
SUBDIR += tkabber
SUBDIR += tkabber-plugins
SUBDIR += toot
SUBDIR += tox
SUBDIR += tox12
SUBDIR += toxbot

41
net-im/toot/Makefile Normal file
View file

@ -0,0 +1,41 @@
# $FreeBSD$
PORTNAME= toot
DISTVERSION= 0.17.1
CATEGORIES= net-im python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= 0mp@FreeBSD.org
COMMENT= Interact with the Mastodon social network from the command line
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.0.0:devel/py-pytest@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-cov>=2.4.0:devel/py-pytest-cov@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.5.0<5.0:www/py-beautifulsoup@${FLAVOR}
USES= python:3.3+
USE_PYTHON= autoplist distutils
USE_GITHUB= yes
GH_ACCOUNT= ihabunek
NO_ARCH= yes
OPTIONS_DEFINE= DOCS
PORTDOCS= CHANGELOG.md README.rst
MAKE_ENV= PATH+=${STAGEDIR}${PREFIX}/bin
TEST_TARGET= coverage
pre-test:
@${REINPLACE_CMD} -e 's|py.test |py.test-${PYTHON_VER} |' ${WRKSRC}/Makefile
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/CHANGELOG.md ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.rst ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>

3
net-im/toot/distinfo Normal file
View file

@ -0,0 +1,3 @@
TIMESTAMP = 1523981665
SHA256 (ihabunek-toot-0.17.1_GH0.tar.gz) = ebdf0ce28b90e0f943fdbec6b14eccfbdbe39fa791df9880e60e2b80d1aaaf18
SIZE (ihabunek-toot-0.17.1_GH0.tar.gz) = 34149

View file

@ -0,0 +1,10 @@
--- tests/test_config.py.orig 2018-04-17 19:03:23 UTC
+++ tests/test_config.py
@@ -126,6 +126,7 @@ def test_get_config_file_path():
fn = config.get_config_file_path
os.unsetenv('XDG_CONFIG_HOME')
+ os.environ.pop('XDG_CONFIG_HOME', None)
assert fn() == os.path.expanduser('~/.config/toot/config.json')

6
net-im/toot/pkg-descr Normal file
View file

@ -0,0 +1,6 @@
Toot is a Mastodon CLI client written in Python, which lets you log into your
Mastodon account, search for users and hashtags, display timelines, post
(toot), upload media files and perform account related actions such us
following, muting and blocking.
WWW: https://github.com/ihabunek/toot