Move to new upstream; Matthew Brush is now maintaining libcfu.

Use my github, since I've fixed the clang warnings in it too, so hopefully
Matthew will pull in my changes.
This commit is contained in:
Chris Rees 2013-05-25 13:37:08 +00:00
parent 99a1397120
commit 02111b30a2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=319049
8 changed files with 28 additions and 154 deletions

View file

@ -1,17 +1,26 @@
# $FreeBSD$
PORTNAME= libcfu
PORTVERSION= 0.03
DISTVERSION= 0.04a
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}/
MASTER_SITES= GH
MAINTAINER= crees@FreeBSD.org
COMMENT= Simple library of tools for developing multithreaded software
LICENSE= BSD
GNU_CONFIGURE= yes
USE_AUTOTOOLS= automake aclocal
USE_GITHUB= yes
GH_ACCOUNT= crees
GH_COMMIT= 947dba4
GH_TAGNAME= 947dba4
USES= pkgconfig pathfix
PATHFIX_MAKEFILEIN= Makefile.am
USE_AUTOTOOLS= autoconf autoheader automake aclocal libtool libtoolize
AUTOMAKE_ARGS= --add-missing
ACLOCAL_ARGS= -I ${LIBTOOL_M4:C,[^/]*$,,}
INFO= ${PORTNAME}
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (libcfu-0.03.tar.gz) = 0581559917edaba3e6a0df9115658f6490ea9f4bb88334eb2bfed26181150e51
SIZE (libcfu-0.03.tar.gz) = 193634
SHA256 (libcfu-0.04a.tar.gz) = 13ad04d6f430e0815106676526d8adcc5afda2498b97c9b82fa07ddb34fd6eef
SIZE (libcfu-0.04a.tar.gz) = 159317

View file

@ -1,18 +0,0 @@
--- configure.ac.orig 2013-05-23 22:56:29.764274319 +0100
+++ configure.ac 2013-05-23 22:59:46.595272055 +0100
@@ -15,12 +15,12 @@
SAVELIBS="$LIBS"
CFLAGS="-pthread $CFLAGS"
LIBS="-pthread $LIBS"
-AC_CHECK_FUNC(pthread_mutex_init,,
- CFLAGS="$SAVECFLAGS"
+AC_CHECK_FUNC(pthread_mutex_init, ,
+ [CFLAGS="$SAVECFLAGS"
LIBS="$SAVELIBS"
AC_CHECK_LIB(pthread, pthread_mutex_init,,
AC_CHECK_LIB(pthreads, pthread_mutex_init,,
- AC_MSG_ERROR([No pthreads support found.]))))
+ AC_MSG_ERROR([No pthreads support found.])))])
# Checks for header files.
AC_HEADER_STDC

View file

@ -1,11 +0,0 @@
--- examples/Makefile.am.orig 2013-05-23 22:51:44.426274513 +0100
+++ examples/Makefile.am 2013-05-23 22:51:55.801273539 +0100
@@ -4,7 +4,7 @@
if DEBUG
AM_CFLAGS = -Wall -W -Werror -I$(top_srcdir)/include -DCFU_DEBUG=1
else
-AM_CFLAGS = -Wall -W -Werror -I$(top_srcdir)/include
+AM_CFLAGS = -Wall -W -I$(top_srcdir)/include
endif
AM_LDFLAGS = -Xlinker -rpath -Xlinker $(top_src_dir)/src

View file

@ -1,49 +0,0 @@
--- ./examples/hash_usage.c.orig 2013-02-22 17:00:53.679654885 +0000
+++ ./examples/hash_usage.c 2013-02-22 17:02:43.078657742 +0000
@@ -36,8 +36,8 @@
cfuhash_set_flag(hash, CFUHASH_FROZEN_UNTIL_GROWS);
for (i = 0; i < 32; i++) {
- sprintf(list[i][0], "test_var%d", i);
- sprintf(list[i][1], "value%d", i);
+ sprintf(list[i][0], "test_var%zd", i);
+ sprintf(list[i][1], "value%zd", i);
}
cfuhash_put(hash, "var1", "value1");
@@ -58,7 +58,7 @@
printf("got var2='%s'\n", val);
printf("var4 %s\n", cfuhash_exists(hash, "var4") ? "exists" : "does NOT exist!!!");
- printf("%d entries, %d buckets used out of %d\n", cfuhash_num_entries(hash), cfuhash_num_buckets_used(hash), cfuhash_num_buckets(hash));
+ printf("%zd entries, %zd buckets used out of %zd\n", cfuhash_num_entries(hash), cfuhash_num_buckets_used(hash), cfuhash_num_buckets(hash));
cfuhash_pretty_print(hash, stdout);
@@ -69,7 +69,7 @@
size_t num_buckets = cfuhash_num_buckets(hash);
size_t num_entries = cfuhash_num_entries(hash);
cfuhash_put(hash, list[i][0], list[i][1]);
- printf("%d entries, %d buckets used out of %d (%.2f)\n", num_entries, used, num_buckets, (float)num_entries/(float)num_buckets);
+ printf("%zd entries, %zd buckets used out of %zd (%.2f)\n", num_entries, used, num_buckets, (float)num_entries/(float)num_buckets);
}
@@ -82,7 +82,7 @@
keys = (char **)cfuhash_keys_data(hash, &key_count, &key_sizes, 0);
- printf("\n\nkeys (%u):\n", key_count);
+ printf("\n\nkeys (%zu):\n", key_count);
for (i = 0; i < key_count; i++) {
printf("\t%s\n", keys[i]);
free(keys[i]);
@@ -92,7 +92,7 @@
}
cfuhash_clear(hash);
- printf("%d entries, %d buckets used out of %d\n", cfuhash_num_entries(hash), cfuhash_num_buckets_used(hash), cfuhash_num_buckets(hash));
+ printf("%zd entries, %zd buckets used out of %zd\n", cfuhash_num_entries(hash), cfuhash_num_buckets_used(hash), cfuhash_num_buckets(hash));
cfuhash_destroy(hash);

View file

@ -1,31 +0,0 @@
--- ./examples/large_hash.c.orig 2013-02-22 17:03:12.957659394 +0000
+++ ./examples/large_hash.c 2013-02-22 17:03:58.328654728 +0000
@@ -113,8 +113,8 @@
cfutime_begin(time);
for (i = 0; i < num_tests; i++) {
- sprintf(key, "%u", 15000000 - i);
- sprintf(value, "value%d", i);
+ sprintf(key, "%zu", 15000000 - i);
+ sprintf(value, "value%zd", i);
cfuhash_put(hash, key, dup_str(value));
}
cfutime_end(time);
@@ -123,7 +123,7 @@
used = cfuhash_num_buckets_used(hash);
num_buckets = cfuhash_num_buckets(hash);
num_entries = cfuhash_num_entries(hash);
- printf("%d entries, %d/%d buckets (%.2f%%), %.2f%% threshold check\n", num_entries, used, num_buckets, 100.0 * (float)used/(float)num_buckets, 100.0 * (float)num_entries/(float)num_buckets);
+ printf("%zd entries, %zd/%zd buckets (%.2f%%), %.2f%% threshold check\n", num_entries, used, num_buckets, 100.0 * (float)used/(float)num_buckets, 100.0 * (float)num_entries/(float)num_buckets);
cfuhash_destroy_with_free_fn(hash, free_data);
@@ -138,7 +138,7 @@
argc = argc;
argv = argv;
- printf("mutex is %d bytes\n", sizeof(pthread_mutex_t));
+ printf("mutex is %zd bytes\n", sizeof(pthread_mutex_t));
printf("default:\n");
time_it(NULL, &elapsed_time, num_tests);

View file

@ -1,29 +0,0 @@
--- ./examples/strings.c.orig 2013-02-22 17:04:18.476679318 +0000
+++ ./examples/strings.c 2013-02-22 17:04:45.041658118 +0000
@@ -39,7 +39,7 @@
cfustring_append(buf, "test^*string%2^*3");
strings = cfustring_split_to_c_str(buf, &num_strings, 0, "%", "^*", NULL);
- printf("got back %u strings\n", num_strings);
+ printf("got back %zu strings\n", num_strings);
printf("\n");
for (i = 0; i < num_strings; i++) {
@@ -52,7 +52,7 @@
free(strings);
header_lines = cfustring_split(header_block, &num_headers, 0, "\r\n", "\n", NULL);
- printf("got back %u headers\n", num_strings);
+ printf("got back %zu headers\n", num_strings);
for (i = 0; i < num_headers; i++) {
strings = cfustring_split_to_c_str(header_lines[i], &num_strings, 2, ":", NULL);
@@ -61,7 +61,7 @@
size_t j = 0;
for (j = 0; j < num_strings; j++) free(strings[j]);
free(strings);
- fprintf(stderr, "bad header: %u strings from split -- '%s'\n", num_strings, cfustring_get_buffer(header_lines[i]));
+ fprintf(stderr, "bad header: %zu strings from split -- '%s'\n", num_strings, cfustring_get_buffer(header_lines[i]));
continue;
}

View file

@ -1,11 +1,14 @@
include/cfu/cfu.h
include/cfu/cfuconf.h
include/cfu/cfuhash.h
include/cfu/cfulist.h
include/cfu/cfuopt.h
include/cfu/cfustring.h
include/cfu/cfutimer.h
include/cfu/cfuthread_queue.h
lib/libcfu.a
bin/libcfu-config
include/cfulist.h
include/cfuhash.h
include/cfutime.h
include/cfuconf.h
include/cfuthread_queue.h
include/cfuopt.h
include/cfustring.h
include/cfutypes.h
include/cfu.h
lib/libcfu.la
lib/libcfu.so
lib/libcfu.so.0
libdata/pkgconfig/libcfu.pc
@dirrm include/cfu