Enable gold and sysroot support

PR:		ports/165406
Submitted by:	brooks@
This commit is contained in:
Martin Matuska 2012-02-23 12:43:57 +00:00
parent 268105e966
commit 022de42f80
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=292117
4 changed files with 47 additions and 5 deletions

View file

@ -7,6 +7,7 @@
PORTNAME= binutils
PORTVERSION= 2.22
PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
MASTER_SITE_SUBDIR= binutils/releases
@ -14,9 +15,8 @@ MASTER_SITE_SUBDIR= binutils/releases
MAINTAINER= mm@FreeBSD.org
COMMENT= GNU binary tools
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
LICENSE= GPLv3 LGPL3
LICENSE_COMB= multi
BUILD_DEPENDS= ${LOCALBASE}/lib/libgmp.so:${PORTSDIR}/math/gmp \
${LOCALBASE}/lib/libmpfr.so:${PORTSDIR}/math/mpfr
@ -25,14 +25,18 @@ CONFLICTS= libbfd-[0-9]*
OPTIONS= NLS "Enable National Language Support" off
LICENSE= GPLv3 LGPL3
LICENSE_COMB= multi
LICENSE_FILE_GPLv3= ${WRKSRC}/COPYING3
LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING3.LIB
USE_BISON= build
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+= --with-system-zlib \
--with-sysroot=/ \
--disable-werror \
--with-gmp=${LOCALBASE} \
--with-mpfr=${LOCALBASE}
@ -67,6 +71,14 @@ INFO= as \
.include <bsd.port.pre.mk>
# Actual earliest version may differ slightly
.if ${OSVERSION} >= 900044
CONFIGURE_ARGS+= --enable-gold --enable-plugins
PLIST_SUB+= GOLD=""
.else
PLIST_SUB+= GOLD="@comment "
.endif
.if defined(WITH_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
@ -80,6 +92,9 @@ ARCH= x86_64
.endif
post-install:
.if ${OSVERSION} >= 900044
${INSTALL_DATA} ${WRKSRC}/include/plugin-api.h ${PREFIX}/include/
.endif
@${FIND} -ds ${PREFIX}/${CONFIGURE_TARGET} ! -type d | \
${SED} -e 's,^${PREFIX}/,,' >> ${TMPPLIST}
@${FIND} -ds ${PREFIX}/${CONFIGURE_TARGET} -type d | \

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- bfd/Makefile.in.orig
+++ bfd/Makefile.in
@@ -336,7 +336,6 @@
@INSTALL_LIBBFD_FALSE@noinst_LTLIBRARIES = libbfd.la
AM_CFLAGS = $(WARN_CFLAGS)
AM_CPPFLAGS = -DBINDIR='"$(bindir)"'
-@PLUGINS_TRUE@LIBDL = -ldl
# bfd.h goes here, for now
BFD_H = bfd.h

View file

@ -0,0 +1,12 @@
$FreeBSD$
--- gold/Makefile.in.orig
+++ gold/Makefile.in
@@ -368,7 +368,6 @@
@INCINTL@
LIBIBERTY = ../libiberty/libiberty.a
-@PLUGINS_TRUE@LIBDL = -ldl
@THREADS_TRUE@THREADSLIB = -lpthread
AM_YFLAGS = -d

View file

@ -6,6 +6,7 @@ bin/elfedit
bin/gprof
bin/ld
bin/ld.bfd
%%GOLD%%bin/ld.gold
bin/nm
bin/objcopy
bin/objdump
@ -18,6 +19,7 @@ include/ansidecl.h
include/bfd.h
include/bfdlink.h
include/dis-asm.h
%%GOLD%%include/plugin-api.h
include/symcat.h
lib/libbfd.a
lib/libbfd.la