Add nzbget, a NZB binaries format downloader from Usenet groups.

PR:		ports/65509
Submitted by:	Lewis Thompson <purple@lewiz.net>
This commit is contained in:
Pav Lucistnik 2004-04-17 21:26:30 +00:00
parent 5c993dc1ae
commit 02405b3eba
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=107375
9 changed files with 110 additions and 0 deletions

View file

@ -55,6 +55,7 @@
SUBDIR += nntpcache
SUBDIR += nntpswitch
SUBDIR += noffle
SUBDIR += nzbget
SUBDIR += p5-Gateway
SUBDIR += p5-NNTPClient
SUBDIR += p5-News-Article

35
news/nzbget/Makefile Normal file
View file

@ -0,0 +1,35 @@
# New ports collection makefile for: nzbget
# Date created: 13 April 2004
# Whom: Lewis Thompson <purple@lewiz.net>
#
# $FreeBSD$
#
PORTNAME= nzbget
PORTVERSION= 0.1.1
CATEGORIES= news
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= nzbget
MAINTAINER= purple@lewiz.net
COMMENT= A binary newsreader supporting NZB files
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
uu.3:${PORTSDIR}/converters/uulib
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}" \
LOCALBASE="${LOCALBASE}"
USE_GMAKE= yes
USE_REINPLACE= yes
PLIST_FILES= bin/nzbget etc/nzbget.cfg.example
post-patch:
@${REINPLACE_CMD} -e 's|/usr/bin/nzbget|${PREFIX}/bin/nzbget|' ${WRKSRC}/Makefile.in
post-install:
${INSTALL_DATA} ${WRKSRC}/nzbget.cfg.example ${PREFIX}/etc
.include <bsd.port.mk>

2
news/nzbget/distinfo Normal file
View file

@ -0,0 +1,2 @@
MD5 (nzbget-0.1.1.tar.gz) = a653120fac3dde326e0305fb4a1fb27d
SIZE (nzbget-0.1.1.tar.gz) = 82928

View file

@ -0,0 +1,11 @@
--- ArticleDownloader.cpp.orig Fri Apr 2 18:55:19 2004
+++ ArticleDownloader.cpp Sat Apr 17 22:57:09 2004
@@ -27,6 +27,8 @@
#include <config.h>
#endif
+#include <unistd.h>
+
#include "ArticleDownloader.h"
#include "Decoder.h"
#include "global.h"

View file

@ -0,0 +1,11 @@
--- Connection.cpp.orig Fri Apr 2 18:55:19 2004
+++ Connection.cpp Sat Apr 17 23:12:22 2004
@@ -27,6 +27,8 @@
#include <config.h>
#endif
+#include <sys/types.h>
+
#include <string.h>
#include <stdlib.h>
#include <netdb.h>

View file

@ -0,0 +1,11 @@
--- Decoder.cpp.orig Wed Feb 25 13:46:10 2004
+++ Decoder.cpp Sat Apr 17 23:14:45 2004
@@ -29,6 +29,8 @@
#define PROTOTYPES
+#include <unistd.h>
+
#include <stdlib.h>
#include <stdio.h>
#include <uudeview.h>

View file

@ -0,0 +1,10 @@
--- NNTPConnection.h.orig Fri Apr 2 18:55:19 2004
+++ NNTPConnection.h Sat Apr 17 22:53:55 2004
@@ -26,6 +26,7 @@
#ifndef NNTPCONNECTION_H
#define NNTPCONNECTION_H
+#include <sys/types.h>
#include <sys/socket.h>
#include <stdio.h>
#include <vector>

View file

@ -0,0 +1,24 @@
--- configure.orig Thu Feb 26 15:49:46 2004
+++ configure Tue Apr 13 22:55:38 2004
@@ -1303,13 +1303,19 @@
CPPFLAGS="${CPPFLAGS} -D_GNU_SOURCE"
PLATFORM="Linux"
;;
- *-solaris*)
+ *-freebsd*)
+ LIBPREF="${LOCALBASE}"
+ CFLAGS="${CFLAGS}"
+ CPPFLAGS="${CPPFLAGS}"
+ PLATFORM="FreeBSD"
+ ;;
+ *-solaris*)
LIBPREF="/usr/local"
PLATFORM="SunOS"
;;
esac
-CFLAGS="-Wall -g -O0 -pipe" CPPFLAGS="-I. ${CPPFLAGS}"
+CFLAGS="${CFLAGS} -Wall" CPPFLAGS="-I. ${CPPFLAGS}"
ac_ext=cc
ac_cpp='$CXXCPP $CPPFLAGS'

5
news/nzbget/pkg-descr Normal file
View file

@ -0,0 +1,5 @@
NZBGet is a binary newsgrabber, which downloads files from usenet based
on information given in nzb-files. Descriptino of nzb format is available
at http://docs.newzbin.com/
WWW: http://sourceforge.net/projects/nzbget/