Update to 0.9.3.
This commit is contained in:
parent
a25315b9f2
commit
0252402f7a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=155048
14 changed files with 74 additions and 296 deletions
|
@ -7,8 +7,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= rhythmbox
|
||||
PORTVERSION= 0.9.2
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 0.9.3
|
||||
CATEGORIES= audio gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME}
|
||||
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.9
|
||||
|
@ -38,7 +37,8 @@ GCONF_SCHEMAS= rhythmbox.schemas
|
|||
|
||||
OPTIONS= IPOD "Enable iPod support" off \
|
||||
DAAP "Enable iTunes music sharing" off \
|
||||
FAAD "Enable FAAD decoder support" off
|
||||
FAAD "Enable FAAD decoder support" off \
|
||||
NOTIFY "Enable libnotify support" on
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
@ -75,6 +75,12 @@ LIB_DEPENDS+= howl.0:${PORTSDIR}/net/howl
|
|||
CONFIGURE_ARGS+= --disable-daap
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_NOTIFY)
|
||||
LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-libnotify
|
||||
.endif
|
||||
|
||||
pre-everything::
|
||||
.if !defined(WITH_VORBIS)
|
||||
@${ECHO_MSG}
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (gnome2/rhythmbox-0.9.2.tar.bz2) = 533223578c9c37bd72634755b33beab7
|
||||
SHA256 (gnome2/rhythmbox-0.9.2.tar.bz2) = 08e8ee10c0dc48f293b1e58cb5babaac9bfdf2df4e12aea76824ec3c6f4d0340
|
||||
SIZE (gnome2/rhythmbox-0.9.2.tar.bz2) = 2470164
|
||||
MD5 (gnome2/rhythmbox-0.9.3.tar.bz2) = 3ad98939192d44e64982588b15827ffe
|
||||
SHA256 (gnome2/rhythmbox-0.9.3.tar.bz2) = fa8fda4f02391426ee3d854cebf11e6e000dc6f6b9fd96b15b5193cb53140a08
|
||||
SIZE (gnome2/rhythmbox-0.9.3.tar.bz2) = 2510119
|
||||
|
|
|
@ -1,33 +1,18 @@
|
|||
--- configure.orig Mon Nov 28 13:42:56 2005
|
||||
+++ configure Mon Nov 28 13:44:13 2005
|
||||
@@ -22409,7 +22409,7 @@
|
||||
--- configure.orig Thu Feb 2 02:03:39 2006
|
||||
+++ configure Thu Feb 2 02:04:34 2006
|
||||
@@ -21318,9 +21318,9 @@
|
||||
enable_hal02=yes
|
||||
fi
|
||||
fi
|
||||
- if test x$enable_hal05 == xyes || test x$enable_hal02 == xyes; then
|
||||
+ if test x$enable_hal05 = xyes || test x$enable_hal02 = xyes; then
|
||||
enable_hal=yes
|
||||
else
|
||||
enable_hal=no
|
||||
@@ -22426,7 +22426,7 @@
|
||||
_ACEOF
|
||||
|
||||
use_ipod=yes
|
||||
- if test x$enable_hal05 == xyes; then
|
||||
+ if test x$enable_hal05 = xyes; then
|
||||
fi
|
||||
- if test x$enable_hal05 == xyes || test x$enable_hal02 == xyes; then
|
||||
+ if test x$enable_hal05 = xyes || test x$enable_hal02 = xyes; then
|
||||
enable_hal=yes
|
||||
- if test x$enable_hal05 == xyes; then
|
||||
+ if test x$enable_hal05 = xyes; then
|
||||
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
#define HAVE_HAL_0_5 1
|
||||
@@ -22748,7 +22748,7 @@
|
||||
RHYTHMBOX_LIBS="$RHYTHMBOX_LIBS $SOUNDSYSTEM_LIBS"
|
||||
|
||||
|
||||
- if test "x$GST_INSPECT" == "x"; then
|
||||
+ if test "x$GST_INSPECT" = "x"; then
|
||||
# Extract the first word of "gst-inspect-0.8", so it can be a program name with args.
|
||||
set dummy gst-inspect-0.8; ac_word=$2
|
||||
echo "$as_me:$LINENO: checking for $ac_word" >&5
|
||||
@@ -23002,7 +23002,7 @@
|
||||
@@ -22121,7 +22121,7 @@
|
||||
have_avahi_05=yes
|
||||
fi
|
||||
fi
|
||||
|
@ -36,7 +21,7 @@
|
|||
have_avahi=yes
|
||||
else
|
||||
have_avahi=no
|
||||
@@ -23089,7 +23089,7 @@
|
||||
@@ -22208,7 +22208,7 @@
|
||||
|
||||
{ echo "$as_me:$LINENO: Detected Avahi, using it for mDNS/DNS-SD" >&5
|
||||
echo "$as_me: Detected Avahi, using it for mDNS/DNS-SD" >&6;}
|
||||
|
@ -45,7 +30,7 @@
|
|||
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
#define HAVE_AVAHI_0_6 1
|
||||
@@ -23156,7 +23156,7 @@
|
||||
@@ -22275,7 +22275,7 @@
|
||||
{ echo "$as_me:$LINENO: Using Avahi for mDNS/DNS-SD" >&5
|
||||
echo "$as_me: Using Avahi for mDNS/DNS-SD" >&6;}
|
||||
|
||||
|
@ -54,7 +39,7 @@
|
|||
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
#define HAVE_AVAHI_0_6 1
|
||||
@@ -23811,7 +23811,7 @@
|
||||
@@ -23069,7 +23069,7 @@
|
||||
|
||||
|
||||
if test x"$x_includes" != x"NONE" && test -n "$x_includes" ; then
|
||||
|
|
|
@ -1,27 +1,26 @@
|
|||
--- daapsharing/rb-daap-src.c.orig Sun Oct 16 05:50:21 2005
|
||||
+++ daapsharing/rb-daap-src.c Mon Oct 17 10:30:20 2005
|
||||
--- daapsharing/rb-daap-src.c.orig Fri Jan 27 21:11:13 2006
|
||||
+++ daapsharing/rb-daap-src.c Thu Feb 2 02:07:48 2006
|
||||
@@ -34,6 +34,7 @@
|
||||
#include <sys/ioctl.h>
|
||||
#include <netdb.h>
|
||||
#include <unistd.h>
|
||||
+#include <signal.h>
|
||||
#include <ctype.h>
|
||||
|
||||
#include <libgnome/gnome-i18n.h>
|
||||
#include <gst/gst.h>
|
||||
@@ -580,7 +581,15 @@ gst_tcp_socket_write (int socket, const
|
||||
#include <libsoup/soup-headers.h>
|
||||
@@ -435,7 +436,14 @@ rb_daap_src_write (RBDAAPSrc *src, const
|
||||
size_t bytes_written = 0;
|
||||
|
||||
while (bytes_written < count) {
|
||||
- ssize_t wrote = send (socket, buf + bytes_written, count - bytes_written, MSG_NOSIGNAL);
|
||||
- ssize_t wrote = send (src->sock_fd, buf + bytes_written, count - bytes_written, MSG_NOSIGNAL);
|
||||
+ ssize_t wrote;
|
||||
+#ifdef MSG_NOSIGNAL
|
||||
+ wrote = send (socket, buf + bytes_written, count - bytes_written, MSG_NOSIGNAL);
|
||||
+ wrote = send (src->sock_fd, buf + bytes_written, count - bytes_written, MSG_NOSIGNAL);
|
||||
+#else
|
||||
+ signal (SIGPIPE, SIG_IGN);
|
||||
+ wrote = send (socket, buf + bytes_written, count - bytes_written, 0);
|
||||
+ wrote = send (src->sock_fd, buf + bytes_written, count - bytes_written, 0);
|
||||
+ signal (SIGPIPE, SIG_DFL);
|
||||
+#endif
|
||||
+
|
||||
|
||||
if (wrote <= 0) {
|
||||
return bytes_written;
|
||||
if (wrote < 0) {
|
||||
GST_WARNING ("error while writing: %s", g_strerror (errno));
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
===================================================================
|
||||
RCS file: /cvs/gnome/rhythmbox/player/rb-player-gst.c,v
|
||||
retrieving revision 1.51
|
||||
retrieving revision 1.52
|
||||
diff -u -r1.51 -r1.52
|
||||
--- player/rb-player-gst.c 2005/11/30 08:47:21 1.51
|
||||
+++ player/rb-player-gst.c 2005/12/03 10:56:42 1.52
|
||||
@@ -782,7 +782,7 @@
|
||||
|
||||
if (mp->priv->playbin != NULL) {
|
||||
GParamSpec *volume_pspec;
|
||||
- GValue val;
|
||||
+ GValue val = {0,};
|
||||
|
||||
volume_pspec = g_object_class_find_property (G_OBJECT_GET_CLASS (mp->priv->playbin),
|
||||
"volume");
|
|
@ -1,11 +0,0 @@
|
|||
--- shell/main.c.orig Sat Dec 31 14:09:43 2005
|
||||
+++ shell/main.c Sat Dec 31 14:09:54 2005
|
||||
@@ -266,7 +266,7 @@ main (int argc, char **argv)
|
||||
G_TYPE_STRING,
|
||||
"org.gnome.Rhythmbox",
|
||||
G_TYPE_UINT,
|
||||
- DBUS_NAME_FLAG_PROHIBIT_REPLACEMENT,
|
||||
+ DBUS_NAME_FLAG_DO_NOT_QUEUE,
|
||||
G_TYPE_INVALID,
|
||||
G_TYPE_UINT,
|
||||
&request_name_reply,
|
|
@ -4,81 +4,6 @@ libdata/bonobo/servers/GNOME_Rhythmbox.server
|
|||
libdata/bonobo/servers/Rhythmbox_Nautilus_Context_Menu.server
|
||||
libdata/pkgconfig/rhythmbox.pc
|
||||
share/dbus-1/services/org.gnome.Rhythmbox.service
|
||||
%%DOCSDIR%%/ch01.html
|
||||
%%DOCSDIR%%/ch02.html
|
||||
%%DOCSDIR%%/ch03.html
|
||||
%%DOCSDIR%%/ch04.html
|
||||
%%DOCSDIR%%/ch05.html
|
||||
%%DOCSDIR%%/ch06.html
|
||||
%%DOCSDIR%%/ch07.html
|
||||
%%DOCSDIR%%/ch08.html
|
||||
%%DOCSDIR%%/home.png
|
||||
%%DOCSDIR%%/index.html
|
||||
%%DOCSDIR%%/index.sgml
|
||||
%%DOCSDIR%%/left.png
|
||||
%%DOCSDIR%%/rhythmbox-RBCellRendererPixbuf.html
|
||||
%%DOCSDIR%%/rhythmbox-RBSource.html
|
||||
%%DOCSDIR%%/rhythmbox-eel-gconf-extensions.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-cell-renderer-rating.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-debug.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-dialog.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-druid.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-entry-view.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-enums.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-file-helpers.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-glade-helpers.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-header.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-history.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-iradio-source.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-library-source.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-load-failure-dialog.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-metadata.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-new-station-dialog.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-play-order-linear-loop.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-play-order-linear.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-play-order-random-by-age-and-rating.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-play-order-random-by-age.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-play-order-random-by-rating.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-play-order-random-equal-weights.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-play-order-random.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-play-order-shuffle.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-play-order.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-player.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-playlist-manager.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-playlist-source-recorder.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-playlist-source.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-preferences.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-property-view.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-query-creator.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-rating-helper.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-rating.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-recorder.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-search-entry.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-shell-clipboard.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-shell-player.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-shell-preferences.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-shell.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-song-display-box.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-song-info.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-source-header.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-sourcelist-model.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-sourcelist.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-station-properties-dialog.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-statusbar.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-stock-icons.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-string-helpers.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-tray-icon.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-tree-dnd.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-tree-model-sort.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-util.html
|
||||
%%DOCSDIR%%/rhythmbox-rhythmdb-property-model.html
|
||||
%%DOCSDIR%%/rhythmbox-rhythmdb-query-model.html
|
||||
%%DOCSDIR%%/rhythmbox-rhythmdb-tree.html
|
||||
%%DOCSDIR%%/rhythmbox-rhythmdb.html
|
||||
%%DOCSDIR%%/rhythmbox.devhelp
|
||||
%%DOCSDIR%%/right.png
|
||||
%%DOCSDIR%%/style.css
|
||||
%%DOCSDIR%%/up.png
|
||||
share/gnome/application-registry/rhythmbox.applications
|
||||
share/gnome/applications/rhythmbox.desktop
|
||||
share/gnome/help/rhythmbox/C/authors.xml
|
||||
|
@ -175,9 +100,11 @@ share/gnome/rhythmbox/glade/podcast-properties.glade
|
|||
share/gnome/rhythmbox/glade/recorder.glade
|
||||
share/gnome/rhythmbox/glade/song-info-multiple.glade
|
||||
share/gnome/rhythmbox/glade/song-info.glade
|
||||
share/gnome/rhythmbox/glade/station-new.glade
|
||||
share/gnome/rhythmbox/glade/station-properties.glade
|
||||
share/gnome/rhythmbox/glade/uri.glade
|
||||
share/gnome/rhythmbox/iradio-initial.pls
|
||||
share/gnome/rhythmbox/playlists.xml
|
||||
share/gnome/rhythmbox/rhythmbox-ui.xml
|
||||
share/locale/am/LC_MESSAGES/rhythmbox.mo
|
||||
share/locale/ar/LC_MESSAGES/rhythmbox.mo
|
||||
|
@ -234,7 +161,6 @@ share/locale/uk/LC_MESSAGES/rhythmbox.mo
|
|||
share/locale/vi/LC_MESSAGES/rhythmbox.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/rhythmbox.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/rhythmbox.mo
|
||||
@dirrm %%DOCSDIR%%
|
||||
@dirrm share/gnome/rhythmbox/glade
|
||||
@dirrm share/gnome/rhythmbox/art
|
||||
@dirrm share/gnome/rhythmbox
|
||||
|
|
|
@ -7,8 +7,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= rhythmbox
|
||||
PORTVERSION= 0.9.2
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 0.9.3
|
||||
CATEGORIES= audio gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME}
|
||||
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.9
|
||||
|
@ -38,7 +37,8 @@ GCONF_SCHEMAS= rhythmbox.schemas
|
|||
|
||||
OPTIONS= IPOD "Enable iPod support" off \
|
||||
DAAP "Enable iTunes music sharing" off \
|
||||
FAAD "Enable FAAD decoder support" off
|
||||
FAAD "Enable FAAD decoder support" off \
|
||||
NOTIFY "Enable libnotify support" on
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
@ -75,6 +75,12 @@ LIB_DEPENDS+= howl.0:${PORTSDIR}/net/howl
|
|||
CONFIGURE_ARGS+= --disable-daap
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_NOTIFY)
|
||||
LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-libnotify
|
||||
.endif
|
||||
|
||||
pre-everything::
|
||||
.if !defined(WITH_VORBIS)
|
||||
@${ECHO_MSG}
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (gnome2/rhythmbox-0.9.2.tar.bz2) = 533223578c9c37bd72634755b33beab7
|
||||
SHA256 (gnome2/rhythmbox-0.9.2.tar.bz2) = 08e8ee10c0dc48f293b1e58cb5babaac9bfdf2df4e12aea76824ec3c6f4d0340
|
||||
SIZE (gnome2/rhythmbox-0.9.2.tar.bz2) = 2470164
|
||||
MD5 (gnome2/rhythmbox-0.9.3.tar.bz2) = 3ad98939192d44e64982588b15827ffe
|
||||
SHA256 (gnome2/rhythmbox-0.9.3.tar.bz2) = fa8fda4f02391426ee3d854cebf11e6e000dc6f6b9fd96b15b5193cb53140a08
|
||||
SIZE (gnome2/rhythmbox-0.9.3.tar.bz2) = 2510119
|
||||
|
|
|
@ -1,33 +1,18 @@
|
|||
--- configure.orig Mon Nov 28 13:42:56 2005
|
||||
+++ configure Mon Nov 28 13:44:13 2005
|
||||
@@ -22409,7 +22409,7 @@
|
||||
--- configure.orig Thu Feb 2 02:03:39 2006
|
||||
+++ configure Thu Feb 2 02:04:34 2006
|
||||
@@ -21318,9 +21318,9 @@
|
||||
enable_hal02=yes
|
||||
fi
|
||||
fi
|
||||
- if test x$enable_hal05 == xyes || test x$enable_hal02 == xyes; then
|
||||
+ if test x$enable_hal05 = xyes || test x$enable_hal02 = xyes; then
|
||||
enable_hal=yes
|
||||
else
|
||||
enable_hal=no
|
||||
@@ -22426,7 +22426,7 @@
|
||||
_ACEOF
|
||||
|
||||
use_ipod=yes
|
||||
- if test x$enable_hal05 == xyes; then
|
||||
+ if test x$enable_hal05 = xyes; then
|
||||
fi
|
||||
- if test x$enable_hal05 == xyes || test x$enable_hal02 == xyes; then
|
||||
+ if test x$enable_hal05 = xyes || test x$enable_hal02 = xyes; then
|
||||
enable_hal=yes
|
||||
- if test x$enable_hal05 == xyes; then
|
||||
+ if test x$enable_hal05 = xyes; then
|
||||
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
#define HAVE_HAL_0_5 1
|
||||
@@ -22748,7 +22748,7 @@
|
||||
RHYTHMBOX_LIBS="$RHYTHMBOX_LIBS $SOUNDSYSTEM_LIBS"
|
||||
|
||||
|
||||
- if test "x$GST_INSPECT" == "x"; then
|
||||
+ if test "x$GST_INSPECT" = "x"; then
|
||||
# Extract the first word of "gst-inspect-0.8", so it can be a program name with args.
|
||||
set dummy gst-inspect-0.8; ac_word=$2
|
||||
echo "$as_me:$LINENO: checking for $ac_word" >&5
|
||||
@@ -23002,7 +23002,7 @@
|
||||
@@ -22121,7 +22121,7 @@
|
||||
have_avahi_05=yes
|
||||
fi
|
||||
fi
|
||||
|
@ -36,7 +21,7 @@
|
|||
have_avahi=yes
|
||||
else
|
||||
have_avahi=no
|
||||
@@ -23089,7 +23089,7 @@
|
||||
@@ -22208,7 +22208,7 @@
|
||||
|
||||
{ echo "$as_me:$LINENO: Detected Avahi, using it for mDNS/DNS-SD" >&5
|
||||
echo "$as_me: Detected Avahi, using it for mDNS/DNS-SD" >&6;}
|
||||
|
@ -45,7 +30,7 @@
|
|||
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
#define HAVE_AVAHI_0_6 1
|
||||
@@ -23156,7 +23156,7 @@
|
||||
@@ -22275,7 +22275,7 @@
|
||||
{ echo "$as_me:$LINENO: Using Avahi for mDNS/DNS-SD" >&5
|
||||
echo "$as_me: Using Avahi for mDNS/DNS-SD" >&6;}
|
||||
|
||||
|
@ -54,7 +39,7 @@
|
|||
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
#define HAVE_AVAHI_0_6 1
|
||||
@@ -23811,7 +23811,7 @@
|
||||
@@ -23069,7 +23069,7 @@
|
||||
|
||||
|
||||
if test x"$x_includes" != x"NONE" && test -n "$x_includes" ; then
|
||||
|
|
|
@ -1,27 +1,26 @@
|
|||
--- daapsharing/rb-daap-src.c.orig Sun Oct 16 05:50:21 2005
|
||||
+++ daapsharing/rb-daap-src.c Mon Oct 17 10:30:20 2005
|
||||
--- daapsharing/rb-daap-src.c.orig Fri Jan 27 21:11:13 2006
|
||||
+++ daapsharing/rb-daap-src.c Thu Feb 2 02:07:48 2006
|
||||
@@ -34,6 +34,7 @@
|
||||
#include <sys/ioctl.h>
|
||||
#include <netdb.h>
|
||||
#include <unistd.h>
|
||||
+#include <signal.h>
|
||||
#include <ctype.h>
|
||||
|
||||
#include <libgnome/gnome-i18n.h>
|
||||
#include <gst/gst.h>
|
||||
@@ -580,7 +581,15 @@ gst_tcp_socket_write (int socket, const
|
||||
#include <libsoup/soup-headers.h>
|
||||
@@ -435,7 +436,14 @@ rb_daap_src_write (RBDAAPSrc *src, const
|
||||
size_t bytes_written = 0;
|
||||
|
||||
while (bytes_written < count) {
|
||||
- ssize_t wrote = send (socket, buf + bytes_written, count - bytes_written, MSG_NOSIGNAL);
|
||||
- ssize_t wrote = send (src->sock_fd, buf + bytes_written, count - bytes_written, MSG_NOSIGNAL);
|
||||
+ ssize_t wrote;
|
||||
+#ifdef MSG_NOSIGNAL
|
||||
+ wrote = send (socket, buf + bytes_written, count - bytes_written, MSG_NOSIGNAL);
|
||||
+ wrote = send (src->sock_fd, buf + bytes_written, count - bytes_written, MSG_NOSIGNAL);
|
||||
+#else
|
||||
+ signal (SIGPIPE, SIG_IGN);
|
||||
+ wrote = send (socket, buf + bytes_written, count - bytes_written, 0);
|
||||
+ wrote = send (src->sock_fd, buf + bytes_written, count - bytes_written, 0);
|
||||
+ signal (SIGPIPE, SIG_DFL);
|
||||
+#endif
|
||||
+
|
||||
|
||||
if (wrote <= 0) {
|
||||
return bytes_written;
|
||||
if (wrote < 0) {
|
||||
GST_WARNING ("error while writing: %s", g_strerror (errno));
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
===================================================================
|
||||
RCS file: /cvs/gnome/rhythmbox/player/rb-player-gst.c,v
|
||||
retrieving revision 1.51
|
||||
retrieving revision 1.52
|
||||
diff -u -r1.51 -r1.52
|
||||
--- player/rb-player-gst.c 2005/11/30 08:47:21 1.51
|
||||
+++ player/rb-player-gst.c 2005/12/03 10:56:42 1.52
|
||||
@@ -782,7 +782,7 @@
|
||||
|
||||
if (mp->priv->playbin != NULL) {
|
||||
GParamSpec *volume_pspec;
|
||||
- GValue val;
|
||||
+ GValue val = {0,};
|
||||
|
||||
volume_pspec = g_object_class_find_property (G_OBJECT_GET_CLASS (mp->priv->playbin),
|
||||
"volume");
|
|
@ -1,11 +0,0 @@
|
|||
--- shell/main.c.orig Sat Dec 31 14:09:43 2005
|
||||
+++ shell/main.c Sat Dec 31 14:09:54 2005
|
||||
@@ -266,7 +266,7 @@ main (int argc, char **argv)
|
||||
G_TYPE_STRING,
|
||||
"org.gnome.Rhythmbox",
|
||||
G_TYPE_UINT,
|
||||
- DBUS_NAME_FLAG_PROHIBIT_REPLACEMENT,
|
||||
+ DBUS_NAME_FLAG_DO_NOT_QUEUE,
|
||||
G_TYPE_INVALID,
|
||||
G_TYPE_UINT,
|
||||
&request_name_reply,
|
|
@ -4,81 +4,6 @@ libdata/bonobo/servers/GNOME_Rhythmbox.server
|
|||
libdata/bonobo/servers/Rhythmbox_Nautilus_Context_Menu.server
|
||||
libdata/pkgconfig/rhythmbox.pc
|
||||
share/dbus-1/services/org.gnome.Rhythmbox.service
|
||||
%%DOCSDIR%%/ch01.html
|
||||
%%DOCSDIR%%/ch02.html
|
||||
%%DOCSDIR%%/ch03.html
|
||||
%%DOCSDIR%%/ch04.html
|
||||
%%DOCSDIR%%/ch05.html
|
||||
%%DOCSDIR%%/ch06.html
|
||||
%%DOCSDIR%%/ch07.html
|
||||
%%DOCSDIR%%/ch08.html
|
||||
%%DOCSDIR%%/home.png
|
||||
%%DOCSDIR%%/index.html
|
||||
%%DOCSDIR%%/index.sgml
|
||||
%%DOCSDIR%%/left.png
|
||||
%%DOCSDIR%%/rhythmbox-RBCellRendererPixbuf.html
|
||||
%%DOCSDIR%%/rhythmbox-RBSource.html
|
||||
%%DOCSDIR%%/rhythmbox-eel-gconf-extensions.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-cell-renderer-rating.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-debug.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-dialog.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-druid.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-entry-view.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-enums.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-file-helpers.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-glade-helpers.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-header.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-history.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-iradio-source.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-library-source.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-load-failure-dialog.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-metadata.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-new-station-dialog.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-play-order-linear-loop.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-play-order-linear.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-play-order-random-by-age-and-rating.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-play-order-random-by-age.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-play-order-random-by-rating.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-play-order-random-equal-weights.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-play-order-random.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-play-order-shuffle.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-play-order.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-player.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-playlist-manager.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-playlist-source-recorder.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-playlist-source.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-preferences.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-property-view.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-query-creator.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-rating-helper.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-rating.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-recorder.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-search-entry.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-shell-clipboard.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-shell-player.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-shell-preferences.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-shell.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-song-display-box.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-song-info.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-source-header.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-sourcelist-model.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-sourcelist.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-station-properties-dialog.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-statusbar.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-stock-icons.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-string-helpers.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-tray-icon.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-tree-dnd.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-tree-model-sort.html
|
||||
%%DOCSDIR%%/rhythmbox-rb-util.html
|
||||
%%DOCSDIR%%/rhythmbox-rhythmdb-property-model.html
|
||||
%%DOCSDIR%%/rhythmbox-rhythmdb-query-model.html
|
||||
%%DOCSDIR%%/rhythmbox-rhythmdb-tree.html
|
||||
%%DOCSDIR%%/rhythmbox-rhythmdb.html
|
||||
%%DOCSDIR%%/rhythmbox.devhelp
|
||||
%%DOCSDIR%%/right.png
|
||||
%%DOCSDIR%%/style.css
|
||||
%%DOCSDIR%%/up.png
|
||||
share/gnome/application-registry/rhythmbox.applications
|
||||
share/gnome/applications/rhythmbox.desktop
|
||||
share/gnome/help/rhythmbox/C/authors.xml
|
||||
|
@ -175,9 +100,11 @@ share/gnome/rhythmbox/glade/podcast-properties.glade
|
|||
share/gnome/rhythmbox/glade/recorder.glade
|
||||
share/gnome/rhythmbox/glade/song-info-multiple.glade
|
||||
share/gnome/rhythmbox/glade/song-info.glade
|
||||
share/gnome/rhythmbox/glade/station-new.glade
|
||||
share/gnome/rhythmbox/glade/station-properties.glade
|
||||
share/gnome/rhythmbox/glade/uri.glade
|
||||
share/gnome/rhythmbox/iradio-initial.pls
|
||||
share/gnome/rhythmbox/playlists.xml
|
||||
share/gnome/rhythmbox/rhythmbox-ui.xml
|
||||
share/locale/am/LC_MESSAGES/rhythmbox.mo
|
||||
share/locale/ar/LC_MESSAGES/rhythmbox.mo
|
||||
|
@ -234,7 +161,6 @@ share/locale/uk/LC_MESSAGES/rhythmbox.mo
|
|||
share/locale/vi/LC_MESSAGES/rhythmbox.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/rhythmbox.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/rhythmbox.mo
|
||||
@dirrm %%DOCSDIR%%
|
||||
@dirrm share/gnome/rhythmbox/glade
|
||||
@dirrm share/gnome/rhythmbox/art
|
||||
@dirrm share/gnome/rhythmbox
|
||||
|
|
Loading…
Reference in a new issue