pev is a multiplatform PE analysis toolkit that
includes tools to retrieve and parsing information about Windows PE files. PR: ports/173390 Submitted by: Danilo Egea Gondolfo <danilogondolfo@gmail.com> Feature safe: yes
This commit is contained in:
parent
3488c13e39
commit
02595801c1
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=307087
8 changed files with 114 additions and 0 deletions
|
@ -656,6 +656,7 @@
|
|||
SUBDIR += pecl-ssh2
|
||||
SUBDIR += pecl-taint
|
||||
SUBDIR += pecl-tcpwrap
|
||||
SUBDIR += pev
|
||||
SUBDIR += pft
|
||||
SUBDIR += pgp
|
||||
SUBDIR += pgpdump
|
||||
|
|
23
security/pev/Makefile
Normal file
23
security/pev/Makefile
Normal file
|
@ -0,0 +1,23 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= pev
|
||||
PORTVERSION= 0.60
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION}/
|
||||
|
||||
MAINTAINER= danilogondolfo@gmail.com
|
||||
COMMENT= The PE analysis toolkit
|
||||
|
||||
LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
PATCH_STRIP= -p1
|
||||
|
||||
MAN1= readpe.1 pedis.1 pepack.1 pescan.1 \
|
||||
rva2ofs.1 pesec.1 ofs2rva.1 pestr.1 pehash.1
|
||||
|
||||
MANCOMPRESSED= yes
|
||||
|
||||
.include <bsd.port.mk>
|
2
security/pev/distinfo
Normal file
2
security/pev/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (pev-0.60.tar.gz) = 133d4698a25f3b40b95f203d30ddea5895b41db2c8cb7724433cc4ce165c2b43
|
||||
SIZE (pev-0.60.tar.gz) = 216584
|
11
security/pev/files/patch-pev-0.60-a__Makefile
Normal file
11
security/pev/files/patch-pev-0.60-a__Makefile
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- pev-0.60-b/Makefile 2012-11-01 20:32:45.016065672 -0200
|
||||
+++ pev-0.60-a/Makefile 2012-11-01 20:32:59.815066896 -0200
|
||||
@@ -1,6 +1,6 @@
|
||||
LIBPE_DIR = lib/libpe
|
||||
PEV_DIR = src
|
||||
-MAKE = make
|
||||
+MAKE = gmake
|
||||
VERSION = 0.60
|
||||
ZIPFILE = pev.zip
|
||||
|
||||
diff -ur pev-0.60-b/lib/libpe/Makefile pev-0.60-a/lib/libpe/Makefile
|
28
security/pev/files/patch-pev-0.60-a__lib__libpe__Makefile
Normal file
28
security/pev/files/patch-pev-0.60-a__lib__libpe__Makefile
Normal file
|
@ -0,0 +1,28 @@
|
|||
--- pev-0.60-b/lib/libpe/Makefile 2012-11-01 20:32:45.004068869 -0200
|
||||
+++ pev-0.60-a/lib/libpe/Makefile 2012-11-01 20:37:48.321666630 -0200
|
||||
@@ -5,10 +5,10 @@
|
||||
|
||||
####### Compiler, tools and options
|
||||
|
||||
-PREFIX = /usr
|
||||
+PREFIX = /usr/local
|
||||
DEST = $(DESTDIR)/$(PREFIX)/lib
|
||||
VERSION = 1.0
|
||||
-override CFLAGS += -W -Wall -Wextra -pedantic -std=c99 -c
|
||||
+override CFLAGS += -W -Wall -Wextra -pedantic -std=c99 -shared -o libpe.so
|
||||
ifneq ($(PLATFORM_OS), CYGWIN)
|
||||
override CFLAGS += -fPIC
|
||||
endif
|
||||
@@ -46,6 +46,11 @@
|
||||
$(INSTALL) $(LIBNAME).so $(DEST)/$(LIBNAME).so.$(VERSION)
|
||||
cd $(DEST); $(SYMLINK) $(LIBNAME).so.$(VERSION) $(LIBNAME).so
|
||||
cd $(DEST); $(SYMLINK) $(LIBNAME).so.$(VERSION) $(LIBNAME).so.1
|
||||
+else ifeq ($(PLATFORM_OS), FreeBSD)
|
||||
+ $(STRIP) $(LIBNAME).so
|
||||
+ $(INSTALL) $(LIBNAME).so $(DEST)/$(LIBNAME).so.$(VERSION)
|
||||
+ cd $(DEST); $(SYMLINK) $(LIBNAME).so.$(VERSION) $(LIBNAME).so
|
||||
+ cd $(DEST); $(SYMLINK) $(LIBNAME).so.$(VERSION) $(LIBNAME).so.1
|
||||
else ifeq ($(PLATFORM_OS), Darwin)
|
||||
$(STRIP) $(LIBNAME).dylib
|
||||
$(INSTALL) $(LIBNAME).dylib $(DEST)/$(LIBNAME).$(VERSION).dylib
|
||||
diff -ur pev-0.60-b/src/Makefile pev-0.60-a/src/Makefile
|
30
security/pev/files/patch-pev-0.60-a__src__Makefile
Normal file
30
security/pev/files/patch-pev-0.60-a__src__Makefile
Normal file
|
@ -0,0 +1,30 @@
|
|||
--- pev-0.60-b/src/Makefile 2012-11-01 20:32:45.009065928 -0200
|
||||
+++ pev-0.60-a/src/Makefile 2012-11-01 20:49:16.857787046 -0200
|
||||
@@ -5,12 +5,12 @@
|
||||
|
||||
####### Compiler, tools and options
|
||||
|
||||
-PREFIX = /usr
|
||||
+PREFIX = /usr/local
|
||||
DEST = $(DESTDIR)/$(PREFIX)/bin
|
||||
LIBPE = ../lib/libpe
|
||||
LIBUDIS86 = ../lib/libudis86
|
||||
-override LDFLAGS += -L$(LIBPE) -lpe
|
||||
-override CFLAGS += -I$(LIBPE) -W -Wall -Wextra -std=c99 -pedantic
|
||||
+override LDFLAGS += -L/usr/local/lib -L$(LIBPE) -lpe
|
||||
+override CFLAGS += -I/usr/local/include -I$(LIBPE) -W -Wall -Wextra -std=c99 -pedantic
|
||||
ifeq ($(PLATFORM_OS), Darwin)
|
||||
# We disable warnings for deprecated declarations since Apple deprecated OpenSSL in Mac OS X 10.7
|
||||
override CFLAGS += -Wno-deprecated-declarations
|
||||
@@ -20,9 +20,9 @@
|
||||
SOURCES = output.c
|
||||
PROGS = readpe pedis pepack pescan rva2ofs pesec ofs2rva pestr pehash pestr
|
||||
INSTALL = install -m 0755
|
||||
-SHAREDIR = /usr/share/pev
|
||||
+SHAREDIR = /usr/local/share/pev
|
||||
MAN = ../doc/manpages
|
||||
-MANDIR = /usr/share/man/man1
|
||||
+MANDIR = /usr/local/man/man1
|
||||
|
||||
####### Build rules
|
||||
|
5
security/pev/pkg-descr
Normal file
5
security/pev/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
pev is a multiplatform PE analysis toolkit that
|
||||
includes tools to retrieve and parsing information
|
||||
about Windows PE files.
|
||||
|
||||
WWW: http://sourceforge.net/projects/pev/
|
14
security/pev/pkg-plist
Normal file
14
security/pev/pkg-plist
Normal file
|
@ -0,0 +1,14 @@
|
|||
bin/readpe
|
||||
bin/pedis
|
||||
bin/pepack
|
||||
bin/pescan
|
||||
bin/rva2ofs
|
||||
bin/pesec
|
||||
bin/ofs2rva
|
||||
bin/pestr
|
||||
bin/pehash
|
||||
lib/libpe.so
|
||||
lib/libpe.so.1
|
||||
lib/libpe.so.1.0
|
||||
%%DATADIR%%/userdb.txt
|
||||
@dirrm share/pev
|
Loading…
Reference in a new issue