misc/py-synced-collections: New port: Interact with persistent key-value stores using Pythonic abstractions

This commit is contained in:
Yuri Victorovich 2023-07-12 23:44:16 -07:00
parent 3f5d9130a4
commit 02c179d799
5 changed files with 47 additions and 0 deletions

View file

@ -467,6 +467,7 @@
SUBDIR += py-spdx-lookup
SUBDIR += py-spdx-tools
SUBDIR += py-spinners
SUBDIR += py-synced-collections
SUBDIR += py-tes
SUBDIR += py-tflearn
SUBDIR += py-tflite

View file

@ -0,0 +1,25 @@
PORTNAME= synced-collections
DISTVERSION= 1.0.0
CATEGORIES= misc
MASTER_SITES= PYPI # some test files are missing in the PYPI tarball
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME:S/-/_/}-${DISTVERSION}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Interact with persistent key-value stores using Pythonic abstractions
WWW= https://signac.io/
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= ${PY_SETUPTOOLS} \
${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
USES= python
USE_PYTHON= pep517 autoplist pytest # tests fail because of missing packages xx_test, unclear where tp report
NO_ARCH= yes
TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
TIMESTAMP = 1689230043
SHA256 (synced_collections-1.0.0.tar.gz) = c5c72df4074ce95625f155d8bc1ac608ba4d9fbb0fffde4da3c0e3a88a1e30bd
SIZE (synced_collections-1.0.0.tar.gz) = 48819

View file

@ -0,0 +1,11 @@
--- pyproject.toml.orig 2023-07-13 06:36:28 UTC
+++ pyproject.toml
@@ -3,7 +3,7 @@
# This software is licensed under the BSD 3-Clause License.
[build-system]
build-backend = "setuptools.build_meta"
-requires = ["setuptools>=64.0.0"]
+requires = ["setuptools"]
[project]
name = "synced_collections"

View file

@ -0,0 +1,7 @@
The synced_collections package provides Pythonic abstractions over various
underlying data stores, presenting APIs that behave like standard built-in
Python collections like dicts. synced_collections form the backbone of
signac's data and metadata storage, but may be used just as easily outside
of signac. For instance, users wishing to access a JSON file on disk like a
dictionary and automatically persist all changes could use the
synced_collections.JSONDict.