This is the commit message, please edit it.
2019-01-04 net/ssltunnel-server: Does not build, upstream disappeared 2019-01-04 lang/cilkplus: Cilk Plus is on its way out (both in GCC and the Intel compilers) net/ssltunnel-client: client part of expired net/ssltunnel-server
This commit is contained in:
parent
d391416181
commit
02c5ac36ee
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=489339
19 changed files with 3 additions and 319 deletions
3
MOVED
3
MOVED
|
@ -11553,3 +11553,6 @@ multimedia/phonon-vlc@qt4||2019-01-02|vlc-qt4 has been removed, vlc now always u
|
|||
multimedia/phonon-vlc@qt5|multimedia/phonon-vlc|2019-01-02|vlc-qt4 has been removed, vlc now always uses qt5
|
||||
multimedia/vlc3|multimedia/vlc|2019-01-03|multimedia/vlc updated to supported upstream branch (previously vlc3)
|
||||
databases/php7-tarantool|databases/php-tarantool|2019-01-03|Rename php7-tarantool to php-tarantool after php5-tarantool removal
|
||||
net/ssltunnel-server||2019-01-05|Has expired: Does not build, upstream disappeared
|
||||
lang/cilkplus||2019-01-05|Has expired: Cilk Plus is on its way out (both in GCC and the Intel compilers)
|
||||
net/ssltunnel-client||2019-01-05|Removed, client part of expired net/ssltunnel-server
|
||||
|
|
|
@ -33,7 +33,6 @@
|
|||
SUBDIR += chibi-scheme
|
||||
SUBDIR += chicken
|
||||
SUBDIR += chicken5
|
||||
SUBDIR += cilkplus
|
||||
SUBDIR += cim
|
||||
SUBDIR += cint
|
||||
SUBDIR += cjs
|
||||
|
|
|
@ -1,31 +0,0 @@
|
|||
# Created by: Pedro Giffuni
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= cilkplus
|
||||
PORTVERSION= 20160603
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= lang devel
|
||||
MASTER_SITES= https://www.cilkplus.org/sites/default/files/runtime_source/
|
||||
PKGNAMESUFFIX= -rtl
|
||||
DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${HG_REVISION}
|
||||
|
||||
MAINTAINER= pfg@FreeBSD.org
|
||||
COMMENT= Intel Cilk Runtime
|
||||
|
||||
LICENSE= BSD3CLAUSE
|
||||
|
||||
DEPRECATED= Cilk Plus is on its way out (both in GCC and the Intel compilers)
|
||||
EXPIRATION_DATE=2019-01-04
|
||||
|
||||
ONLY_FOR_ARCHS= amd64 i386 sparc64
|
||||
|
||||
HG_REVISION= 004467
|
||||
|
||||
USE_GCC= 7 # GCC 8 removed CilkPlus support
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}${PKGNAMESUFFIX}-src-${HG_REVISION}
|
||||
|
||||
USES= tar:tgz cmake
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,3 +0,0 @@
|
|||
TIMESTAMP = 1472758796
|
||||
SHA256 (cilkplus-rtl-004467.tgz) = e3cc83e42afe34c03da7938b79cdebc3b7f3237d3734a4d45c9ad91d7abe475e
|
||||
SIZE (cilkplus-rtl-004467.tgz) = 447080
|
|
@ -1,18 +0,0 @@
|
|||
--- runtime/declare-alloca.h.orig 2016-06-01 19:59:38 UTC
|
||||
+++ runtime/declare-alloca.h
|
||||
@@ -53,10 +53,14 @@
|
||||
* be wrong. Here's a variant on what's recommended in the autoconf doc
|
||||
*/
|
||||
|
||||
+#include <sys/param.h>
|
||||
+
|
||||
#if defined _MSC_VER
|
||||
# include <malloc.h>
|
||||
# define alloca _alloca
|
||||
-#elif defined HAVE_ALLOCA_H
|
||||
+#elif defined BSD4_4
|
||||
+# include <stdlib.h>
|
||||
+#elif defined HAVE_ALLOCA_H
|
||||
# include <alloca.h>
|
||||
#elif defined __GNUC__
|
||||
# define alloca __builtin_alloca
|
|
@ -1,24 +0,0 @@
|
|||
Intel Cilk Plus is an extension to the C and C++ languages to support data
|
||||
and task parallelism.
|
||||
|
||||
Primary Features
|
||||
|
||||
High Performance:
|
||||
* An efficient work-stealing scheduler provides nearly optimal
|
||||
scheduling of parallel tasks
|
||||
* Vector support unlocks the performance that's been hiding in your
|
||||
processors
|
||||
* Powerful hyperobjects allow for lock-free programming
|
||||
Easy to Learn:
|
||||
* Only 3 new keywords to implement task parallelism
|
||||
* Serial semantics make understanding and debugging the parallel
|
||||
program easier
|
||||
*Array Notations provide a natural way to express data parallelism
|
||||
Easy to Use:
|
||||
* Automatic load balancing provides good behavior in multi-programmed
|
||||
environments
|
||||
* Existing algorithms easily adapted for parallelism with minimal
|
||||
modification
|
||||
* Supports both C and C++ programmers
|
||||
|
||||
WWW: https://www.cilkplus.org/
|
|
@ -1,26 +0,0 @@
|
|||
include/cilk/cilk.h
|
||||
include/cilk/cilk_api.h
|
||||
include/cilk/cilk_api_linux.h
|
||||
include/cilk/cilk_stub.h
|
||||
include/cilk/cilk_undocumented.h
|
||||
include/cilk/common.h
|
||||
include/cilk/holder.h
|
||||
include/cilk/hyperobject_base.h
|
||||
include/cilk/metaprogramming.h
|
||||
include/cilk/reducer.h
|
||||
include/cilk/reducer_file.h
|
||||
include/cilk/reducer_list.h
|
||||
include/cilk/reducer_max.h
|
||||
include/cilk/reducer_min.h
|
||||
include/cilk/reducer_min_max.h
|
||||
include/cilk/reducer_opadd.h
|
||||
include/cilk/reducer_opand.h
|
||||
include/cilk/reducer_opmul.h
|
||||
include/cilk/reducer_opor.h
|
||||
include/cilk/reducer_opxor.h
|
||||
include/cilk/reducer_ostream.h
|
||||
include/cilk/reducer_string.h
|
||||
include/cilk/reducer_vector.h
|
||||
lib/libcilkrts.a
|
||||
lib/libcilkrts.so
|
||||
lib/libcilkrts.so.5
|
|
@ -1388,8 +1388,6 @@
|
|||
SUBDIR += sshping
|
||||
SUBDIR += ssldump
|
||||
SUBDIR += sslh
|
||||
SUBDIR += ssltunnel-client
|
||||
SUBDIR += ssltunnel-server
|
||||
SUBDIR += ssmping
|
||||
SUBDIR += ssspl
|
||||
SUBDIR += ssvnc
|
||||
|
|
|
@ -1,48 +0,0 @@
|
|||
# Created by: at@rominet.net
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ssltunnel
|
||||
PORTVERSION= 1.18
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://www.hsc.fr/ressources/outils/ssltunnel/download/
|
||||
PKGNAMESUFFIX= -client
|
||||
|
||||
MAINTAINER= crees@FreeBSD.org
|
||||
COMMENT= PPP over SSL virtual private networking (client part)
|
||||
|
||||
LICENSE= BSD3CLAUSE
|
||||
|
||||
OPTIONS_DEFINE= GUI DOCS
|
||||
GUI_DESC= GTK 1.2 graphical interface
|
||||
|
||||
CONFIGURE_ARGS= --disable-server \
|
||||
--with-iconv=${ICONV_PREFIX} \
|
||||
--with-openssl=${OPENSSLBASE}
|
||||
GNU_CONFIGURE= yes
|
||||
USES= iconv ssl
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MGUI}
|
||||
USE_GNOME= gtk12
|
||||
USES+= perl5
|
||||
RUN_DEPENDS= p5-Gtk>=0:x11-toolkits/p5-Gtk
|
||||
PLIST_SUB+= PERLGTK=""
|
||||
.else
|
||||
PLIST_SUB+= PERLGTK="@comment "
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's|with_iconv|with-iconv|g' ${WRKSRC}/configure
|
||||
|
||||
post-install:
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/LISEZ-MOI \
|
||||
${STAGEDIR}${DOCSDIR}/client.LISEZ-MOI
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/client.README
|
||||
${MKDIR} ${STAGEDIR}${ETCDIR}/
|
||||
${INSTALL_DATA} ${WRKSRC}/client/tunnel.conf \
|
||||
${STAGEDIR}${ETCDIR}/client.conf.sample
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (ssltunnel-1.18.tar.gz) = 1d2e4bbc935341775e7cc26dae980d6bdd5e8351f5a0cbf4d85363ac5d71081f
|
||||
SIZE (ssltunnel-1.18.tar.gz) = 132302
|
|
@ -1,43 +0,0 @@
|
|||
--- client/ntlmauth.c.orig 2009-02-05 15:32:12 UTC
|
||||
+++ client/ntlmauth.c
|
||||
@@ -56,7 +56,7 @@ extern int write_timeout(int s, char *b
|
||||
extern int read_timeout(int s, char *buffer, int size, int tmo);
|
||||
extern void do_log( int prio, char *format , ...);
|
||||
|
||||
-static void setup_des_key(unsigned char *key56, des_key_schedule *ks);
|
||||
+static void setup_des_key(unsigned char *key56, DES_key_schedule *ks);
|
||||
static void calc_resp(unsigned char *keys, unsigned char *plaintext, unsigned char *results);
|
||||
static char *do_ntlm_auth_1(char *username, char *password);
|
||||
static char *do_ntlm_auth_2(iconv_t myiconv, char *username, char *password, char *challenge);
|
||||
@@ -156,8 +156,8 @@ static char *do_ntlm_auth_2(iconv_t myic
|
||||
unsigned char *nt_pw = NULL,*lm_resp,*nt_resp;
|
||||
const unsigned char magic[] = "KGS!@#$%";
|
||||
unsigned char lm_hpw[50];
|
||||
- des_key_schedule ks1;
|
||||
- des_key_schedule ks2;
|
||||
+ DES_key_schedule ks1;
|
||||
+ DES_key_schedule ks2;
|
||||
unsigned char nt_hpw[50];
|
||||
MD4_CTX context;
|
||||
unsigned short server_flags;
|
||||
@@ -558,9 +558,9 @@ catch:
|
||||
* turns a 56 bit key into the 64 bit, odd parity key and sets the key.
|
||||
* The key schedule ks is also set.
|
||||
*/
|
||||
-static void setup_des_key(unsigned char key_56[], des_key_schedule *ks)
|
||||
+static void setup_des_key(unsigned char key_56[], DES_key_schedule *ks)
|
||||
{
|
||||
- des_cblock key;
|
||||
+ DES_cblock key;
|
||||
|
||||
key[0] = key_56[0];
|
||||
key[1] = ((key_56[0] << 7) & 0xFF) | (key_56[1] >> 1);
|
||||
@@ -582,7 +582,7 @@ static void setup_des_key(unsigned char
|
||||
*/
|
||||
static void calc_resp(unsigned char *keys, unsigned char *plaintext, unsigned char *results)
|
||||
{
|
||||
- des_key_schedule ks;
|
||||
+ DES_key_schedule ks;
|
||||
|
||||
setup_des_key(keys, &ks);
|
||||
DES_ecb_encrypt((const_DES_cblock *) plaintext, (const_DES_cblock *) results, &ks, DES_ENCRYPT);
|
|
@ -1,9 +0,0 @@
|
|||
ssltunnel is a client/server software to establish PPP links over
|
||||
SSL/TLS sessions. Client and server are mutually authenticated using
|
||||
X509 certificates, PPP packets are encrypted/decrypted realtime on
|
||||
each side. The client has the ability to initiate the connection
|
||||
through an HTTP/HTTPS relay, even if an authentification is needed.
|
||||
|
||||
This is the client part.
|
||||
|
||||
WWW: http://www.hsc.fr/ressources/outils/ssltunnel/
|
|
@ -1,7 +0,0 @@
|
|||
bin/pppclient
|
||||
%%PERLGTK%%bin/gpppclient
|
||||
@sample %%ETCDIR%%/client.conf.sample
|
||||
man/man1/pppclient.1.gz
|
||||
man/man5/ssltunnelrc.5.gz
|
||||
%%PORTDOCS%%%%DOCSDIR%%/client.LISEZ-MOI
|
||||
%%PORTDOCS%%%%DOCSDIR%%/client.README
|
|
@ -1,50 +0,0 @@
|
|||
# Created by: at@rominet.net
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ssltunnel
|
||||
PORTVERSION= 1.18
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://www.hsc.fr/ressources/outils/ssltunnel/download/
|
||||
PKGNAMESUFFIX= -server
|
||||
|
||||
MAINTAINER= crees@FreeBSD.org
|
||||
COMMENT= PPP over SSL virtual private networking (server part)
|
||||
|
||||
BROKEN= Does not build
|
||||
DEPRECATED= Does not build, upstream disappeared
|
||||
EXPIRATION_DATE= 2019-01-04
|
||||
|
||||
LICENSE= BSD3CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
OPTIONS_DEFINE= TCPWRAPPERS DOCS
|
||||
TCPWRAPPERS_DESC= libwrap support
|
||||
|
||||
TCPWRAPPERS_CONFIGURE_ON= --with-libwrap
|
||||
|
||||
USES= ssl
|
||||
USE_RC_SUBR= ${PORTNAME}
|
||||
SUB_FILES+= pkg-message
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --disable-client
|
||||
CFLAGS+= -I${OPENSSLINC}
|
||||
LDFLAGS+= -L${OPENSSLLIB}
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's^#include <utmp.h>^/*utmp.h not for FreeBSD*/^' \
|
||||
${WRKSRC}/server/main.c \
|
||||
${WRKSRC}/server/pppwho.c \
|
||||
${WRKSRC}/server/sessions.c
|
||||
@${REINPLACE_CMD} -e 's^sbin/pppd^sbin/ppp^g' ${WRKSRC}/server/users
|
||||
@${AWK} '{print}/ppp/ { print "args -direct" }' \
|
||||
${WRKSRC}/server/users > ${WRKSRC}/server/users.new
|
||||
|
||||
post-install:
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${MV} ${STAGEDIR}${ETCDIR}/tunnel.conf.default ${STAGEDIR}${ETCDIR}/tunnel.conf.sample
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/server.README
|
||||
${INSTALL_DATA} ${WRKSRC}/LISEZ-MOI ${STAGEDIR}${DOCSDIR}/server.LISEZ-MOI
|
||||
${INSTALL_DATA} ${WRKSRC}/server/users.new ${STAGEDIR}${ETCDIR}/users.sample
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (ssltunnel-1.18.tar.gz) = 1d2e4bbc935341775e7cc26dae980d6bdd5e8351f5a0cbf4d85363ac5d71081f
|
||||
SIZE (ssltunnel-1.18.tar.gz) = 132302
|
|
@ -1,11 +0,0 @@
|
|||
All ppp parameters that were to go into %%ETCDIR%%/users should
|
||||
go to /etc/ppp/ppp.conf for example:
|
||||
|
||||
default:
|
||||
# set log Phase Chat LCP IPCP CCP tun command
|
||||
set log Phase tun
|
||||
ident user-ppp VERSION
|
||||
set timeout 0
|
||||
enable echo
|
||||
disable ipv6cp
|
||||
set ifaddr 192.168.230.13:192.168.230.20
|
|
@ -1,26 +0,0 @@
|
|||
#!/bin/sh
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
# PROVIDE: ssltunnel
|
||||
# REQUIRE: LOGIN
|
||||
# KEYWORD: shutdown
|
||||
#
|
||||
# To enable ssltunnel, add the following line to rc.conf:
|
||||
# ssltunnel_enable=yes
|
||||
|
||||
. /etc/rc.subr
|
||||
|
||||
name=ssltunnel
|
||||
rcvar=ssltunnel_enable
|
||||
|
||||
load_rc_config ssltunnel
|
||||
|
||||
: ${ssltunnel_enable:=yes}
|
||||
|
||||
command="%%PREFIX%%/libexec/pppserver"
|
||||
command_args="%%ETCDIR%%/tunnel.conf"
|
||||
required_files="%%ETCDIR%%/tunnel.conf"
|
||||
pidfile=/var/run/pppserver.pid
|
||||
|
||||
run_rc_command $1
|
|
@ -1,9 +0,0 @@
|
|||
ssltunnel is a client/server software to establish PPP links over
|
||||
SSL/TLS sessions. Client and server are mutually authenticated using
|
||||
X509 certificates, PPP packets are encrypted/decrypted realtime on
|
||||
each side. The client has the ability to initiate the connection
|
||||
through an HTTP/HTTPS relay, even if an authentification is needed.
|
||||
|
||||
This is the server part.
|
||||
|
||||
WWW: http://www.hsc.fr/ressources/outils/ssltunnel/
|
|
@ -1,7 +0,0 @@
|
|||
@unexec if cmp -s %D/%%ETCDIR%%/users %D/%%ETCDIR%%/users.sample; then rm -f %D/%%ETCDIR%%/users; fi
|
||||
@sample %%ETCDIR%%/tunnel.conf.sample
|
||||
%%ETCDIR%%/users.sample
|
||||
libexec/pppserver
|
||||
sbin/pppwho
|
||||
%%PORTDOCS%%%%DOCSDIR%%/server.LISEZ-MOI
|
||||
%%PORTDOCS%%%%DOCSDIR%%/server.README
|
Loading…
Reference in a new issue