Add rtpproxy - a high-performance RTP proxy server for the SIP
Express Router (SER) or OpenSER.
This commit is contained in:
parent
dea0c173ed
commit
02cff2632a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=214993
6 changed files with 70 additions and 0 deletions
|
@ -793,6 +793,7 @@
|
|||
SUBDIR += rsync
|
||||
SUBDIR += rtg
|
||||
SUBDIR += rtpbreak
|
||||
SUBDIR += rtpproxy
|
||||
SUBDIR += ruby-dict
|
||||
SUBDIR += ruby-icmp
|
||||
SUBDIR += ruby-ldap
|
||||
|
|
31
net/rtpproxy/Makefile
Normal file
31
net/rtpproxy/Makefile
Normal file
|
@ -0,0 +1,31 @@
|
|||
# New ports collection makefile for: rtpproxy
|
||||
# Date created: 20 April 2005
|
||||
# Whom: sobomax@FreeBSD.org
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= rtpproxy
|
||||
PORTVERSION= 1.1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://www.rtpproxy.org/chrome/site/
|
||||
|
||||
MAINTAINER= sobomax@FreeBSD.org
|
||||
COMMENT= A high-performance RTP proxy server for the SIP Express Router (SER)
|
||||
|
||||
LIB_DEPENDS= gsm.1:${PORTSDIR}/audio/gsm
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
|
||||
LIBS=-L${LOCALBASE}/lib
|
||||
#CONFIGURE_ARGS= --mandir=${LOCALBASE}/man
|
||||
MAN8= rtpproxy.8
|
||||
|
||||
post-build:
|
||||
${SED} 's|%%PREFIX%%|${PREFIX}|g ; s|%%RC_SUBR%%|/etc/rc.subr|g' \
|
||||
${WRKSRC}/freebsd/rtpproxy.in > ${WRKDIR}/rtpproxy
|
||||
|
||||
post-install:
|
||||
${INSTALL_SCRIPT} ${WRKDIR}/rtpproxy ${PREFIX}/etc/rc.d/rtpproxy
|
||||
|
||||
.include <bsd.port.mk>
|
3
net/rtpproxy/distinfo
Normal file
3
net/rtpproxy/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (rtpproxy-1.1.tar.gz) = 76140b62c41932681a30714adcfa94a9
|
||||
SHA256 (rtpproxy-1.1.tar.gz) = 181ec3686f272b3d105a25a63a41dc960fb3caadfb83680784730849899a4817
|
||||
SIZE (rtpproxy-1.1.tar.gz) = 189829
|
14
net/rtpproxy/files/patch-freebsd_rtpproxy.in
Normal file
14
net/rtpproxy/files/patch-freebsd_rtpproxy.in
Normal file
|
@ -0,0 +1,14 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- freebsd/rtpproxy.in
|
||||
+++ freebsd/rtpproxy.in
|
||||
@@ -24,7 +24,7 @@
|
||||
load_rc_config ${name}
|
||||
|
||||
rtpproxy_enable=${rtpproxy_enable:-"NO"}
|
||||
-rtpproxy_laddr=${rtpproxy_laddr:-"*"}
|
||||
+rtpproxy_laddr=${rtpproxy_laddr:-"0.0.0.0"}
|
||||
|
||||
command_args="-l ${rtpproxy_laddr} -p /var/run/rtpproxy.pid"
|
||||
|
18
net/rtpproxy/pkg-descr
Normal file
18
net/rtpproxy/pkg-descr
Normal file
|
@ -0,0 +1,18 @@
|
|||
The Sippy RTPproxy is a high-performance software proxy for RTP streams that
|
||||
can work together with SIP Express Router (SER), OpenSER or Sippy B2BUA or
|
||||
any other SIP proxy or SIP B2BUA capable of rewriting SDP bodies in SIP
|
||||
messages that it relays.
|
||||
|
||||
The main purpose of RTPproxy is to make the communication between SIP user
|
||||
agents behind NAT(s) (Network Address Translator) possible. Several cases
|
||||
exists when direct end-to-end communication is not possible and RTP streams
|
||||
have to be relayed through another host. The RTPproxy can be used to setup
|
||||
such a relaying host.
|
||||
|
||||
Originally created for handling NAT scenarious it can also act as a generic
|
||||
media relay as well as gateway RTP sessions between IPv4 and IPv6 networks.
|
||||
It can also perform number of additional functions, including call recording,
|
||||
playing pre-encoded announcements, real-time stream copying and RTP payload
|
||||
reframing.
|
||||
|
||||
WWW: http://www.rtpproxy.org/
|
3
net/rtpproxy/pkg-plist
Normal file
3
net/rtpproxy/pkg-plist
Normal file
|
@ -0,0 +1,3 @@
|
|||
etc/rc.d/rtpproxy
|
||||
bin/makeann
|
||||
bin/rtpproxy
|
Loading…
Reference in a new issue