- Update to 0.6.0.
- Fix CFLAGS. - Use USE_GNOME tricks instead of ugly REINPLACE_CMD. PR: 80059 Submitted by: danfe
This commit is contained in:
parent
52fa68bbe9
commit
02ec2b0ae3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=133570
6 changed files with 40 additions and 20 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= libtorrent
|
||||
PORTVERSION= 0.5.4
|
||||
PORTVERSION= 0.6.0
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://libtorrent.rakshasa.no/downloads/
|
||||
|
||||
|
@ -16,18 +16,14 @@ COMMENT= BitTorrent Library written in C++
|
|||
LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20
|
||||
|
||||
USE_GCC= 3.4
|
||||
USE_GNOME= pkgconfig gnomehack
|
||||
USE_REINPLACE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
USE_INC_LIBTOOL_VER= 13
|
||||
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e "s#\(pkgconfigdir =\).*#\1 ${PREFIX}/libdata/pkgconfig#" \
|
||||
${WRKSRC}/Makefile.in
|
||||
# uphold CXXFLAGS
|
||||
@${REINPLACE_CMD} -E \
|
||||
-e 's#^(CXXFLAGS[[:space:]]*=[[:space:]]*).*-O.*$$#\1${CXXFLAGS}#' \
|
||||
-e 's#^(CFLAGS[[:space:]]*=[[:space:]]*).*-O.*$$#\1${CFLAGS}#' \
|
||||
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
|
||||
@${REINPLACE_CMD} -e 's/-O3/${CFLAGS}/' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e '/malloc\.h/d' ${WRKSRC}/src/utils/sha_fast.cc
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (libtorrent-0.5.4.tar.gz) = 77d1c39f2c17bddc572ae426b53e8367
|
||||
SIZE (libtorrent-0.5.4.tar.gz) = 294733
|
||||
MD5 (libtorrent-0.6.0.tar.gz) = 0593d611f1079c42c1d431057c74865c
|
||||
SIZE (libtorrent-0.6.0.tar.gz) = 304858
|
||||
|
|
14
net-p2p/libtorrent/files/patch-src_net_socket__fd.cc
Normal file
14
net-p2p/libtorrent/files/patch-src_net_socket__fd.cc
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- src/net/socket_fd.cc.orig Mon Apr 18 00:55:09 2005
|
||||
+++ src/net/socket_fd.cc Mon Apr 18 17:27:38 2005
|
||||
@@ -24,9 +24,11 @@
|
||||
|
||||
#include <errno.h>
|
||||
#include <fcntl.h>
|
||||
+#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
#include <arpa/inet.h>
|
||||
#include <netinet/in.h>
|
||||
+#include <netinet/in_systm.h>
|
||||
#include <netinet/ip.h>
|
||||
|
||||
#include "torrent/exceptions.h"
|
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= libtorrent
|
||||
PORTVERSION= 0.5.4
|
||||
PORTVERSION= 0.6.0
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://libtorrent.rakshasa.no/downloads/
|
||||
|
||||
|
@ -16,18 +16,14 @@ COMMENT= BitTorrent Library written in C++
|
|||
LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20
|
||||
|
||||
USE_GCC= 3.4
|
||||
USE_GNOME= pkgconfig gnomehack
|
||||
USE_REINPLACE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
USE_INC_LIBTOOL_VER= 13
|
||||
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e "s#\(pkgconfigdir =\).*#\1 ${PREFIX}/libdata/pkgconfig#" \
|
||||
${WRKSRC}/Makefile.in
|
||||
# uphold CXXFLAGS
|
||||
@${REINPLACE_CMD} -E \
|
||||
-e 's#^(CXXFLAGS[[:space:]]*=[[:space:]]*).*-O.*$$#\1${CXXFLAGS}#' \
|
||||
-e 's#^(CFLAGS[[:space:]]*=[[:space:]]*).*-O.*$$#\1${CFLAGS}#' \
|
||||
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
|
||||
@${REINPLACE_CMD} -e 's/-O3/${CFLAGS}/' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e '/malloc\.h/d' ${WRKSRC}/src/utils/sha_fast.cc
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (libtorrent-0.5.4.tar.gz) = 77d1c39f2c17bddc572ae426b53e8367
|
||||
SIZE (libtorrent-0.5.4.tar.gz) = 294733
|
||||
MD5 (libtorrent-0.6.0.tar.gz) = 0593d611f1079c42c1d431057c74865c
|
||||
SIZE (libtorrent-0.6.0.tar.gz) = 304858
|
||||
|
|
14
net/libtorrent/files/patch-src_net_socket__fd.cc
Normal file
14
net/libtorrent/files/patch-src_net_socket__fd.cc
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- src/net/socket_fd.cc.orig Mon Apr 18 00:55:09 2005
|
||||
+++ src/net/socket_fd.cc Mon Apr 18 17:27:38 2005
|
||||
@@ -24,9 +24,11 @@
|
||||
|
||||
#include <errno.h>
|
||||
#include <fcntl.h>
|
||||
+#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
#include <arpa/inet.h>
|
||||
#include <netinet/in.h>
|
||||
+#include <netinet/in_systm.h>
|
||||
#include <netinet/ip.h>
|
||||
|
||||
#include "torrent/exceptions.h"
|
Loading…
Reference in a new issue