- Pass maintainership to submitter.
- Make portlint happy. PR: ports/138993 Submitted by: Sylvio Cesar <scjamorim@bsd.com.br> Feature safe: yes
This commit is contained in:
parent
f668321e6f
commit
03222431d0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=241825
5 changed files with 29 additions and 21 deletions
|
@ -12,12 +12,12 @@ CATEGORIES= audio
|
|||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/2.0-pre6
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p/pre/}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= scjamorim@bsd.com.br
|
||||
COMMENT= An ncurses based frontend to mpg123
|
||||
|
||||
RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-kenrevs/
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-kenrevs
|
||||
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
@ -29,13 +29,12 @@ PLIST_FILES= bin/cmp3 bin/rnmp3
|
|||
RUN_DEPENDS+= ogg123:${PORTSDIR}/audio/vorbis-tools
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/cmp3 ${PREFIX}/bin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/rnmp3 ${PREFIX}/bin
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/cmp3rc ${DOCSDIR}/sample.cmp3rc
|
||||
.for docs in ${PORTDOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- Makefile.in.orig Sun Jul 29 14:43:49 2001
|
||||
+++ Makefile.in Thu Mar 18 22:27:35 2004
|
||||
--- Makefile.in.orig 2001-07-29 02:43:49.000000000 -0300
|
||||
+++ Makefile.in 2009-09-20 11:17:07.000000000 -0300
|
||||
@@ -5,19 +5,19 @@
|
||||
# initial_directory is now set in the config file
|
||||
mpg123_location := "mpg123"
|
||||
|
@ -32,3 +32,12 @@
|
|||
CC= @CC@
|
||||
OBJS= cmp3common.o cmp3fileio.o cmp3manager.o cmp3curses.o \
|
||||
cmp3llist.o cmp3main.o cmp3listfiles.o cmp3playlist.o cmp3volume.o \
|
||||
@@ -103,7 +103,7 @@
|
||||
install: rnmp3 cmp3
|
||||
install -c -s cmp3 $(install_directory)/cmp3
|
||||
install -c -s rnmp3 $(install_directory)/rnmp3
|
||||
- cp -i cmp3rc $(config_file)
|
||||
+ cp -i cmp3rc sample.cmp3rc
|
||||
ifdef ass_repository
|
||||
@if [ ! -x $(ass_repository) ]; then mkdir $(ass_repository); \
|
||||
echo mkdir $(ass_repository); fi;
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- cmp3main.c.orig Fri Mar 17 08:40:00 2000
|
||||
+++ cmp3main.c Fri Jan 12 02:16:41 2001
|
||||
--- cmp3main.c.orig 2001-07-07 16:17:23.000000000 -0300
|
||||
+++ cmp3main.c 2009-09-20 11:11:06.000000000 -0300
|
||||
@@ -33,13 +33,18 @@
|
||||
int lastleftline = 0;
|
||||
int lastrightline = 0;
|
|
@ -1,10 +0,0 @@
|
|||
--- nevlib/Makefile.in.orig Sun Jul 29 14:09:13 2001
|
||||
+++ nevlib/Makefile.in Thu Mar 18 22:26:26 2004
|
||||
@@ -1,6 +1,6 @@
|
||||
CC = @CC@
|
||||
|
||||
-CFLAGS = -Wall -ansi -O2 -g
|
||||
+CFLAGS = @CFLAGS@
|
||||
|
||||
FILES=llist.o inifile.o
|
||||
LIBNAME=libnev.a
|
10
audio/cmp3/files/patch-nevlib_Makefile.in
Normal file
10
audio/cmp3/files/patch-nevlib_Makefile.in
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- nevlib/Makefile.in.orig 2001-07-29 02:09:13.000000000 -0300
|
||||
+++ nevlib/Makefile.in 2009-09-20 11:11:06.000000000 -0300
|
||||
@@ -1,6 +1,6 @@
|
||||
CC = @CC@
|
||||
|
||||
-CFLAGS = -Wall -ansi -O2 -g
|
||||
+CFLAGS = @CFLAGS@
|
||||
|
||||
FILES=llist.o inifile.o
|
||||
LIBNAME=libnev.a
|
Loading…
Reference in a new issue