Fix build with or without the scandir changes.
Feature safe: yes
This commit is contained in:
parent
52a27282b0
commit
0393ad6459
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=249897
2 changed files with 30 additions and 2 deletions
|
@ -7,7 +7,7 @@
|
|||
|
||||
PORTNAME= libcompizconfig
|
||||
PORTVERSION= 0.8.4
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= x11-wm
|
||||
MASTER_SITES= http://releases.compiz.org/${PORTVERSION}/
|
||||
|
||||
|
@ -28,6 +28,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
|||
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
|
||||
|
||||
post-patch:
|
||||
echo ${OSVERSION}
|
||||
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \
|
||||
${WRKSRC}/src/main.c \
|
||||
${WRKSRC}/src/lists.c \
|
||||
|
@ -35,4 +36,11 @@ post-patch:
|
|||
${WRKSRC}/src/ini.c \
|
||||
${WRKSRC}/backend/ini.c
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if (${OSVERSION} < 800501) || \
|
||||
(${OSVERSION} >= 900000 && ${OSVERSION} < 900006)
|
||||
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src-compiz.cpp
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
20
x11-wm/libcompizconfig/files/extra-patch-src-compiz.cpp
Normal file
20
x11-wm/libcompizconfig/files/extra-patch-src-compiz.cpp
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- src/compiz.cpp.orig 2009-03-04 21:22:22.000000000 -0600
|
||||
+++ src/compiz.cpp 2009-04-06 01:58:35.000000000 -0500
|
||||
@@ -957,7 +957,7 @@
|
||||
|
||||
|
||||
static int
|
||||
-pluginNameFilter (const struct dirent *name)
|
||||
+pluginNameFilter (struct dirent *name)
|
||||
{
|
||||
int length = strlen (name->d_name);
|
||||
|
||||
@@ -972,7 +972,7 @@
|
||||
}
|
||||
|
||||
static int
|
||||
-pluginXMLFilter (const struct dirent *name)
|
||||
+pluginXMLFilter (struct dirent *name)
|
||||
{
|
||||
int length = strlen (name->d_name);
|
||||
|
Loading…
Reference in a new issue