[NEW PORT] www/py-prawcore: Low-level communication layer for PRAW 4+
prawcore is a low-level communication layer for PRAW 4+. Features: * Dynamic rate limiting based on reddit's response headers. * Authorization URL generation * Retrieval of access and refresh tokens from authorization grants * Access and refresh token revocation WWW: https://github.com/praw-dev/prawcore
This commit is contained in:
parent
59d56cd7c0
commit
039b396607
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=501833
5 changed files with 58 additions and 0 deletions
|
@ -1770,6 +1770,7 @@
|
|||
SUBDIR += py-plonetheme.sunburst
|
||||
SUBDIR += py-poster
|
||||
SUBDIR += py-praw
|
||||
SUBDIR += py-prawcore
|
||||
SUBDIR += py-prewikka
|
||||
SUBDIR += py-priority
|
||||
SUBDIR += py-puppetboard
|
||||
|
|
30
www/py-prawcore/Makefile
Normal file
30
www/py-prawcore/Makefile
Normal file
|
@ -0,0 +1,30 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= prawcore
|
||||
PORTVERSION= 1.0.1
|
||||
CATEGORIES= www python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
MAINTAINER= koobs@FreeBSD.org
|
||||
COMMENT= Low-level communication layer for PRAW 4+
|
||||
|
||||
LICENSE= BSD2CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.6.0,<3.0.0:www/py-requests@${PY_FLAVOR}
|
||||
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=0.8:devel/py-mock@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}testfixtures>4.13.2,<7:devel/py-testfixtures@${PY_FLAVOR}
|
||||
# to be ported betamax >=0.8, <0.9
|
||||
# betamax-matchers >=0.3.0, <0.5
|
||||
# betamax-serializers >=0.2, <0.3
|
||||
|
||||
USES= python
|
||||
USE_PYTHON= autoplist distutils
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
do-test:
|
||||
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
|
||||
|
||||
.include <bsd.port.mk>
|
3
www/py-prawcore/distinfo
Normal file
3
www/py-prawcore/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1558063235
|
||||
SHA256 (prawcore-1.0.1.tar.gz) = ab5558efb438aa73fc66c4178bfc809194dea3ce2addf4dec873de7e2fd2824e
|
||||
SIZE (prawcore-1.0.1.tar.gz) = 1148891
|
14
www/py-prawcore/files/patch-setup.py
Normal file
14
www/py-prawcore/files/patch-setup.py
Normal file
|
@ -0,0 +1,14 @@
|
|||
# Unpin mock dependency. mock 3.x works
|
||||
# https://github.com/praw-dev/prawcore/pull/77
|
||||
|
||||
--- setup.py.orig 2019-05-17 03:34:46 UTC
|
||||
+++ setup.py
|
||||
@@ -40,7 +40,7 @@ setup(name=PACKAGE_NAME,
|
||||
tests_require=['betamax >=0.8, <0.9',
|
||||
'betamax_matchers >=0.4.0, <0.5',
|
||||
'betamax-serializers >=0.2.0, <0.3',
|
||||
- 'mock >=0.8, <3',
|
||||
+ 'mock >=0.8',
|
||||
'testfixtures >4.13.2, <7'],
|
||||
test_suite='tests',
|
||||
url='https://github.com/praw-dev/prawcore',
|
10
www/py-prawcore/pkg-descr
Normal file
10
www/py-prawcore/pkg-descr
Normal file
|
@ -0,0 +1,10 @@
|
|||
prawcore is a low-level communication layer for PRAW 4+.
|
||||
|
||||
Features:
|
||||
|
||||
* Dynamic rate limiting based on reddit's response headers.
|
||||
* Authorization URL generation
|
||||
* Retrieval of access and refresh tokens from authorization grants
|
||||
* Access and refresh token revocation
|
||||
|
||||
WWW: https://github.com/praw-dev/prawcore
|
Loading…
Reference in a new issue