net-p2p/deluge: update to 1.3.13

- update to 1.3.13
- switch to option helpers
- add creatiion of .python-eggs for deluge_web - this resolves
  installation of plugins for deluge_web [1]

This release also fixing Scheduler plugin as reported by dbn@ [2], so
this is the reason for MFH request.

Changes: http://dev.deluge-torrent.org/wiki/ChangeLog#Deluge1.3.1320July2016

PR:		207558 [2]
Submitted by:	Marlon Leerkotte <mrleerkotte@protonmail.com> [1] (private mail)
Reported by:	dbn [2]
MFH:    2016Q3
This commit is contained in:
Ruslan Makhmatkhanov 2016-07-22 20:49:47 +00:00
parent 4b9e850d4d
commit 03c14a4336
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=418935
4 changed files with 34 additions and 58 deletions

View file

@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= deluge
PORTVERSION= 1.3.12
PORTVERSION= 1.3.13
PORTEPOCH= 1
CATEGORIES= net-p2p python
MASTER_SITES= http://download.deluge-torrent.org/source/
@ -22,28 +22,23 @@ USE_RC_SUBR= deluged deluge_web
SUB_LIST+= PYTHON_CMD=${PYTHON_CMD}
NO_ARCH= yes
USES= gettext python:2 tar:lzma twisted:run,web
USES= gettext python:2.7 tar:xz twisted:run,web
USE_PYTHON= autoplist distutils
USE_OPENSSL= yes
OPTIONS_DEFINE= GTK2
OPTIONS_DEFINE= DOCS GTK2
OPTIONS_DEFAULT=GTK2
OPTIONS_SUB= yes
PORTDOCS= ChangeLog README
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGTK2}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}dbus>=0.83:devel/py-dbus \
GTK2_RUN_DEPENDS= \
${PYTHON_PKGNAMEPREFIX}dbus>=0.83:devel/py-dbus \
${PYTHON_PKGNAMEPREFIX}game>=1.8.1:devel/py-game \
${PYTHON_PKGNAMEPREFIX}notify>=0.1.1:devel/py-notify \
xdg-utils>=1.0.2:devel/xdg-utils
GTK2_USE= GNOME=intltool librsvg2 pygnome2 pygtk2
GTK2_USES= desktop-file-utils
GTK2_VARS= INSTALLS_ICONS= yes
USE_GNOME+= intltool librsvg2 pygnome2 pygtk2
USES+= desktop-file-utils
INSTALLS_ICONS= yes
.endif
PORTDOCS= ChangeLog README
post-patch:
@${REINPLACE_CMD} -e '/"new_release_check":/s|True,|False,|g ; \
@ -52,8 +47,6 @@ post-patch:
@${REINPLACE_CMD} -e '/"check_new_releases":/s|True,|False,|g ; \
/"show_new_releases":/s|True,|False,|g' \
${WRKSRC}/deluge/ui/gtkui/gtkui.py
@${REINPLACE_CMD} -e 's|GTK|GTK;|' \
${WRKSRC}/deluge/data/share/applications/deluge.desktop.in
post-install:
# do these by hand, else they wind up in the wrong place
@ -69,16 +62,18 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/deluge/data/pixmaps/deluge.${pic} \
${STAGEDIR}${PREFIX}/share/pixmaps
.endfor
.if ${PORT_OPTIONS:MGTK2}
${INSTALL_DATA} ${WRKSRC}/deluge/data/share/applications/deluge.desktop \
${STAGEDIR}${PREFIX}/share/applications
.endif
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
# install man pages
.for man in deluge.1 deluge-console.1 deluge-gtk.1 deluge-web.1 deluged.1
${INSTALL_MAN} ${WRKSRC}/docs/man/${man} ${STAGEDIR}${MANPREFIX}/man/man1/
.endfor
post-install-GTK2-on:
${INSTALL_DATA} ${WRKSRC}/deluge/data/share/applications/deluge.desktop \
${STAGEDIR}${PREFIX}/share/applications
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>

View file

@ -1,2 +1,3 @@
SHA256 (deluge-1.3.12.tar.lzma) = eb875724a8f52ac36c3890bdcee9f77c648ef03b6375387af5c26d5229fdc65e
SIZE (deluge-1.3.12.tar.lzma) = 1449148
TIMESTAMP = 1469200565
SHA256 (deluge-1.3.13.tar.xz) = fe8059a66834abd656693a8736b0829cb3342bb803c55384abad3756097d394e
SIZE (deluge-1.3.13.tar.xz) = 1460948

View file

@ -52,8 +52,14 @@ deluge_web_prestart()
mkdir -p /var/run/${name}
fi
if [ ! -d "/home/${deluge_web_user}/.python-eggs" ]; then
mkdir -p /home/${deluge_web_user}/.python-eggs
fi
chmod 0755 /var/run/${name}
chown -R $deluge_web_user /var/run/${name}
chown -R $deluge_web_user /home/${deluge_web_user}/.python-eggs
export PYTHON_EGG_CACHE="/home/${deluge_web_user}/.python-eggs"
}
deluge_web_poststop()

View file

@ -1,43 +1,17 @@
--- setup.py.orig 2015-09-13 20:32:11 UTC
--- setup.py.orig 2016-07-20 14:23:28 UTC
+++ setup.py
@@ -216,6 +216,8 @@ except ImportError:
@@ -215,6 +215,7 @@ except ImportError:
build_libtorrent = True
else:
build_libtorrent = False
+build_libtorrent = False
+
if build_libtorrent:
got_libtorrent = False
if not os.path.exists("libtorrent"):
@@ -490,31 +492,7 @@ cmdclass = {
# Data files to be installed to the system.
_data_files = []
if not windows_check():
- _data_files = [
- ('share/icons/hicolor/scalable/apps', ['deluge/data/icons/scalable/apps/deluge.svg']),
- ('share/icons/hicolor/128x128/apps', ['deluge/data/icons/hicolor/128x128/apps/deluge.png']),
- ('share/icons/hicolor/16x16/apps', ['deluge/data/icons/hicolor/16x16/apps/deluge.png']),
- ('share/icons/hicolor/192x192/apps', ['deluge/data/icons/hicolor/192x192/apps/deluge.png']),
- ('share/icons/hicolor/22x22/apps', ['deluge/data/icons/hicolor/22x22/apps/deluge.png']),
- ('share/icons/hicolor/24x24/apps', ['deluge/data/icons/hicolor/24x24/apps/deluge.png']),
- ('share/icons/hicolor/256x256/apps', ['deluge/data/icons/hicolor/256x256/apps/deluge.png']),
- ('share/icons/hicolor/32x32/apps', ['deluge/data/icons/hicolor/32x32/apps/deluge.png']),
- ('share/icons/hicolor/36x36/apps', ['deluge/data/icons/hicolor/36x36/apps/deluge.png']),
- ('share/icons/hicolor/48x48/apps', ['deluge/data/icons/hicolor/48x48/apps/deluge.png']),
- ('share/icons/hicolor/64x64/apps', ['deluge/data/icons/hicolor/64x64/apps/deluge.png']),
- ('share/icons/hicolor/72x72/apps', ['deluge/data/icons/hicolor/72x72/apps/deluge.png']),
- ('share/icons/hicolor/96x96/apps', ['deluge/data/icons/hicolor/96x96/apps/deluge.png']),
- ('share/pixmaps', ['deluge/data/pixmaps/deluge.png', 'deluge/data/pixmaps/deluge.xpm']),
- ('share/man/man1', [
- 'docs/man/deluge.1',
- 'docs/man/deluged.1',
- 'docs/man/deluge-gtk.1',
- 'docs/man/deluge-web.1',
- 'docs/man/deluge-console.1'])
- ]
-
- if os.path.exists(desktop_data):
- _data_files.append(('share/applications', [desktop_data]))
@@ -515,6 +516,7 @@ if not windows_check() and not osx_check
if os.path.exists(desktop_data):
_data_files.append(('share/applications', [desktop_data]))
+ _data_files = []
entry_points = {