- add stage support
- make DBI an OPTION instead guessing during build time - adjust pkg-plist
This commit is contained in:
parent
3568b5aa3f
commit
03ff560404
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=347652
3 changed files with 68 additions and 13 deletions
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= mod_log_sql
|
||||
PORTVERSION= 1.101
|
||||
PORTREVISION= 5
|
||||
PORTREVISION= 6
|
||||
CATEGORIES= www databases
|
||||
MASTER_SITES= http://www.outoforder.cc/downloads/${PORTNAME}/
|
||||
PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
|
||||
|
@ -12,24 +12,31 @@ PKGNAMESUFFIX= -dtc
|
|||
MAINTAINER= apache@FreeBSD.org
|
||||
COMMENT= Allows Apache to log to a MySQL database
|
||||
|
||||
OPTIONS_DEFINE= DBI
|
||||
DBI_DESC= depend on databases/libdbi
|
||||
|
||||
OPTIONS_SUB= yes
|
||||
DBI_CONFIGURE_ON= --with-dbi=${LOCALBASE}
|
||||
DBI_CONFIGURE_OFF= --without-dbi
|
||||
DBI_LIB_DEPENDS= libdbi.so:${PORTSDIR}/databases/libdbi
|
||||
|
||||
LATEST_LINK= mod_log_sql2-dtc
|
||||
GNU_CONFIGURE= yes
|
||||
USES= gmake
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
USE_APACHE= 22
|
||||
CONFIGURE_ARGS+= --with-apxs=${APXS}
|
||||
SSL_PLIST= ""
|
||||
PLIST_SUB+= SSL=${SSL_PLIST}
|
||||
|
||||
USE_MYSQL= yes
|
||||
CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -L${LOCALBASE}/lib/mysql"
|
||||
|
||||
NO_STAGE= yes
|
||||
.include <bsd.port.pre.mk>
|
||||
.if defined(WITH_DBI) || exists(${LOCALBASE}/include/dbi/dbi.h)
|
||||
CONFIGURE_ARGS+= --with-dbi=${LOCALBASE}
|
||||
LIB_DEPENDS+= dbi.1:${PORTSDIR}/databases/libdbi
|
||||
.endif
|
||||
|
||||
CONFIGURE_ARGS+= --with-apxs=${APXS}
|
||||
CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -L${LOCALBASE}/lib/mysql"
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's|@APXS_STAGE@|-S LIBEXECDIR=${STAGEDIR}${PREFIX}/${APACHEMODDIR}|' \
|
||||
${WRKSRC}/Makefile.in
|
||||
|
||||
pre-install:
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
47
www/mod_log_sql2-dtc/files/patch-Makefile.in
Normal file
47
www/mod_log_sql2-dtc/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,47 @@
|
|||
--- ./Makefile.in.orig 2006-11-05 04:47:23.000000000 +0100
|
||||
+++ ./Makefile.in 2014-03-09 15:26:45.000000000 +0100
|
||||
@@ -12,6 +12,7 @@
|
||||
winconfig.h
|
||||
|
||||
CFLAGS = -Wc,-Wall -Wc,-fno-strict-aliasing
|
||||
+APX_STAGE= @APXS_STAGE@
|
||||
|
||||
ifeq (@OOO_MAINTAIN@,1)
|
||||
CFLAGS += -Wc,-Werror
|
||||
@@ -153,19 +154,19 @@
|
||||
install: $(TARGETS) install-subdirs
|
||||
@@APXS_BIN@ -n $(coreNAME) -i $(coreTARGET); \
|
||||
if test @WANT_MYSQL_MOD@ -eq 1; then \
|
||||
- @APXS_BIN@ -n $(mysqlNAME) -i $(mysqlTARGET); \
|
||||
+ @APXS_BIN@ @APXS_STAGE@ -n $(mysqlNAME) -i $(mysqlTARGET); \
|
||||
fi; \
|
||||
if test @WANT_PGSQL_MOD@ -eq 1; then \
|
||||
- @APXS_BIN@ -n $(pgsqlNAME) -i $(pgsqlTARGET); \
|
||||
+ @APXS_BIN@ @APXS_STAGE@ -n $(pgsqlNAME) -i $(pgsqlTARGET); \
|
||||
fi; \
|
||||
if test @WANT_DBI_MOD@ -eq 1; then \
|
||||
- @APXS_BIN@ -n $(dbiNAME) -i $(dbiTARGET); \
|
||||
+ @APXS_BIN@ @APXS_STAGE@ -n $(dbiNAME) -i $(dbiTARGET); \
|
||||
fi; \
|
||||
if test @WANT_SSL_MOD@ -eq 1; then \
|
||||
- @APXS_BIN@ -n $(sslNAME) -i $(sslTARGET); \
|
||||
+ @APXS_BIN@ @APXS_STAGE@ -n $(sslNAME) -i $(sslTARGET); \
|
||||
fi; \
|
||||
if test @WANT_LOGIO_MOD@ -eq 1; then \
|
||||
- @APXS_BIN@ -n $(logioNAME) -i $(logioTARGET); \
|
||||
+ @APXS_BIN@ @APXS_STAGE@ -n $(logioNAME) -i $(logioTARGET); \
|
||||
fi; \
|
||||
echo "*************************************************************************"; \
|
||||
echo "*** The mod_log_sql modules have been installed."; \
|
||||
@@ -183,9 +184,9 @@
|
||||
echo "*************************************************************************";
|
||||
|
||||
activate: activate-subdirs
|
||||
- @@APXS_BIN@ -n $(coreNAME) -i -a $(coreTARGET); \
|
||||
+ @@APXS_BIN@ @APXS_STAGE@ -n $(coreNAME) -i $(coreTARGET); \
|
||||
if test @WANT_SSL_MOD@ -eq 1; then \
|
||||
- @APXS_BIN@ -n $(sslNAME) -i -a $(sslTARGET); \
|
||||
+ @APXS_BIN@ @APXS_STAGE@ -n $(sslNAME) -i $(sslTARGET); \
|
||||
fi
|
||||
|
||||
clean: clean-subdirs
|
|
@ -3,4 +3,5 @@
|
|||
@unexec /usr/bin/sed -i '' '/LoadModule %%AP_NAME%%_module/d' %D/%%APACHEETCDIR%%/httpd.conf
|
||||
%%APACHEMODDIR%%/mod_log_sql_mysql.so
|
||||
%%APACHEMODDIR%%/mod_log_sql_logio.so
|
||||
%%SSL%%%%APACHEMODDIR%%/mod_log_sql_ssl.so
|
||||
%%APACHEMODDIR%%/mod_log_sql_ssl.so
|
||||
%%DBI%%%%APACHEMODDIR%%/mod_log_sql_dbi.so
|
||||
|
|
Loading…
Reference in a new issue