- Fix build on powerpc and sparc64

Submitted by:	Andreas Tobler <andreast-list AT fgznet.ch>
This commit is contained in:
Beat Gaetzi 2009-08-19 01:58:38 +00:00
parent 5288f87e23
commit 041534db9e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=239920
6 changed files with 50 additions and 18 deletions

View file

@ -59,10 +59,6 @@ OPTIONS= DBUS "Enable D-BUS support" on \
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
BROKEN= Does not compile on sparc64: invokes i386 assembler
.endif
GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 '%{\!pg: %{pthread:' | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
.if ${HAVE_GNOME:Mlibgnomeui}!=""

View file

@ -1,19 +1,27 @@
--- security/coreconf/FreeBSD.mk.orig 2008-07-06 00:10:00.000000000 -0500
+++ security/coreconf/FreeBSD.mk 2008-07-06 00:12:34.000000000 -0500
@@ -45,8 +45,12 @@
--- security/coreconf/FreeBSD.mk.orig 2009-07-30 17:30:28.000000000 +0200
+++ security/coreconf/FreeBSD.mk 2009-08-17 22:29:03.510890513 +0200
@@ -45,8 +45,20 @@
ifeq ($(OS_TEST),alpha)
CPU_ARCH = alpha
else
+ifeq ($(OS_TEST),amd64)
+CPU_ARCH = amd64
+else
+ifeq ($(OS_TEST),powerpc)
+CPU_ARCH = powerpc
+else
+ifeq ($(OS_TEST),sparc64)
+CPU_ARCH = sparc64
+else
CPU_ARCH = x86
endif
+endif
+endif
+endif
OS_CFLAGS = $(DSO_CFLAGS) -ansi -Wall -Wno-switch -DFREEBSD -DHAVE_STRERROR -DHAVE_BSD_FLOCK
@@ -73,7 +77,7 @@
@@ -73,7 +85,7 @@
DLL_SUFFIX = so.1.0
endif
@ -22,7 +30,7 @@
ifdef MAPFILE
MKSHLIB += -Wl,--version-script,$(MAPFILE)
endif
@@ -82,4 +86,4 @@
@@ -82,4 +94,4 @@
G++INCLUDES = -I/usr/include/g++

View file

@ -59,10 +59,6 @@ OPTIONS= DBUS "Enable D-BUS support" on \
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
BROKEN= Does not compile on sparc64
.endif
.if ${OSVERSION} < 700000
LIB_DEPENDS+= pulse.0:${PORTSDIR}/audio/pulseaudio
EXTRA_PATCHES= ${FILESDIR}/releng6_pulseaudio

View file

@ -0,0 +1,11 @@
--- content/xslt/public/txDouble.h.orig 2009-08-16 21:46:27.000000000 +0200
+++ content/xslt/public/txDouble.h 2009-08-16 21:49:53.000000000 +0200
@@ -43,7 +43,7 @@
//A trick to handle IEEE floating point exceptions on FreeBSD - E.D.
#ifdef __FreeBSD__
#include <ieeefp.h>
-#ifdef __alpha__
+#if defined (__alpha__) || defined (__powerpc__) || defined (__sparc__)
static fp_except_t allmask = FP_X_INV|FP_X_OFL|FP_X_UFL|FP_X_DZ|FP_X_IMP;
#else
static fp_except_t allmask = FP_X_INV|FP_X_OFL|FP_X_UFL|FP_X_DZ|FP_X_IMP|FP_X_DNML;

View file

@ -0,0 +1,13 @@
--- js/src/configure.orig 2009-06-23 23:44:34.000000000 +0200
+++ js/src/configure 2009-06-23 23:44:46.000000000 +0200
@@ -6916,10 +6916,6 @@
ENABLE_JIT=1
NANOJIT_ARCH=ARM
;;
-sparc*-*)
- ENABLE_JIT=1
- NANOJIT_ARCH=Sparc
- ;;
esac
# Check whether --enable-jit or --disable-jit was given.

View file

@ -1,19 +1,27 @@
--- security/coreconf/FreeBSD.mk.orig 2008-07-06 00:10:00.000000000 -0500
+++ security/coreconf/FreeBSD.mk 2008-07-06 00:12:34.000000000 -0500
@@ -45,8 +45,12 @@
--- security/coreconf/FreeBSD.mk.orig 2009-07-30 17:30:28.000000000 +0200
+++ security/coreconf/FreeBSD.mk 2009-08-17 22:29:03.510890513 +0200
@@ -45,8 +45,20 @@
ifeq ($(OS_TEST),alpha)
CPU_ARCH = alpha
else
+ifeq ($(OS_TEST),amd64)
+CPU_ARCH = amd64
+else
+ifeq ($(OS_TEST),powerpc)
+CPU_ARCH = powerpc
+else
+ifeq ($(OS_TEST),sparc64)
+CPU_ARCH = sparc64
+else
CPU_ARCH = x86
endif
+endif
+endif
+endif
OS_CFLAGS = $(DSO_CFLAGS) -ansi -Wall -Wno-switch -DFREEBSD -DHAVE_STRERROR -DHAVE_BSD_FLOCK
@@ -73,7 +77,7 @@
@@ -73,7 +85,7 @@
DLL_SUFFIX = so.1.0
endif
@ -22,7 +30,7 @@
ifdef MAPFILE
MKSHLIB += -Wl,--version-script,$(MAPFILE)
endif
@@ -82,4 +86,4 @@
@@ -82,4 +94,4 @@
G++INCLUDES = -I/usr/include/g++