machine/soundcard.h -> sys/soundcard.h
Submitted by: bento
This commit is contained in:
parent
3842be2417
commit
0467aae499
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=60745
19 changed files with 94 additions and 7 deletions
|
@ -15,6 +15,11 @@ MAINTAINER= 3d@FreeBSD.org
|
|||
GNU_CONFIGURE= yes
|
||||
USE_NEWGCC= yes
|
||||
|
||||
post-patch:
|
||||
@${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' \
|
||||
< ${WRKSRC}/output.c > ${WRKSRC}/output.c.new
|
||||
@${MV} ${WRKSRC}/output.c.new ${WRKSRC}/output.c
|
||||
|
||||
pre-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/ac3dec
|
||||
|
|
25
audio/aumix/files/patch-src::common.h
Normal file
25
audio/aumix/files/patch-src::common.h
Normal file
|
@ -0,0 +1,25 @@
|
|||
$FreeBSD$
|
||||
|
||||
--- src/common.h.orig Thu Jun 6 19:50:10 2002
|
||||
+++ src/common.h Thu Jun 6 19:51:01 2002
|
||||
@@ -24,18 +24,14 @@
|
||||
#include <unistd.h>
|
||||
#include <fcntl.h>
|
||||
#include <sys/ioctl.h>
|
||||
-/* "The nice thing about standards..." */
|
||||
-#if defined (__FreeBSD__)
|
||||
-#include <machine/soundcard.h>
|
||||
-#else
|
||||
+/* "The nice thing about standards..." */
|
||||
#if defined (__NetBSD__) || defined (__OpenBSD__)
|
||||
#include <soundcard.h> /* OSS emulation */
|
||||
#undef ioctl
|
||||
#else
|
||||
-/* BSDI, Linux, Solaris */
|
||||
+/* FreeBSD, BSDI, Linux, Solaris */
|
||||
#include <sys/soundcard.h>
|
||||
#endif /* __NetBSD__ or __OpenBSD__ */
|
||||
-#endif /* __FreeBSD__ */
|
||||
#ifdef HAVE_ALSA
|
||||
#include <sys/asoundlib.h>
|
||||
#endif /* HAVE_ALSA */
|
|
@ -16,6 +16,11 @@ MAINTAINER= kunia@istc.kiev.ua
|
|||
MAN1= fmio.1
|
||||
MANCOMPRESSED= no
|
||||
|
||||
post-patch:
|
||||
@${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
|
||||
${WRKSRC}/mixer.c > ${WRKSRC}/mixer.c.new
|
||||
@${MV} ${WRKSRC}/mixer.c.new ${WRKSRC}/mixer.c
|
||||
|
||||
pre-build:
|
||||
.if !defined(WITH_BKTR)
|
||||
@${ECHO_MSG}
|
||||
|
|
|
@ -15,6 +15,13 @@ MAINTAINER= nox@jelal.kn-bremen.de
|
|||
ALL_TARGET= gramofile
|
||||
USE_GMAKE= yes
|
||||
|
||||
post-patch:
|
||||
.for file in bplay.c sndfunc.c
|
||||
@${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
|
||||
${WRKSRC}/bplaysrc/${file} > ${WRKSRC}/bplaysrc/${file}.new
|
||||
@${MV} ${WRKSRC}/bplaysrc/${file}.new ${WRKSRC}/bplaysrc/${file}
|
||||
.endfor
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/gramofile ${WRKSRC}/bplay_gramo ${PREFIX}/bin
|
||||
${MKDIR} ${PREFIX}/share/doc/gramofile
|
||||
|
|
|
@ -16,6 +16,12 @@ MAINTAINER= ports@FreeBSD.org
|
|||
|
||||
NO_WRKSUBDIR= yes
|
||||
|
||||
post-patch:
|
||||
@${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
|
||||
${WRKSRC}/configuration.sh > ${WRKSRC}/configuration.sh.new
|
||||
@${MV} ${WRKSRC}/configuration.sh.new ${WRKSRC}/configuration.sh
|
||||
@${CHMOD} a+x ${WRKSRC}/configuration.sh
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/maplay ${PREFIX}/bin
|
||||
.if !defined(NOPORTDOCS)
|
||||
|
|
|
@ -99,4 +99,9 @@ OPT_ARCH?= i586
|
|||
MAKE_ARGS+= OPT_ARCH=${OPT_ARCH}
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
|
||||
${WRKSRC}/audio_oss.c > ${WRKSRC}/audio_oss.c.new
|
||||
@${MV} ${WRKSRC}/audio_oss.c.new ${WRKSRC}/audio_oss.c
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -15,4 +15,13 @@ MAINTAINER= seiken@ARGV.AC
|
|||
MANLANG= ja
|
||||
MAN1= play.1
|
||||
MANCOMPRESSED = yes
|
||||
|
||||
post-patch:
|
||||
.for file in play_audio.c mixer_ctl.c encode_sun.c encode_riff.c speed.c
|
||||
@${CHMOD} u+w ${WRKSRC}/${file}
|
||||
@${SED} 's,machine/soundcard.h,sys/soundcard.h,' < ${WRKSRC}/${file} \
|
||||
> ${WRKSRC}/${file}.new
|
||||
@${MV} ${WRKSRC}/${file}.new ${WRKSRC}/${file}
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -17,4 +17,9 @@ NO_WRKSUBDIR= yes
|
|||
MAKE_FLAGS= FreeBSD -f
|
||||
MAN1= radio.1 broadcast.1
|
||||
|
||||
post-patch:
|
||||
@${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
|
||||
${WRKSRC}/radio.c > ${WRKSRC}/radio.c.new
|
||||
@${MV} ${WRKSRC}/radio.c.new ${WRKSRC}/radio.c
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -32,7 +32,7 @@ post-patch:
|
|||
s,-lpthread,${PTHREAD_LIBS},g ; \
|
||||
s,/usr/local,${PREFIX},g" ${WRKSRC}/Makefile
|
||||
@${GREP} -lR "linux/" ${WRKSRC} | ${XARGS} \
|
||||
${PERL} -pi -e "s,linux/,machine/,g"
|
||||
${PERL} -pi -e "s,linux/,sys/,g"
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/rawrec ${PREFIX}/bin
|
||||
|
|
|
@ -22,6 +22,11 @@ MAN1= ${UTILS:S/$/.1/} ${DEMNS:S/$/.1/} ${DDEMNS:S/$/.1/}
|
|||
|
||||
MAKE_ENV= "OPTFLAGS=${CFLAGS}"
|
||||
|
||||
post-patch:
|
||||
@${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
|
||||
${WRKSRC}/soundbyte.c > ${WRKSRC}/soundbyte.c.new
|
||||
@${MV} ${WRKSRC}/soundbyte.c.new ${WRKSRC}/soundbyte.c
|
||||
|
||||
do-install:
|
||||
if [ ! -d ${SFLIB} ]; then \
|
||||
${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755 ${SFLIB}; \
|
||||
|
|
|
@ -21,6 +21,11 @@ TIINS= goemon.tgz
|
|||
INSTALL_TARGET= install.all
|
||||
MAN1= timidity.1
|
||||
|
||||
post-patch:
|
||||
@${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
|
||||
${WRKSRC}/linux_a.c > ${WRKSRC}/linux_a.c.new
|
||||
@${MV} ${WRKSRC}/linux_a.c.new ${WRKSRC}/linux_a.c
|
||||
|
||||
post-install:
|
||||
cd ${PREFIX}/lib/timidity && \
|
||||
tar zxf ${DISTDIR}/${TIINS} && \
|
||||
|
|
|
@ -18,6 +18,11 @@ RESTRICTED= "Non-redistributable beta"
|
|||
WRKSRC= ${WRKDIR}/tracker
|
||||
INSTALL_TARGET= install install.info
|
||||
|
||||
post-patch:
|
||||
@${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
|
||||
${WRKSRC}/Arch/PCux/audio.c > ${WRKSRC}/Arch/PCux/audio.c.new
|
||||
@${MV} ${WRKSRC}/Arch/PCux/audio.c.new ${WRKSRC}/Arch/PCux/audio.c
|
||||
|
||||
post-install:
|
||||
@install-info ${PREFIX}/info/tracker.info ${PREFIX}/info/dir
|
||||
.if !defined(NOPORTDOCS)
|
||||
|
|
|
@ -21,7 +21,7 @@
|
|||
+ #ifndef FREEBSD
|
||||
#include <linux/soundcard.h>
|
||||
+ #else
|
||||
+ #include <machine/soundcard.h>
|
||||
+ #include <sys/soundcard.h>
|
||||
+ #endif
|
||||
#include "wavplay.h"
|
||||
#include "client.h"
|
||||
|
|
|
@ -21,7 +21,7 @@
|
|||
+ #ifndef FREEBSD
|
||||
#include <linux/soundcard.h>
|
||||
+ #else
|
||||
+ #include <machine/soundcard.h>
|
||||
+ #include <sys/soundcard.h>
|
||||
+ #endif
|
||||
#include "wavplay.h"
|
||||
|
||||
|
|
|
@ -21,7 +21,7 @@
|
|||
+ #ifndef FREEBSD
|
||||
#include <linux/soundcard.h>
|
||||
+ #else
|
||||
+ #include <machine/soundcard.h>
|
||||
+ #include <sys/soundcard.h>
|
||||
+ #endif
|
||||
#include "wavplay.h"
|
||||
|
||||
|
|
|
@ -16,7 +16,7 @@
|
|||
+ #ifndef FREEBSD
|
||||
#include <linux/soundcard.h>
|
||||
+ #else
|
||||
+ #include <machine/soundcard.h>
|
||||
+ #include <sys/soundcard.h>
|
||||
+ #endif
|
||||
#include "wavplay.h"
|
||||
#include "server.h"
|
||||
|
|
|
@ -21,7 +21,7 @@
|
|||
+ #ifndef FREEBSD
|
||||
#include <linux/soundcard.h>
|
||||
+ #else
|
||||
+ #include <machine/soundcard.h>
|
||||
+ #include <sys/soundcard.h>
|
||||
+ #endif
|
||||
#include "wavplay.h"
|
||||
#include "server.h"
|
||||
|
|
|
@ -13,7 +13,7 @@
|
|||
+ #include <sys/types.h>
|
||||
+ #include <sys/dir.h>
|
||||
+ #include <sys/file.h>
|
||||
+ #include <machine/soundcard.h>
|
||||
+ #include <sys/soundcard.h>
|
||||
+ #include <stdlib.h>
|
||||
+ #include <string.h>
|
||||
+ #include <unistd.h>
|
||||
|
|
|
@ -22,6 +22,11 @@ MAN1= ${UTILS:S/$/.1/} ${DEMNS:S/$/.1/} ${DDEMNS:S/$/.1/}
|
|||
|
||||
MAKE_ENV= "OPTFLAGS=${CFLAGS}"
|
||||
|
||||
post-patch:
|
||||
@${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
|
||||
${WRKSRC}/soundbyte.c > ${WRKSRC}/soundbyte.c.new
|
||||
@${MV} ${WRKSRC}/soundbyte.c.new ${WRKSRC}/soundbyte.c
|
||||
|
||||
do-install:
|
||||
if [ ! -d ${SFLIB} ]; then \
|
||||
${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755 ${SFLIB}; \
|
||||
|
|
Loading…
Reference in a new issue