Remove dns/nsd2 at maintainer's request:
This version of nsd is end of life since 2007 and unsupported. See the details at http://nlnetlabs.nl/projects/nsd/nsd-v2.html. The current version also contains a vulnerability. It is much more sensible to move to a supported version (as available in the port dns/nsd). PR: ports/161122 Submitted by: Jaap Akkerhuis <jaap@NLnetLabs.nl> (maintainer)
This commit is contained in:
parent
d8a4632c6f
commit
04f4501eff
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=282683
9 changed files with 1 additions and 181 deletions
1
MOVED
1
MOVED
|
@ -2716,3 +2716,4 @@ www/zope-coreblog2||2011-09-30|Depends on www/plone, which is FORBIDDEN
|
||||||
www/zope-i18nlayer||2011-09-30|Depends on www/plone, which is FORBIDDEN
|
www/zope-i18nlayer||2011-09-30|Depends on www/plone, which is FORBIDDEN
|
||||||
www/zope-plonelanguagetool||2011-09-30|Depends on www/plone, which is FORBIDDEN
|
www/zope-plonelanguagetool||2011-09-30|Depends on www/plone, which is FORBIDDEN
|
||||||
www/zope-simpleblog||2011-09-30|Depends on www/plone, which is FORBIDDEN
|
www/zope-simpleblog||2011-09-30|Depends on www/plone, which is FORBIDDEN
|
||||||
|
dns/nsd2||2011-09-30|EOL since 2007, unsupported. Use dns/nsd instead.
|
||||||
|
|
|
@ -74,7 +74,6 @@
|
||||||
SUBDIR += mydns-ng
|
SUBDIR += mydns-ng
|
||||||
SUBDIR += noip
|
SUBDIR += noip
|
||||||
SUBDIR += nsd
|
SUBDIR += nsd
|
||||||
SUBDIR += nsd2
|
|
||||||
SUBDIR += nslint
|
SUBDIR += nslint
|
||||||
SUBDIR += nsping
|
SUBDIR += nsping
|
||||||
SUBDIR += nss_mdns
|
SUBDIR += nss_mdns
|
||||||
|
|
|
@ -1,110 +0,0 @@
|
||||||
# New ports collection makefile for: nsd2
|
|
||||||
# Date created: 16 October 2006
|
|
||||||
# Whom: oli@isnic.is
|
|
||||||
#
|
|
||||||
# $FreeBSD$
|
|
||||||
#
|
|
||||||
|
|
||||||
PORTNAME= nsd
|
|
||||||
PORTVERSION= 2.3.7
|
|
||||||
PORTREVISION= 2
|
|
||||||
CATEGORIES= dns ipv6
|
|
||||||
MASTER_SITES= http://www.nlnetlabs.nl/downloads/nsd/ \
|
|
||||||
ftp://ftp.rhnet.is/pub/nsd/
|
|
||||||
|
|
||||||
MAINTAINER= jaap@NLnetLabs.nl
|
|
||||||
COMMENT= An authoritative only non-recursive name server
|
|
||||||
|
|
||||||
FORBIDDEN= Vulnerable since 2009-05-19, http://portaudit.freebsd.org/37a8603d-4494-11de-bea7-000c29a67389.html
|
|
||||||
EXPIRATION_DATE= 2011-10-14
|
|
||||||
|
|
||||||
CONFLICTS= nsd-[3-9]*
|
|
||||||
|
|
||||||
USE_RC_SUBR= nsd.sh
|
|
||||||
GNU_CONFIGURE= yes
|
|
||||||
CONFIGURE_ARGS= --with-user=${NSDUSER} \
|
|
||||||
--with-configdir=${NSDDIR} \
|
|
||||||
--with-pidfile=/var/run/nsd.pid \
|
|
||||||
--with-dbfile=${NSDDBFILE} \
|
|
||||||
--with-libwrap
|
|
||||||
|
|
||||||
OPTIONS= ROOT_SERVER "Configure NSD as a root server" Off \
|
|
||||||
IPV6 "Enable IPv6 support" On \
|
|
||||||
DNSSEC "Enable DNSSEC" On \
|
|
||||||
AXFR "Enable AXFR" On \
|
|
||||||
BIND8_STATS "Enable BIND8 like NSTATS & XSTATS" Off \
|
|
||||||
NSID "Enable NSID support" Off \
|
|
||||||
PLUGINS "Enable plugin support" Off \
|
|
||||||
CHECKING "Enable internal runtime checks" Off \
|
|
||||||
TSIG "Enable TSIG support" On \
|
|
||||||
MMAP "Load database using mmap(2)" Off
|
|
||||||
|
|
||||||
MAN8= nsd.8 nsdc.8 zonec.8 nsd-notify.8 nsd-xfer.8
|
|
||||||
|
|
||||||
PORTDOCS= CREDITS LICENSE NSD-DATABASE README README.icc \
|
|
||||||
RELNOTES REQUIREMENTS TODO
|
|
||||||
|
|
||||||
NSDUSER?= bind
|
|
||||||
NSDDIR?= ${PREFIX}/etc/nsd
|
|
||||||
NSDDBFILE?= /var/db/nsd.database
|
|
||||||
|
|
||||||
SUB_LIST= NSDUSER="${NSDUSER}" \
|
|
||||||
NSDDIR="${NSDDIR}" \
|
|
||||||
NSDDBFILE="${NSDDBFILE}"
|
|
||||||
|
|
||||||
LATEST_LINK= nsd2
|
|
||||||
|
|
||||||
.include <bsd.port.pre.mk>
|
|
||||||
|
|
||||||
.if defined(WITH_ROOT_SERVER)
|
|
||||||
CONFIGURE_ARGS+= --enable-root-server
|
|
||||||
.endif
|
|
||||||
|
|
||||||
.if defined(WITHOUT_IPV6)
|
|
||||||
CONFIGURE_ARGS+= --disable-ipv6
|
|
||||||
.endif
|
|
||||||
|
|
||||||
.if defined(WITHOUT_DNSSEC)
|
|
||||||
CONFIGURE_ARGS+= --disable-dnssec
|
|
||||||
.endif
|
|
||||||
|
|
||||||
.if defined(WITHOUT_AXFR)
|
|
||||||
CONFIGURE_ARGS+= --disable-axfr
|
|
||||||
.endif
|
|
||||||
|
|
||||||
.if defined(WITH_BIND8_STATS)
|
|
||||||
CONFIGURE_ARGS+= --enable-bind8-stats
|
|
||||||
.endif
|
|
||||||
|
|
||||||
.if defined(WITH_NSID)
|
|
||||||
CONFIGURE_ARGS+= --enable-nsid
|
|
||||||
.endif
|
|
||||||
|
|
||||||
.if defined(WITH_PLUGINS)
|
|
||||||
CONFIGURE_ARGS+= --enable-plugins
|
|
||||||
.endif
|
|
||||||
|
|
||||||
.if defined(WITH_CHECKING)
|
|
||||||
CONFIGURE_ARGS+= --enable-checking
|
|
||||||
.endif
|
|
||||||
|
|
||||||
.if defined(WITHOUT_TSIG)
|
|
||||||
CONFIGURE_ARGS+= --disable-tsig
|
|
||||||
.endif
|
|
||||||
|
|
||||||
.if defined(WITH_MMAP)
|
|
||||||
CONFIGURE_ARGS+= --enable-mmap
|
|
||||||
.endif
|
|
||||||
|
|
||||||
post-install:
|
|
||||||
${INSTALL_DATA} ${WRKSRC}/nsd.zones.sample ${NSDDIR}
|
|
||||||
${INSTALL_SCRIPT} ${WRKDIR}/nsd.sh ${PREFIX}/etc/rc.d
|
|
||||||
.if !defined(NOPORTDOCS)
|
|
||||||
@${MKDIR} ${DOCSDIR}
|
|
||||||
.for f in ${PORTDOCS}
|
|
||||||
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/${f}
|
|
||||||
.endfor
|
|
||||||
.endif
|
|
||||||
@${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
|
|
||||||
|
|
||||||
.include <bsd.port.post.mk>
|
|
|
@ -1,2 +0,0 @@
|
||||||
SHA256 (nsd-2.3.7.tar.gz) = c2286ed03a8ec8e5036b334db3133dfc10f9558f855bbb27276564e27dbc32b7
|
|
||||||
SIZE (nsd-2.3.7.tar.gz) = 230688
|
|
|
@ -1,29 +0,0 @@
|
||||||
#!/bin/sh
|
|
||||||
#
|
|
||||||
# $FreeBSD$
|
|
||||||
#
|
|
||||||
# PROVIDE: nsd
|
|
||||||
# REQUIRE: DAEMON
|
|
||||||
#
|
|
||||||
# Add the following lines to /etc/rc.conf to enable nsd:
|
|
||||||
#
|
|
||||||
# nsd_enable="YES"
|
|
||||||
# nsd_flags="<set as needed>"
|
|
||||||
|
|
||||||
|
|
||||||
. /etc/rc.subr
|
|
||||||
|
|
||||||
name=nsd
|
|
||||||
rcvar=`set_rcvar`
|
|
||||||
|
|
||||||
required_files=%%NSDDIR%%/nsd.zones
|
|
||||||
|
|
||||||
command=%%PREFIX%%/sbin/${name}
|
|
||||||
pidfile=/var/run/${name}.pid
|
|
||||||
|
|
||||||
# set defaults
|
|
||||||
|
|
||||||
nsd_enable=${nsd_enable:-"NO"}
|
|
||||||
|
|
||||||
load_rc_config ${name}
|
|
||||||
run_rc_command "$1"
|
|
|
@ -1,13 +0,0 @@
|
||||||
--- query.c
|
|
||||||
+++ query.c
|
|
||||||
@@ -239,8 +239,8 @@
|
|
||||||
* MAXDOMAINLEN ...
|
|
||||||
*/
|
|
||||||
if ((*src & 0xc0) ||
|
|
||||||
- (src + *src + 1 > buffer_end(query->packet)) ||
|
|
||||||
- (src + *src + 1 > query_name + MAXDOMAINLEN))
|
|
||||||
+ (src + *src + 2 > buffer_end(query->packet)) ||
|
|
||||||
+ (src + *src + 2 > query_name + MAXDOMAINLEN))
|
|
||||||
{
|
|
||||||
return 0;
|
|
||||||
}
|
|
|
@ -1,4 +0,0 @@
|
||||||
NSD (Name Server Daemon) is a complete implementation of an
|
|
||||||
authoritative DNS nameserver.
|
|
||||||
|
|
||||||
WWW: http://www.nlnetlabs.nl/nsd
|
|
|
@ -1,12 +0,0 @@
|
||||||
**************************************************************************
|
|
||||||
* *
|
|
||||||
* This version of NSD is considered EOL. Please update to *
|
|
||||||
* the latest version (/usr/ports/dns/nsd). *
|
|
||||||
* *
|
|
||||||
* See also http://nlnetlabs.nl/projects/nsd/nsd-v2.html *
|
|
||||||
* *
|
|
||||||
**************************************************************************
|
|
||||||
* *
|
|
||||||
* To run nsd from startup, add nsd_enable="YES" to your /etc/rc.conf *
|
|
||||||
* *
|
|
||||||
**************************************************************************
|
|
|
@ -1,10 +0,0 @@
|
||||||
@comment $FreeBSD$
|
|
||||||
etc/rc.d/nsd.sh
|
|
||||||
etc/nsd/nsdc.conf.sample
|
|
||||||
etc/nsd/nsd.zones.sample
|
|
||||||
sbin/nsd
|
|
||||||
sbin/zonec
|
|
||||||
sbin/nsdc
|
|
||||||
sbin/nsd-notify
|
|
||||||
sbin/nsd-xfer
|
|
||||||
@dirrm etc/nsd
|
|
Loading…
Reference in a new issue