- Fix build on -current
- Utilize INFO PR: ports/62434 Submitted by: Ports Fury
This commit is contained in:
parent
eda222ba4d
commit
05079e4428
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=100144
13 changed files with 164 additions and 23 deletions
|
@ -7,29 +7,31 @@
|
|||
|
||||
PORTNAME= xlogmaster
|
||||
PORTVERSION= 1.6.0
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ${MASTER_SITE_GNU}
|
||||
MASTER_SITE_SUBDIR= xlogmaster
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Quick & easy monitoring of logfiles and devices
|
||||
|
||||
USE_XLIB= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= gtk12
|
||||
USE_GETOPT_LONG= yes
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
|
||||
MAN1= xlogmaster.1
|
||||
INFO= xlogmaster
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
CPPFLAGS= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT
|
||||
LDFLAGS= -L${LOCALBASE}/lib
|
||||
|
||||
.if ${OSVERSION} >= 500113
|
||||
BROKEN= "Does not compile (bad C++ code)"
|
||||
.endif
|
||||
post-extract:
|
||||
-${RM} ${WRKSRC}/import/getopt*
|
||||
|
||||
post-install:
|
||||
@install-info ${PREFIX}/info/xlogmaster.info ${PREFIX}/info/dir
|
||||
${INSTALL_DATA} ${FILESDIR}/xlogmasterrc ${PREFIX}/etc/xlogmaster
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- configure.orig Wed Mar 31 08:00:59 1999
|
||||
+++ configure Fri Feb 11 00:28:01 2000
|
||||
--- configure.orig Thu Apr 1 01:00:59 1999
|
||||
+++ configure Thu Feb 5 22:01:46 2004
|
||||
@@ -860,7 +860,7 @@
|
||||
|
||||
|
||||
|
@ -9,12 +9,12 @@
|
|||
if test x${CXXFLAGS+set} = xset ; then
|
||||
:
|
||||
else
|
||||
@@ -2835,7 +2835,7 @@
|
||||
s%@host_os@%$host_os%g
|
||||
s%@LN_S@%$LN_S%g
|
||||
s%@GTK_CONFIG@%$GTK_CONFIG%g
|
||||
-s%@GTK_CFLAGS@%$GTK_CFLAGS%g
|
||||
+s%@GTK_CFLAGS@%$CFLAGS $GTK_CFLAGS%g
|
||||
s%@GTK_LIBS@%$GTK_LIBS%g
|
||||
s%@CPP@%$CPP%g
|
||||
s%@NEED_LIBIMPORT_TRUE@%$NEED_LIBIMPORT_TRUE%g
|
||||
@@ -1874,7 +1874,7 @@
|
||||
import_sources="$force_libimport"
|
||||
rx_sources="$force_libimport"
|
||||
|
||||
-for ac_func in getopt_long_only
|
||||
+for ac_func in getopt_long
|
||||
do
|
||||
echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
|
||||
echo "configure:1881: checking for $ac_func" >&5
|
||||
|
|
13
sysutils/xlogmaster/files/patch-src::Makefile.in
Normal file
13
sysutils/xlogmaster/files/patch-src::Makefile.in
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- src/Makefile.in.orig Thu Apr 1 01:01:02 1999
|
||||
+++ src/Makefile.in Thu Feb 5 22:17:35 2004
|
||||
@@ -80,8 +80,8 @@
|
||||
@DEVELMODE_TRUE@DEVELFLAGS = -g -Wall
|
||||
|
||||
CLEANFILES = *~ .deps/*
|
||||
-CXXFLAGS = $(GTK_CFLAGS) -DXLM_HOME=\"$(XLM_HOME)\" -DXLM_DB=\"$(XLM_DB)\" -DXLM_USER_DB=\"$(XLM_USER_DB)\" -DXLM_LIB=\"$(XLM_LIB)\" -I../import $(DEVELFLAGS)
|
||||
-LDFLAGS = $(GTK_LIBS)
|
||||
+CXXFLAGS = @CXXFLAGS@ $(GTK_CFLAGS) -DXLM_HOME=\"$(XLM_HOME)\" -DXLM_DB=\"$(XLM_DB)\" -DXLM_USER_DB=\"$(XLM_USER_DB)\" -DXLM_LIB=\"$(XLM_LIB)\" -I../import $(DEVELFLAGS)
|
||||
+LDFLAGS = @LDFLAGS@ $(GTK_LIBS)
|
||||
|
||||
bin_PROGRAMS = xlogmaster
|
||||
xlogmaster_SOURCES = xlogmaster.cc alert.cc audio.cc database.cc dialog.cc execute.cc file.cc logclass.cc menu.cc customize.cc watchdog.cc output.cc
|
11
sysutils/xlogmaster/files/patch-src::database.cc
Normal file
11
sysutils/xlogmaster/files/patch-src::database.cc
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/database.cc.orig Thu Apr 1 01:00:29 1999
|
||||
+++ src/database.cc Thu Feb 5 21:39:55 2004
|
||||
@@ -38,6 +38,8 @@
|
||||
#include "logclass.H"
|
||||
#include "database.H"
|
||||
#include "extern.H"
|
||||
+#include <iostream>
|
||||
+using namespace std;
|
||||
|
||||
/*}}}*/
|
||||
|
11
sysutils/xlogmaster/files/patch-src::execute.cc
Normal file
11
sysutils/xlogmaster/files/patch-src::execute.cc
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/execute.cc.orig Thu Apr 1 01:00:29 1999
|
||||
+++ src/execute.cc Thu Feb 5 21:39:55 2004
|
||||
@@ -38,6 +38,8 @@
|
||||
#include "logclass.H"
|
||||
#include "execute.H"
|
||||
#include "extern.H"
|
||||
+#include <iostream>
|
||||
+using namespace std;
|
||||
|
||||
/*}}}*/
|
||||
|
11
sysutils/xlogmaster/files/patch-src::file.cc
Normal file
11
sysutils/xlogmaster/files/patch-src::file.cc
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/file.cc.orig Thu Apr 1 01:00:29 1999
|
||||
+++ src/file.cc Thu Feb 5 22:11:38 2004
|
||||
@@ -38,6 +38,8 @@
|
||||
#include "logclass.H"
|
||||
#include "file.H"
|
||||
#include "extern.H"
|
||||
+#include <iostream>
|
||||
+using namespace std;
|
||||
|
||||
/*}}}*/
|
||||
|
20
sysutils/xlogmaster/files/patch-src::logclass.H
Normal file
20
sysutils/xlogmaster/files/patch-src::logclass.H
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- src/logclass.H.orig Thu Apr 1 01:00:29 1999
|
||||
+++ src/logclass.H Thu Feb 5 21:39:55 2004
|
||||
@@ -28,7 +28,7 @@
|
||||
|
||||
class Log {
|
||||
/*{{{ Functions */
|
||||
- friend Filter;
|
||||
+ friend class Filter;
|
||||
public:
|
||||
Log();
|
||||
~Log();
|
||||
@@ -200,7 +200,7 @@
|
||||
class Filter
|
||||
{
|
||||
/*{{{ Functions */
|
||||
- friend Log;
|
||||
+ friend class Log;
|
||||
public:
|
||||
Filter();
|
||||
~Filter();
|
11
sysutils/xlogmaster/files/patch-src::logclass.cc
Normal file
11
sysutils/xlogmaster/files/patch-src::logclass.cc
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/logclass.cc.orig Thu Apr 1 01:00:29 1999
|
||||
+++ src/logclass.cc Thu Feb 5 21:39:55 2004
|
||||
@@ -37,6 +37,8 @@
|
||||
#include "../import/import.h"
|
||||
#include "logclass.H"
|
||||
#include "extern.H"
|
||||
+#include <iostream>
|
||||
+using namespace std;
|
||||
|
||||
/*}}}*/
|
||||
|
11
sysutils/xlogmaster/files/patch-src::output.cc
Normal file
11
sysutils/xlogmaster/files/patch-src::output.cc
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/output.cc.orig Thu Apr 1 01:00:29 1999
|
||||
+++ src/output.cc Thu Feb 5 21:39:55 2004
|
||||
@@ -38,6 +38,8 @@
|
||||
#include "logclass.H"
|
||||
#include "output.H"
|
||||
#include "extern.H"
|
||||
+#include <iostream>
|
||||
+using namespace std;
|
||||
|
||||
/*}}}*/
|
||||
|
14
sysutils/xlogmaster/files/patch-src::sysinc.H
Normal file
14
sysutils/xlogmaster/files/patch-src::sysinc.H
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- src/sysinc.H.orig Thu Apr 1 01:00:29 1999
|
||||
+++ src/sysinc.H Thu Feb 5 22:12:43 2004
|
||||
@@ -20,8 +20,9 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <fcntl.h>
|
||||
-#include <fstream.h>
|
||||
-#include <strstream.h>
|
||||
+#include <fstream>
|
||||
+#include <strstream>
|
||||
+using namespace std;
|
||||
#include <unistd.h>
|
||||
#include <string.h>
|
||||
#include <time.h>
|
11
sysutils/xlogmaster/files/patch-src::watchdog.cc
Normal file
11
sysutils/xlogmaster/files/patch-src::watchdog.cc
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/watchdog.cc.orig Thu Apr 1 01:00:29 1999
|
||||
+++ src/watchdog.cc Thu Feb 5 21:39:55 2004
|
||||
@@ -38,6 +38,8 @@
|
||||
#include "logclass.H"
|
||||
#include "watchdog.H"
|
||||
#include "extern.H"
|
||||
+#include <iostream>
|
||||
+using namespace std;
|
||||
|
||||
/*}}}*/
|
||||
|
29
sysutils/xlogmaster/files/patch-src::xlogmaster.cc
Normal file
29
sysutils/xlogmaster/files/patch-src::xlogmaster.cc
Normal file
|
@ -0,0 +1,29 @@
|
|||
--- src/xlogmaster.cc.orig Thu Apr 1 01:00:29 1999
|
||||
+++ src/xlogmaster.cc Thu Feb 5 22:09:28 2004
|
||||
@@ -41,6 +41,8 @@
|
||||
|
||||
#include "../graphics/logo.xpm"
|
||||
#include "../graphics/logo_small.xpm"
|
||||
+#include <iostream>
|
||||
+using namespace std;
|
||||
|
||||
/*}}}*/
|
||||
|
||||
@@ -996,7 +998,7 @@
|
||||
int gtkrc = FALSE;
|
||||
terse = FALSE;
|
||||
|
||||
- x = getopt_long_only(argc, argv, "", options, &opt_index);
|
||||
+ x = getopt_long(argc, argv, "", options, &opt_index);
|
||||
while ( x != -1 && x != '?' ){
|
||||
const gchar* opt = options[opt_index].name;
|
||||
|
||||
@@ -1183,7 +1185,7 @@
|
||||
}
|
||||
}
|
||||
|
||||
- x = getopt_long_only(argc, argv, "", options, &opt_index);
|
||||
+ x = getopt_long(argc, argv, "", options, &opt_index);
|
||||
};
|
||||
|
||||
if ( optind < argc || x == '?' )
|
|
@ -28,9 +28,6 @@ etc/xlogmaster/sound/uniconify
|
|||
etc/xlogmaster/steelblue.gtkrc
|
||||
etc/xlogmaster/xlogmaster.gtkrc
|
||||
etc/xlogmaster/xlogmasterrc
|
||||
@unexec install-info --delete %D/info/xlogmaster.info %D/info/dir
|
||||
info/xlogmaster.info
|
||||
@exec install-info %D/info/xlogmaster.info %D/info/dir
|
||||
@dirrm etc/xlogmaster/database
|
||||
@dirrm etc/xlogmaster/output-plugins
|
||||
@dirrm etc/xlogmaster/scripts
|
||||
|
|
Loading…
Reference in a new issue