security/keepassxc: Update to 2.7.0
PR: 262953 Reported by: courtney.hicks1@icloud.com
This commit is contained in:
parent
d3d8f2d692
commit
05087b0b8a
7 changed files with 84 additions and 64 deletions
|
@ -1,6 +1,5 @@
|
|||
PORTNAME= keepassxc
|
||||
DISTVERSION= 2.6.6
|
||||
PORTREVISION= 2
|
||||
DISTVERSION= 2.7.0
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= https://github.com/keepassxreboot/keepassxc/releases/download/${DISTVERSION}/${PORTNAME}-${DISTVERSION}-src.tar.xz?dummy=/
|
||||
|
||||
|
@ -16,15 +15,13 @@ LICENSE_PERMS_NOKIA-LGPL-EXCEPTION= dist-mirror dist-sell pkg-mirror pkg-sell au
|
|||
|
||||
BUILD_DEPENDS= asciidoctor:textproc/rubygem-asciidoctor
|
||||
LIB_DEPENDS= libargon2.so:security/libargon2 \
|
||||
libgcrypt.so:security/libgcrypt \
|
||||
libgpg-error.so:security/libgpg-error \
|
||||
libqrencode.so:graphics/libqrencode \
|
||||
libsodium.so:security/libsodium
|
||||
libbotan-2.so:security/botan2
|
||||
|
||||
USES= cmake compiler:c++11-lang desktop-file-utils pkgconfig qt:5 \
|
||||
USES= cmake compiler:c++17-lang desktop-file-utils pkgconfig qt:5 \
|
||||
readline shared-mime-info tar:xz xorg
|
||||
USE_QT= concurrent core dbus gui network svg widgets buildtools_build \
|
||||
linguisttools_build qmake_build testlib_build
|
||||
linguisttools_build qmake_build testlib_build x11extras
|
||||
USE_XORG= x11
|
||||
|
||||
CMAKE_OFF= WITH_XC_UPDATECHECK
|
||||
|
@ -37,7 +34,7 @@ OPTIONS_SUB= yes
|
|||
|
||||
AUTOTYPE_CMAKE_BOOL= WITH_XC_AUTOTYPE
|
||||
AUTOTYPE_DESC= Auto-type passwords in input fields
|
||||
AUTOTYPE_USE= QT=x11extras XORG=xi,xtst
|
||||
AUTOTYPE_USE= XORG=xi,xtst
|
||||
|
||||
BROWSER_CMAKE_BOOL= WITH_XC_BROWSER
|
||||
BROWSER_DESC= Browser integration with KeePassXC-Browser
|
||||
|
@ -45,9 +42,9 @@ BROWSER_DESC= Browser integration with KeePassXC-Browser
|
|||
FDOSECRETS_CMAKE_BOOL= WITH_XC_FDOSECRETS
|
||||
FDOSECRETS_DESC= freedesktop.org secrets service support
|
||||
|
||||
KEESHARE_CMAKE_BOOL= WITH_XC_KEESHARE WITH_XC_KEESHARE_SECURE
|
||||
KEESHARE_CMAKE_BOOL= WITH_XC_KEESHARE
|
||||
KEESHARE_DESC= Sharing integration with KeeShare
|
||||
KEESHARE_LIB_DEPENDS= libquazip1-qt5.so:archivers/quazip
|
||||
KEESHARE_LIB_DEPENDS= libminizip.so:archivers/minizip
|
||||
|
||||
# Legacy/Deprecated.
|
||||
NETWORKING_CMAKE_BOOL= WITH_XC_NETWORKING
|
||||
|
@ -58,8 +55,7 @@ SSHAGENT_DESC= SSH agent support
|
|||
|
||||
YUBIKEY_CMAKE_BOOL= WITH_XC_YUBIKEY
|
||||
YUBIKEY_DESC= YubiKey support
|
||||
YUBIKEY_LIB_DEPENDS= libykpers-1.so:security/ykpers \
|
||||
libyubikey.so:security/libyubikey
|
||||
YUBIKEY_LIB_DEPENDS= libpcsclite.so:devel/pcsc-lite
|
||||
|
||||
TEST_CMAKE_BOOL= WITH_TESTS WITH_GUI_TESTS
|
||||
TEST_TEST_TARGET= test
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1624333502
|
||||
SHA256 (keepassxc-2.6.6.tar.xz) = 3603b11ac39b289c47fac77fa150e05fd64b393d8cfdf5732dc3ef106650a4e2
|
||||
SIZE (keepassxc-2.6.6.tar.xz) = 7640532
|
||||
TIMESTAMP = 1648564382
|
||||
SHA256 (keepassxc-2.7.0.tar.xz) = 83be76890904cd6703343fa097d68bcfdd99bb525cf518fa62a7df9293026aa7
|
||||
SIZE (keepassxc-2.7.0.tar.xz) = 8846780
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- src/keeshare/CMakeLists.txt.orig 2021-06-22 18:07:30 UTC
|
||||
+++ src/keeshare/CMakeLists.txt
|
||||
@@ -25,6 +25,7 @@ if(WITH_XC_KEESHARE)
|
||||
find_package(QuaZip)
|
||||
if(QUAZIP_FOUND)
|
||||
set(WITH_XC_KEESHARE_SECURE ON PARENT_SCOPE)
|
||||
+ target_link_directories(keeshare BEFORE PUBLIC ${QUAZIP_LIBRARY_DIRS})
|
||||
target_include_directories(keeshare SYSTEM PRIVATE ${QUAZIP_INCLUDE_DIRS})
|
||||
target_link_libraries(keeshare PRIVATE ${QUAZIP_LIBRARIES})
|
||||
else()
|
11
security/keepassxc/files/patch-src_keeshare_ShareExport.cpp
Normal file
11
security/keepassxc/files/patch-src_keeshare_ShareExport.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/keeshare/ShareExport.cpp.orig 2022-03-21 22:47:20 UTC
|
||||
+++ src/keeshare/ShareExport.cpp
|
||||
@@ -27,7 +27,7 @@
|
||||
|
||||
#include <QBuffer>
|
||||
#include <botan/pubkey.h>
|
||||
-#include <zip.h>
|
||||
+#include <minizip/zip.h>
|
||||
|
||||
namespace
|
||||
{
|
11
security/keepassxc/files/patch-src_keeshare_ShareImport.cpp
Normal file
11
security/keepassxc/files/patch-src_keeshare_ShareImport.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/keeshare/ShareImport.cpp.orig 2022-03-21 22:47:20 UTC
|
||||
+++ src/keeshare/ShareImport.cpp
|
||||
@@ -21,7 +21,7 @@
|
||||
#include "keys/PasswordKey.h"
|
||||
|
||||
#include <QBuffer>
|
||||
-#include <unzip.h>
|
||||
+#include <minizip/unzip.h>
|
||||
|
||||
namespace
|
||||
{
|
|
@ -0,0 +1,11 @@
|
|||
--- src/thirdparty/ykcore/CMakeLists.txt.orig 2022-03-21 22:47:20 UTC
|
||||
+++ src/thirdparty/ykcore/CMakeLists.txt
|
||||
@@ -27,7 +27,7 @@ elseif(UNIX AND NOT APPLE)
|
||||
elseif(UNIX AND NOT APPLE)
|
||||
target_sources(ykcore PRIVATE ykcore_libusb-1.0.c)
|
||||
|
||||
- find_library(LIBUSB_LIBRARY NAMES usb-1.0)
|
||||
+ find_library(LIBUSB_LIBRARY NAMES usb-1.0 usb)
|
||||
find_path(LIBUSB_INCLUDE_DIR NAMES libusb.h PATH_SUFFIXES "libusb-1.0" "libusb")
|
||||
if(NOT LIBUSB_LIBRARY OR NOT LIBUSB_INCLUDE_DIR)
|
||||
message(FATAL_ERROR "libusb-1.0 dev package required, but not found")
|
|
@ -1,7 +1,7 @@
|
|||
bin/keepassxc
|
||||
bin/keepassxc-cli
|
||||
%%BROWSER%%bin/keepassxc-proxy
|
||||
%%AUTOTYPE%%lib/keepassxc/libkeepassx-autotype-xcb.so
|
||||
%%AUTOTYPE%%lib/keepassxc/libkeepassxc-autotype-xcb.so
|
||||
man/man1/keepassxc-cli.1.gz
|
||||
man/man1/keepassxc.1.gz
|
||||
share/applications/org.keepassxc.KeePassXC.desktop
|
||||
|
@ -18,44 +18,45 @@ share/icons/hicolor/scalable/mimetypes/application-x-keepassxc.svg
|
|||
%%DATADIR%%/docs/KeePassXC_KeyboardShortcuts.html
|
||||
%%DATADIR%%/docs/KeePassXC_UserGuide.html
|
||||
%%DATADIR%%/icons/application/256x256/apps/keepassxc.png
|
||||
%%DATADIR%%/translations/keepassx_ar.qm
|
||||
%%DATADIR%%/translations/keepassx_bg.qm
|
||||
%%DATADIR%%/translations/keepassx_ca.qm
|
||||
%%DATADIR%%/translations/keepassx_cs.qm
|
||||
%%DATADIR%%/translations/keepassx_da.qm
|
||||
%%DATADIR%%/translations/keepassx_de.qm
|
||||
%%DATADIR%%/translations/keepassx_el.qm
|
||||
%%DATADIR%%/translations/keepassx_en.qm
|
||||
%%DATADIR%%/translations/keepassx_en_GB.qm
|
||||
%%DATADIR%%/translations/keepassx_en_US.qm
|
||||
%%DATADIR%%/translations/keepassx_es.qm
|
||||
%%DATADIR%%/translations/keepassx_et.qm
|
||||
%%DATADIR%%/translations/keepassx_fi.qm
|
||||
%%DATADIR%%/translations/keepassx_fr.qm
|
||||
%%DATADIR%%/translations/keepassx_fr_CA.qm
|
||||
%%DATADIR%%/translations/keepassx_hr_HR.qm
|
||||
%%DATADIR%%/translations/keepassx_hu.qm
|
||||
%%DATADIR%%/translations/keepassx_id.qm
|
||||
%%DATADIR%%/translations/keepassx_it.qm
|
||||
%%DATADIR%%/translations/keepassx_ja.qm
|
||||
%%DATADIR%%/translations/keepassx_ko.qm
|
||||
%%DATADIR%%/translations/keepassx_lt.qm
|
||||
%%DATADIR%%/translations/keepassx_nb.qm
|
||||
%%DATADIR%%/translations/keepassx_nl_NL.qm
|
||||
%%DATADIR%%/translations/keepassx_pl.qm
|
||||
%%DATADIR%%/translations/keepassx_pt_BR.qm
|
||||
%%DATADIR%%/translations/keepassx_pt_PT.qm
|
||||
%%DATADIR%%/translations/keepassx_ro.qm
|
||||
%%DATADIR%%/translations/keepassx_ru.qm
|
||||
%%DATADIR%%/translations/keepassx_sk.qm
|
||||
%%DATADIR%%/translations/keepassx_sl_SI.qm
|
||||
%%DATADIR%%/translations/keepassx_sr.qm
|
||||
%%DATADIR%%/translations/keepassx_sv.qm
|
||||
%%DATADIR%%/translations/keepassx_th.qm
|
||||
%%DATADIR%%/translations/keepassx_tr.qm
|
||||
%%DATADIR%%/translations/keepassx_uk.qm
|
||||
%%DATADIR%%/translations/keepassx_zh_CN.qm
|
||||
%%DATADIR%%/translations/keepassx_zh_TW.qm
|
||||
%%DATADIR%%/translations/keepassxc_ar.qm
|
||||
%%DATADIR%%/translations/keepassxc_bg.qm
|
||||
%%DATADIR%%/translations/keepassxc_ca.qm
|
||||
%%DATADIR%%/translations/keepassxc_cs.qm
|
||||
%%DATADIR%%/translations/keepassxc_da.qm
|
||||
%%DATADIR%%/translations/keepassxc_de.qm
|
||||
%%DATADIR%%/translations/keepassxc_el.qm
|
||||
%%DATADIR%%/translations/keepassxc_en.qm
|
||||
%%DATADIR%%/translations/keepassxc_en_GB.qm
|
||||
%%DATADIR%%/translations/keepassxc_en_US.qm
|
||||
%%DATADIR%%/translations/keepassxc_es.qm
|
||||
%%DATADIR%%/translations/keepassxc_et.qm
|
||||
%%DATADIR%%/translations/keepassxc_fi.qm
|
||||
%%DATADIR%%/translations/keepassxc_fr.qm
|
||||
%%DATADIR%%/translations/keepassxc_fr_CA.qm
|
||||
%%DATADIR%%/translations/keepassxc_he.qm
|
||||
%%DATADIR%%/translations/keepassxc_hr.qm
|
||||
%%DATADIR%%/translations/keepassxc_hu.qm
|
||||
%%DATADIR%%/translations/keepassxc_id.qm
|
||||
%%DATADIR%%/translations/keepassxc_it.qm
|
||||
%%DATADIR%%/translations/keepassxc_ja.qm
|
||||
%%DATADIR%%/translations/keepassxc_ko.qm
|
||||
%%DATADIR%%/translations/keepassxc_my.qm
|
||||
%%DATADIR%%/translations/keepassxc_nb.qm
|
||||
%%DATADIR%%/translations/keepassxc_nl.qm
|
||||
%%DATADIR%%/translations/keepassxc_pl.qm
|
||||
%%DATADIR%%/translations/keepassxc_pt_BR.qm
|
||||
%%DATADIR%%/translations/keepassxc_pt_PT.qm
|
||||
%%DATADIR%%/translations/keepassxc_ro.qm
|
||||
%%DATADIR%%/translations/keepassxc_ru.qm
|
||||
%%DATADIR%%/translations/keepassxc_sk.qm
|
||||
%%DATADIR%%/translations/keepassxc_sl.qm
|
||||
%%DATADIR%%/translations/keepassxc_sr.qm
|
||||
%%DATADIR%%/translations/keepassxc_sv.qm
|
||||
%%DATADIR%%/translations/keepassxc_th.qm
|
||||
%%DATADIR%%/translations/keepassxc_tr.qm
|
||||
%%DATADIR%%/translations/keepassxc_uk.qm
|
||||
%%DATADIR%%/translations/keepassxc_zh_CN.qm
|
||||
%%DATADIR%%/translations/keepassxc_zh_TW.qm
|
||||
%%DATADIR%%/wordlists/eff_large.wordlist
|
||||
share/metainfo/org.keepassxc.KeePassXC.appdata.xml
|
||||
share/mime/packages/keepassxc.xml
|
||||
|
|
Loading…
Reference in a new issue