Update to version 3.9.7 which is required for salt-3001
PR: 247390 Submitted by: ohauer@
This commit is contained in:
parent
265f35137b
commit
050d2b5a0d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=539566
3 changed files with 4 additions and 33 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= pycryptodome
|
||||
DISTVERSION= 3.9.0
|
||||
DISTVERSION= 3.9.7
|
||||
CATEGORIES= security python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1572390856
|
||||
SHA256 (pycryptodome-3.9.0.tar.gz) = dbeb08ad850056747aa7d5f33273b7ce0b9a77910604a1be7b7a6f2ef076213f
|
||||
SIZE (pycryptodome-3.9.0.tar.gz) = 11561613
|
||||
TIMESTAMP = 1582738914
|
||||
SHA256 (pycryptodome-3.9.7.tar.gz) = f1add21b6d179179b3c177c33d18a2186a09cc0d3af41ff5ed3f377360b869f2
|
||||
SIZE (pycryptodome-3.9.7.tar.gz) = 15451558
|
||||
|
|
|
@ -1,29 +0,0 @@
|
|||
commit b3a394d0837ff92919d35d01de9952b8809e802d
|
||||
Author: Helder Eijs <helderijs@gmail.com>
|
||||
Date: Wed Aug 28 07:52:19 2019 +0200
|
||||
|
||||
Force UTF-8 encoding when translating files
|
||||
|
||||
diff --git ./setup.py ./setup.py
|
||||
index 9d88bc1e..1d70caad 100644
|
||||
--- ./setup.py
|
||||
+++ ./setup.py
|
||||
@@ -222,14 +222,18 @@ def create_cryptodome_lib():
|
||||
if full_file_name_src != "py.typed":
|
||||
continue
|
||||
|
||||
- with open(full_file_name_dst, "rt") as fd:
|
||||
+ if sys.version_info[0] > 2:
|
||||
+ extra_param = { "encoding": "utf-8" }
|
||||
+ else:
|
||||
+ extra_param = {}
|
||||
+ with open(full_file_name_dst, "rt", **extra_param) as fd:
|
||||
content = (fd.read().
|
||||
replace("Crypto.", "Cryptodome.").
|
||||
replace("Crypto ", "Cryptodome ").
|
||||
replace("'Crypto'", "'Cryptodome'").
|
||||
replace('"Crypto"', '"Cryptodome"'))
|
||||
os.remove(full_file_name_dst)
|
||||
- with open(full_file_name_dst, "wt") as fd:
|
||||
+ with open(full_file_name_dst, "wt", **extra_param) as fd:
|
||||
fd.write(content)
|
Loading…
Reference in a new issue