Add dnsmasq 1.12, a caching DNS forwarder.
PR: 52840 Submitted by: Steven Honson <shonson@isoproplex.net>
This commit is contained in:
parent
80b21198f5
commit
0521957a16
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=82078
15 changed files with 151 additions and 0 deletions
29
dns/dnsmasq/Makefile
Normal file
29
dns/dnsmasq/Makefile
Normal file
|
@ -0,0 +1,29 @@
|
|||
# New ports collection makefile for: dnsmasq
|
||||
# Date created: 1 June 2003
|
||||
# Whom: Steven Honson <shonson@isoproplex.net>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= dnsmasq
|
||||
PORTVERSION= 1.12
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://www.thekelleys.org.uk/dnsmasq/
|
||||
|
||||
MAINTAINER= shonson@isoproplex.net
|
||||
COMMENT= A caching DNS forwarder
|
||||
|
||||
.if defined(WITH_IPV6)
|
||||
CFLAGS += -DWITH_IPV6
|
||||
.endif
|
||||
|
||||
MAN8= dnsmasq.8
|
||||
|
||||
pre-fetch:
|
||||
.if !defined(WITH_IPV6)
|
||||
@${ECHO_CMD} ""
|
||||
@${ECHO_CMD} "Define WITH_IPV6 to build dnsmasq with IPv6 support."
|
||||
@${ECHO_CMD} ""
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
dns/dnsmasq/distinfo
Normal file
1
dns/dnsmasq/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (dnsmasq-1.12.tar.gz) = 41f4ef37bb38e7b50430d00de92d5789
|
11
dns/dnsmasq/files/patch-Makefile
Normal file
11
dns/dnsmasq/files/patch-Makefile
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Makefile.orig Mon Jun 2 22:22:30 2003
|
||||
+++ Makefile Mon Jun 2 22:22:35 2003
|
||||
@@ -3,7 +3,7 @@
|
||||
MANDIR = /usr/local/man
|
||||
|
||||
CC = gcc
|
||||
-CFLAGS = -O2
|
||||
+CFLAGS += -O2
|
||||
|
||||
all : dnsmasq
|
||||
|
12
dns/dnsmasq/files/patch-config.h
Normal file
12
dns/dnsmasq/files/patch-config.h
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- config.h.orig Mon Jun 2 22:04:52 2003
|
||||
+++ config.h Mon Jun 2 22:05:03 2003
|
||||
@@ -35,7 +35,7 @@
|
||||
/* We assume that systems which don't have IPv6
|
||||
headers don't have ntop and pton either */
|
||||
|
||||
-#if defined(INET6_ADDRSTRLEN)
|
||||
+#if defined(INET6_ADDRSTRLEN) && defined(WITH_IPV6)
|
||||
# define HAVE_IPV6
|
||||
# define ADDRSTRLEN INET6_ADDRSTRLEN
|
||||
#elif defined(INET_ADDRSTRLEN)
|
||||
|
11
dns/dnsmasq/files/patch-dnsmasq.h
Normal file
11
dns/dnsmasq/files/patch-dnsmasq.h
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- dnsmasq.h.orig Mon Jun 2 00:17:58 2003
|
||||
+++ dnsmasq.h Mon Jun 2 00:18:08 2003
|
||||
@@ -16,7 +16,7 @@
|
||||
#include <sys/types.h>
|
||||
#include <netinet/in.h>
|
||||
/* and this for C library versions */
|
||||
-#include <libio.h>
|
||||
+/* #include <libio.h> */
|
||||
|
||||
#include "config.h"
|
||||
|
10
dns/dnsmasq/pkg-descr
Normal file
10
dns/dnsmasq/pkg-descr
Normal file
|
@ -0,0 +1,10 @@
|
|||
Dnsmasq is a caching DNS forwarder designed to provide DNS service on a
|
||||
small network. It is targeted at home networks using NAT and connected to
|
||||
the internet via a modem, cable-modem or ADSL connection but would be a
|
||||
good choice for any small network where low resource use and ease of
|
||||
configuration are important.
|
||||
|
||||
WWW: http://www.thekelleys.org.uk/dnsmasq/doc.html
|
||||
|
||||
- Steven Honson
|
||||
shonson@isoproplex.net
|
1
dns/dnsmasq/pkg-plist
Normal file
1
dns/dnsmasq/pkg-plist
Normal file
|
@ -0,0 +1 @@
|
|||
sbin/dnsmasq
|
|
@ -113,6 +113,7 @@
|
|||
SUBDIR += dlint
|
||||
SUBDIR += dnrd
|
||||
SUBDIR += dns_balance
|
||||
SUBDIR += dnsmasq
|
||||
SUBDIR += dnssecwalker
|
||||
SUBDIR += dnstop
|
||||
SUBDIR += dnstracer
|
||||
|
|
29
net/dnsmasq/Makefile
Normal file
29
net/dnsmasq/Makefile
Normal file
|
@ -0,0 +1,29 @@
|
|||
# New ports collection makefile for: dnsmasq
|
||||
# Date created: 1 June 2003
|
||||
# Whom: Steven Honson <shonson@isoproplex.net>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= dnsmasq
|
||||
PORTVERSION= 1.12
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://www.thekelleys.org.uk/dnsmasq/
|
||||
|
||||
MAINTAINER= shonson@isoproplex.net
|
||||
COMMENT= A caching DNS forwarder
|
||||
|
||||
.if defined(WITH_IPV6)
|
||||
CFLAGS += -DWITH_IPV6
|
||||
.endif
|
||||
|
||||
MAN8= dnsmasq.8
|
||||
|
||||
pre-fetch:
|
||||
.if !defined(WITH_IPV6)
|
||||
@${ECHO_CMD} ""
|
||||
@${ECHO_CMD} "Define WITH_IPV6 to build dnsmasq with IPv6 support."
|
||||
@${ECHO_CMD} ""
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
net/dnsmasq/distinfo
Normal file
1
net/dnsmasq/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (dnsmasq-1.12.tar.gz) = 41f4ef37bb38e7b50430d00de92d5789
|
11
net/dnsmasq/files/patch-Makefile
Normal file
11
net/dnsmasq/files/patch-Makefile
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Makefile.orig Mon Jun 2 22:22:30 2003
|
||||
+++ Makefile Mon Jun 2 22:22:35 2003
|
||||
@@ -3,7 +3,7 @@
|
||||
MANDIR = /usr/local/man
|
||||
|
||||
CC = gcc
|
||||
-CFLAGS = -O2
|
||||
+CFLAGS += -O2
|
||||
|
||||
all : dnsmasq
|
||||
|
12
net/dnsmasq/files/patch-config.h
Normal file
12
net/dnsmasq/files/patch-config.h
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- config.h.orig Mon Jun 2 22:04:52 2003
|
||||
+++ config.h Mon Jun 2 22:05:03 2003
|
||||
@@ -35,7 +35,7 @@
|
||||
/* We assume that systems which don't have IPv6
|
||||
headers don't have ntop and pton either */
|
||||
|
||||
-#if defined(INET6_ADDRSTRLEN)
|
||||
+#if defined(INET6_ADDRSTRLEN) && defined(WITH_IPV6)
|
||||
# define HAVE_IPV6
|
||||
# define ADDRSTRLEN INET6_ADDRSTRLEN
|
||||
#elif defined(INET_ADDRSTRLEN)
|
||||
|
11
net/dnsmasq/files/patch-dnsmasq.h
Normal file
11
net/dnsmasq/files/patch-dnsmasq.h
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- dnsmasq.h.orig Mon Jun 2 00:17:58 2003
|
||||
+++ dnsmasq.h Mon Jun 2 00:18:08 2003
|
||||
@@ -16,7 +16,7 @@
|
||||
#include <sys/types.h>
|
||||
#include <netinet/in.h>
|
||||
/* and this for C library versions */
|
||||
-#include <libio.h>
|
||||
+/* #include <libio.h> */
|
||||
|
||||
#include "config.h"
|
||||
|
10
net/dnsmasq/pkg-descr
Normal file
10
net/dnsmasq/pkg-descr
Normal file
|
@ -0,0 +1,10 @@
|
|||
Dnsmasq is a caching DNS forwarder designed to provide DNS service on a
|
||||
small network. It is targeted at home networks using NAT and connected to
|
||||
the internet via a modem, cable-modem or ADSL connection but would be a
|
||||
good choice for any small network where low resource use and ease of
|
||||
configuration are important.
|
||||
|
||||
WWW: http://www.thekelleys.org.uk/dnsmasq/doc.html
|
||||
|
||||
- Steven Honson
|
||||
shonson@isoproplex.net
|
1
net/dnsmasq/pkg-plist
Normal file
1
net/dnsmasq/pkg-plist
Normal file
|
@ -0,0 +1 @@
|
|||
sbin/dnsmasq
|
Loading…
Reference in a new issue