- include dependecy to mathlib

- remove -lm patches
Suggested by: kris

Caveats: All linkage with netpbm includes mathlib now.
This commit is contained in:
Dirk Meyer 2004-04-04 06:34:02 +00:00
parent 91542b5c85
commit 052718d444
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=106097
6 changed files with 6 additions and 47 deletions

View file

@ -7,6 +7,7 @@
PORTNAME= netpbm
PORTVERSION= 10.21
PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}

View file

@ -1,11 +0,0 @@
--- converter/other/Makefile.orig Fri Jul 11 05:23:53 2003
+++ converter/other/Makefile Tue Mar 30 06:59:13 2004
@@ -7,6 +7,8 @@
include $(BUILDDIR)/Makefile.config
+LADD += -lm
+
SUBDIRS = jbig pnmtopalm
ifneq ($(BUILD_FIASCO), N)
SUBDIRS += fiasco

View file

@ -1,11 +0,0 @@
--- converter/other/jbig/Makefile.orig Sat Sep 13 04:43:39 2003
+++ converter/other/jbig/Makefile Tue Mar 30 07:04:32 2004
@@ -7,6 +7,8 @@
include $(BUILDDIR)/Makefile.config
+LADD += -lm
+
LIBJBIG_OBJECTS = jbig.o jbig_tab.o
INCLUDES =

View file

@ -1,11 +0,0 @@
--- converter/other/pnmtopalm/Makefile.orig Sat Sep 13 04:43:54 2003
+++ converter/other/pnmtopalm/Makefile Tue Mar 30 07:05:24 2004
@@ -7,6 +7,8 @@
include $(BUILDDIR)/Makefile.config
+LADD += -lm
+
BINARIES = palmtopnm pnmtopalm
SCRIPTS =
OBJECTS = $(BINARIES:%=%.o) palmcolormap.o

View file

@ -1,11 +0,0 @@
--- converter/pbm/pbmtoppa/Makefile.orig Fri Jun 6 04:54:07 2003
+++ converter/pbm/pbmtoppa/Makefile Tue Mar 30 06:53:38 2004
@@ -7,6 +7,8 @@
include $(BUILDDIR)/Makefile.config
+LADD += -lm
+
all: pbmtoppa
BINARIES = pbmtoppa

View file

@ -1,5 +1,5 @@
--- lib/Makefile.orig Thu Mar 18 19:09:21 2004
+++ lib/Makefile Tue Mar 30 06:34:58 2004
+++ lib/Makefile Sun Apr 4 08:05:19 2004
@@ -34,6 +34,8 @@
# Library objects to be linked but not built by Makefile.common:
LIBOBJECTS_X = util/shhopt.o util/nstring.o
@ -26,7 +26,7 @@
ifeq ($(NETPBMLIBTYPE),irixshared)
# The libxxx.so link is needed to link the executables.
@@ -104,11 +109,8 @@
@@ -104,12 +109,9 @@
# The $(SONAME) link is needed only to test the programs without
# installing the libraries (in that case, you also need to direct the
# dynamic linker to the source directories, e.g. set LD_LIBRARY_PATH).
@ -35,11 +35,13 @@
- $(SYMLINK) $< $@
-libnetpbm.$(NETPBMLIBSUFFIX).$(MAJ).$(MIN): $(LIBOBJECTS) $(LIBOBJECTS_X)
- $(LD) $(LDSHLIB) -o $@ $(LIBOBJECTS) $(LIBOBJECTS_X) \
- $(SHLIB_CLIB) $(LADD)
+$(SONAME): $(SHLIBOBJECTS) $(LIBOBJECTS_X)
+ $(LD) $(LDSHLIB) -o $@ $(SHLIBOBJECTS) $(LIBOBJECTS_X) \
$(SHLIB_CLIB) $(LADD)
+ $(SHLIB_CLIB) $(MATHLIB) $(LADD)
endif
ifeq ($(NETPBMLIBTYPE),dll)
@@ -186,13 +188,10 @@
.PHONY: install.lib
ifeq ($(NETPBMLIBTYPE),unixshared)