Add h3 3.6.4
H3 is a geospatial indexing system using a hexagonal grid that can be (approximately) subdivided into finer and finer hexagonal grids, combining the benefits of a hexagonal grid with S2's hierarchical subdivisions. WWW: https://github.com/uber/h3
This commit is contained in:
parent
641847e5ad
commit
0562c54665
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=548310
6 changed files with 80 additions and 0 deletions
|
@ -327,6 +327,7 @@
|
|||
SUBDIR += guile-cairo
|
||||
SUBDIR += guilib
|
||||
SUBDIR += gwenview
|
||||
SUBDIR += h3
|
||||
SUBDIR += hdr_tools
|
||||
SUBDIR += heimer
|
||||
SUBDIR += hiptext
|
||||
|
|
23
graphics/h3/Makefile
Normal file
23
graphics/h3/Makefile
Normal file
|
@ -0,0 +1,23 @@
|
|||
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= h3
|
||||
PORTVERSION= 3.6.4
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= graphics
|
||||
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= Hexagonal hierarchical geospatial indexing system
|
||||
|
||||
LICENSE= APACHE20
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
USES= cmake
|
||||
|
||||
CMAKE_ON= BUILD_SHARED_LIBS
|
||||
USE_CSTD= c99
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= uber
|
||||
|
||||
.include <bsd.port.mk>
|
3
graphics/h3/distinfo
Normal file
3
graphics/h3/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1599729117
|
||||
SHA256 (uber-h3-v3.6.4_GH0.tar.gz) = b80c2eee2b3e645de77893e27ca149e63d3bb6bf95d33e3a384e3f390e2681bb
|
||||
SIZE (uber-h3-v3.6.4_GH0.tar.gz) = 17297475
|
30
graphics/h3/files/patch-CMakeLists.txt
Normal file
30
graphics/h3/files/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,30 @@
|
|||
--- CMakeLists.txt.orig 2020-06-20 00:40:07 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -274,27 +274,6 @@ elseif(NOT CLANG_TIDY_PATH)
|
||||
"so source code linting is disabled")
|
||||
endif()
|
||||
|
||||
-# Docs
|
||||
-find_package(Doxygen)
|
||||
-option(ENABLE_DOCS "Enable building documentation." ON)
|
||||
-if(DOXYGEN_FOUND AND ENABLE_DOCS)
|
||||
- set_property(DIRECTORY APPEND PROPERTY ADDITIONAL_MAKE_CLEAN_FILES "${CMAKE_CURRENT_BINARY_DIR}/dev-docs/_build")
|
||||
- configure_file(dev-docs/Doxyfile.in
|
||||
- dev-docs/Doxyfile
|
||||
- ESCAPE_QUOTES
|
||||
- )
|
||||
- add_custom_target(docs
|
||||
- ALL
|
||||
- ${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/dev-docs/Doxyfile
|
||||
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/dev-docs
|
||||
- COMMENT "Generating API documentation with Doxygen" VERBATIM
|
||||
- )
|
||||
-else()
|
||||
- add_custom_target(docs
|
||||
- echo "Doxygen was not installed when CMake was run or ENABLE_DOCS was OFF. Check that Doxygen is installed and rerun `cmake .`" VERBATIM
|
||||
- )
|
||||
-endif()
|
||||
-
|
||||
# Metadata for bindings
|
||||
if (WIN32)
|
||||
add_custom_target(binding-functions
|
5
graphics/h3/pkg-descr
Normal file
5
graphics/h3/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
H3 is a geospatial indexing system using a hexagonal grid that can be
|
||||
(approximately) subdivided into finer and finer hexagonal grids, combining the
|
||||
benefits of a hexagonal grid with S2's hierarchical subdivisions.
|
||||
|
||||
WWW: https://github.com/uber/h3
|
18
graphics/h3/pkg-plist
Normal file
18
graphics/h3/pkg-plist
Normal file
|
@ -0,0 +1,18 @@
|
|||
bin/geoToH3
|
||||
bin/h3ToComponents
|
||||
bin/h3ToGeo
|
||||
bin/h3ToGeoBoundary
|
||||
bin/h3ToGeoBoundaryHier
|
||||
bin/h3ToGeoHier
|
||||
bin/h3ToHier
|
||||
bin/h3ToLocalIj
|
||||
bin/hexRange
|
||||
bin/kRing
|
||||
bin/localIjToH3
|
||||
include/h3/h3api.h
|
||||
lib/cmake/h3/h3Config.cmake
|
||||
lib/cmake/h3/h3ConfigVersion.cmake
|
||||
lib/cmake/h3/h3Targets-%%CMAKE_BUILD_TYPE%%.cmake
|
||||
lib/cmake/h3/h3Targets.cmake
|
||||
lib/libh3.so
|
||||
lib/libh3.so.1
|
Loading…
Reference in a new issue