- Add LICENSE
- Switch to options helpers - Add NO_ARCH - Regenerate patches with `make makepatch` Approved by: portmgr blanket
This commit is contained in:
parent
220cf09b32
commit
05659f6b81
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=404423
3 changed files with 11 additions and 10 deletions
|
@ -12,10 +12,14 @@ DISTNAME= forgetSQL-${PORTVERSION}
|
|||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Python module for object-oriented access to SQL databases
|
||||
|
||||
LICENSE= LGPL21
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
USES= python:2
|
||||
USE_PYTHON= distutils autoplist
|
||||
NO_ARCH= yes
|
||||
|
||||
DOCS= BUGS README TODO
|
||||
PORTDOCS= BUGS README TODO
|
||||
|
||||
OPTIONS_DEFINE= DOCS MYSQL PGSQL
|
||||
|
||||
|
@ -37,11 +41,11 @@ post-install:
|
|||
@${ECHO_MSG} "===> you should install py-psycopg or py-MySQLdb from ports/databases."
|
||||
@${ECHO}
|
||||
.endif
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
${INSTALL} -d -o root -g wheel -m 0755 ${STAGEDIR}${DOCSDIR}
|
||||
.for f in ${DOCS}
|
||||
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for f in ${PORTDOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- lib/forgetSQL.py.orig Sat Nov 20 16:59:07 2004
|
||||
+++ lib/forgetSQL.py Sat Nov 20 16:59:39 2004
|
||||
--- lib/forgetSQL.py.orig 2004-03-08 12:16:25 UTC
|
||||
+++ lib/forgetSQL.py
|
||||
@@ -1,4 +1,5 @@
|
||||
#!/usr/bin/env python
|
||||
+# -*- coding: ISO-8859-1 -*-
|
||||
|
|
|
@ -1,3 +0,0 @@
|
|||
%%PORTDOCS%%%%DOCSDIR%%/BUGS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/TODO
|
Loading…
Reference in a new issue