- Support CXX/CXXFLAGS/X11BASE/MAKE properly
- Add WWW: line into pkg/DESCR PR: 18048 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
This commit is contained in:
parent
b0ebb7577e
commit
056ad3997c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=27757
4 changed files with 42 additions and 11 deletions
|
@ -1,4 +1,4 @@
|
|||
# New ports collection makefile for: oonsoo
|
||||
# New ports collection makefile for: oonsoo
|
||||
# Date created: 23rd June, 1997
|
||||
# Whom: Joel Sutton <jsutton@bbcon.com.au>
|
||||
#
|
||||
|
@ -19,6 +19,6 @@ pre-patch:
|
|||
@${CP} ${WRKSRC}/Makefile.Linux ${WRKSRC}/Makefile
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/oonsoo ${PREFIX}/bin/
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/oonsoo ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,11 +1,23 @@
|
|||
--- Makefile.orig Thu Feb 24 03:02:50 2000
|
||||
+++ Makefile Thu Feb 24 03:03:06 2000
|
||||
@@ -12,7 +12,7 @@
|
||||
CPPFLAGS=-O -ansi
|
||||
--- Makefile.orig Thu Feb 24 03:29:29 2000
|
||||
+++ Makefile Thu Feb 24 03:42:58 2000
|
||||
@@ -6,16 +6,16 @@
|
||||
###############################################################################
|
||||
|
||||
## C++ compiler to use
|
||||
-CC=g++
|
||||
+CC = ${CXX}
|
||||
|
||||
## C++ compiler flags
|
||||
-CPPFLAGS=-O -ansi
|
||||
+CPPFLAGS = ${CXXFLAGS} -ansi
|
||||
|
||||
## System Includes
|
||||
-SYS_INCLUDES =
|
||||
+SYS_INCLUDE = -I/usr/X11R6/include
|
||||
+SYS_INCLUDE = -I${X11BASE}/include
|
||||
|
||||
## System Libraries
|
||||
SYS_LIBS = -L/usr/X11R6/lib -lX11
|
||||
-SYS_LIBS = -L/usr/X11R6/lib -lX11
|
||||
+SYS_LIBS = -L${X11BASE}/lib -lX11
|
||||
|
||||
## Archiver
|
||||
AR=ar
|
||||
|
|
20
games/oonsoo/files/patch-ab
Normal file
20
games/oonsoo/files/patch-ab
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- Makefile.common.orig Tue Jan 11 08:36:39 2000
|
||||
+++ Makefile.common Thu Feb 24 04:14:30 2000
|
||||
@@ -33,7 +33,7 @@
|
||||
echo ""; \
|
||||
echo "------ Building: $$dir"; \
|
||||
cd $$dir; \
|
||||
- make $(MAKEPARMS) MAKEPARMS="$(MAKEPARMS)" all; \
|
||||
+ $(MAKE) $(MAKEPARMS) MAKEPARMS="$(MAKEPARMS)" all; \
|
||||
if [ $$? -eq 0 ] ; \
|
||||
then \
|
||||
cd ..; \
|
||||
@@ -48,7 +48,7 @@
|
||||
echo ""; \
|
||||
echo "------ Cleaning: $$dir"; \
|
||||
cd $$dir; \
|
||||
- make $(MAKEPARMS) MAKEPARMS="$(MAKEPARMS)" clean; \
|
||||
+ $(MAKE) $(MAKEPARMS) MAKEPARMS="$(MAKEPARMS)" clean; \
|
||||
if [ $$? -eq 0 ] ; \
|
||||
then \
|
||||
cd ..; \
|
|
@ -3,10 +3,9 @@ onto twelve playing decks. When the game starts, one card face down
|
|||
and one card face up is dealt to each of the playing decks.
|
||||
|
||||
This game is a little harder than most because a different deck of
|
||||
cards is used. Sounds effects are also built in. Check out the
|
||||
following URL for more information:
|
||||
cards is used. Sounds effects are also built in.
|
||||
|
||||
http://www4.ncsu.edu/~bwmott/www/oonsoo/
|
||||
WWW: http://www4.ncsu.edu/~bwmott/www/oonsoo/
|
||||
|
||||
Share and enjoy,
|
||||
|
||||
|
|
Loading…
Reference in a new issue