audio/dpf-plugins-lv2: Update 1.3 -> 1.4
Reported by: portscout
This commit is contained in:
parent
3a9743cebc
commit
05879cd12e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=561798
6 changed files with 27 additions and 28 deletions
|
@ -2,8 +2,7 @@
|
|||
|
||||
PORTNAME= dpf-plugins
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 1.3
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 1.4
|
||||
CATEGORIES= audio
|
||||
PKGNAMESUFFIX= -lv2
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1563641510
|
||||
SHA256 (DISTRHO-DPF-Plugins-v1.3_GH0.tar.gz) = 0e26726bc8c722325d7e847ffe3b452852991e31ce457855291e3dea70840929
|
||||
SIZE (DISTRHO-DPF-Plugins-v1.3_GH0.tar.gz) = 8289023
|
||||
TIMESTAMP = 1610868324
|
||||
SHA256 (DISTRHO-DPF-Plugins-v1.4_GH0.tar.gz) = 2bdf76975cc4018f6001ef87ea40290e2a990db9dc66de3f0a7c21062fb21034
|
||||
SIZE (DISTRHO-DPF-Plugins-v1.4_GH0.tar.gz) = 8295487
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- Makefile.orig 2019-02-28 06:54:29 UTC
|
||||
--- Makefile.orig 2021-01-15 11:38:19 UTC
|
||||
+++ Makefile
|
||||
@@ -113,13 +113,13 @@ clean:
|
||||
@@ -117,13 +117,13 @@ clean:
|
||||
# --------------------------------------------------------------
|
||||
|
||||
install:
|
||||
|
@ -14,5 +14,5 @@
|
|||
- install -m 644 bin/*-ladspa.* $(DESTDIR)$(PREFIX)/lib/ladspa/
|
||||
+ #install -m 644 bin/*-ladspa.* $(DESTDIR)$(PREFIX)/lib/ladspa/
|
||||
install -m 644 bin/*-dssi.* $(DESTDIR)$(PREFIX)/lib/dssi/
|
||||
install -m 644 bin/*-vst.* $(DESTDIR)$(PREFIX)/lib/vst/
|
||||
|
||||
ifeq ($(MACOS),true)
|
||||
cp -r bin/*.vst $(DESTDIR)$(PREFIX)/lib/vst/
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- dpf/Makefile.base.mk.orig 2019-02-28 18:07:46 UTC
|
||||
--- dpf/Makefile.base.mk.orig 2021-01-15 11:38:19 UTC
|
||||
+++ dpf/Makefile.base.mk
|
||||
@@ -90,7 +90,7 @@ endif
|
||||
# Set build and link flags
|
||||
@@ -136,7 +136,7 @@ BASE_FLAGS = -Wall -Wextra -pipe -MD -MP
|
||||
BASE_OPTS = -O3 -ffast-math -fdata-sections -ffunction-sections
|
||||
|
||||
BASE_FLAGS = -Wall -Wextra -pipe -MD -MP
|
||||
-BASE_OPTS = -O3 -ffast-math -mtune=generic -msse -msse2 -fdata-sections -ffunction-sections
|
||||
+BASE_OPTS = -O3 -ffast-math $(SIMD_FLAGS) -fdata-sections -ffunction-sections
|
||||
ifeq ($(CPU_I386_OR_X86_64),true)
|
||||
-BASE_OPTS += -mtune=generic -msse -msse2 -mfpmath=sse
|
||||
+BASE_OPTS += $(SIMD_FLAGS)
|
||||
endif
|
||||
|
||||
ifeq ($(MACOS),true)
|
||||
# MacOS linker flags
|
||||
ifeq ($(CPU_ARM),true)
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- dpf/dgl/src/Window.cpp.orig 2019-02-28 06:54:29 UTC
|
||||
--- dpf/dgl/src/Window.cpp.orig 2021-01-15 11:38:19 UTC
|
||||
+++ dpf/dgl/src/Window.cpp
|
||||
@@ -51,6 +51,10 @@ extern "C" {
|
||||
@@ -65,6 +65,10 @@ extern "C" {
|
||||
#include "../StandaloneWindow.hpp"
|
||||
#include "../../distrho/extra/String.hpp"
|
||||
|
||||
|
@ -11,7 +11,7 @@
|
|||
#define FOR_EACH_WIDGET(it) \
|
||||
for (std::list<Widget*>::iterator it = fWidgets.begin(); it != fWidgets.end(); ++it)
|
||||
|
||||
@@ -1216,7 +1220,12 @@ bool Window::openFileBrowser(const FileB
|
||||
@@ -1426,7 +1430,12 @@ bool Window::openFileBrowser(const FileBrowserOptions&
|
||||
# ifdef DISTRHO_OS_LINUX
|
||||
if (startDir.isEmpty())
|
||||
{
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- dpf/utils/lv2-ttl-generator/GNUmakefile.orig 2018-08-18 06:55:42 UTC
|
||||
--- dpf/utils/lv2-ttl-generator/GNUmakefile.orig 2021-01-17 07:29:47 UTC
|
||||
+++ dpf/utils/lv2-ttl-generator/GNUmakefile
|
||||
@@ -9,7 +9,7 @@ build: ../lv2_ttl_generator
|
||||
@@ -15,7 +15,7 @@ build: ../lv2_ttl_generator.exe
|
||||
else # WINDOWS
|
||||
|
||||
ifneq ($(HAIKU),true)
|
||||
-LDFLAGS += -ldl
|
||||
+#LDFLAGS += -ldl
|
||||
endif
|
||||
|
||||
../lv2_ttl_generator: lv2_ttl_generator.c
|
||||
- $(CC) $< $(CFLAGS) -o $@ $(LDFLAGS) -ldl
|
||||
+ $(CC) $< $(CFLAGS) -o $@ $(LDFLAGS)
|
||||
|
||||
../lv2_ttl_generator.exe: lv2_ttl_generator.c
|
||||
$(CC) $< $(CFLAGS) -o $@ $(LDFLAGS) -static
|
||||
build: ../lv2_ttl_generator
|
||||
|
|
Loading…
Reference in a new issue