- Update to version 2.2.13
- Add LICENSE - Switch to PLIST_FILES - Support staging - Remove Author tag from pkg-descr PR: ports/181059 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
parent
452af786b2
commit
058eff382b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=332412
6 changed files with 50 additions and 53 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= gkrelltop
|
||||
PORTVERSION= 2.2.10
|
||||
PORTVERSION= 2.2.13
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= SF
|
||||
DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
|
||||
|
@ -10,30 +10,40 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
|
|||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Plugin for gkrellm 2.x shows top three processes, requires procfs
|
||||
|
||||
RUN_DEPENDS= gkrellmd:${PORTSDIR}/sysutils/gkrellm2
|
||||
BUILD_DEPENDS:= ${RUN_DEPENDS}
|
||||
LICENSE= GPLv2
|
||||
|
||||
USES= gmake pkgconfig
|
||||
MAKE_ARGS= INSTALLDIR=${LOCALBASE}/libexec/gkrellm2/plugins \
|
||||
INSTALLDIRD=${PREFIX}/libexec/gkrellm2/plugins-gkrellmd
|
||||
|
||||
.if defined(GKRELLM_SERVER_ONLY)
|
||||
ALL_TARGET= server
|
||||
INSTALL_TARGET= install-server
|
||||
PLIST_SUB+= CLIENT="@comment "
|
||||
.else
|
||||
PLIST_SUB+= CLIENT=""
|
||||
.endif
|
||||
BUILD_DEPENDS= gkrellmd:${PORTSDIR}/sysutils/gkrellm2
|
||||
RUN_DEPENDS:= ${BUILD_DEPENDS}
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
|
||||
|
||||
NO_STAGE= yes
|
||||
post-patch:
|
||||
USES= gmake pkgconfig
|
||||
MAKE_ARGS= CC="${CC} ${CFLAGS} $$(pkg-config gtk+-2.0 --cflags)" \
|
||||
CCD="${CC} ${CFLAGS} $$(pkg-config glib-2.0 --cflags)" \
|
||||
INSTALLDIR=${PREFIX}/libexec/gkrellm2/plugins \
|
||||
INSTALLDIRD=${PREFIX}/libexec/gkrellm2/plugins-gkrellmd
|
||||
|
||||
CFLAGS+= -fPIC -DFREEBSD -DGKRELLM2
|
||||
|
||||
PLIST_FILES= libexec/gkrellm2/plugins-gkrellmd/gkrelltopd.so
|
||||
PLIST_DIRS= libexec/gkrellm2/plugins-gkrellmd \
|
||||
libexec/gkrellm2/plugins \
|
||||
libexec/gkrellm2
|
||||
|
||||
.if defined(GKRELLM_SERVER_ONLY)
|
||||
${REINPLACE_CMD} 's/^\(PKG.*\)gkrellm/\1gkrellmd/' ${WRKSRC}/configure
|
||||
ALL_TARGET= server
|
||||
.else
|
||||
PLIST_FILES+= libexec/gkrellm2/plugins/gkrelltop.so
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
do-install:
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/libexec/gkrellm2/plugins-gkrellmd
|
||||
(cd ${WRKSRC} && ${INSTALL_DATA} gkrelltopd.so \
|
||||
${STAGEDIR}${PREFIX}/libexec/gkrellm2/plugins-gkrellmd)
|
||||
.if !defined(GKRELLM_SERVER_ONLY)
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/libexec/gkrellm2/plugins
|
||||
(cd ${WRKSRC} && ${INSTALL_DATA} gkrelltop.so \
|
||||
${STAGEDIR}${PREFIX}/libexec/gkrellm2/plugins)
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (gkrelltop_2.2.10.orig.tar.gz) = 7975dcd2b242639948ad69d07b347037dd6074b37eead80aaf544aa48ec45c6c
|
||||
SIZE (gkrelltop_2.2.10.orig.tar.gz) = 46018
|
||||
SHA256 (gkrelltop_2.2.13.orig.tar.gz) = b2585c4186cc3805fcde73645a71d8eb3f798358caeb31cf3f598795e6ea42e6
|
||||
SIZE (gkrelltop_2.2.13.orig.tar.gz) = 49023
|
||||
|
|
|
@ -1,28 +0,0 @@
|
|||
--- Makefile.orig 2007-07-21 04:52:00.000000000 +0000
|
||||
+++ Makefile
|
||||
@@ -28,9 +28,9 @@
|
||||
OSFLAG = $(shell uname | tr '[:lower:]' '[:upper:]')
|
||||
SHELL=/bin/sh
|
||||
|
||||
-GKRELL1FLAG=1
|
||||
+GKRELL1FLAG=0
|
||||
#find out if we have gkrellm 2 or 1 (from the gtk+ version)
|
||||
-GKRELL1FLAG=$(shell bash -c 'pkg-config gtk+-2.0 --cflags &>/dev/null && echo 0')
|
||||
+#GKRELL1FLAG=$(shell bash -c 'pkg-config gtk+-2.0 --cflags &>/dev/null && echo 0')
|
||||
GKRELLTOP = gkrelltop.so
|
||||
OBJ = top_three.o gkrelltop.o
|
||||
EXTRA = krell_panel1.xpm
|
||||
@@ -65,11 +65,11 @@ WANT_GLIB12 = yes
|
||||
endif
|
||||
|
||||
ifeq ($(WANT_GLIB12),yes)
|
||||
-CFLAGSD = -I/usr/X11R6/include -D$(OSFLAG) -fPIC -Wall `glib-config --cflags`
|
||||
+CFLAGSD = -I${PREFIX}/include -D$(OSFLAG) -fPIC -Wall `glib-config --cflags`
|
||||
LIBSD = `glib-config --libs`
|
||||
CONFIGURE_ARGS += --with-glib12
|
||||
else
|
||||
-CFLAGSD = -D$(OSFLAG) -fPIC -Wall `pkg-config glib-2.0 --cflags`
|
||||
+CFLAGSD = -D$(OSFLAG) -I${PREFIX}/include -fPIC -Wall `pkg-config glib-2.0 --cflags`
|
||||
LIBSD = `pkg-config glib-2.0 --libs`
|
||||
endif
|
||||
INSTALLDIRD ?= $(PREFIXD)/$(DESTDIR)
|
18
sysutils/gkrelltop/files/patch-gkrelltop.c
Normal file
18
sysutils/gkrelltop/files/patch-gkrelltop.c
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- gkrelltop.c.orig
|
||||
+++ gkrelltop.c
|
||||
@@ -354,6 +354,7 @@
|
||||
if(pluginMode == cpu)
|
||||
snprintf(tmp,sizeof(tmp), "%d: %4.1f%c %6.2d %.30s%c",
|
||||
i+1, best[i]->amount, '%', best[i]->pid, best[i]->name, ch);
|
||||
+#if defined(LINUX)
|
||||
else if(pluginMode == mem)
|
||||
snprintf(tmp,sizeof(tmp), "%d: %4.1f%c %6.2dMB %6.2d %.30s%c",
|
||||
i+1, best[i]->amount, '%', best[i]->rss/MEG,
|
||||
@@ -365,6 +366,7 @@
|
||||
(float)(best[i]->io_read - best[i]->previous_io_read)/KIL,
|
||||
(float)(best[i]->io_write - best[i]->previous_io_write)/KIL,
|
||||
best[i]->pid, best[i]->name, ch);
|
||||
+#endif
|
||||
|
||||
strncat(g_tooltip_text,tmp,sizeof(g_tooltip_text)-strlen(g_tooltip_text));
|
||||
}
|
|
@ -2,5 +2,4 @@ GKrellM top plugin
|
|||
|
||||
Plugin that displays top three processes. Requires /proc to be mounted.
|
||||
|
||||
Author: Adi Zaimi <zaimi@pegasus.rutgers.edu>
|
||||
WWW: http://psychology.rutgers.edu/~zaimi/software.html
|
||||
WWW: http://sourceforge.net/projects/gkrelltop/
|
||||
|
|
|
@ -1,2 +0,0 @@
|
|||
libexec/gkrellm2/plugins-gkrellmd/gkrelltopd.so
|
||||
%%CLIENT%%libexec/gkrellm2/plugins/gkrelltop.so
|
Loading…
Reference in a new issue