graphics/yagf: fix build with c++11, pet portlint
- fix build with c++11, errors like: src/core/qipgrayscaleimage.cpp:168:19: error: non-constant-expression cannot be narrowed from type 'quint32' (aka 'unsigned int') to 'int' in initializer list [-Wc++11-narrowing] IntRect r1 = {x1,y1,x2,(y1+y2)/2}; - pet portlint: * sort ONLY_FOR_ARCHS; * place ONLY_FOR_ARCHS earlier. Reported by: pkg-fallout MFH: 2018Q4
This commit is contained in:
parent
676a54f7ce
commit
0592184419
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=481619
2 changed files with 16 additions and 7 deletions
|
@ -12,9 +12,9 @@ COMMENT= Graphical interface for an OCR program (cuneiform and tesseract)
|
|||
LICENSE= GPLv3
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
LIB_DEPENDS= libaspell.so:textproc/aspell
|
||||
ONLY_FOR_ARCHS= amd64 i386
|
||||
|
||||
ONLY_FOR_ARCHS= i386 amd64
|
||||
LIB_DEPENDS= libaspell.so:textproc/aspell
|
||||
|
||||
OPTIONS_MULTI= OCRENGINE
|
||||
OPTIONS_MULTI_OCRENGINE=CUNEIFORM TESSERACT
|
||||
|
|
|
@ -1,13 +1,22 @@
|
|||
--- CMakeLists.txt.orig 2014-02-19 14:15:50.000000000 +0400
|
||||
+++ CMakeLists.txt 2014-03-15 16:39:26.911288073 +0400
|
||||
@@ -8,8 +8,8 @@ if(MPTIFF_SUPPORT)
|
||||
set(TIFFIO_SRC src/qxttiffiohandler.cpp)
|
||||
endif(MPTIFF_SUPPORT)
|
||||
--- CMakeLists.txt.orig 2015-02-17 01:50:24 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -2,8 +2,8 @@ project(yagf C CXX)
|
||||
cmake_minimum_required(VERSION 2.6.0)
|
||||
#set(QT_QMAKE_EXECUTABLE /usr/bin/qmake-qt4)
|
||||
if (NOT DEFINED ${CMAKE_INSTALL_PREFIX})
|
||||
-set(CPACK_INSTALL_PREFIX /usr/)
|
||||
-set (CMAKE_INSTALL_PREFIX /usr/)
|
||||
+set(CPACK_INSTALL_PREFIX ${PREFIX})
|
||||
+set (CMAKE_INSTALL_PREFIX ${PREFIX})
|
||||
endif()
|
||||
set (LIB_PATH_SUFFIX )
|
||||
if (CMAKE_SIZEOF_VOID_P EQUAL 8)
|
||||
@@ -13,6 +13,8 @@ if (CMAKE_SIZEOF_VOID_P EQUAL 8)
|
||||
set_property (GLOBAL PROPERTY FIND_LIBRARY_USE_LIB64_PATHS TRUE)
|
||||
endif(CMAKE_SIZEOF_VOID_P EQUAL 8)
|
||||
add_definitions( -DPRILIBRARY_PATH="${CMAKE_INSTALL_PREFIX}lib${LIB_PATH_SUFFIX}/yagf/")
|
||||
+
|
||||
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-c++11-narrowing")
|
||||
|
||||
# following 2 lines define where interface translations will be installed
|
||||
set(QML_DESTINATION share/yagf/translations/)
|
||||
|
|
Loading…
Reference in a new issue