databases/py-pylibmc: Update to 1.4.1, Allow Python 3 support
- Update to 1.4.1 - Allow Python 3 support [1] - Update COMMENT to match PyPi upstream - Add TESTS option, TEST_DEPENDS and regression-test target - Strip shared library - Patch setup.{py,cfg} to add allow 'test' command to run - Update pkg-descr to match upstream - pkg-descr: Update WWW: URL to match PyPi upstream This update passes QA (test suite) under Python 2.7 and 3.4. Changes: http://sendapatch.se/projects/pylibmc/changelog.html [1] https://github.com/lericson/pylibmc/issues/146
This commit is contained in:
parent
def26a01da
commit
05bb847615
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=374342
5 changed files with 43 additions and 9 deletions
|
@ -2,22 +2,33 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= pylibmc
|
||||
PORTVERSION= 1.3.0
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.4.1
|
||||
CATEGORIES= databases python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
MAINTAINER= koobs@FreeBSD.org
|
||||
COMMENT= Python wrapper around the libmemcached interface
|
||||
COMMENT= Quick and small memcached client for Python
|
||||
|
||||
LICENSE= BSD3CLAUSE
|
||||
|
||||
LIB_DEPENDS= libmemcached.so:${PORTSDIR}/databases/libmemcached
|
||||
TEST_DEPENDS= memcached:${PORTSDIR}/databases/memcached \
|
||||
nosetests:${PORTSDIR}/devel/py-nose
|
||||
|
||||
USES= python:2
|
||||
OPTIONS_DEFINE= TESTS
|
||||
TESTS_DESC= Install test suite dependencies
|
||||
TESTS_BUILD_DEPENDS= ${TEST_DEPENDS}
|
||||
|
||||
USES= python
|
||||
USE_PYTHON= distutils autoplist
|
||||
|
||||
MAKE_ENV+= LIBMEMCACHED="${LOCALBASE}"
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/_pylibmc.so
|
||||
|
||||
regression-test: build
|
||||
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (pylibmc-1.3.0.tar.gz) = a6945a4c77f96d5b744118805247fb24c09f1d353aebbce6dd510a6042689b45
|
||||
SIZE (pylibmc-1.3.0.tar.gz) = 49949
|
||||
SHA256 (pylibmc-1.4.1.tar.gz) = a00e75f5c76e573e95ac5b29cb8a816728930f29332c49c74dbfd326d598088f
|
||||
SIZE (pylibmc-1.4.1.tar.gz) = 53360
|
||||
|
|
8
databases/py-pylibmc/files/patch-setup.cfg
Normal file
8
databases/py-pylibmc/files/patch-setup.cfg
Normal file
|
@ -0,0 +1,8 @@
|
|||
--- setup.cfg.orig 2014-12-09 01:22:54 UTC
|
||||
+++ setup.cfg
|
||||
@@ -1,5 +1,4 @@
|
||||
[nosetests]
|
||||
-with-info=1
|
||||
with-doctest=1
|
||||
debug=nose.plugins.pylibmc
|
||||
doctest-extension=txt
|
8
databases/py-pylibmc/files/patch-setup.py
Normal file
8
databases/py-pylibmc/files/patch-setup.py
Normal file
|
@ -0,0 +1,8 @@
|
|||
--- setup.py.orig 2014-12-09 01:16:30 UTC
|
||||
+++ setup.py
|
||||
@@ -122,4 +122,5 @@ setup(
|
||||
'Programming Language :: Python :: 3.3',
|
||||
'Programming Language :: Python :: 3.4',
|
||||
],
|
||||
+ test_suite = 'nose.collector'
|
||||
)
|
|
@ -1,4 +1,11 @@
|
|||
pylibmc is a Python wrapper around the accompanying C Python extension
|
||||
_pylibmc, which is a wrapper around libmemcached from TangentOrg.
|
||||
pylibmc is a client in Python for memcached. It is a wrapper around
|
||||
TangentOrg's libmemcached library.
|
||||
|
||||
WWW: https://pypi.python.org/pypi/pylibmc
|
||||
The interface is intentionally made as close to python-memcached as possible,
|
||||
so that applications can drop-in replace it.
|
||||
|
||||
pylibmc leverages among other things configurable behaviors, data pickling,
|
||||
data compression, battle-tested GIL retention, consistent distribution, and
|
||||
the binary memcached protocol.
|
||||
|
||||
WWW: http://sendapatch.se/projects/pylibmc
|
||||
|
|
Loading…
Reference in a new issue