mail/tkrat2: support stage
- Convert lib depends to new format - Add LICENSE PR: 191615 Submitted by: Muhammad Moinur Rahman
This commit is contained in:
parent
6ce3141128
commit
05ca61204e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=361322
6 changed files with 166 additions and 99 deletions
|
@ -3,17 +3,19 @@
|
|||
|
||||
PORTNAME= tkrat
|
||||
PORTVERSION= 2.1.5
|
||||
PORTREVISION= 4
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= mail tk
|
||||
MASTER_SITES= http://tkrat.org/downloads/stable/ \
|
||||
ftp://ftp.tkrat.org/pub/tkrat/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= sjroz@verizon.net
|
||||
COMMENT= Mail user agent for X with a Tcl/Tk user interface
|
||||
|
||||
LIB_DEPENDS= tcl84:${PORTSDIR}/lang/tcl84 \
|
||||
tk84:${PORTSDIR}/x11-toolkits/tk84 \
|
||||
c-client4.9:${PORTSDIR}/mail/cclient
|
||||
LICENSE= BSD3CLAUSE
|
||||
|
||||
LIB_DEPENDS= libtcl84.so:${PORTSDIR}/lang/tcl84 \
|
||||
libtk84.so:${PORTSDIR}/x11-toolkits/tk84 \
|
||||
libc-client4.so:${PORTSDIR}/mail/cclient
|
||||
|
||||
USE_XORG= x11 xt
|
||||
|
||||
|
@ -22,32 +24,44 @@ GNU_CONFIGURE= yes
|
|||
CONFIGURE_ARGS= --with-tcl-config=${PREFIX}/lib/tcl8.4 \
|
||||
--with-tk-config=${PREFIX}/lib/tk8.4 \
|
||||
--with-tcl-include=${PREFIX}/include/tcl8.4 \
|
||||
--with-tk-include=${PREFIX}/include/tk8.4
|
||||
--with-tk-include=${PREFIX}/include/tk8.4 \
|
||||
--prefix=${PREFIX}
|
||||
MAKE_ARGS+= -j2 -B
|
||||
|
||||
OPTIONS= DOCS
|
||||
|
||||
DOCFILES= CONFIGURATION COPYRIGHT README doc/interface doc/userprocs \
|
||||
doc/userproc.example
|
||||
|
||||
MAN1= tkrat.1
|
||||
|
||||
NO_STAGE= yes
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} == "sparc64"
|
||||
BROKEN= Build fails on sparc64
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} '-e s|@INSTALL_PREFIX@|${STAGEDIR}${PREFIX}|g' \
|
||||
${WRKSRC}/lib/Makefile.in ${WRKSRC}/util/Makefile.in \
|
||||
${WRKSRC}/tkrat/Makefile.in ${WRKSRC}/misc/Makefile.in \
|
||||
${WRKSRC}/doc/Makefile.in
|
||||
@${REINPLACE_CMD} '-e s|@libdir@|/lib|g' \
|
||||
${WRKSRC}/lib/Makefile.in ${WRKSRC}/util/Makefile.in
|
||||
@${REINPLACE_CMD} '-e s|@datadir@|/share|g' \
|
||||
${WRKSRC}/util/Makefile.in ${WRKSRC}/tkrat/Makefile.in \
|
||||
${WRKSRC}/misc/Makefile.in
|
||||
@${REINPLACE_CMD} '-e s|@bindir@|/bin|g' ${WRKSRC}/tkrat/Makefile.in
|
||||
@${REINPLACE_CMD} '-e s|@mandir@|/man|g' ${WRKSRC}/doc/Makefile.in
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${ECHO_MSG} "===> Copying documents to ${PREFIX}/${PORTDOCDIR}"
|
||||
@${MKDIR} ${PREFIX}/share/doc/tkrat
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for f in ${DOCFILES}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
|
||||
.endfor
|
||||
.else
|
||||
@${ECHO_MSG} "===> Not copying available documents"
|
||||
.endif
|
||||
@${MKDIR} ${PREFIX}/lib/ratatosk
|
||||
${INSTALL_DATA} ${FILESDIR}/ratatoskrc ${PREFIX}/lib/ratatosk
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/ratatosk
|
||||
${INSTALL_DATA} ${FILESDIR}/ratatoskrc ${STAGEDIR}${PREFIX}/lib/ratatosk
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/tkrat/ratatosk2.1.so
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/tkrat/blt_busy1.0.so
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
13
mail/tkrat2/files/patch-lib_Makefile.in
Normal file
13
mail/tkrat2/files/patch-lib_Makefile.in
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- lib/Makefile.in.orig 2014-07-05 01:55:25.030451755 +0600
|
||||
+++ lib/Makefile.in 2014-07-05 02:00:25.024429652 +0600
|
||||
@@ -24,8 +24,8 @@
|
||||
exec_prefix = @exec_prefix@
|
||||
MAN_DIR = @mandir@
|
||||
BIN_DIR = @bindir@
|
||||
- DATA_DIR = @datadir@/`echo tkrat${VERSION} | sed '${TRANSFORM}'`
|
||||
- LIB_DIR = @libdir@/`echo tkrat${VERSION} | sed '${TRANSFORM}'`
|
||||
+ DATA_DIR = @datadir@/tkrat
|
||||
+ LIB_DIR = @libdir@/tkrat
|
||||
|
||||
# Pointer to the imap c-client directory
|
||||
C_CLIENT = ${TOP_DIR}/imap/c-client
|
13
mail/tkrat2/files/patch-misc_Makefile.in
Normal file
13
mail/tkrat2/files/patch-misc_Makefile.in
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- misc/Makefile.in.orig 2014-07-05 02:28:16.826314579 +0600
|
||||
+++ misc/Makefile.in 2014-07-05 02:28:45.627312853 +0600
|
||||
@@ -11,8 +11,8 @@
|
||||
exec_prefix = @exec_prefix@
|
||||
MAN_DIR = @mandir@
|
||||
BIN_DIR = @bindir@
|
||||
- DATA_DIR = @datadir@/`echo tkrat${VERSION} | sed '${TRANSFORM}'`
|
||||
- LIB_DIR = @libdir@/`echo tkrat${VERSION} | sed '${TRANSFORM}'`
|
||||
+ DATA_DIR = @datadir@/tkrat
|
||||
+ LIB_DIR = @libdir@/tkrat
|
||||
|
||||
SHELL = /bin/sh
|
||||
VERSION = @VERSION@
|
13
mail/tkrat2/files/patch-tkrat_Makefile.in
Normal file
13
mail/tkrat2/files/patch-tkrat_Makefile.in
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- tkrat/Makefile.in.orig 2014-07-05 02:33:47.024291586 +0600
|
||||
+++ tkrat/Makefile.in 2014-07-05 02:34:16.376307317 +0600
|
||||
@@ -13,8 +13,8 @@
|
||||
exec_prefix = @exec_prefix@
|
||||
MAN_DIR = @mandir@
|
||||
BIN_DIR = @bindir@
|
||||
- DATA_DIR = @datadir@/`echo tkrat${VERSION} | sed '${TRANSFORM}'`
|
||||
- LIB_DIR = @libdir@/`echo tkrat${VERSION} | sed '${TRANSFORM}'`
|
||||
+ DATA_DIR = @datadir@/tkrat
|
||||
+ LIB_DIR = @libdir@/tkrat
|
||||
sysconfdir = @sysconfdir@
|
||||
|
||||
INSTALL = @INSTALL@
|
13
mail/tkrat2/files/patch-util_Makefile.in
Normal file
13
mail/tkrat2/files/patch-util_Makefile.in
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- util/Makefile.in.orig 2014-07-05 02:10:52.166388201 +0600
|
||||
+++ util/Makefile.in 2014-07-05 02:11:35.955384041 +0600
|
||||
@@ -37,8 +37,8 @@
|
||||
exec_prefix = @exec_prefix@
|
||||
MAN_DIR = @mandir@
|
||||
BIN_DIR = @bindir@
|
||||
- DATA_DIR = @datadir@/`echo tkrat${VERSION} | sed '${TRANSFORM}'`
|
||||
- LIB_DIR = @libdir@/`echo tkrat${VERSION} | sed '${TRANSFORM}'`
|
||||
+ DATA_DIR = @datadir@/tkrat
|
||||
+ LIB_DIR = @libdir@/tkrat
|
||||
|
||||
CC = @CC@
|
||||
INCLUDES = @TCL_INCLUDE@ @XINCLUDES@
|
|
@ -1,92 +1,93 @@
|
|||
bin/tkrat
|
||||
lib/ratatosk/ratatoskrc
|
||||
lib/tkrat2.1/blt_busy1.0.so
|
||||
lib/tkrat2.1/pkgIndex.tcl
|
||||
lib/tkrat2.1/ratatosk2.1.so
|
||||
lib/tkrat/blt_busy1.0.so
|
||||
lib/tkrat/pkgIndex.tcl
|
||||
lib/tkrat/ratatosk2.1.so
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CONFIGURATION
|
||||
%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/interface
|
||||
%%PORTDOCS%%%%DOCSDIR%%/userproc.example
|
||||
%%PORTDOCS%%%%DOCSDIR%%/userprocs
|
||||
share/tkrat2.1/alias.tcl
|
||||
share/tkrat2.1/client.tcl
|
||||
share/tkrat2.1/compose.tcl
|
||||
share/tkrat2.1/convert.tcl
|
||||
share/tkrat2.1/dbase.tcl
|
||||
share/tkrat2.1/dialog.tcl
|
||||
share/tkrat2.1/dsn.tcl
|
||||
share/tkrat2.1/exp.tcl
|
||||
share/tkrat2.1/folder.tcl
|
||||
share/tkrat2.1/font.tcl
|
||||
share/tkrat2.1/help.tcl
|
||||
share/tkrat2.1/html.tcl
|
||||
share/tkrat2.1/info.tcl
|
||||
share/tkrat2.1/keydef.tcl
|
||||
share/tkrat2.1/languages.tcl
|
||||
share/tkrat2.1/mime.tcl
|
||||
share/tkrat2.1/options.tcl
|
||||
share/tkrat2.1/pgp.tcl
|
||||
share/tkrat2.1/pkgIndex.tcl
|
||||
share/tkrat2.1/preferences.tcl
|
||||
share/tkrat2.1/print.tcl
|
||||
share/tkrat2.1/show.tcl
|
||||
share/tkrat2.1/source.tcl
|
||||
share/tkrat2.1/start.tcl
|
||||
share/tkrat2.1/tclIndex
|
||||
share/tkrat2.1/text_balText_de.tcl
|
||||
share/tkrat2.1/text_balText_en.tcl
|
||||
share/tkrat2.1/text_balText_fr.tcl
|
||||
share/tkrat2.1/text_balText_it.tcl
|
||||
share/tkrat2.1/text_balText_pl.tcl
|
||||
share/tkrat2.1/text_balText_pt.tcl
|
||||
share/tkrat2.1/text_balText_sr.tcl
|
||||
share/tkrat2.1/text_balText_sv.tcl
|
||||
share/tkrat2.1/text_changes_de.tcl
|
||||
share/tkrat2.1/text_changes_en.tcl
|
||||
share/tkrat2.1/text_changes_fr.tcl
|
||||
share/tkrat2.1/text_changes_it.tcl
|
||||
share/tkrat2.1/text_changes_pl.tcl
|
||||
share/tkrat2.1/text_changes_pt.tcl
|
||||
share/tkrat2.1/text_changes_sr.tcl
|
||||
share/tkrat2.1/text_changes_sv.tcl
|
||||
share/tkrat2.1/text_help_de.tcl
|
||||
share/tkrat2.1/text_help_en.tcl
|
||||
share/tkrat2.1/text_help_fr.tcl
|
||||
share/tkrat2.1/text_help_it.tcl
|
||||
share/tkrat2.1/text_help_pl.tcl
|
||||
share/tkrat2.1/text_help_pt.tcl
|
||||
share/tkrat2.1/text_help_sr.tcl
|
||||
share/tkrat2.1/text_help_sv.tcl
|
||||
share/tkrat2.1/text_t_de.tcl
|
||||
share/tkrat2.1/text_t_en.tcl
|
||||
share/tkrat2.1/text_t_fr.tcl
|
||||
share/tkrat2.1/text_t_it.tcl
|
||||
share/tkrat2.1/text_t_pl.tcl
|
||||
share/tkrat2.1/text_t_pt.tcl
|
||||
share/tkrat2.1/text_t_sr.tcl
|
||||
share/tkrat2.1/text_t_sv.tcl
|
||||
share/tkrat2.1/tkrat.xbm
|
||||
share/tkrat2.1/tkrat.xpm
|
||||
share/tkrat2.1/tkrat_small.xbm
|
||||
share/tkrat2.1/tkrat_smallmask.xbm
|
||||
share/tkrat2.1/tkratmask.xbm
|
||||
share/tkrat2.1/util/pkgIndex.tcl
|
||||
share/tkrat2.1/util/rat_balloon.tcl
|
||||
share/tkrat2.1/util/rat_ed.tcl
|
||||
share/tkrat2.1/util/rat_edit.tcl
|
||||
share/tkrat2.1/util/rat_enriched.tcl
|
||||
share/tkrat2.1/util/rat_fbox.tcl
|
||||
share/tkrat2.1/util/rat_ispell.tcl
|
||||
share/tkrat2.1/util/rat_list.tcl
|
||||
share/tkrat2.1/util/rat_textlist.tcl
|
||||
share/tkrat2.1/util/rat_tree.tcl
|
||||
share/tkrat2.1/vfolder.tcl
|
||||
share/tkrat2.1/vfolderdef.tcl
|
||||
share/tkrat2.1/watcher.tcl
|
||||
share/tkrat2.1/winctl.tcl
|
||||
%%DATADIR%%/alias.tcl
|
||||
%%DATADIR%%/client.tcl
|
||||
%%DATADIR%%/compose.tcl
|
||||
%%DATADIR%%/convert.tcl
|
||||
%%DATADIR%%/dbase.tcl
|
||||
%%DATADIR%%/dialog.tcl
|
||||
%%DATADIR%%/dsn.tcl
|
||||
%%DATADIR%%/exp.tcl
|
||||
%%DATADIR%%/folder.tcl
|
||||
%%DATADIR%%/font.tcl
|
||||
%%DATADIR%%/help.tcl
|
||||
%%DATADIR%%/html.tcl
|
||||
%%DATADIR%%/info.tcl
|
||||
%%DATADIR%%/keydef.tcl
|
||||
%%DATADIR%%/languages.tcl
|
||||
%%DATADIR%%/mime.tcl
|
||||
%%DATADIR%%/options.tcl
|
||||
%%DATADIR%%/pgp.tcl
|
||||
%%DATADIR%%/pkgIndex.tcl
|
||||
%%DATADIR%%/preferences.tcl
|
||||
%%DATADIR%%/print.tcl
|
||||
%%DATADIR%%/show.tcl
|
||||
%%DATADIR%%/source.tcl
|
||||
%%DATADIR%%/start.tcl
|
||||
%%DATADIR%%/tclIndex
|
||||
%%DATADIR%%/text_balText_de.tcl
|
||||
%%DATADIR%%/text_balText_en.tcl
|
||||
%%DATADIR%%/text_balText_fr.tcl
|
||||
%%DATADIR%%/text_balText_it.tcl
|
||||
%%DATADIR%%/text_balText_pl.tcl
|
||||
%%DATADIR%%/text_balText_pt.tcl
|
||||
%%DATADIR%%/text_balText_sr.tcl
|
||||
%%DATADIR%%/text_balText_sv.tcl
|
||||
%%DATADIR%%/text_changes_de.tcl
|
||||
%%DATADIR%%/text_changes_en.tcl
|
||||
%%DATADIR%%/text_changes_fr.tcl
|
||||
%%DATADIR%%/text_changes_it.tcl
|
||||
%%DATADIR%%/text_changes_pl.tcl
|
||||
%%DATADIR%%/text_changes_pt.tcl
|
||||
%%DATADIR%%/text_changes_sr.tcl
|
||||
%%DATADIR%%/text_changes_sv.tcl
|
||||
%%DATADIR%%/text_help_de.tcl
|
||||
%%DATADIR%%/text_help_en.tcl
|
||||
%%DATADIR%%/text_help_fr.tcl
|
||||
%%DATADIR%%/text_help_it.tcl
|
||||
%%DATADIR%%/text_help_pl.tcl
|
||||
%%DATADIR%%/text_help_pt.tcl
|
||||
%%DATADIR%%/text_help_sr.tcl
|
||||
%%DATADIR%%/text_help_sv.tcl
|
||||
%%DATADIR%%/text_t_de.tcl
|
||||
%%DATADIR%%/text_t_en.tcl
|
||||
%%DATADIR%%/text_t_fr.tcl
|
||||
%%DATADIR%%/text_t_it.tcl
|
||||
%%DATADIR%%/text_t_pl.tcl
|
||||
%%DATADIR%%/text_t_pt.tcl
|
||||
%%DATADIR%%/text_t_sr.tcl
|
||||
%%DATADIR%%/text_t_sv.tcl
|
||||
%%DATADIR%%/tkrat.xbm
|
||||
%%DATADIR%%/tkrat.xpm
|
||||
%%DATADIR%%/tkrat_small.xbm
|
||||
%%DATADIR%%/tkrat_smallmask.xbm
|
||||
%%DATADIR%%/tkratmask.xbm
|
||||
%%DATADIR%%/util/pkgIndex.tcl
|
||||
%%DATADIR%%/util/rat_balloon.tcl
|
||||
%%DATADIR%%/util/rat_ed.tcl
|
||||
%%DATADIR%%/util/rat_edit.tcl
|
||||
%%DATADIR%%/util/rat_enriched.tcl
|
||||
%%DATADIR%%/util/rat_fbox.tcl
|
||||
%%DATADIR%%/util/rat_ispell.tcl
|
||||
%%DATADIR%%/util/rat_list.tcl
|
||||
%%DATADIR%%/util/rat_textlist.tcl
|
||||
%%DATADIR%%/util/rat_tree.tcl
|
||||
%%DATADIR%%/vfolder.tcl
|
||||
%%DATADIR%%/vfolderdef.tcl
|
||||
%%DATADIR%%/watcher.tcl
|
||||
%%DATADIR%%/winctl.tcl
|
||||
man/man1/tkrat.1.gz
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@dirrm share/tkrat2.1/util
|
||||
@dirrm share/tkrat2.1
|
||||
@dirrm %%DATADIR%%/util
|
||||
@dirrm %%DATADIR%%
|
||||
@dirrm lib/ratatosk
|
||||
@dirrm lib/tkrat2.1
|
||||
@dirrm lib/tkrat
|
||||
|
|
Loading…
Reference in a new issue