- Update to 0.45.3
- Remove FORBIDDEN - Convert to OPTIONS - Hand maintainership to submitter PR: ports/65093 Submitted by: Yarema <yds@CoolRat.org>
This commit is contained in:
parent
ebacd32966
commit
061c1a65db
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=106055
6 changed files with 230 additions and 380 deletions
|
@ -6,29 +6,20 @@
|
|||
#
|
||||
|
||||
PORTNAME= courier
|
||||
PORTVERSION= 0.44.2
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.45.3
|
||||
CATEGORIES= mail ipv6
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= courier
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= yds@CoolRat.org
|
||||
COMMENT= Courier SMTP IMAP POP3 HTTP mail server suite
|
||||
|
||||
FORBIDDEN= http://vuxml.freebsd.org/98bd69c3-834b-11d8-a41f-0020ed76ef5a.html
|
||||
|
||||
CONFLICTS= exim-4.* courier-imap-2.* maildrop-1.* \
|
||||
postfix-1.* postfix-2.* \
|
||||
qmail-1.* qmail-*-1.* \
|
||||
sendmail-8.* sendmail-*-8.* \
|
||||
smail-3.* sqwebmail-3.* zmailer-2.*
|
||||
|
||||
.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
|
||||
GSPORT?= print/ghostscript-afpl
|
||||
.else
|
||||
GSPORT?= print/ghostscript-gnu
|
||||
.endif
|
||||
|
||||
LIB_DEPENDS= fam.0:${PORTSDIR}/devel/fam
|
||||
RUN_DEPENDS= ${LOCALBASE}/share/sysconftool/sysconftool:${PORTSDIR}/devel/sysconftool \
|
||||
${SITE_PERL}/Net/CIDR.pm:${PORTSDIR}/net-mgmt/p5-Net-CIDR
|
||||
|
@ -63,6 +54,7 @@ LOCALSTATEDIR= /var/spool/courier
|
|||
CACHEDIR= /var/spool/webmail
|
||||
CALENDIR= /var/spool/calendar
|
||||
MIMETYPES= ${LOCALBASE}/etc/apache/mime.types:${LOCALBASE}/etc/apache2/mime.types
|
||||
WITH_TRANSPORT= local esmtp dsn
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_SUBMAKE= yes
|
||||
|
@ -79,6 +71,7 @@ CONFIGURE_ENV= REHASH=${SCRIPTDIR}/c_rehash \
|
|||
CPPFLAGS='${CPPFLAGS}' \
|
||||
LDFLAGS='${LDFLAGS}'
|
||||
MAKE_ENV:= ${CONFIGURE_ENV}
|
||||
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ARGS= --disable-root-check --with-db=db \
|
||||
--enable-syslog=1 --enable-use-flock \
|
||||
--program-transform-name=s,^,, \
|
||||
|
@ -97,9 +90,9 @@ CONFIGURE_ARGS= --disable-root-check --with-db=db \
|
|||
--with-cachedir=${CACHEDIR} \
|
||||
--with-cacheowner=${CACHEOWN} \
|
||||
--with-calendardir=${CALENDIR} \
|
||||
--with-transport='${WITH_TRANSPORT}' \
|
||||
--with-default-maildrop=${MAILDROPDEFAULT} \
|
||||
--enable-workarounds-for-imap-client-bugs
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
|
||||
PKGMESSAGE= ${WRKDIR}/.PKGMESSAGE
|
||||
|
||||
|
@ -110,58 +103,208 @@ PLIST_SUB+= BINOWN="${BINOWN}" BINGRP="${BINGRP}" \
|
|||
MAILUID="${MAILUID}" MAILGID="${MAILGID}" \
|
||||
CACHEOWN="${CACHEOWN}"
|
||||
|
||||
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
|
||||
WITH_EXPECT="${WITH_EXPECT:L}" \
|
||||
WITH_GNUPG="${WITH_GNUPG:L}" \
|
||||
WITH_ASPELL="${WITH_ASPELL:L}" \
|
||||
WITH_ISPELL="${WITH_ISPELL:L}" \
|
||||
WITH_LDAP="${WITH_LDAP:L}" \
|
||||
WITH_MYSQL="${WITH_MYSQL:L}" \
|
||||
WITH_PGSQL="${WITH_PGSQL:L}" \
|
||||
WITH_VPOPMAIL="${WITH_VPOPMAIL:L}" \
|
||||
WITH_PROCMAIL="${WITH_PROCMAIL:L}" \
|
||||
WITH_SENDFAX="${WITH_SENDFAX:L}" \
|
||||
WITH_UUCP="${WITH_UUCP:L}" \
|
||||
WITH_IPV6="${WITH_IPV6:L}" \
|
||||
TOUCH="${TOUCH}" \
|
||||
MKDIR="${MKDIR}"
|
||||
|
||||
.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
|
||||
.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
|
||||
OPTIONS+=EXPECT "Expect support for WebMail change passwd"
|
||||
.if exists(${LOCALBASE}/bin/expect) || defined(WITH_EXPECT)
|
||||
OPTIONS+=on
|
||||
.else
|
||||
OPTIONS+=off
|
||||
.endif
|
||||
|
||||
OPTIONS+=GNUPG "GNU Privacy Guard support for WebMail"
|
||||
.if exists(${LOCALBASE}/bin/gpg) || defined(WITH_GNUPG)
|
||||
OPTIONS+=on
|
||||
.else
|
||||
OPTIONS+=off
|
||||
.endif
|
||||
|
||||
OPTIONS+=ASPELL "ASpell support for WebMail / mutually"
|
||||
.if exists(${LOCALBASE}/bin/aspell) || defined(WITH_ASPELL)
|
||||
OPTIONS+=on
|
||||
.else
|
||||
OPTIONS+=off
|
||||
.endif
|
||||
|
||||
OPTIONS+=ISPELL "ISpell support for WebMail \ exclusive"
|
||||
.if exists(${LOCALBASE}/bin/ispell) || defined(WITH_ISPELL)
|
||||
OPTIONS+=on
|
||||
.else
|
||||
OPTIONS+=off
|
||||
.endif
|
||||
|
||||
OPTIONS+=OPENLDAP "OpenLDAP 2.x authentication support"
|
||||
.if (exists(${LOCALBASE}/lib/libldap.so.2) && exists(${LOCALBASE}/lib/liblber.so.2)) || defined(WITH_OPENLDAP)
|
||||
OPTIONS+=on
|
||||
.else
|
||||
OPTIONS+=off
|
||||
.endif
|
||||
|
||||
OPTIONS+=MYSQL "MySQL authentication support"
|
||||
.if exists(${LOCALBASE}/lib/mysql/libmysqlclient.so.14) || defined(WITH_MYSQL)
|
||||
OPTIONS+=on
|
||||
.else
|
||||
OPTIONS+=off
|
||||
.endif
|
||||
|
||||
OPTIONS+=PGSQL "PostgreSQL authentication support"
|
||||
.if exists(${PGSQLBASE}/lib/libpq.so.3) || defined(WITH_PGSQL)
|
||||
OPTIONS+=on
|
||||
.else
|
||||
OPTIONS+=off
|
||||
.endif
|
||||
|
||||
OPTIONS+=VCHKPW "VPopMail authentication support"
|
||||
.if exists(${LOCALBASE}/vpopmail/lib/libvpopmail.a) || defined(WITH_VCHKPW)
|
||||
OPTIONS+=on
|
||||
.else
|
||||
OPTIONS+=off
|
||||
.endif
|
||||
|
||||
OPTIONS+=PROCMAIL "Procmail local delivery support"
|
||||
.if exists(${LOCALBASE}/bin/procmail) || defined(WITH_PROCMAIL)
|
||||
OPTIONS+=on
|
||||
.else
|
||||
OPTIONS+=off
|
||||
.endif
|
||||
|
||||
OPTIONS+=SENDFAX "mgetty+sendfax support"
|
||||
.if exists(${LOCALBASE}/sbin/sendfax) && exists(${LOCALBASE}/bin/pnmscale) && exists(${LOCALBASE}/bin/gs) || defined(WITH_SENDFAX)
|
||||
OPTIONS+=on
|
||||
.else
|
||||
OPTIONS+=off
|
||||
.endif
|
||||
|
||||
OPTIONS+=UUCP "UUCP support"
|
||||
.if exists(/usr/bin/uux) || exists(${LOCALBASE}/bin/uux) || defined(WITH_UUCP)
|
||||
OPTIONS+=on
|
||||
.else
|
||||
OPTIONS+=off
|
||||
.endif
|
||||
|
||||
OPTIONS+=IPV6 "IPv6 support"
|
||||
.if defined(WITH_IPV6) && !defined(WITHOUT_IPV6)
|
||||
OPTIONS+=on
|
||||
.else
|
||||
OPTIONS+=off
|
||||
.endif
|
||||
|
||||
.include "${.CURDIR}/Makefile.man"
|
||||
.include "${.CURDIR}/Makefile.doc"
|
||||
.include "${.CURDIR}/Makefile.own"
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITH_EXPECT) && !defined(WITHOUT_EXPECT)
|
||||
BUILD_DEPENDS+= expect:${PORTSDIR}/lang/expect
|
||||
PLIST_SUB+= SUB_EXPECT=""
|
||||
.else
|
||||
CONFIGURE_ARGS+=--disable-changepass
|
||||
PLIST_SUB+= SUB_EXPECT="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITH_GNUPG) && !defined(WITHOUT_GNUPG)
|
||||
BUILD_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
|
||||
.endif
|
||||
|
||||
.if defined(WITH_ASPELL) && !defined(WITHOUT_ASPELL) && !defined(WITH_ISPELL)
|
||||
BUILD_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
|
||||
CONFIGURE_ARGS+=--with-ispell=${LOCALBASE}/bin/aspell
|
||||
.endif
|
||||
|
||||
.if defined(WITH_ISPELL) && !defined(WITHOUT_ISPELL) && !defined(WITH_ASPELL)
|
||||
BUILD_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
|
||||
CONFIGURE_ARGS+=--with-ispell=${LOCALBASE}/bin/ispell
|
||||
.endif
|
||||
|
||||
.if defined(WITH_ASPELL) && defined(WITH_ISPELL)
|
||||
BROKEN= ASpell and ISpell are mutually exclusive.
|
||||
.endif
|
||||
|
||||
.if !defined(WITH_ASPELL) && !defined(WITH_ISPELL)
|
||||
CONFIGURE_ARGS+=--without-ispell
|
||||
.endif
|
||||
|
||||
.if defined(WITH_OPENLDAP) && !defined(WITHOUT_OPENLDAP)
|
||||
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-ldap
|
||||
USE_OPENLDAP= yes
|
||||
CONFIGURE_ARGS+=--with-authldap
|
||||
PLIST_SUB+= SUB_LDAP=""
|
||||
.else
|
||||
CONFIGURE_ARGS+=--without-authldap
|
||||
PLIST_SUB+= SUB_LDAP="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITH_MYSQL) && !defined(WITHOUT_MYSQL) && !defined(WITH_VCHKPW)
|
||||
.if exists(${LOCALBASE}/vpopmail/lib/libvpopmail.a)
|
||||
BROKEN+= VPopMail and MySQL are mutually exclusive.\
|
||||
Uninstall VPopMail if you want MySQL authentication.
|
||||
.endif
|
||||
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-mysql
|
||||
USE_MYSQL= yes
|
||||
CONFIGURE_ARGS+=--with-authmysql \
|
||||
--with-mysql-libs=${LOCALBASE}/lib/mysql \
|
||||
--with-mysql-includes=${LOCALBASE}/include/mysql
|
||||
PLIST_SUB+= SUB_MYSQL=""
|
||||
.else
|
||||
CONFIGURE_ARGS+=--without-authmysql
|
||||
PLIST_SUB+= SUB_MYSQL="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITH_PGSQL) && !defined(WITHOUT_PGSQL)
|
||||
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-pgsql
|
||||
LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
|
||||
CONFIGURE_ARGS+=--with-authpgsql
|
||||
--with-pgsql-libs=${PGSQLBASE}/lib
|
||||
--with-pgsql-includes=${PGSQLINCLUDES}
|
||||
PLIST_SUB+= SUB_PGSQL=""
|
||||
.else
|
||||
CONFIGURE_ARGS+=--without-authpgsql
|
||||
PLIST_SUB+= SUB_PGSQL="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITH_VCHKPW) && !defined(WITHOUT_VCHKPW) && !defined(WITH_MYSQL)
|
||||
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-vpopmail
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/vpopmail/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
|
||||
CONFIGURE_ARGS+=--with-authvchkpw
|
||||
.else
|
||||
CONFIGURE_ARGS+=--without-authvchkpw
|
||||
.endif
|
||||
|
||||
.if defined(WITH_PROCMAIL) && !defined(WITHOUT_PROCMAIL)
|
||||
BUILD_DEPENDS+= procmail:${PORTSDIR}/mail/procmail
|
||||
.endif
|
||||
|
||||
.if defined(WITH_SENDFAX) && !defined(WITHOUT_SENDFAX)
|
||||
USE_GHOSTSCRIPT=yes
|
||||
SENDFAX_DEPENDS=sendfax:${PORTSDIR}/comms/mgetty+sendfax \
|
||||
pnmscale:${PORTSDIR}/graphics/netpbm
|
||||
BUILD_DEPENDS+= ${SENDFAX_DEPENDS}
|
||||
RUN_DEPENDS+= ${SENDFAX_DEPENDS}
|
||||
WITH_TRANSPORT+=fax
|
||||
PLIST_SUB+= SUB_FAX=""
|
||||
.else
|
||||
PLIST_SUB+= SUB_FAX="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITH_UUCP) && !defined(WITHOUT_UUCP)
|
||||
.if !exists(/usr/bin/uux)
|
||||
BUILD_DEPENDS+= uux:${PORTSDIR}/net/freebsd-uucp
|
||||
RUN_DEPENDS+= uux:${PORTSDIR}/net/freebsd-uucp
|
||||
.endif
|
||||
WITH_TRANSPORT+=uucp
|
||||
PLIST_SUB+= SUB_UUCP=""
|
||||
.else
|
||||
PLIST_SUB+= SUB_UUCP="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_IPV6) || !defined(WITH_IPV6)
|
||||
CONFIGURE_ARGS+=--without-ipv6
|
||||
.else
|
||||
CONFIGURE_ARGS+=--with-ipv6
|
||||
.endif
|
||||
|
||||
pre-everything::
|
||||
@${ECHO_MSG} ""
|
||||
@${ECHO_MSG} "You may use the following build options:"
|
||||
@${ECHO_MSG} ""
|
||||
@${ECHO_MSG} " WITH_EXPECT=yes Expect support for WebMail change passwd"
|
||||
@${ECHO_MSG} " WITH_GNUPG=yes GNU Privacy Guard support for WebMail"
|
||||
@${ECHO_MSG} " WITH_ASPELL=yes ASpell support for WebMail"
|
||||
@${ECHO_MSG} " WITH_ISPELL=yes ISpell support for WebMail"
|
||||
@${ECHO_MSG} " WITH_LDAP=yes OpenLDAP 2.x authentication support"
|
||||
.if !defined(WANT_OPENLDAP_VER)
|
||||
@${ECHO_MSG} " WANT_OPENLDAP_VER=?? See <bsd.port.mk> for legal values"
|
||||
.endif
|
||||
@${ECHO_MSG} " WITH_MYSQL=yes MySQL authentication support"
|
||||
@${ECHO_MSG} " WITH_PGSQL=yes PostgreSQL authentication support"
|
||||
@${ECHO_MSG} " WITH_VPOPMAIL=yes VPopMail authentication support"
|
||||
@${ECHO_MSG} " WITH_PROCMAIL=yes Procmail local delivery support"
|
||||
@${ECHO_MSG} " WITH_SENDFAX=yes mgetty+sendfax support"
|
||||
.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
|
||||
@${ECHO_MSG} " WITH_GHOSTSCRIPT_AFPL=yes to use AFPL Postscript"
|
||||
@${ECHO_MSG} " interpreter instead of GNU one"
|
||||
@${ECHO_MSG} " for mgetty+sendfax support"
|
||||
.endif
|
||||
@${ECHO_MSG} " WITH_UUCP=yes UUCP support"
|
||||
@${ECHO_MSG} " WITH_IPV6=yes Pv6 support"
|
||||
@${ECHO_MSG} ""
|
||||
@${ECHO_MSG} " BATCH=yes To skip INTERACTIVE selection"
|
||||
@${ECHO_MSG} " of above tunables"
|
||||
@${ECHO_MSG} ""
|
||||
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.${PORTNAME}
|
||||
@${ECHO_MSG} "===> -------------------------------------------"
|
||||
@${ECHO_MSG} "===> Run 'make config' to (re)configure the port"
|
||||
@${ECHO_MSG} "===> -------------------------------------------"
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e 's:\@datadir\@:\@sysconfdir\@:g;' \
|
||||
|
@ -173,6 +316,13 @@ post-patch:
|
|||
@${PERL} -pi -e 's:^(RANDFILE = )\@datadir\@\S+:$$1\@sysconfdir\@/random.tmp:g;' \
|
||||
${WRKSRC}/*/*.cnf.in \
|
||||
${WRKSRC}/*/*/*.cnf.in
|
||||
@${PERL} -pi -e 's:^ sharedindexsplit sharedindexinstall::g;' \
|
||||
${WRKSRC}/courier/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's:"\\$${SHELL} \\$$(install_sh) -c -s":"\\$${BSD_INSTALL_PROGRAM}":' \
|
||||
${WRKSRC}/configure \
|
||||
${WRKSRC}/*/configure \
|
||||
${WRKSRC}/*/*/configure \
|
||||
${WRKSRC}/*/*/*/configure
|
||||
|
||||
pre-configure:
|
||||
@${SED} -e s:%%RC_SUBR%%:${RC_SUBR}: \
|
||||
|
@ -206,6 +356,8 @@ post-install:
|
|||
@${INSTALL_DATA} /dev/null ${SYSCONFDIR}/locallowercase
|
||||
@${INSTALL_DATA} ${WRKDIR}/crontab ${PREFIX}/etc/courier/
|
||||
@${INSTALL_SCRIPT} ${WRKDIR}/courier.sh ${PREFIX}/etc/rc.d/
|
||||
@${INSTALL_SCRIPT} ${WRKSRC}/maildir/sharedindexsplit ${PREFIX}/sbin/
|
||||
@${INSTALL_SCRIPT} ${WRKSRC}/maildir/sharedindexinstall ${PREFIX}/sbin/
|
||||
.for file in ${OWNER0}
|
||||
@-${CHOWN} ${BINOWN}:${BINGRP} ${PREFIX}/${file}
|
||||
.endfor
|
||||
|
@ -216,8 +368,8 @@ post-install:
|
|||
.if !defined(NOPORTDOCS)
|
||||
@${INSTALL} -d -o ${DOCOWN} -g ${DOCGRP} ${DOCSDIR}/html
|
||||
@${INSTALL_DATA} ${DATADIR}/htmldoc/* ${DOCSDIR}/html
|
||||
.for file in ${DOCS}
|
||||
@${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
|
||||
.for f in ${DOCS}
|
||||
@${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
@${RM} -rf ${DATADIR}/htmldoc
|
||||
|
@ -231,18 +383,15 @@ post-install:
|
|||
@${ECHO_MSG} ""
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
@${ECHO_MSG} ""
|
||||
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
|
||||
@PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
|
||||
.else
|
||||
.if defined(BATCH) || defined(PACKAGE_BUILDING)
|
||||
@${ECHO_MSG} " To activate Courier in /etc/mail/mailer.conf or to"
|
||||
@${ECHO_MSG} " replace {sendmail,mailq,newaliases} with Courier"
|
||||
@${ECHO_MSG} " versions execute the following as root user:"
|
||||
@${ECHO_MSG} ""
|
||||
@${ECHO_MSG} "PKG_PREFIX=\"${PREFIX}\" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL"
|
||||
@${ECHO_MSG} ""
|
||||
.else
|
||||
@PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
|
||||
.endif
|
||||
|
||||
post-clean:
|
||||
@${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -6,6 +6,7 @@ MAN1= \
|
|||
dot-forward.1 \
|
||||
lockmail.1 \
|
||||
mailbot.1 \
|
||||
maildiracl.1 \
|
||||
maildirkw.1 \
|
||||
maildirmake.1 \
|
||||
maildrop.1 \
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (courier-0.44.2.tar.bz2) = 8c607c70a692d8f8ccb769a3f96d2f28
|
||||
SIZE (courier-0.44.2.tar.bz2) = 4001993
|
||||
MD5 (courier-0.45.3.tar.bz2) = c1f657b5b0fd8d41d2eb2372fdfe1b41
|
||||
SIZE (courier-0.45.3.tar.bz2) = 4317585
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
--- configure.orig Fri Nov 28 20:37:46 2003
|
||||
+++ configure Wed Jan 7 03:17:25 2004
|
||||
@@ -18967,9 +18967,6 @@
|
||||
echo "$as_me: WARNING: === the INSTALL file you should have known this. So" >&2;}
|
||||
{ echo "$as_me:$LINENO: WARNING: === you better read INSTALL again" >&5
|
||||
echo "$as_me: WARNING: === you better read INSTALL again" >&2;}
|
||||
- { { echo "$as_me:$LINENO: error: aborted." >&5
|
||||
-echo "$as_me: error: aborted." >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
fi
|
||||
fi
|
||||
|
|
@ -5,6 +5,8 @@
|
|||
@exec install -d -o %%MAILOWN%% -g %%MAILGRP%% -m 0755 %D/etc/courier/esmtpacceptmailfor.dir
|
||||
@exec install -d -o %%MAILOWN%% -g %%MAILGRP%% -m 0755 %D/etc/courier/esmtppercentrelay.dir
|
||||
@exec install -d -o %%MAILOWN%% -g %%MAILGRP%% -m 0750 %D/etc/courier/filters/active
|
||||
@exec install -d -o %%MAILOWN%% -g %%MAILGRP%% -m 0755 %D/etc/courier/shared
|
||||
@exec install -d -o %%MAILOWN%% -g %%MAILGRP%% -m 0755 %D/etc/courier/shared.tmp
|
||||
@exec install -d -o %%MAILOWN%% -g %%MAILGRP%% -m 0755 %D/etc/courier/smtpaccess
|
||||
@exec install -d -o %%MAILOWN%% -g %%MAILGRP%% -m 0700 %D/etc/courier/webadmin/added
|
||||
@exec install -d -o %%MAILOWN%% -g %%MAILGRP%% -m 0700 %D/etc/courier/webadmin/removed
|
||||
|
@ -37,6 +39,7 @@ bin/dotforward
|
|||
bin/imapd
|
||||
bin/lockmail
|
||||
bin/mailbot
|
||||
bin/maildiracl
|
||||
bin/maildirkw
|
||||
bin/maildirmake
|
||||
bin/maildrop
|
||||
|
@ -125,6 +128,8 @@ etc/courier/webmail.authpam
|
|||
@unexec rmdir %D/etc/courier/esmtppercentrelay.dir 2>/dev/null || true
|
||||
@unexec rmdir %D/etc/courier/filters/active 2>/dev/null || true
|
||||
@unexec rmdir %D/etc/courier/filters 2>/dev/null || true
|
||||
@unexec rmdir %D/etc/courier/shared 2>/dev/null || true
|
||||
@unexec rmdir %D/etc/courier/shared.tmp 2>/dev/null || true
|
||||
@unexec rmdir %D/etc/courier/smtpaccess 2>/dev/null || true
|
||||
@unexec rmdir %D/etc/courier/webadmin/added 2>/dev/null || true
|
||||
@unexec rmdir %D/etc/courier/webadmin/removed 2>/dev/null || true
|
||||
|
@ -177,6 +182,7 @@ libexec/filters/perlfilter
|
|||
@dirrm libexec/courier/webmail
|
||||
@dirrm libexec/courier
|
||||
@dirrm libexec/filters
|
||||
sbin/authenumerate
|
||||
sbin/courier
|
||||
sbin/courieresmtpd
|
||||
sbin/courierfilter
|
||||
|
@ -203,6 +209,8 @@ sbin/mkpop3dcert
|
|||
sbin/pop3d
|
||||
sbin/pop3d-ssl
|
||||
sbin/pw2userdb
|
||||
sbin/sharedindexinstall
|
||||
sbin/sharedindexsplit
|
||||
sbin/showconfig
|
||||
sbin/showmodules
|
||||
sbin/userdb
|
||||
|
@ -509,6 +517,7 @@ share/courier/sqwebmail/html/en-us/LANGUAGE_PREF
|
|||
share/courier/sqwebmail/html/en-us/LOCALE
|
||||
share/courier/sqwebmail/html/en-us/TIMEZONELIST
|
||||
share/courier/sqwebmail/html/en-us/abooklist.html
|
||||
share/courier/sqwebmail/html/en-us/acl.html
|
||||
share/courier/sqwebmail/html/en-us/attachments.html
|
||||
share/courier/sqwebmail/html/en-us/autoresponder.html
|
||||
share/courier/sqwebmail/html/en-us/calendarlogin.inc.html
|
||||
|
@ -572,6 +581,7 @@ share/courier/sqwebmail/images/graybottomleft.png
|
|||
share/courier/sqwebmail/images/graybottomright.png
|
||||
share/courier/sqwebmail/images/graytopleft.png
|
||||
share/courier/sqwebmail/images/graytopright.png
|
||||
share/courier/sqwebmail/images/key.png
|
||||
share/courier/sqwebmail/images/last.png
|
||||
share/courier/sqwebmail/images/left.png
|
||||
share/courier/sqwebmail/images/left2.png
|
||||
|
@ -667,6 +677,7 @@ share/courier/vchkpw2userdb
|
|||
%%PORTDOCS%%%%DOCSDIR%%/html/lockmail.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/mailbot.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/maildir.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/maildiracl.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/maildirkw.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/maildirmake.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/maildirquota.html
|
||||
|
|
|
@ -1,299 +0,0 @@
|
|||
#!/bin/sh
|
||||
# $FreeBSD: /tmp/pcvs/ports/mail/courier/scripts/Attic/configure.courier,v 1.11 2004-01-15 15:12:32 sergei Exp $
|
||||
|
||||
[ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ] && exit
|
||||
|
||||
tempfile=`mktemp -t checklist`
|
||||
|
||||
if [ -x ${PREFIX}/pgsql/bin/postgres -a ! -x ${PREFIX}/bin/postgres ]; then
|
||||
PGSQLBASE=${PREFIX}/pgsql
|
||||
PGSQLINCLUDES=${PGSQLBASE}/include
|
||||
else
|
||||
PGSQLBASE=${PREFIX}
|
||||
PGSQLINCLUDES=${PGSQLBASE}/include/pgsql
|
||||
fi
|
||||
|
||||
if [ ":${BATCH}" = ':yes' ]; then
|
||||
[ ":${WITH_EXPECT}" = ':yes' ] && OPTIONS="${OPTIONS} \"Expect\""
|
||||
[ ":${WITH_GNUPG}" = ':yes' ] && OPTIONS="${OPTIONS} \"GnuPG\""
|
||||
[ ":${WITH_ASPELL}" = ':yes' ] && OPTIONS="${OPTIONS} \"ASpell\""
|
||||
[ ":${WITH_ISPELL}" = ':yes' ] && OPTIONS="${OPTIONS} \"ISpell\""
|
||||
[ ":${WITH_LDAP}" = ':yes' ] && OPTIONS="${OPTIONS} \"OpenLDAP\""
|
||||
[ ":${WITH_MYSQL}" = ':yes' ] && OPTIONS="${OPTIONS} \"MySQL\""
|
||||
[ ":${WITH_PGSQL}" = ':yes' ] && OPTIONS="${OPTIONS} \"PostgreSQL\""
|
||||
[ ":${WITH_VPOPMAIL}" = ':yes' ] && OPTIONS="${OPTIONS} \"VPopMail\""
|
||||
[ ":${WITH_PROCMAIL}" = ':yes' ] && OPTIONS="${OPTIONS} \"Procmail\""
|
||||
[ ":${WITH_SENDFAX}" = ':yes' ] && OPTIONS="${OPTIONS} \"SendFax\""
|
||||
[ ":${WITH_UUCP}" = ':yes' ] && OPTIONS="${OPTIONS} \"UUCP\""
|
||||
[ ":${WITH_IPV6}" = ':yes' ] && OPTIONS="${OPTIONS} \"IPv6\""
|
||||
[ -n "${OPTIONS}" ] && set ${OPTIONS}
|
||||
else
|
||||
if [ ":${WITH_EXPECT}" = ':yes' \
|
||||
-o -x ${LOCALBASE}/bin/expect ]; then
|
||||
SET_EXPECT="ON"
|
||||
else
|
||||
SET_EXPECT="OFF"
|
||||
fi
|
||||
if [ ":${WITH_GNUPG}" = ':yes' \
|
||||
-o -x ${LOCALBASE}/bin/gpg ]; then
|
||||
SET_GNUPG="ON"
|
||||
else
|
||||
SET_GNUPG="OFF"
|
||||
fi
|
||||
if [ ":${WITH_ASPELL}" = ':yes' \
|
||||
-o -x ${LOCALBASE}/bin/aspell ]; then
|
||||
SET_ASPELL="ON"
|
||||
SET_ISPELL="OFF"
|
||||
else
|
||||
SET_ASPELL="OFF"
|
||||
fi
|
||||
if [ ":${WITH_ISPELL}" = ':yes' \
|
||||
-o -x ${LOCALBASE}/bin/ispell \
|
||||
-a "${SET_ASPELL}" = "OFF" ]; then
|
||||
SET_ISPELL="ON"
|
||||
SET_ASPELL="OFF"
|
||||
else
|
||||
SET_ISPELL="OFF"
|
||||
fi
|
||||
if [ ":${WITH_LDAP}" = ':yes' \
|
||||
-o -f ${LOCALBASE}/lib/libldap.so.2 \
|
||||
-a -f ${LOCALBASE}/lib/liblber.so.2 ]; then
|
||||
SET_LDAP="ON"
|
||||
else
|
||||
SET_LDAP="OFF"
|
||||
fi
|
||||
if [ ":${WITH_MYSQL}" = ':yes' \
|
||||
-o -f ${LOCALBASE}/lib/mysql/libmysqlclient.so.12 ]; then
|
||||
SET_MYSQL="ON"
|
||||
else
|
||||
SET_MYSQL="OFF"
|
||||
fi
|
||||
if [ ":${WITH_PGSQL}" = ':yes' \
|
||||
-o -f ${PGSQLBASE}/lib/libpq.so.3 ]; then
|
||||
SET_PGSQL="ON"
|
||||
else
|
||||
SET_PGSQL="OFF"
|
||||
fi
|
||||
if [ ":${WITH_VPOPMAIL}" = ':yes' \
|
||||
-o -f ${LOCALBASE}/vpopmail/lib/libvpopmail.a ]; then
|
||||
SET_VPOPMAIL="ON" # authvchkpw and authmysql
|
||||
SET_MYSQL="OFF" # are mutually exclusive
|
||||
else
|
||||
SET_VPOPMAIL="OFF"
|
||||
fi
|
||||
if [ ":${WITH_PROCMAIL}" = ':yes' \
|
||||
-o -x ${LOCALBASE}/bin/procmail ]; then
|
||||
SET_PROCMAIL="ON"
|
||||
else
|
||||
SET_PROCMAIL="OFF"
|
||||
fi
|
||||
if [ ":${WITH_SENDFAX}" = ':yes' \
|
||||
-o -x ${LOCALBASE}/sbin/sendfax \
|
||||
-a -x ${LOCALBASE}/bin/pnmscale \
|
||||
-a -x ${LOCALBASE}/bin/giftopnm \
|
||||
-a -x ${LOCALBASE}/bin/jpegtopnm \
|
||||
-a -x ${LOCALBASE}/bin/ppmtopgm \
|
||||
-a -x ${LOCALBASE}/bin/pgmtopbm \
|
||||
-a -x ${LOCALBASE}/bin/pbmtog3 \
|
||||
-a -x ${LOCALBASE}/bin/g3topbm \
|
||||
-a -x ${LOCALBASE}/bin/pngtopnm \
|
||||
-a -x ${LOCALBASE}/bin/pnmtopng \
|
||||
-a -x ${LOCALBASE}/bin/gs ]; then
|
||||
SET_SENDFAX="ON"
|
||||
else
|
||||
SET_SENDFAX="OFF"
|
||||
fi
|
||||
if [ ":${WITH_UUCP}" = ':yes' \
|
||||
-o -x ${LOCALBASE}/bin/uux \
|
||||
-o -x /usr/bin/uux ]; then
|
||||
SET_UUCP="ON"
|
||||
else
|
||||
SET_UUCP="OFF"
|
||||
fi
|
||||
if [ ":${WITH_IPV6}" = ':yes' ]; then
|
||||
SET_IPV6="ON"
|
||||
else
|
||||
SET_IPV6="OFF"
|
||||
fi
|
||||
|
||||
/usr/bin/dialog --title "Courier configuration options" --clear \
|
||||
--checklist "\n\
|
||||
Please select desired options:" -1 -1 16 \
|
||||
Expect "Expect support for WebMail change passwd" ${SET_EXPECT} \
|
||||
GnuPG "GNU Privacy Guard support for WebMail" ${SET_GNUPG} \
|
||||
ASpell "ASpell support for WebMail" ${SET_ASPELL} \
|
||||
ISpell "ISpell support for WebMail" ${SET_ISPELL} \
|
||||
OpenLDAP "OpenLDAP 2.x authentication support" ${SET_LDAP} \
|
||||
MySQL "MySQL authentication support" ${SET_MYSQL} \
|
||||
PostgreSQL "PostgreSQL authentication support" ${SET_PGSQL} \
|
||||
VPopMail "VPopMail authentication support" ${SET_VPOPMAIL} \
|
||||
Procmail "Procmail local delivery support" ${SET_PROCMAIL} \
|
||||
SendFax "mgetty+sendfax support" ${SET_SENDFAX} \
|
||||
UUCP "UUCP support" ${SET_UUCP} \
|
||||
IPv6 "IPv6 support" ${SET_IPV6} \
|
||||
2> ${tempfile}
|
||||
|
||||
retval=$?
|
||||
|
||||
[ -s ${tempfile} ] && set `cat ${tempfile}`
|
||||
rm -f ${tempfile}
|
||||
|
||||
case ${retval} in
|
||||
0) [ -z "$*" ] && echo "Nothing selected" ;;
|
||||
1) echo "Cancel pressed." && exit 1 ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
${MKDIR} ${WRKDIRPREFIX}${CURDIR}
|
||||
exec > ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
|
||||
|
||||
echo "PREFIX= ${PREFIX}"
|
||||
|
||||
WITH_TRANSPORT="local esmtp dsn"
|
||||
WITH_EXPECT="--disable-changepass"
|
||||
WITH_ISPELL="--without-ispell"
|
||||
WITH_LDAP="--without-authldap"
|
||||
WITH_MYSQL="--without-authmysql"
|
||||
WITH_PGSQL="--without-authpgsql"
|
||||
WITH_VCHKPW="--without-authvchkpw"
|
||||
WITH_IPV6="--without-ipv6"
|
||||
|
||||
SUB_EXPECT="@comment "
|
||||
SUB_FAX="@comment "
|
||||
SUB_LDAP="@comment "
|
||||
SUB_MYSQL="@comment "
|
||||
SUB_PGSQL="@comment "
|
||||
SUB_UUCP="@comment "
|
||||
|
||||
while [ "$1" ]; do
|
||||
case $1 in
|
||||
\"Expect\")
|
||||
echo "BUILD_DEPENDS+= expect:\${PORTSDIR}/lang/expect"
|
||||
WITH_EXPECT=""
|
||||
SUB_EXPECT=""
|
||||
;;
|
||||
\"GnuPG\")
|
||||
echo "BUILD_DEPENDS+= gpg:\${PORTSDIR}/security/gnupg"
|
||||
;;
|
||||
\"ASpell\")
|
||||
if [ "$ISPELL" ]; then
|
||||
echo "ASpell and ISpell are mutually exclusive." > /dev/stderr
|
||||
rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
|
||||
exit 1
|
||||
fi
|
||||
echo "BUILD_DEPENDS+= aspell:\${PORTSDIR}/textproc/aspell"
|
||||
WITH_ISPELL="--with-ispell=\${LOCALBASE}/bin/aspell"
|
||||
ASPELL=1
|
||||
;;
|
||||
\"ISpell\")
|
||||
if [ "$ASPELL" ]; then
|
||||
echo "ASpell and ISpell are mutually exclusive." > /dev/stderr
|
||||
rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
|
||||
exit 1
|
||||
fi
|
||||
echo "BUILD_DEPENDS+= ispell:\${PORTSDIR}/textproc/ispell"
|
||||
WITH_ISPELL="--with-ispell=\${LOCALBASE}/bin/ispell"
|
||||
ISPELL=1
|
||||
;;
|
||||
\"OpenLDAP\")
|
||||
echo "USE_OPENLDAP= yes"
|
||||
WITH_LDAP="--with-authldap"
|
||||
PKGNAMESUFFIX="${PKGNAMESUFFIX}-ldap"
|
||||
SUB_LDAP=""
|
||||
;;
|
||||
\"MySQL\")
|
||||
if [ -f ${LOCALBASE}/vpopmail/lib/libvpopmail.a ]; then
|
||||
echo "VPopMAil and MySQL are mutually exclusive." > /dev/stderr
|
||||
echo "Uninstall VPopMAil if you want MySQL authentication." > /dev/stderr
|
||||
rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
|
||||
exit 1
|
||||
else
|
||||
echo "USE_MYSQL= yes"
|
||||
WITH_MYSQL="--with-authmysql"
|
||||
WITH_MYSQL="${WITH_MYSQL} --with-mysql-libs=\${LOCALBASE}/lib/mysql"
|
||||
WITH_MYSQL="${WITH_MYSQL} --with-mysql-includes=\${LOCALBASE}/include/mysql"
|
||||
PKGNAMESUFFIX="${PKGNAMESUFFIX}-mysql"
|
||||
SUB_MYSQL=""
|
||||
fi
|
||||
;;
|
||||
\"PostgreSQL\")
|
||||
echo "POSTGRESQL_PORT?= databases/postgresql7"
|
||||
echo "LIB_DEPENDS+= pq.3:\${PORTSDIR}/\${POSTGRESQL_PORT}"
|
||||
WITH_PGSQL="--with-authpgsql"
|
||||
WITH_PGSQL="${WITH_PGSQL} --with-pgsql-libs=${PGSQLBASE}/lib"
|
||||
WITH_PGSQL="${WITH_PGSQL} --with-pgsql-includes=${PGSQLINCLUDES}"
|
||||
PKGNAMESUFFIX="${PKGNAMESUFFIX}-pgsql"
|
||||
SUB_PGSQL=""
|
||||
;;
|
||||
\"VPopMail\")
|
||||
echo "BUILD_DEPENDS+= \${LOCALBASE}/vpopmail/lib/libvpopmail.a:\${PORTSDIR}/mail/vpopmail"
|
||||
WITH_VCHKPW="--with-authvchkpw"
|
||||
PKGNAMESUFFIX="${PKGNAMESUFFIX}-vpopmail"
|
||||
;;
|
||||
\"Procmail\")
|
||||
echo "BUILD_DEPENDS+= procmail:\${PORTSDIR}/mail/procmail"
|
||||
;;
|
||||
\"SendFax\")
|
||||
echo "BUILD_DEPENDS+= sendfax:\${PORTSDIR}/comms/mgetty+sendfax"
|
||||
echo "BUILD_DEPENDS+= pnmscale:\${PORTSDIR}/graphics/netpbm"
|
||||
echo "BUILD_DEPENDS+= giftopnm:\${PORTSDIR}/graphics/netpbm"
|
||||
echo "BUILD_DEPENDS+= jpegtopnm:\${PORTSDIR}/graphics/netpbm"
|
||||
echo "BUILD_DEPENDS+= ppmtopgm:\${PORTSDIR}/graphics/netpbm"
|
||||
echo "BUILD_DEPENDS+= pgmtopbm:\${PORTSDIR}/graphics/netpbm"
|
||||
echo "BUILD_DEPENDS+= pbmtog3:\${PORTSDIR}/graphics/netpbm"
|
||||
echo "BUILD_DEPENDS+= g3topbm:\${PORTSDIR}/graphics/netpbm"
|
||||
echo "BUILD_DEPENDS+= pngtopnm:\${PORTSDIR}/graphics/netpbm"
|
||||
echo "BUILD_DEPENDS+= pnmtopng:\${PORTSDIR}/graphics/netpbm"
|
||||
echo "BUILD_DEPENDS+= gs:\${PORTSDIR}/\${GSPORT}"
|
||||
echo "RUN_DEPENDS+= sendfax:\${PORTSDIR}/comms/mgetty+sendfax"
|
||||
echo "RUN_DEPENDS+= pnmscale:\${PORTSDIR}/graphics/netpbm"
|
||||
echo "RUN_DEPENDS+= giftopnm:\${PORTSDIR}/graphics/netpbm"
|
||||
echo "RUN_DEPENDS+= jpegtopnm:\${PORTSDIR}/graphics/netpbm"
|
||||
echo "RUN_DEPENDS+= ppmtopgm:\${PORTSDIR}/graphics/netpbm"
|
||||
echo "RUN_DEPENDS+= pgmtopbm:\${PORTSDIR}/graphics/netpbm"
|
||||
echo "RUN_DEPENDS+= pbmtog3:\${PORTSDIR}/graphics/netpbm"
|
||||
echo "RUN_DEPENDS+= g3topbm:\${PORTSDIR}/graphics/netpbm"
|
||||
echo "RUN_DEPENDS+= pngtopnm:\${PORTSDIR}/graphics/netpbm"
|
||||
echo "RUN_DEPENDS+= pnmtopng:\${PORTSDIR}/graphics/netpbm"
|
||||
echo "RUN_DEPENDS+= gs:\${PORTSDIR}/\${GSPORT}"
|
||||
echo "WITH_FAX= yes"
|
||||
WITH_TRANSPORT="${WITH_TRANSPORT} fax"
|
||||
SUB_FAX=""
|
||||
;;
|
||||
\"UUCP\")
|
||||
if [ ! -x /usr/bin/uux ]; then
|
||||
echo "BUILD_DEPENDS+= uux:\${PORTSDIR}/net/freebsd-uucp"
|
||||
echo "RUN_DEPENDS+= uux:\${PORTSDIR}/net/freebsd-uucp"
|
||||
fi
|
||||
WITH_TRANSPORT="${WITH_TRANSPORT} uucp"
|
||||
SUB_UUCP=""
|
||||
;;
|
||||
\"IPv6\")
|
||||
WITH_IPV6=""
|
||||
;;
|
||||
*)
|
||||
echo "Invalid option(s): $*" > /dev/stderr
|
||||
rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
|
||||
exit 1
|
||||
;;
|
||||
esac
|
||||
shift
|
||||
done
|
||||
|
||||
echo "CONFIGURE_ARGS+=${WITH_EXPECT}"
|
||||
echo "CONFIGURE_ARGS+=${WITH_ISPELL}"
|
||||
echo "CONFIGURE_ARGS+=${WITH_LDAP}"
|
||||
echo "CONFIGURE_ARGS+=${WITH_MYSQL}"
|
||||
echo "CONFIGURE_ARGS+=${WITH_PGSQL}"
|
||||
echo "CONFIGURE_ARGS+=${WITH_VCHKPW}"
|
||||
echo "CONFIGURE_ARGS+=${WITH_IPV6}"
|
||||
echo "CONFIGURE_ARGS+=--with-transport='${WITH_TRANSPORT}'"
|
||||
echo "PLIST_SUB+= SUB_EXPECT='${SUB_EXPECT}'"
|
||||
echo "PLIST_SUB+= SUB_FAX='${SUB_FAX}'"
|
||||
echo "PLIST_SUB+= SUB_LDAP='${SUB_LDAP}'"
|
||||
echo "PLIST_SUB+= SUB_MYSQL='${SUB_MYSQL}'"
|
||||
echo "PLIST_SUB+= SUB_PGSQL='${SUB_PGSQL}'"
|
||||
echo "PLIST_SUB+= SUB_UUCP='${SUB_UUCP}'"
|
||||
[ -n "${PKGNAMESUFFIX}" ] && echo "PKGNAMESUFFIX= ${PKGNAMESUFFIX}"
|
||||
|
||||
exit 0
|
Loading…
Reference in a new issue