Upgrade to 3.26.
This commit is contained in:
parent
ad6538ae3a
commit
063163509d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=35034
5 changed files with 31 additions and 49 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= xscreensaver
|
||||
PORTVERSION= 3.24
|
||||
PORTVERSION= 3.26
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://www.jwz.org/xscreensaver/
|
||||
|
||||
|
@ -17,20 +17,21 @@ USE_XPM= yes
|
|||
USE_MESA= yes
|
||||
WANT_GTK= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --without-pam --with-gl --with-gle --with-xpm
|
||||
CONFIGURE_ARGS= --without-pam --with-gl --with-gle --with-xpm --without-gnome
|
||||
|
||||
MAN1= attraction.1 blitspin.1 bouboule.1 braid.1 \
|
||||
bsod.1 bubbles.1 critical.1 decayscreen.1 \
|
||||
deco.1 distort.1 drift.1 epicycle.1 flag.1 flame.1 \
|
||||
forest.1 galaxy.1 goop.1 grav.1 greynetic.1 \
|
||||
forest.1 galaxy.1 gflux.1 goop.1 grav.1 greynetic.1 \
|
||||
halo.1 helix.1 hopalong.1 hypercube.1 ifs.1 \
|
||||
imsmap.1 jigsaw.1 julia.1 kaleidescope.1 lament.1 laser.1 \
|
||||
lightning.1 lisa.1 lmorph.1 maze.1 moire.1 munch.1 noseguy.1 \
|
||||
pedal.1 penrose.1 phosphor.1 pyro.1 qix.1 rd-bomb.1 rocks.1 \
|
||||
rorschach.1 sierpinski.1 slidescreen.1 slip.1 sonar.1 sphere.1\
|
||||
spiral.1 spotlight.1 squiral.1 starfish.1 strange.1 swirl.1 \
|
||||
t3d.1 vidwhacker.1 vines.1 webcollage.1 xflame.1 xjack.1 \
|
||||
xlyap.1 xmatrix.1 xroger.1 xscreensaver-command.1 \
|
||||
lightning.1 lisa.1 lmorph.1 maze.1 moire.1 munch.1 nerverot.1 \
|
||||
noseguy.1 pedal.1 penrose.1 petri.1 phosphor.1 pyro.1 qix.1 \
|
||||
rd-bomb.1 rocks.1 rorschach.1 sierpinski.1 slidescreen.1 \
|
||||
slip.1 sonar.1 sphere.1 spiral.1 spotlight.1 squiral.1 \
|
||||
starfish.1 strange.1 swirl.1 t3d.1 vidwhacker.1 vines.1 \
|
||||
webcollage.1 xflame.1 xjack.1 xlyap.1 xmatrix.1 xroger.1 \
|
||||
xscreensaver-command.1 xscreensaver-gl-helper.1 \
|
||||
xscreensaver.1 xsublim.1 xteevee.1
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (xscreensaver-3.24.tar.gz) = 9de6fb18edec39043af5caabebfb5b4a
|
||||
MD5 (xscreensaver-3.26.tar.gz) = 81afd1e8510024f8feb8ddd335d63c06
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- configure.orig Mon Apr 3 05:03:52 2000
|
||||
+++ configure Mon May 8 17:46:15 2000
|
||||
--- configure.orig Sat Nov 11 10:43:52 2000
|
||||
+++ configure Sun Nov 12 11:14:09 2000
|
||||
@@ -3174,7 +3174,7 @@
|
||||
fi
|
||||
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
|
||||
|
@ -9,7 +9,7 @@
|
|||
else
|
||||
echo "$ac_t""no" 1>&6
|
||||
fi
|
||||
@@ -5267,7 +5267,7 @@
|
||||
@@ -5336,7 +5336,7 @@
|
||||
PASSWD_LIBS="$PASSWD_LIBS -lkrb4 -ldes425 -lkrb5 -lk5crypto -lcrypt -lcom_err"
|
||||
elif test "$have_kerberos" = yes ; then
|
||||
# from Tim Showalter <tjs+@andrew.cmu.edu>
|
||||
|
@ -18,30 +18,3 @@
|
|||
fi
|
||||
|
||||
if test "$have_kerberos" = yes ; then
|
||||
@@ -6151,7 +6151,7 @@
|
||||
gtk_path="$gtk_dir:$gtk_dir:$gtk_path"
|
||||
fi
|
||||
|
||||
- for ac_prog in glib-config
|
||||
+ for ac_prog in `basename ${GLIB_CONFIG}`
|
||||
do
|
||||
# Extract the first word of "$ac_prog", so it can be a program name with args.
|
||||
set dummy $ac_prog; ac_word=$2
|
||||
@@ -6191,7 +6191,7 @@
|
||||
test -n "$glib_config" && break
|
||||
done
|
||||
|
||||
- for ac_prog in gtk-config
|
||||
+ for ac_prog in `basename ${GTK_CONFIG}`
|
||||
do
|
||||
# Extract the first word of "$ac_prog", so it can be a program name with args.
|
||||
set dummy $ac_prog; ac_word=$2
|
||||
@@ -6485,7 +6485,7 @@
|
||||
if eval "test \"`echo '$''{'ac_cv_gtk_version_string'+set}'`\" = set"; then
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
- ac_cv_gtk_version_string=`$glib_config --version`
|
||||
+ ac_cv_gtk_version_string=`${GTK_CONFIG} --version`
|
||||
fi
|
||||
|
||||
echo "$ac_t""$ac_cv_gtk_version_string" 1>&6
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- driver/Makefile.in.orig Mon Apr 3 05:04:08 2000
|
||||
+++ driver/Makefile.in Mon May 8 19:09:10 2000
|
||||
@@ -147,17 +147,17 @@
|
||||
--- driver/Makefile.in.orig Sat Nov 11 10:44:07 2000
|
||||
+++ driver/Makefile.in Sun Nov 12 11:17:08 2000
|
||||
@@ -148,18 +148,16 @@
|
||||
CMD_LIBS = $(LIBS) $(X_LIBS) \
|
||||
$(X_PRE_LIBS) -lX11 -lXext $(X_EXTRA_LIBS)
|
||||
|
||||
|
@ -13,19 +13,22 @@
|
|||
-MEN = xscreensaver.man xscreensaver-demo.man \
|
||||
+MEN = xscreensaver.man \
|
||||
xscreensaver-command.man
|
||||
ALL_MEN = xscreensaver.man \
|
||||
-ALL_MEN = xscreensaver.man \
|
||||
- xscreensaver-demo.man xscreensaver-command.man
|
||||
+ xscreensaver-command.man
|
||||
+ALL_MEN = xscreensaver.man xscreensaver-command.man
|
||||
EXTRAS = README Makefile.in XScreenSaver.ad.in xscreensaver.pam \
|
||||
- xscreensaver.kss xscreensaver-demo.glade \
|
||||
+ xscreensaver.kss \
|
||||
screensaver-properties.desktop.in .gdbinit
|
||||
- screensaver-properties.desktop.in .gdbinit
|
||||
+ xscreensaver.kss screensaver-properties.desktop.in .gdbinit
|
||||
VMSFILES = compile_axp.com compile_decc.com link_axp.com link_decc.com \
|
||||
vms-getpwnam.c vms-pwd.h vms-hpwd.c vms-validate.c \
|
||||
@@ -211,8 +211,6 @@
|
||||
$$inst xscreensaver $(install_prefix)$(bindir)/xscreensaver
|
||||
vms_axp.opt vms_axp_12.opt vms_decc.opt vms_decc_12.opt
|
||||
@@ -214,10 +212,6 @@
|
||||
$(install_prefix)$(bindir)/xscreensaver-command ; \
|
||||
$(INSTALL_PROGRAM) xscreensaver-command \
|
||||
$(install_prefix)$(bindir)/xscreensaver-command
|
||||
- @echo $(INSTALL_PROGRAM) xscreensaver-demo \
|
||||
- $(install_prefix)$(bindir)/xscreensaver-demo ; \
|
||||
- $(INSTALL_PROGRAM) xscreensaver-demo \
|
||||
- $(install_prefix)$(bindir)/xscreensaver-demo
|
||||
|
||||
|
|
|
@ -31,6 +31,7 @@ bin/flow
|
|||
bin/forest
|
||||
bin/galaxy
|
||||
bin/gears
|
||||
bin/gflux
|
||||
bin/glplanet
|
||||
bin/goop
|
||||
bin/grav
|
||||
|
@ -38,6 +39,7 @@ bin/greynetic
|
|||
bin/halo
|
||||
bin/helix
|
||||
bin/hopalong
|
||||
bin/hyperball
|
||||
bin/hypercube
|
||||
bin/ifs
|
||||
bin/imsmap
|
||||
|
@ -60,6 +62,7 @@ bin/moire2
|
|||
bin/morph3d
|
||||
bin/mountain
|
||||
bin/munch
|
||||
bin/nerverot
|
||||
bin/noseguy
|
||||
bin/pedal
|
||||
bin/penetrate
|
||||
|
@ -104,9 +107,11 @@ bin/xflame
|
|||
bin/xjack
|
||||
bin/xlyap
|
||||
bin/xmatrix
|
||||
bin/xrayswarm
|
||||
bin/xroger
|
||||
bin/xscreensaver
|
||||
bin/xscreensaver-command
|
||||
bin/xscreensaver-gl-helper
|
||||
bin/xspirograph
|
||||
bin/xsublim
|
||||
bin/xteevee
|
||||
|
|
Loading…
Reference in a new issue