devel/py-dateutil: Update to 2.2, Modernise
- Update to 2.2 - Add LICENSE_FILE - Update COMMENT (Via setup.py) - Fix RUN_DEPENDS assignment - Modernise Python framework entries - Canonicalise regression-test - Patch setup.py to support `test` command - Remove unecessary patch to dateutil/__init__.py (unicode -> plain) Changes: 2.2 * Updated zoneinfo to 2013h * fuzzy_with_tokens parse addon * Bug with LANG=C fixed QA: Ran 492 tests in 0.688s - OK (Python 2.7 / 3.4)
This commit is contained in:
parent
476b29c598
commit
06cbb6786d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=366387
4 changed files with 19 additions and 20 deletions
|
@ -2,24 +2,23 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= dateutil
|
||||
PORTVERSION= 2.1
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 2.2
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
DISTNAME= python-dateutil-${PORTVERSION}
|
||||
|
||||
MAINTAINER= koobs@FreeBSD.org
|
||||
COMMENT= Provides powerful extensions to the standard datetime module
|
||||
COMMENT= Extensions to the standard Python datetime module
|
||||
|
||||
LICENSE= BSD3CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six
|
||||
RUN_DEPENDS+= ${BUILD_DEPENDS}
|
||||
RUN_DEPENDS:= ${BUILD_DEPENDS}
|
||||
|
||||
USE_PYTHON= yes
|
||||
USE_PYDISTUTILS= yes
|
||||
PYDISTUTILS_AUTOPLIST= yes
|
||||
USES= python
|
||||
USE_PYTHON= autoplist distutils
|
||||
|
||||
# Fix incorrect permissions
|
||||
post-patch:
|
||||
|
@ -27,6 +26,6 @@ post-patch:
|
|||
@${REINPLACE_CMD} -e 's|import winreg|from six.moves import winreg|' ${WRKSRC}/dateutil/tzwin.py
|
||||
|
||||
regression-test: build
|
||||
@cd ${WRKSRC} && ${PYTHON_CMD} test.py
|
||||
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (python-dateutil-2.1.tar.gz) = 4c44ec3f9ff057b8c7b4c78beca5fdd8710600ea9a1df42f31bfcbae2f059dee
|
||||
SIZE (python-dateutil-2.1.tar.gz) = 152334
|
||||
SHA256 (python-dateutil-2.2.tar.gz) = eec865307ebe7f329a6a9945c15453265a449cdaaf3710340828a1934d53e468
|
||||
SIZE (python-dateutil-2.2.tar.gz) = 259085
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- ./dateutil/__init__.py.orig 2012-03-28 18:25:44.000000000 +0400
|
||||
+++ ./dateutil/__init__.py 2013-01-23 14:12:35.000000000 +0400
|
||||
@@ -5,6 +5,6 @@
|
||||
This module offers extensions to the standard Python
|
||||
datetime module.
|
||||
"""
|
||||
-__author__ = "Tomi Pieviläinen <tomi.pievilainen@iki.fi>"
|
||||
+__author__ = "Tomi Pievilainen <tomi.pievilainen@iki.fi>"
|
||||
__license__ = "Simplified BSD"
|
||||
__version__ = "2.1"
|
10
devel/py-dateutil/files/patch-setup.py
Normal file
10
devel/py-dateutil/files/patch-setup.py
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- ./setup.py.orig 2014-08-28 18:39:38.459159039 +1000
|
||||
+++ ./setup.py 2014-08-28 18:39:48.929863352 +1000
|
||||
@@ -47,5 +47,6 @@
|
||||
'Programming Language :: Python :: 3.2',
|
||||
'Programming Language :: Python :: 3.3',
|
||||
'Topic :: Software Development :: Libraries',
|
||||
- ]
|
||||
+ ],
|
||||
+ test_suite='test',
|
||||
)
|
Loading…
Reference in a new issue