- Update to 2.7.2
- Allow packaging as a user adn don't use @exec directives in plist
This commit is contained in:
parent
a8b14d8f16
commit
06e0b323a6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=367193
5 changed files with 44 additions and 363 deletions
|
@ -10,8 +10,7 @@
|
|||
# MAILDROP_LOG_COLUMNS lenght of 'File:' line in log - 8; default: 72
|
||||
|
||||
PORTNAME= maildrop
|
||||
PORTVERSION= 2.7.1
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 2.7.2
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= SF/courier/${PORTNAME}/${PORTVERSION}
|
||||
|
||||
|
@ -20,7 +19,7 @@ COMMENT= Mail delivery agent (MDA) with filtering abilities
|
|||
|
||||
LICENSE= GPLv3
|
||||
|
||||
USES= iconv shebangfix perl5 tar:bzip2
|
||||
USES= iconv perl5 tar:bzip2
|
||||
USE_PERL5= build
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --enable-syslog=1 \
|
||||
|
@ -31,11 +30,10 @@ INSTALL_TARGET= install-strip
|
|||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
|
||||
SHEBANG_FILES= libs/unicode/*.pl
|
||||
CONFLICTS= courier-0.65* libunicode-[0-9]*
|
||||
|
||||
CONFLICTS= courier-0.65*
|
||||
|
||||
LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
|
||||
LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre \
|
||||
libunicode.so:${PORTSDIR}/devel/courier-unicode
|
||||
|
||||
MAILDROP_LOG_COLUMNS?= 72 # lenght of 'File:' line in log
|
||||
|
||||
|
@ -75,18 +73,17 @@ MAILWRAPPER_CONFIGURE_OFF= --enable-sendmail=/usr/sbin/sendmail
|
|||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if defined(MAILDROP_SUID)
|
||||
.if defined(MAILDROP_SUID) && defined(MAILDROP_SGID)
|
||||
CONFIGURE_ARGS+= --enable-maildrop-uid="${MAILDROP_SUID}" --enable-maildrop-gid="${MAILDROP_SGID}"
|
||||
PLIST_SUB+= MMODE='6755' MUID='${MAILDROP_SUID}' MGID='${MAILDROP_SGID}'
|
||||
.elif defined(MAILDROP_SUID)
|
||||
CONFIGURE_ARGS+= --enable-maildrop-uid="${MAILDROP_SUID}"
|
||||
PLIST_SUB+= MSUID='' MUID='${MAILDROP_SUID}'
|
||||
.else
|
||||
PLIST_SUB+= MSUID='@comment ' MUID='root'
|
||||
.endif
|
||||
|
||||
.if defined(MAILDROP_SGID)
|
||||
PLIST_SUB+= MMODE='4755' MUID='${MAILDROP_SUID}'
|
||||
.elif defined(MAILDROP_SGID)
|
||||
CONFIGURE_ARGS+= --enable-maildrop-gid="${MAILDROP_SGID}"
|
||||
PLIST_SUB+= MSGID='' MGID='${MAILDROP_SGID}'
|
||||
PLIST_SUB+= MMODE='2755' MGID='${MAILDROP_SGID}'
|
||||
.else
|
||||
PLIST_SUB+= MSGID='@comment ' MGID='mail'
|
||||
PLIST_SUB+= MMODE='' MUID='root' MGID='mail'
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MFAM}
|
||||
|
@ -133,11 +130,5 @@ post-install:
|
|||
${INSTALL_DATA} ${WRKSRC}/libs/maildir/quotawarnmsg \
|
||||
${STAGEDIR}${PREFIX}/etc/quotawarnmsg.sample
|
||||
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS:S/maildir\//libs\/&/} ${STAGEDIR}${DOCSDIR}
|
||||
.if defined(MAILDROP_SUID)
|
||||
${CHMOD} u+s ${STAGEDIR}${PREFIX}/bin/lockmail ${STAGEDIR}${PREFIX}/bin/maildrop
|
||||
.endif
|
||||
.if defined(MAILDROP_SGID)
|
||||
${CHMOD} g+s ${STAGEDIR}${PREFIX}/bin/lockmail ${STAGEDIR}${PREFIX}/bin/maildrop
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
SHA256 (maildrop-2.7.1.tar.bz2) = fe1c3528c527e3a5bfe44b2e7437912bf55a5829fae442255347acb4a1caeb1b
|
||||
SIZE (maildrop-2.7.1.tar.bz2) = 2211838
|
||||
SHA256 (maildrop-2.7.2.tar.bz2) = d978cba4a6f1f139216f22cf03ee3c878fe2b287c9409024a2d41ef54931a4a6
|
||||
SIZE (maildrop-2.7.2.tar.bz2) = 1968673
|
||||
SHA256 (maildrop-2.7.0-dovecotauth.patch.txt) = 2987e56071d78dc55ac2ce523fe041dbf6565a90e98410f9fa2219d7434b945b
|
||||
SIZE (maildrop-2.7.0-dovecotauth.patch.txt) = 22063
|
||||
|
|
|
@ -1,16 +1,16 @@
|
|||
--- Makefile.in.orig 2013-09-28 19:28:36.000000000 +0200
|
||||
+++ Makefile.in 2013-10-01 17:24:51.798480620 +0200
|
||||
@@ -372,7 +372,7 @@
|
||||
--- Makefile.in.orig 2014-09-01 14:50:09.000000000 +0200
|
||||
+++ Makefile.in 2014-09-02 00:46:38.638094906 +0200
|
||||
@@ -376,7 +376,7 @@
|
||||
host_cpu = @host_cpu@
|
||||
host_os = @host_os@
|
||||
host_vendor = @host_vendor@
|
||||
-htmldir = $(pkgdatadir)/html
|
||||
-htmldir = $(docdir)/html
|
||||
+htmldir = $(datadir)/doc/@PACKAGE@
|
||||
includedir = @includedir@
|
||||
infodir = @infodir@
|
||||
install_sh = @install_sh@
|
||||
@@ -406,16 +406,16 @@
|
||||
maildroptips.txt COPYING.GPL manpage.css pgpkeys.txt
|
||||
@@ -411,15 +411,15 @@
|
||||
maildroptips.txt COPYING.GPL manpage.css $(HTMLWWW)
|
||||
|
||||
scriptdir = $(pkgdatadir)/scripts
|
||||
-DELIVERQUOTAHTMLSOURCE = maildirquota.html deliverquota.html
|
||||
|
@ -19,18 +19,17 @@
|
|||
-DELIVERQUOTAMAN = maildirquota.7 deliverquota.8
|
||||
+DELIVERQUOTAMAN = maildirquota.7 maildrop-deliverquota.8
|
||||
MAILDROPHTML = lockmail.html maildiracl.html maildirkw.html \
|
||||
- maildirmake.html maildropex.html \
|
||||
- maildirmake.html maildropex.html maildir.html \
|
||||
+ maildrop-maildirmake.html maildropex.html \
|
||||
maildir.html \
|
||||
maildropfilter.html maildropgdbm.html maildrop.html mailbot.html \
|
||||
makemime.html reformail.html reformime.html
|
||||
|
||||
-MAILDROPMAN = lockmail.1 maildirmake.1 maildrop.1 mailbot.1 maildropex.7 \
|
||||
+MAILDROPMAN = lockmail.1 maildrop-maildirmake.1 maildrop.1 mailbot.1 maildropex.7 \
|
||||
maildir.5 \
|
||||
maildropfilter.7 maildropgdbm.7 makemime.1 reformail.1 reformime.1
|
||||
|
||||
@@ -1255,21 +1255,21 @@
|
||||
maildropfilter.html maildropgdbm.html maildrop.html \
|
||||
mailbot.html makemime.html reformail.html reformime.html \
|
||||
$(am__append_1)
|
||||
-MAILDROPMAN = lockmail.1 maildirmake.1 maildrop.1 mailbot.1 \
|
||||
+MAILDROPMAN = lockmail.1 maildrop-maildirmake.1 maildrop.1 mailbot.1 \
|
||||
maildropex.7 maildir.5 maildropfilter.7 maildropgdbm.7 \
|
||||
makemime.1 reformail.1 reformime.1 $(am__append_2)
|
||||
EXTRA_LTLIBRARIES = librfc822.la librfc2045.la
|
||||
@@ -1257,21 +1257,21 @@
|
||||
|
||||
install-deliverquota:
|
||||
$(mkinstalldirs) $(DESTDIR)$(bindir)
|
||||
|
@ -58,7 +57,7 @@
|
|||
|
||||
# In maildrop 0.74, maildirmake was installed as bindir/maildrop.maildirmake
|
||||
# and a soft link was created from maildirmake to maildrop.maildirmake
|
||||
@@ -1287,7 +1287,7 @@
|
||||
@@ -1289,7 +1289,7 @@
|
||||
$(INSTALL_PROGRAM) libs/maildrop/$$f $(DESTDIR)$(bindir)/$$f ; \
|
||||
done
|
||||
$(INSTALL_PROGRAM) libs/liblock/lockmail $(DESTDIR)$(bindir)/lockmail
|
||||
|
@ -67,16 +66,16 @@
|
|||
$(INSTALL_PROGRAM) libs/rfc2045/reformime $(DESTDIR)$(bindir)/reformime
|
||||
$(INSTALL_PROGRAM) libs/rfc2045/makemime $(DESTDIR)$(bindir)/makemime
|
||||
test "@USE_DB@@USE_GDBM@" = "00" && exit 0; \
|
||||
@@ -1298,7 +1298,7 @@
|
||||
@@ -1300,7 +1300,7 @@
|
||||
. libs/maildrop/uidgid ; test -z "$$uid" && exit 0; test -w /etc || exit 0; cd $(DESTDIR)$(bindir) && chown $$uid maildrop lockmail && chmod 755 maildrop lockmail
|
||||
|
||||
uninstall-maildrop:
|
||||
- for f in maildrop mailbot maildirmake reformail lockmail makemime reformime; do \
|
||||
+ for f in maildrop mailbot maildrop-maildirmake reformail lockmail makemime reformime; do \
|
||||
+ for f in maildrop mailbot maildir-maildirmake reformail lockmail makemime reformime; do \
|
||||
rm -f $(DESTDIR)$(bindir)/$$f ; \
|
||||
done
|
||||
test "@USE_DB@@USE_GDBM@" = "00" && exit 0; \
|
||||
@@ -1352,11 +1352,11 @@
|
||||
@@ -1354,11 +1354,11 @@
|
||||
maildirkw.html: libs/maildir/maildirkw.html
|
||||
cp -f $(srcdir)/libs/maildir/maildirkw.html maildirkw.html
|
||||
|
||||
|
|
|
@ -1,311 +0,0 @@
|
|||
--- libs/unicode/configure.orig 2013-08-26 03:55:18.000000000 +0900
|
||||
+++ libs/unicode/configure 2014-04-21 15:49:46.000000000 +0900
|
||||
@@ -2382,7 +2382,7 @@
|
||||
|
||||
ac_config_headers="$ac_config_headers unicode_config.h"
|
||||
|
||||
-am__api_version='1.13'
|
||||
+am__api_version='1.14'
|
||||
|
||||
# Find a good install program. We prefer a C program (faster),
|
||||
# so one script is as good as another. But avoid the broken or
|
||||
@@ -2910,6 +2910,47 @@
|
||||
|
||||
|
||||
|
||||
+# POSIX will say in a future version that running "rm -f" with no argument
|
||||
+# is OK; and we want to be able to make that assumption in our Makefile
|
||||
+# recipes. So use an aggressive probe to check that the usage we want is
|
||||
+# actually supported "in the wild" to an acceptable degree.
|
||||
+# See automake bug#10828.
|
||||
+# To make any issue more visible, cause the running configure to be aborted
|
||||
+# by default if the 'rm' program in use doesn't match our expectations; the
|
||||
+# user can still override this though.
|
||||
+if rm -f && rm -fr && rm -rf; then : OK; else
|
||||
+ cat >&2 <<'END'
|
||||
+Oops!
|
||||
+
|
||||
+Your 'rm' program seems unable to run without file operands specified
|
||||
+on the command line, even when the '-f' option is present. This is contrary
|
||||
+to the behaviour of most rm programs out there, and not conforming with
|
||||
+the upcoming POSIX standard: <http://austingroupbugs.net/view.php?id=542>
|
||||
+
|
||||
+Please tell bug-automake@gnu.org about your system, including the value
|
||||
+of your $PATH and any error possibly output before this message. This
|
||||
+can help us improve future automake versions.
|
||||
+
|
||||
+END
|
||||
+ if test x"$ACCEPT_INFERIOR_RM_PROGRAM" = x"yes"; then
|
||||
+ echo 'Configuration will proceed anyway, since you have set the' >&2
|
||||
+ echo 'ACCEPT_INFERIOR_RM_PROGRAM variable to "yes"' >&2
|
||||
+ echo >&2
|
||||
+ else
|
||||
+ cat >&2 <<'END'
|
||||
+Aborting the configuration process, to ensure you take notice of the issue.
|
||||
+
|
||||
+You can download and install GNU coreutils to get an 'rm' implementation
|
||||
+that behaves properly: <http://www.gnu.org/software/coreutils/>.
|
||||
+
|
||||
+If you want to complete the configuration process using your problematic
|
||||
+'rm' anyway, export the environment variable ACCEPT_INFERIOR_RM_PROGRAM
|
||||
+to "yes", and re-run configure.
|
||||
+
|
||||
+END
|
||||
+ as_fn_error $? "Your 'rm' program is bad, sorry." "$LINENO" 5
|
||||
+ fi
|
||||
+fi
|
||||
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether ${MAKE-make} sets \$(MAKE)" >&5
|
||||
$as_echo_n "checking whether ${MAKE-make} sets \$(MAKE)... " >&6; }
|
||||
@@ -3959,6 +4000,65 @@
|
||||
ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
|
||||
ac_compiler_gnu=$ac_cv_c_compiler_gnu
|
||||
|
||||
+ac_ext=c
|
||||
+ac_cpp='$CPP $CPPFLAGS'
|
||||
+ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
|
||||
+ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
|
||||
+ac_compiler_gnu=$ac_cv_c_compiler_gnu
|
||||
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether $CC understands -c and -o together" >&5
|
||||
+$as_echo_n "checking whether $CC understands -c and -o together... " >&6; }
|
||||
+if ${am_cv_prog_cc_c_o+:} false; then :
|
||||
+ $as_echo_n "(cached) " >&6
|
||||
+else
|
||||
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
+/* end confdefs.h. */
|
||||
+
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+
|
||||
+ ;
|
||||
+ return 0;
|
||||
+}
|
||||
+_ACEOF
|
||||
+ # Make sure it works both with $CC and with simple cc.
|
||||
+ # Following AC_PROG_CC_C_O, we do the test twice because some
|
||||
+ # compilers refuse to overwrite an existing .o file with -o,
|
||||
+ # though they will create one.
|
||||
+ am_cv_prog_cc_c_o=yes
|
||||
+ for am_i in 1 2; do
|
||||
+ if { echo "$as_me:$LINENO: $CC -c conftest.$ac_ext -o conftest2.$ac_objext" >&5
|
||||
+ ($CC -c conftest.$ac_ext -o conftest2.$ac_objext) >&5 2>&5
|
||||
+ ac_status=$?
|
||||
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
+ (exit $ac_status); } \
|
||||
+ && test -f conftest2.$ac_objext; then
|
||||
+ : OK
|
||||
+ else
|
||||
+ am_cv_prog_cc_c_o=no
|
||||
+ break
|
||||
+ fi
|
||||
+ done
|
||||
+ rm -f core conftest*
|
||||
+ unset am_i
|
||||
+fi
|
||||
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $am_cv_prog_cc_c_o" >&5
|
||||
+$as_echo "$am_cv_prog_cc_c_o" >&6; }
|
||||
+if test "$am_cv_prog_cc_c_o" != yes; then
|
||||
+ # Losing compiler, so override with the script.
|
||||
+ # FIXME: It is wrong to rewrite CC.
|
||||
+ # But if we don't then we get into trouble of one sort or another.
|
||||
+ # A longer-term fix would be to have automake use am__CC in this case,
|
||||
+ # and then we could set am__CC="\$(top_srcdir)/compile \$(CC)"
|
||||
+ CC="$am_aux_dir/compile $CC"
|
||||
+fi
|
||||
+ac_ext=c
|
||||
+ac_cpp='$CPP $CPPFLAGS'
|
||||
+ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
|
||||
+ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
|
||||
+ac_compiler_gnu=$ac_cv_c_compiler_gnu
|
||||
+
|
||||
+
|
||||
depcc="$CC" am_compiler_list=
|
||||
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking dependency style of $depcc" >&5
|
||||
@@ -10515,14 +10615,10 @@
|
||||
# before this can be enabled.
|
||||
hardcode_into_libs=yes
|
||||
|
||||
- # Add ABI-specific directories to the system library path.
|
||||
- sys_lib_dlsearch_path_spec="/lib64 /usr/lib64 /lib /usr/lib"
|
||||
-
|
||||
# Append ld.so.conf contents to the search path
|
||||
if test -f /etc/ld.so.conf; then
|
||||
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;s/"//g;/^$/d' | tr '\n' ' '`
|
||||
- sys_lib_dlsearch_path_spec="$sys_lib_dlsearch_path_spec $lt_ld_extra"
|
||||
-
|
||||
+ sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
||||
fi
|
||||
|
||||
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
||||
@@ -12055,6 +12151,65 @@
|
||||
ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
|
||||
ac_compiler_gnu=$ac_cv_c_compiler_gnu
|
||||
|
||||
+ac_ext=c
|
||||
+ac_cpp='$CPP $CPPFLAGS'
|
||||
+ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
|
||||
+ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
|
||||
+ac_compiler_gnu=$ac_cv_c_compiler_gnu
|
||||
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether $CC understands -c and -o together" >&5
|
||||
+$as_echo_n "checking whether $CC understands -c and -o together... " >&6; }
|
||||
+if ${am_cv_prog_cc_c_o+:} false; then :
|
||||
+ $as_echo_n "(cached) " >&6
|
||||
+else
|
||||
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
+/* end confdefs.h. */
|
||||
+
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+
|
||||
+ ;
|
||||
+ return 0;
|
||||
+}
|
||||
+_ACEOF
|
||||
+ # Make sure it works both with $CC and with simple cc.
|
||||
+ # Following AC_PROG_CC_C_O, we do the test twice because some
|
||||
+ # compilers refuse to overwrite an existing .o file with -o,
|
||||
+ # though they will create one.
|
||||
+ am_cv_prog_cc_c_o=yes
|
||||
+ for am_i in 1 2; do
|
||||
+ if { echo "$as_me:$LINENO: $CC -c conftest.$ac_ext -o conftest2.$ac_objext" >&5
|
||||
+ ($CC -c conftest.$ac_ext -o conftest2.$ac_objext) >&5 2>&5
|
||||
+ ac_status=$?
|
||||
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
+ (exit $ac_status); } \
|
||||
+ && test -f conftest2.$ac_objext; then
|
||||
+ : OK
|
||||
+ else
|
||||
+ am_cv_prog_cc_c_o=no
|
||||
+ break
|
||||
+ fi
|
||||
+ done
|
||||
+ rm -f core conftest*
|
||||
+ unset am_i
|
||||
+fi
|
||||
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $am_cv_prog_cc_c_o" >&5
|
||||
+$as_echo "$am_cv_prog_cc_c_o" >&6; }
|
||||
+if test "$am_cv_prog_cc_c_o" != yes; then
|
||||
+ # Losing compiler, so override with the script.
|
||||
+ # FIXME: It is wrong to rewrite CC.
|
||||
+ # But if we don't then we get into trouble of one sort or another.
|
||||
+ # A longer-term fix would be to have automake use am__CC in this case,
|
||||
+ # and then we could set am__CC="\$(top_srcdir)/compile \$(CC)"
|
||||
+ CC="$am_aux_dir/compile $CC"
|
||||
+fi
|
||||
+ac_ext=c
|
||||
+ac_cpp='$CPP $CPPFLAGS'
|
||||
+ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
|
||||
+ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
|
||||
+ac_compiler_gnu=$ac_cv_c_compiler_gnu
|
||||
+
|
||||
+
|
||||
depcc="$CC" am_compiler_list=
|
||||
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking dependency style of $depcc" >&5
|
||||
@@ -15446,14 +15601,10 @@
|
||||
# before this can be enabled.
|
||||
hardcode_into_libs=yes
|
||||
|
||||
- # Add ABI-specific directories to the system library path.
|
||||
- sys_lib_dlsearch_path_spec="/lib64 /usr/lib64 /lib /usr/lib"
|
||||
-
|
||||
# Append ld.so.conf contents to the search path
|
||||
if test -f /etc/ld.so.conf; then
|
||||
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;s/"//g;/^$/d' | tr '\n' ' '`
|
||||
- sys_lib_dlsearch_path_spec="$sys_lib_dlsearch_path_spec $lt_ld_extra"
|
||||
-
|
||||
+ sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
||||
fi
|
||||
|
||||
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
||||
@@ -16405,33 +16556,72 @@
|
||||
|
||||
fi
|
||||
|
||||
-save_LIBS="$LIBS"
|
||||
-
|
||||
-LIBS="$LIBS -liconv"
|
||||
-
|
||||
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing iconv_open" >&5
|
||||
+$as_echo_n "checking for library containing iconv_open... " >&6; }
|
||||
+if ${ac_cv_search_iconv_open+:} false; then :
|
||||
+ $as_echo_n "(cached) " >&6
|
||||
+else
|
||||
+ ac_func_search_save_LIBS=$LIBS
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
/* end confdefs.h. */
|
||||
|
||||
-#include <iconv.h>
|
||||
-
|
||||
+/* Override any GCC internal prototype to avoid an error.
|
||||
+ Use char because int might match the return type of a GCC
|
||||
+ builtin and then its argument prototype would still apply. */
|
||||
+#ifdef __cplusplus
|
||||
+extern "C"
|
||||
+#endif
|
||||
+char iconv_open ();
|
||||
int
|
||||
main ()
|
||||
{
|
||||
-
|
||||
-
|
||||
-iconv_open("","");
|
||||
-
|
||||
+return iconv_open ();
|
||||
;
|
||||
return 0;
|
||||
}
|
||||
_ACEOF
|
||||
-if ac_fn_c_try_link "$LINENO"; then :
|
||||
- :
|
||||
-else
|
||||
- LIBS="$save_LIBS"
|
||||
+for ac_lib in '' iconv; do
|
||||
+ if test -z "$ac_lib"; then
|
||||
+ ac_res="none required"
|
||||
+ else
|
||||
+ ac_res=-l$ac_lib
|
||||
+ LIBS="-l$ac_lib $ac_func_search_save_LIBS"
|
||||
+ fi
|
||||
+ if ac_fn_c_try_link "$LINENO"; then :
|
||||
+ ac_cv_search_iconv_open=$ac_res
|
||||
fi
|
||||
rm -f core conftest.err conftest.$ac_objext \
|
||||
- conftest$ac_exeext conftest.$ac_ext
|
||||
+ conftest$ac_exeext
|
||||
+ if ${ac_cv_search_iconv_open+:} false; then :
|
||||
+ break
|
||||
+fi
|
||||
+done
|
||||
+if ${ac_cv_search_iconv_open+:} false; then :
|
||||
+
|
||||
+else
|
||||
+ ac_cv_search_iconv_open=no
|
||||
+fi
|
||||
+rm conftest.$ac_ext
|
||||
+LIBS=$ac_func_search_save_LIBS
|
||||
+fi
|
||||
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_search_iconv_open" >&5
|
||||
+$as_echo "$ac_cv_search_iconv_open" >&6; }
|
||||
+ac_res=$ac_cv_search_iconv_open
|
||||
+if test "$ac_res" != no; then :
|
||||
+ test "$ac_res" = "none required" || LIBS="$ac_res $LIBS"
|
||||
+
|
||||
+else
|
||||
+ as_fn_error $? "iconv library was not found." "$LINENO" 5
|
||||
+fi
|
||||
+
|
||||
+ac_fn_c_check_header_mongrel "$LINENO" "iconv.h" "ac_cv_header_iconv_h" "$ac_includes_default"
|
||||
+if test "x$ac_cv_header_iconv_h" = xyes; then :
|
||||
+
|
||||
+else
|
||||
+ as_fn_error $? "iconv.h was not found." "$LINENO" 5
|
||||
+fi
|
||||
+
|
||||
+
|
||||
|
||||
if test "$GCC" = "yes"
|
||||
then
|
|
@ -1,8 +1,14 @@
|
|||
bin/maildrop-deliverquota
|
||||
@owner %%MUID%%
|
||||
@group %%MGID%%
|
||||
@mode %%MMODE%%
|
||||
bin/lockmail
|
||||
bin/maildrop
|
||||
@owner
|
||||
@group
|
||||
@mode
|
||||
bin/maildrop-deliverquota
|
||||
bin/mailbot
|
||||
bin/maildrop-maildirmake
|
||||
bin/maildrop
|
||||
bin/makedat
|
||||
bin/makedatprog
|
||||
bin/makemime
|
||||
|
@ -13,6 +19,7 @@ man/man1/lockmail.1.gz
|
|||
man/man1/mailbot.1.gz
|
||||
man/man1/maildrop-maildirmake.1.gz
|
||||
man/man1/maildrop.1.gz
|
||||
man/man1/makedat.1.gz
|
||||
man/man1/makemime.1.gz
|
||||
man/man1/reformail.1.gz
|
||||
man/man1/reformime.1.gz
|
||||
|
@ -40,7 +47,6 @@ man/man8/maildrop-deliverquota.8.gz
|
|||
%%PORTDOCS%%%%DOCSDIR%%/maildrop-deliverquota.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/lockmail.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/mailbot.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/maildir.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/maildiracl.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/maildirkw.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/maildrop-maildirmake.html
|
||||
|
@ -58,7 +64,3 @@ man/man8/maildrop-deliverquota.8.gz
|
|||
%%PORTDOCS%%%%DOCSDIR%%/rfc2045.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rfc822.html
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@exec chown %%MUID%% %D/bin/lockmail %D/bin/maildrop
|
||||
%%MSUID%%@exec chmod u+s %D/bin/lockmail %D/bin/maildrop
|
||||
@exec chgrp %%MGID%% %D/bin/lockmail %D/bin/maildrop
|
||||
%%MSGID%%@exec chmod g+s %D/bin/lockmail %D/bin/maildrop
|
||||
|
|
Loading…
Reference in a new issue