FSF gcc-2.95.2 for embedded ARM cross-development
This is used to generate code that is independent of any operating system.
This commit is contained in:
parent
1d8f062168
commit
06f8644cbf
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=36575
9 changed files with 288 additions and 0 deletions
|
@ -12,6 +12,7 @@
|
|||
SUBDIR += adabroker
|
||||
SUBDIR += amulet
|
||||
SUBDIR += arm-aout-binutils
|
||||
SUBDIR += arm-aout-gcc295
|
||||
SUBDIR += asis
|
||||
SUBDIR += asl
|
||||
SUBDIR += astyle
|
||||
|
|
50
devel/arm-aout-gcc295/Makefile
Normal file
50
devel/arm-aout-gcc295/Makefile
Normal file
|
@ -0,0 +1,50 @@
|
|||
# ex:ts=8
|
||||
# New ports collection makefile for: armgcc-2.95.2
|
||||
# Date created: 22 Aug 2000
|
||||
# Whom: Paul Becke <pbecke@javagear.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= arm-aout-gcc295
|
||||
PORTVERSION= 2.95.2
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_GNU}
|
||||
MASTER_SITE_SUBDIR= gcc
|
||||
DISTNAME= gcc-2.95.2
|
||||
|
||||
MAINTAINER= pbecke@javagear.com
|
||||
|
||||
EXTRACT_AFTER_ARGS= | ${TAR} -xf - -T ${FILESDIR}/tlist -X ${FILESDIR}/xlist
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --target=arm-aout --with-gnu-as --with-gnu-ld --with-newlib
|
||||
MAKE_FLAGS= LANGUAGES="c c++"
|
||||
MAN1= arm-aout-addr2line.1 arm-aout-ar.1 arm-aout-as.1 \
|
||||
arm-aout-c++filt.1 arm-aout-ld.1 arm-aout-nlmconv.1 \
|
||||
arm-aout-nm.1 arm-aout-objcopy.1 arm-aout-objdump.1 \
|
||||
arm-aout-ranlib.1 arm-aout-size.1 arm-aout-strings.1 \
|
||||
arm-aout-strip.1
|
||||
|
||||
post-extract:
|
||||
${MKDIR} ${WRKSRC}/gcc/target
|
||||
${LN} -s ${FILESDIR}/include ${WRKSRC}/gcc/target/include
|
||||
|
||||
do-configure:
|
||||
cd ${WRKSRC}/libiberty ; ./configure ${CONFIGURE_ARGS}
|
||||
cd ${WRKSRC}/gcc ; ./configure ${CONFIGURE_ARGS}
|
||||
|
||||
do-build:
|
||||
cd ${WRKSRC}/libiberty ; ${GMAKE}
|
||||
cd ${WRKSRC}/gcc ; ${GMAKE}
|
||||
|
||||
do-install:
|
||||
cd ${WRKSRC}/gcc ; ${GMAKE} install
|
||||
${LN} -f ${PREFIX}/bin/arm-aout-g++ ${PREFIX}/arm-aout/bin/g++
|
||||
${LN} -f ${PREFIX}/bin/arm-aout-c++filt ${PREFIX}/arm-aout/bin/c++filt
|
||||
cd ${PREFIX}/lib ; ${MV} -f libbfd.* libiberty.* libopcodes.* \
|
||||
${PREFIX}/lib/gcc-lib/arm-aout/${PORTVERSION}
|
||||
|
||||
.include <bsd.port.mk>
|
1
devel/arm-aout-gcc295/distinfo
Normal file
1
devel/arm-aout-gcc295/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (gcc-2.95.2.tar.bz2) = 7caa851b4a360b6ff027897f455348d5
|
55
devel/arm-aout-gcc295/files/patch-Makefile.in
Normal file
55
devel/arm-aout-gcc295/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,55 @@
|
|||
--- gcc/Makefile.in.orig Fri Aug 13 02:46:55 1999
|
||||
+++ gcc/Makefile.in Fri Aug 25 20:43:36 2000
|
||||
@@ -167,7 +167,7 @@
|
||||
# The GCC to use for compiling libgcc2.a, enquire, and libgcc1-test.
|
||||
# Usually the one we just built.
|
||||
# Don't use this as a dependency--use $(GCC_PASSES) or $(GCC_PARTS).
|
||||
-GCC_FOR_TARGET = ./xgcc -B$(build_tooldir)/bin/ -B./ -I$(build_tooldir)/include
|
||||
+GCC_FOR_TARGET = ./xgcc -B./ -I./target/include
|
||||
|
||||
# This is used instead of ALL_CFLAGS when compiling with GCC_FOR_TARGET.
|
||||
# It omits XCFLAGS, and specifies -B./.
|
||||
@@ -190,31 +190,10 @@
|
||||
# objdir is set by configure.
|
||||
objdir = @objdir@
|
||||
|
||||
-AR_FOR_TARGET = ` \
|
||||
- if [ -f $(objdir)/../binutils/ar ] ; then \
|
||||
- echo $(objdir)/../binutils/ar ; \
|
||||
- else \
|
||||
- if [ "$(host_canonical)" = "$(target)" ] ; then \
|
||||
- echo ar; \
|
||||
- else \
|
||||
- t='$(program_transform_name)'; echo ar | sed -e $$t ; \
|
||||
- fi; \
|
||||
- fi`
|
||||
+AR_FOR_TARGET = $(prefix)/bin/arm-aout-ar
|
||||
AR_FLAGS_FOR_TARGET = rc
|
||||
-RANLIB_FOR_TARGET = ` \
|
||||
- if [ -f $(objdir)/../binutils/ranlib ] ; then \
|
||||
- echo $(objdir)/../binutils/ranlib ; \
|
||||
- else \
|
||||
- if [ "$(host_canonical)" = "$(target)" ] ; then \
|
||||
- echo ranlib; \
|
||||
- else \
|
||||
- t='$(program_transform_name)'; echo ranlib | sed -e $$t ; \
|
||||
- fi; \
|
||||
- fi`
|
||||
-RANLIB_TEST_FOR_TARGET = \
|
||||
- [ -f $(RANLIB_FOR_TARGET) ] \
|
||||
- || ( [ "$(host_canonical)" = "$(target)" ] \
|
||||
- && [ -f /usr/bin/ranlib -o -f /bin/ranlib ] )
|
||||
+RANLIB_FOR_TARGET = $(prefix)/bin/arm-aout-ranlib
|
||||
+RANLIB_TEST_FOR_TARGET = [ -f $(RANLIB_FOR_TARGET) ]
|
||||
|
||||
# Dir to search for system headers. Overridden by cross-make.
|
||||
SYSTEM_HEADER_DIR = /usr/include
|
||||
@@ -2433,7 +2412,7 @@
|
||||
# Install the driver last so that the window when things are
|
||||
# broken is small.
|
||||
install-normal: install-common $(INSTALL_HEADERS) $(INSTALL_LIBGCC) \
|
||||
- $(INSTALL_CPP) install-man install-info intl.install lang.install-normal \
|
||||
+ $(INSTALL_CPP) lang.install-normal \
|
||||
install-driver
|
||||
|
||||
# Do nothing while making gcc with a cross-compiler. The person who
|
52
devel/arm-aout-gcc295/files/tlist
Normal file
52
devel/arm-aout-gcc295/files/tlist
Normal file
|
@ -0,0 +1,52 @@
|
|||
gcc-2.95.2/config.if
|
||||
gcc-2.95.2/symlink-tree
|
||||
gcc-2.95.2/ylwrap
|
||||
gcc-2.95.2/move-if-change
|
||||
gcc-2.95.2/config.sub
|
||||
gcc-2.95.2/config-ml.in
|
||||
gcc-2.95.2/install-sh
|
||||
gcc-2.95.2/ltconfig
|
||||
gcc-2.95.2/ltmain.sh
|
||||
gcc-2.95.2/include
|
||||
gcc-2.95.2/install
|
||||
gcc-2.95.2/libiberty
|
||||
gcc-2.95.2/mkinstalldirs
|
||||
gcc-2.95.2/gcc/config/arm
|
||||
gcc-2.95.2/gcc/config/i386
|
||||
gcc-2.95.2/gcc/config/*.[ch]
|
||||
gcc-2.95.2/gcc/config/t-netbsd
|
||||
gcc-2.95.2/gcc/cp
|
||||
gcc-2.95.2/gcc/ginclude
|
||||
gcc-2.95.2/gcc/fixinc
|
||||
gcc-2.95.2/gcc/po
|
||||
gcc-2.95.2/gcc/intl
|
||||
gcc-2.95.2/gcc/*.[chy]
|
||||
gcc-2.95.2/gcc/README*
|
||||
gcc-2.95.2/gcc/*.def
|
||||
gcc-2.95.2/gcc/build-make
|
||||
gcc-2.95.2/gcc/cross-make
|
||||
gcc-2.95.2/gcc/configure
|
||||
gcc-2.95.2/gcc/dostage2
|
||||
gcc-2.95.2/gcc/dostage3
|
||||
gcc-2.95.2/gcc/exgettext
|
||||
gcc-2.95.2/gcc/fixcpp
|
||||
gcc-2.95.2/gcc/fixincludes
|
||||
gcc-2.95.2/gcc/fixproto
|
||||
gcc-2.95.2/gcc/genmultilib
|
||||
gcc-2.95.2/gcc/INSTALL
|
||||
gcc-2.95.2/gcc/listing
|
||||
gcc-2.95.2/gcc/just-fixinc
|
||||
gcc-2.95.2/gcc/mkinstalldirs
|
||||
gcc-2.95.2/gcc/move-if-change
|
||||
gcc-2.95.2/gcc/sort-protos
|
||||
gcc-2.95.2/gcc/cpp.fns
|
||||
gcc-2.95.2/gcc/configure.frag
|
||||
gcc-2.95.2/gcc/c-parse.gperf
|
||||
gcc-2.95.2/gcc/config.guess
|
||||
gcc-2.95.2/gcc/*.in
|
||||
gcc-2.95.2/gcc/configure.lang
|
||||
gcc-2.95.2/gcc/aclocal.m4
|
||||
gcc-2.95.2/gcc/*.com
|
||||
gcc-2.95.2/gcc/*.sed
|
||||
gcc-2.95.2/gcc/*.sh
|
||||
gcc-2.95.2/gcc/*.texi
|
41
devel/arm-aout-gcc295/files/xlist
Normal file
41
devel/arm-aout-gcc295/files/xlist
Normal file
|
@ -0,0 +1,41 @@
|
|||
gcc-2.95.2/gcc/ch/*
|
||||
gcc-2.95.2/gcc/f/*
|
||||
gcc-2.95.2/gcc/java/*
|
||||
gcc-2.95.2/gcc/objc/*
|
||||
gcc-2.95.2/gcc/testsuite/*
|
||||
gcc-2.95.2/gcc/config/1750a/*
|
||||
gcc-2.95.2/gcc/config/a29k/*
|
||||
gcc-2.95.2/gcc/config/alpha/*
|
||||
gcc-2.95.2/gcc/config/arc/*
|
||||
gcc-2.95.2/gcc/config/c4x/*
|
||||
gcc-2.95.2/gcc/config/clipper/*
|
||||
gcc-2.95.2/gcc/config/convex/*
|
||||
gcc-2.95.2/gcc/config/dsp16xx/*
|
||||
gcc-2.95.2/gcc/config/elxsi/*
|
||||
gcc-2.95.2/gcc/config/fx80/*
|
||||
gcc-2.95.2/gcc/config/gmicro/*
|
||||
gcc-2.95.2/gcc/config/h8300/*
|
||||
gcc-2.95.2/gcc/config/i370/*
|
||||
gcc-2.95.2/gcc/config/i860/*
|
||||
gcc-2.95.2/gcc/config/i960/*
|
||||
gcc-2.95.2/gcc/config/m32r/*
|
||||
gcc-2.95.2/gcc/config/m68k/*
|
||||
gcc-2.95.2/gcc/config/m88k/*
|
||||
gcc-2.95.2/gcc/config/mips/*
|
||||
gcc-2.95.2/gcc/config/mn10200/*
|
||||
gcc-2.95.2/gcc/config/mn10300/*
|
||||
gcc-2.95.2/gcc/config/msdos/*
|
||||
gcc-2.95.2/gcc/config/ns32k/*
|
||||
gcc-2.95.2/gcc/config/pa/*
|
||||
gcc-2.95.2/gcc/config/pdp11/*
|
||||
gcc-2.95.2/gcc/config/pyr/*
|
||||
gcc-2.95.2/gcc/config/romp/*
|
||||
gcc-2.95.2/gcc/config/rs6000/*
|
||||
gcc-2.95.2/gcc/config/sh/*
|
||||
gcc-2.95.2/gcc/config/sparc/*
|
||||
gcc-2.95.2/gcc/config/spur/*
|
||||
gcc-2.95.2/gcc/config/tahoe/*
|
||||
gcc-2.95.2/gcc/config/v850/*
|
||||
gcc-2.95.2/gcc/config/vax/*
|
||||
gcc-2.95.2/gcc/config/we32k/*
|
||||
gcc-2.95.2/gcc/config/winnt/*
|
1
devel/arm-aout-gcc295/pkg-comment
Normal file
1
devel/arm-aout-gcc295/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
FSF Gcc 2.95.2 for embedded ARM cross-development
|
10
devel/arm-aout-gcc295/pkg-descr
Normal file
10
devel/arm-aout-gcc295/pkg-descr
Normal file
|
@ -0,0 +1,10 @@
|
|||
FSF gcc-2.95.2 for embedded ARM cross-development
|
||||
|
||||
This is used to generate code that is independent of any operating system.
|
||||
In particular, it is used to compile the kernel, since there is no operating
|
||||
system that it can depend on.
|
||||
|
||||
devel/arm/kernel uses this port as a dependency.
|
||||
--------------------------------------------------------------------------
|
||||
Paul Becke
|
||||
pbecke@javagear.com
|
77
devel/arm-aout-gcc295/pkg-plist
Normal file
77
devel/arm-aout-gcc295/pkg-plist
Normal file
|
@ -0,0 +1,77 @@
|
|||
arm-aout/bin/gcc
|
||||
arm-aout/bin/g++
|
||||
arm-aout/bin/c++filt
|
||||
bin/arm-aout-c++
|
||||
bin/arm-aout-c++filt
|
||||
bin/arm-aout-g++
|
||||
bin/arm-aout-gcc
|
||||
bin/arm-aout-protoize
|
||||
bin/arm-aout-unprotoize
|
||||
bin/gcov
|
||||
include/ansidecl.h
|
||||
include/bfd.h
|
||||
include/bfdlink.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/SYSCALLS.c.X
|
||||
lib/gcc-lib/arm-aout/2.95.2/be/fpu/libgcc.a
|
||||
lib/gcc-lib/arm-aout/2.95.2/be/libgcc.a
|
||||
lib/gcc-lib/arm-aout/2.95.2/cc1
|
||||
lib/gcc-lib/arm-aout/2.95.2/cc1plus
|
||||
lib/gcc-lib/arm-aout/2.95.2/collect2
|
||||
lib/gcc-lib/arm-aout/2.95.2/cpp
|
||||
lib/gcc-lib/arm-aout/2.95.2/fpu/libgcc.a
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/README
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/assert.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/exception
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/fixed
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/float.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/iso646.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/limits.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/new
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/new.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/proto.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/stdarg.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/stdbool.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/stddef.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/syslimits.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/typeinfo
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/va-alpha.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/va-arc.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/va-c4x.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/va-clipper.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/va-h8300.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/va-i860.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/va-i960.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/va-m32r.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/va-m88k.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/va-mips.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/va-mn10200.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/va-mn10300.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/va-pa.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/va-ppc.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/va-pyr.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/va-sh.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/va-sparc.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/va-spur.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/va-v850.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/include/varargs.h
|
||||
lib/gcc-lib/arm-aout/2.95.2/le/fpu/libgcc.a
|
||||
lib/gcc-lib/arm-aout/2.95.2/le/libgcc.a
|
||||
lib/gcc-lib/arm-aout/2.95.2/libgcc.a
|
||||
lib/gcc-lib/arm-aout/2.95.2/specs
|
||||
lib/gcc-lib/arm-aout/2.95.2/libbfd.a
|
||||
lib/gcc-lib/arm-aout/2.95.2/libbfd.la
|
||||
lib/gcc-lib/arm-aout/2.95.2/libiberty.a
|
||||
lib/gcc-lib/arm-aout/2.95.2/libopcodes.a
|
||||
lib/gcc-lib/arm-aout/2.95.2/libopcodes.la
|
||||
@dirrm arm-aout/bin
|
||||
@dirrm arm-aout
|
||||
@dirrm lib/gcc-lib/arm-aout/2.95.2/include
|
||||
@dirrm lib/gcc-lib/arm-aout/2.95.2/be/fpu
|
||||
@dirrm lib/gcc-lib/arm-aout/2.95.2/be
|
||||
@dirrm lib/gcc-lib/arm-aout/2.95.2/le/fpu
|
||||
@dirrm lib/gcc-lib/arm-aout/2.95.2/le
|
||||
@dirrm lib/gcc-lib/arm-aout/2.95.2/fpu
|
||||
@dirrm lib/gcc-lib/arm-aout/2.95.2
|
||||
@dirrm lib/gcc-lib/arm-aout
|
||||
@dirrm lib/gcc-lib
|
||||
@dirrm lib
|
Loading…
Reference in a new issue