Update to 1.10.0
Changes: https://github.com/ffi/ffi/blob/master/CHANGELOG.md PR: 234875 Submitted by: Jose Luis Duran <jlduran@gmail.com>
This commit is contained in:
parent
d2cca95ebf
commit
07571d65cf
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=490008
5 changed files with 5 additions and 78 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ffi
|
||||
PORTVERSION= 1.9.25
|
||||
PORTVERSION= 1.10.0
|
||||
CATEGORIES= devel rubygems
|
||||
MASTER_SITES= RG
|
||||
|
||||
|
@ -14,11 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
|
|||
|
||||
LIB_DEPENDS= libffi.so:devel/libffi
|
||||
|
||||
USE_RUBY= yes
|
||||
USES= gem
|
||||
|
||||
post-patch:
|
||||
@${LN} -s i386-freebsd ${WRKSRC}/lib/ffi/platform/arm-freebsd
|
||||
@${LN} -s x86_64-freebsd ${WRKSRC}/lib/ffi/platform/aarch64-freebsd
|
||||
USE_RUBY= yes
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1528202798
|
||||
SHA256 (rubygem/ffi-1.9.25.gem) = f854f08f08190fec772a12e863f33761d02ad3efea3c3afcdeffc8a06313f54a
|
||||
SIZE (rubygem/ffi-1.9.25.gem) = 867840
|
||||
TIMESTAMP = 1547227029
|
||||
SHA256 (rubygem/ffi-1.10.0.gem) = 17001940b28a961c94251a39f0ae00b32c2d0850479b5978c971759591fc1749
|
||||
SIZE (rubygem/ffi-1.10.0.gem) = 869376
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- ffi.gemspec.orig 2018-07-29 17:14:15 UTC
|
||||
+++ ffi.gemspec
|
||||
@@ -21,6 +21,8 @@ Gem::Specification.new do |s|
|
||||
s.rubygems_version = "2.7.7".freeze
|
||||
s.summary = "Ruby FFI".freeze
|
||||
|
||||
+ s.files += ["lib/ffi/platform/aarch64-freebsd/types.conf".freeze, "lib/ffi/platform/arm-freebsd/types.conf".freeze]
|
||||
+
|
||||
if s.respond_to? :specification_version then
|
||||
s.specification_version = 4
|
||||
|
|
@ -1,20 +0,0 @@
|
|||
--- lib/ffi/platform/i386-freebsd/types.conf.orig 2017-01-24 15:24:36 UTC
|
||||
+++ lib/ffi/platform/i386-freebsd/types.conf
|
||||
@@ -25,7 +25,7 @@ rbx.platform.typedef.__register_t = int
|
||||
rbx.platform.typedef.__segsz_t = int
|
||||
rbx.platform.typedef.__size_t = uint
|
||||
rbx.platform.typedef.__ssize_t = int
|
||||
-rbx.platform.typedef.__time_t = int
|
||||
+rbx.platform.typedef.__time_t = long
|
||||
rbx.platform.typedef.__uintfptr_t = uint
|
||||
rbx.platform.typedef.__uintmax_t = ulong_long
|
||||
rbx.platform.typedef.__uintptr_t = uint
|
||||
@@ -136,7 +136,7 @@ rbx.platform.typedef.segsz_t = int
|
||||
rbx.platform.typedef.size_t = uint
|
||||
rbx.platform.typedef.ssize_t = int
|
||||
rbx.platform.typedef.suseconds_t = long
|
||||
-rbx.platform.typedef.time_t = int
|
||||
+rbx.platform.typedef.time_t = long
|
||||
rbx.platform.typedef.u_register_t = uint
|
||||
rbx.platform.typedef.uid_t = uint
|
||||
rbx.platform.typedef.useconds_t = uint
|
|
@ -1,38 +0,0 @@
|
|||
--- lib/ffi/platform/x86_64-freebsd/types.conf.orig 2017-01-24 15:23:43 UTC
|
||||
+++ lib/ffi/platform/x86_64-freebsd/types.conf
|
||||
@@ -37,7 +37,7 @@ rbx.platform.typedef.__off_t = long_long
|
||||
rbx.platform.typedef.__ptrdiff_t = long
|
||||
rbx.platform.typedef.__size_t = ulong
|
||||
rbx.platform.typedef.__ssize_t = long
|
||||
-rbx.platform.typedef.__time_t = int
|
||||
+rbx.platform.typedef.__time_t = long
|
||||
rbx.platform.typedef.__timer_t = int
|
||||
rbx.platform.typedef.__wchar_t = int
|
||||
rbx.platform.typedef.__wint_t = int
|
||||
@@ -63,7 +63,7 @@ rbx.platform.typedef.__socklen_t = uint
|
||||
rbx.platform.typedef.__swblk_t = int
|
||||
rbx.platform.typedef.__uid_t = uint
|
||||
rbx.platform.typedef.__useconds_t = uint
|
||||
-rbx.platform.typedef.__suseconds_t = int
|
||||
+rbx.platform.typedef.__suseconds_t = long
|
||||
rbx.platform.typedef.u_char = uchar
|
||||
rbx.platform.typedef.u_short = ushort
|
||||
rbx.platform.typedef.u_int = uint
|
||||
@@ -113,7 +113,7 @@ rbx.platform.typedef.segsz_t = int
|
||||
rbx.platform.typedef.swblk_t = int
|
||||
rbx.platform.typedef.uid_t = uint
|
||||
rbx.platform.typedef.useconds_t = uint
|
||||
-rbx.platform.typedef.suseconds_t = int
|
||||
+rbx.platform.typedef.suseconds_t = long
|
||||
rbx.platform.typedef.in_addr_t = uint
|
||||
rbx.platform.typedef.in_port_t = ushort
|
||||
rbx.platform.typedef.sa_family_t = uchar
|
||||
@@ -122,7 +122,7 @@ rbx.platform.typedef.clock_t = int
|
||||
rbx.platform.typedef.clockid_t = int
|
||||
rbx.platform.typedef.size_t = ulong
|
||||
rbx.platform.typedef.ssize_t = long
|
||||
-rbx.platform.typedef.time_t = int
|
||||
+rbx.platform.typedef.time_t = long
|
||||
rbx.platform.typedef.timer_t = int
|
||||
rbx.platform.typedef.off_t = long_long
|
||||
rbx.platform.typedef.__fd_mask = int
|
Loading…
Reference in a new issue