Update to JNetHack-3.4.3-0.1.

This commit is contained in:
Akinori MUSHA 2004-02-09 03:19:32 +00:00
parent d3ae9931c0
commit 076e6f780e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=100461
8 changed files with 45 additions and 62 deletions

View file

@ -6,20 +6,18 @@
#
PORTNAME= nethack
PORTVERSION= 3.4.1
PORTREVISION= 2
PORTVERSION= 3.4.3
CATEGORIES= japanese games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}-src
EXTRACT_SUFX= .tgz
MAINTAINER= knu@FreeBSD.org
COMMENT= Japanized NetHack
PATCH_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
PATCH_SITE_SUBDIR= jnethack/5795
PATCHFILES= jnethack-${PORTVERSION}-0.4.diff.gz
PATCH_SITE_SUBDIR= jnethack/7432
PATCHFILES= jnethack-${PORTVERSION}-0.1.diff.gz
PATCH_DIST_STRIP= -p1
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}

View file

@ -1,2 +1,4 @@
MD5 (nethack-341.tgz) = aefcbeb20210b2d64511c84bd03c3e4e
MD5 (jnethack-3.4.1-0.4.diff.gz) = 14affaa217d4aac60098c7321018ad8a
MD5 (nethack-343-src.tgz) = 21479c95990eefe7650df582426457f9
SIZE (nethack-343-src.tgz) = 3497458
MD5 (jnethack-3.4.3-0.1.diff.gz) = 785e75d3fde705a113b70c2b322eda6a
SIZE (jnethack-3.4.3-0.1.diff.gz) = 922501

View file

@ -1,11 +1,11 @@
--- include/config.h.orig Fri Dec 20 02:09:41 2002
+++ include/config.h Fri Dec 20 02:09:42 2002
@@ -248,7 +248,7 @@
# ifdef __APPLE__
# define HACKDIR "jnethackdir" /* nethack directory */
# else
-# define HACKDIR "/usr/games/lib/jnethackdir"
+# define HACKDIR "%%HACKDIR%%"
# endif
--- include/config.h.orig Mon Feb 9 11:56:31 2004
+++ include/config.h Mon Feb 9 11:59:57 2004
@@ -222,7 +222,7 @@
* otherwise it will be the current directory.
*/
# ifndef HACKDIR
-# define HACKDIR "/usr/games/lib/jnethackdir"
+# define HACKDIR "%%HACKDIR%%"
# endif
/*

View file

@ -1,22 +1,13 @@
--- include/system.h.orig Thu Mar 21 08:42:55 2002
+++ include/system.h Sun Jun 16 15:49:55 2002
--- include/system.h.orig Sat Aug 30 09:07:23 2003
+++ include/system.h Tue Sep 2 00:39:39 2003
@@ -79,7 +79,9 @@
# if !defined(__SC__) && !defined(LINUX)
E long NDECL(random);
# endif
-# if !defined(SUNOS4) || defined(RANDOM)
-# if (!defined(SUNOS4) && !defined(bsdi) && !defined(__FreeBSD__)) || defined(RANDOM)
+# if defined(__FreeBSD__)
+E void FDECL(srandom, (unsigned long));
+# elif !defined(SUNOS4) || defined(RANDOM)
+# elif (!defined(SUNOS4) && !defined(bsdi) && !defined(__FreeBSD__)) || defined(RANDOM)
E void FDECL(srandom, (unsigned int));
# else
# if !defined(bsdi) && !defined(__FreeBSD__)
@@ -521,7 +523,7 @@
# endif
# endif
-# if defined(ULTRIX) || defined(SYSV) || defined(MICRO) || defined(VMS) || defined(MAC) || (defined(HPUX) && defined(_POSIX_SOURCE))
+# if defined(ULTRIX) || defined(SYSV) || defined(MICRO) || defined(VMS) || defined(MAC) || (defined(HPUX) && defined(_POSIX_SOURCE)) || defined(__FreeBSD__)
E time_t FDECL(time, (time_t *));
# else
E long FDECL(time, (time_t *));

View file

@ -1,11 +1,11 @@
--- include/unixconf.h.orig Fri Jun 20 21:10:39 2003
+++ include/unixconf.h Fri Jun 20 21:13:50 2003
--- include/unixconf.h.orig Mon Feb 9 12:02:12 2004
+++ include/unixconf.h Mon Feb 9 12:02:48 2004
@@ -19,7 +19,7 @@
*/
/* define exactly one of the following four choices */
-/* #define BSD 1 */ /* define for 4.n BSD */
+#define BSD 1 /* define for 4.n BSD */
-/* #define BSD 1 */ /* define for 4.n/Free/Open/Net BSD */
+#define BSD 1 /* define for 4.n/Free/Open/Net BSD */
/* also for relatives like SunOS 4.x, DG/UX, and */
/* older versions of Linux */
/* #define ULTRIX */ /* define for Ultrix v3.0 or higher (but not lower) */
@ -18,7 +18,7 @@
/* The Andrew Message System does mail a little differently from normal
* UNIX. Mail is deposited in the user's own directory in ~/Mailbox
@@ -280,7 +280,7 @@
@@ -284,7 +284,7 @@
#endif
#if defined(BSD) || defined(ULTRIX)

View file

@ -1,6 +1,6 @@
--- sys/unix/Makefile.src.orig Fri Jun 20 21:14:30 2003
+++ sys/unix/Makefile.src Fri Jun 20 21:18:33 2003
@@ -147,19 +147,28 @@
--- sys/unix/Makefile.src.orig Mon Feb 9 12:10:20 2004
+++ sys/unix/Makefile.src Mon Feb 9 12:11:52 2004
@@ -149,19 +149,29 @@
# directories. The ones given below is the usual spot for linux systems.
# The paths are for glibconfig.h and gnomesupport.h respectively.
#
@ -21,19 +21,20 @@
+ifeq ("$(GRAPHICS)","GNOME_GRAPHICS")
+CFLAGS += -DGNOME_GRAPHICS ${CPPFLAGS}
+endif
LFLAGS =
+
LFLAGS =
# The Qt and Be window systems are written in C++, while the rest of
# NetHack is standard C. If using Qt, uncomment the LD line here to get
# NetHack is standard C. If using Qt, uncomment the LINK line here to get
# the C++ libraries linked in.
-CXXFLAGS = $(CFLAGS) -I. -I$(QTDIR)/include
-CXX=g++
+CXXFLAGS += -I. -I../include ${QTCPPFLAGS}
+#CXX=g++
#LD=g++
# flags for IPv6 support
@@ -223,7 +232,26 @@
#LINK=g++
# For cross-compiling, eg. with gcc on Linux (see also CC further up):
#CXX=arm-linux-g++
@@ -228,7 +238,26 @@
#
#
WINSRC = $(WINTTYSRC)
@ -60,7 +61,7 @@
# on some systems the termcap library is in -ltermcap or -lcurses
# on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
@@ -243,19 +271,19 @@
@@ -248,19 +277,19 @@
#
# libraries for X11
# If USE_XPM is defined in config.h, you will also need -lXpm here.
@ -83,7 +84,7 @@
#
# libraries for Gem port
WINGEMLIB = -le_gem -lgem
@@ -264,6 +292,15 @@
@@ -269,6 +298,15 @@
WINBELIB = -lbe
WINLIB = $(WINTTYLIB)
@ -99,16 +100,7 @@
# any other strange libraries your system needs (for Sysunix only -- the more
# specialized targets should already be right)
@@ -297,7 +334,7 @@
# make NetHack
#JP by issei(96/5/27)
-GAME = jnethack
+GAME = %%HACKNAME%%
# GAME = nethack.prg
# if you defined RANDOM in unixconf.h/tosconf.h since your system did not come
@@ -473,13 +510,13 @@
@@ -478,13 +516,13 @@
# Qt windowport meta-object-compiler output
qt_kde0.moc: ../include/qt_kde0.h

View file

@ -1,5 +1,5 @@
--- sys/unix/Makefile.top.orig Tue Aug 13 06:38:30 2002
+++ sys/unix/Makefile.top Tue Aug 13 06:40:41 2002
--- sys/unix/Makefile.top.orig Mon Feb 9 12:12:22 2004
+++ sys/unix/Makefile.top Mon Feb 9 12:13:05 2004
@@ -14,18 +14,17 @@
# MAKE = make
@ -37,8 +37,8 @@
# per discussion in Install.X11 and Install.Qt
-VARDATND =
+# VARDATND =
# VARDATND = x11tiles pet_mark.xbm
# VARDATND = x11tiles pet_mark.xbm rip.xpm
# VARDATND = x11tiles NetHack.ad pet_mark.xbm
# VARDATND = x11tiles NetHack.ad pet_mark.xbm rip.xpm
# for Atari/Gem
@@ -48,7 +47,7 @@
# for BeOS

View file

@ -2,9 +2,9 @@ bin/%%HACKNAME%%
%%HACKDIR%%/%%HACKNAME%%
@exec mkdir %D/%%HACKDIR%%/save
@exec chmod -R 775 %D/%%HACKDIR%%
@exec chmod 2755 %D/%%HACKDIR%%/nethack
@exec chmod 2755 %D/%%HACKDIR%%/%%HACKNAME%%
@exec chown games:games %D/%%HACKDIR%%/save
@unexec rm -rf %D/%%HACKDIR%%/save
@unexec rmdir %D/%%HACKDIR%%/save 2>/dev/null || true
%%HACKDIR%%/Arc-fila.lev
%%HACKDIR%%/Arc-filb.lev
%%HACKDIR%%/Arc-goal.lev