gimp-app:

Depend on glib-networking [2], which is used for https connection.
Fix plist when default-off options are enabled [1].
While here overhaul dependancies.

py-gimp:
Fix a issue with unresolved symbols in the python library, due to incorrect linking.

PR:		232066 [1], 232047 [2]
Reported by:	bsd@dino.sk [1], rsmith@xs4all.nl [2]
This commit is contained in:
Koop Mast 2018-10-14 17:14:32 +00:00
parent fc5281c98b
commit 07882a9351
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=482098
4 changed files with 43 additions and 46 deletions

View file

@ -3,6 +3,7 @@
PORTNAME?= gimp-app
PORTVERSION= 2.10.6
PORTREVISION= 1
PORTEPOCH?= 1
CATEGORIES?= graphics gnome
MASTER_SITES= GIMP/gimp/v${PORTVERSION:R}
@ -15,33 +16,30 @@ LICENSE= GPLv3 LGPL3
LICENSE_COMB= multi
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes \
glib-networking>=0:net/glib-networking \
mypaint-brushes>0:graphics/mypaint-brushes
LIB_DEPENDS= libpng.so:graphics/png \
libtiff.so:graphics/tiff \
libwebp.so:graphics/webp \
libIex-2_3.so:graphics/ilmbase \
libasound.so:audio/alsa-lib \
liblcms2.so:graphics/lcms2 \
libgegl-0.4.so:graphics/gegl \
libbabl-0.1.so:x11/babl \
libharfbuzz.so:print/harfbuzz \
libfontconfig.so:x11-fonts/fontconfig \
libdbus-1.so:devel/dbus \
libpoppler-glib.so:graphics/poppler-glib \
libgexiv2.so:graphics/gexiv2 \
libjson-c.so:devel/json-c \
libIlmImf.so:graphics/openexr \
libjson-glib-1.0.so:devel/json-glib \
libfribidi.so:converters/fribidi \
libmypaint.so:graphics/libmypaint \
libfreetype.so:print/freetype2
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes \
glib-networking>=0:net/glib-networking \
mypaint-brushes>0:graphics/mypaint-brushes
GNU_CONFIGURE= yes
USES+= compiler:c++14-lang cpe gettext gmake gnome jpeg libtool \
localbase pathfix pkgconfig shebangfix tar:bzip2
USE_XORG= ice sm xcursor xext xfixes xmu xpm xt x11
USE_GNOME+= cairo gtk20 intlhack librsvg2
localbase pkgconfig shebangfix tar:bzip2
USE_XORG= ice sm x11 xcursor xext xfixes xmu xpm xt
USE_GNOME+= cairo gtk20 intltool librsvg2
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
@ -53,6 +51,7 @@ CONFIGURE_ARGS?=--with-html-dir=${PREFIX}/share/doc/gimp \
--disable-gtk-doc \
--without-linux-input \
--with-print \
--without-gudev \
--enable-default-binary \
--disable-gimp-console \
--disable-python \
@ -74,14 +73,11 @@ PLIST_SUB+= LIBVER=0.1000.${PORTVERSION:E}
USES+= desktop-file-utils
OPTIONS_DEFINE?= AA LIBEXIF GHOSTSCRIPT GVFS HELPBROWSER \
LIBHEIF LIBMNG OPENJPEG POPPLER SIMD WMF
OPTIONS_DEFAULT= AA LIBEXIF GVFS LIBMNG OPENJPEG POPPLER WMF
OPTIONS_DEFINE?= AA GHOSTSCRIPT HELPBROWSER \
LIBHEIF LIBMNG OPENEXR OPENJPEG SIMD WEBP WMF
OPTIONS_DEFAULT= AA LIBMNG OPENEXR OPENJPEG WEBP WMF
OPTIONS_SUB= yes
AA_DESC= Ascii-art Plug-in
HELPBROWSER_DESC= Internal help browser
.endif
.if defined(GIMP_SLAVE)
@ -96,42 +92,42 @@ LIB_DEPENDS+= libgimp-2.0.so:graphics/gimp-app
DEBUG_CONFIGURE_ON= --enable-debug
AA_DESC= Ascii-art Plug-in
AA_LIB_DEPENDS= libaa.so:graphics/aalib
AA_CONFIGURE_OFF= --without-aa
AA_CONFIGURE_WITH= aa
# libheif
LIBHEIF_DESC= ISO/IEC 23008-12:2017 HEIF file format support
LIBHEIF_LIB_DEPENDS= libheif.so:graphics/libheif
LIBHEIF_CONFIGURE_WITH= libheif
GHOSTSCRIPT_USES= ghostscript
GHOSTSCRIPT_CONFIGURE_WITH= gs
GVFS_USE= GNOME=gvfs
GVFS_LIB_DEPENDS_OFF= libcurl.so:ftp/curl
GVFS_CONFIGURE_OFF= --without-gvfs
HELPBROWSER_DESC= Internal help browser and web page plugin
HELPBROWSER_LIB_DEPENDS= libwebkitgtk-1.0.so:www/webkit-gtk2 \
libsoup-2.4.so:devel/libsoup
HELPBROWSER_CONFIGURE_WITH= webkit
LIBEXIF_LIB_DEPENDS= libexif.so:graphics/libexif
LIBEXIF_CONFIGURE_OFF= --without-libexif
LIBMNG_LIB_DEPENDS= libmng.so:graphics/libmng
LIBMNG_CONFIGURE_OFF= --without-libmng
LIBMNG_CONFIGURE_WITH= libmng
OPENEXR_CONFIGURE_WITH= openexr
OPENEXR_LIB_DEPENDS= libIlmImf.so:graphics/openexr \
libIex-2_3.so:graphics/ilmbase
OPENJPEG_DESC= Enhanced JPEG (jpeg2000) graphics support
OPENJPEG_LIB_DEPENDS= libopenjp2.so:graphics/openjpeg
OPENJPEG_CONFIGURE_WITH=jpeg2000
POPPLER_LIB_DEPENDS= libpoppler-glib.so:graphics/poppler-glib
POPPLER_CONFIGURE_OFF= --without-poppler
SIMD_CONFIGURE_OFF= --disable-mmx \
--disable-sse \
--disable-altivec
WEBP_CONFIGURE_WITH= webp
WEBP_LIB_DEPENDS= libwebp.so:graphics/webp
WMF_LIB_DEPENDS= libwmf.so:graphics/libwmf
WMF_CONFIGURE_OFF= --without-wmf
WMF_CONFIGURE_WITH= wmf
.endif
@ -140,7 +136,7 @@ post-patch:
s|%%GIMP_THUMB_LIBS%%|${GIMP_THUMB_LIBS}|; \
s|%%GIMP_UI_LIBS%%|${GIMP_UI_LIBS}|' \
${WRKSRC}/plug-ins/pygimp/Makefile.in
@${REINPLACE_CMD} -e 's|"libpng"|"libpng15"|' \
@${REINPLACE_CMD} \
-e 's|x86_64|amd64|g' \
${WRKSRC}/configure

View file

@ -1,6 +1,6 @@
--- plug-ins/pygimp/Makefile.in.orig 2018-07-15 19:04:00.269226000 +0200
+++ plug-ins/pygimp/Makefile.in 2018-07-15 19:07:22.157457000 +0200
@@ -146,7 +146,7 @@ am__installdirs = "$(DESTDIR)$(pygimpdir)" "$(DESTDIR)
--- plug-ins/pygimp/Makefile.in.orig 2018-08-19 18:48:46.000000000 +0200
+++ plug-ins/pygimp/Makefile.in 2018-10-14 17:48:35.278550000 +0200
@@ -140,7 +140,7 @@ am__installdirs = "$(DESTDIR)$(pygimpdir)" "$(DESTDIR)
"$(DESTDIR)$(pygimpdir)"
LTLIBRARIES = $(pygimp_LTLIBRARIES)
am__DEPENDENCIES_1 =
@ -9,7 +9,7 @@
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_1)
am__gimpenums_la_OBJECTS = gimpenumsmodule.lo
@@ -158,17 +158,16 @@ am__v_lt_1 =
@@ -152,17 +152,16 @@ am__v_lt_1 =
_gimpenums_la_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
$(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
$(_gimpenums_la_LDFLAGS) $(LDFLAGS) -o $@
@ -31,7 +31,7 @@
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
am_gimp_la_OBJECTS = gimpmodule.lo pygimp-item.lo pygimp-display.lo \
pygimp-drawable.lo pygimp-image.lo pygimp-parasite.lo \
@@ -177,14 +176,14 @@ gimp_la_OBJECTS = $(am_gimp_la_OBJECTS)
@@ -171,14 +170,14 @@ gimp_la_OBJECTS = $(am_gimp_la_OBJECTS)
gimp_la_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
$(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
$(gimp_la_LDFLAGS) $(LDFLAGS) -o $@
@ -48,7 +48,7 @@
$(am__DEPENDENCIES_1)
am_gimpthumb_la_OBJECTS = gimpthumbmodule.lo gimpthumb.lo
gimpthumb_la_OBJECTS = $(am_gimpthumb_la_OBJECTS)
@@ -761,10 +760,7 @@ gimp_la_LDFLAGS = -module -avoid-version $(no_undefine
@@ -766,10 +765,7 @@ gimp_la_LDFLAGS = -module -avoid-version $(no_undefine
-export-symbols-regex initgimp
gimp_la_LIBADD = \
@ -56,11 +56,11 @@
- $(libgimpcolor) \
- $(libgimpbase) \
- $(libgimpui) \
+ %%GIMP_LIBS%% \
+ %%GIMP_UI_LIBS%% \
$(GLIB_LIBS) \
$(GEGL_LIBS) \
$(PYLINK_LIBS) \
@@ -777,9 +773,7 @@ _gimpenums_la_LDFLAGS = -module -avoid-version $(no_un
@@ -782,9 +778,7 @@ _gimpenums_la_LDFLAGS = -module -avoid-version $(no_un
-export-symbols-regex init_gimpenums
_gimpenums_la_LIBADD = \
@ -71,7 +71,7 @@
$(GLIB_LIBS) \
$(PYLINK_LIBS) \
$(RT_LIBS)
@@ -794,7 +788,7 @@ gimpcolor_la_LDFLAGS = -module -avoid-version $(no_und
@@ -799,7 +793,7 @@ gimpcolor_la_LDFLAGS = -module -avoid-version $(no_und
-export-symbols-regex initgimpcolor
gimpcolor_la_LIBADD = \
@ -80,7 +80,7 @@
$(GLIB_LIBS) \
$(PYLINK_LIBS)
@@ -806,13 +800,7 @@ _gimpui_la_LDFLAGS = -module -avoid-version $(no_undef
@@ -811,13 +805,7 @@ _gimpui_la_LDFLAGS = -module -avoid-version $(no_undef
-export-symbols-regex init_gimpui
_gimpui_la_LIBADD = \
@ -95,7 +95,7 @@
$(GTK_LIBS) \
$(PYLINK_LIBS) \
$(RT_LIBS) \
@@ -826,7 +814,7 @@ gimpthumb_la_LDFLAGS = -module -avoid-version $(no_und
@@ -831,7 +819,7 @@ gimpthumb_la_LDFLAGS = -module -avoid-version $(no_und
-export-symbols-regex initgimpthumb
gimpthumb_la_LIBADD = \

View file

@ -317,7 +317,7 @@ libexec/gimp/2.2/plug-ins/file-csource/file-csource
libexec/gimp/2.2/plug-ins/file-darktable/file-darktable
libexec/gimp/2.2/plug-ins/file-desktop-link/file-desktop-link
libexec/gimp/2.2/plug-ins/file-dicom/file-dicom
libexec/gimp/2.2/plug-ins/file-exr/file-exr
%%OPENEXR%%libexec/gimp/2.2/plug-ins/file-exr/file-exr
libexec/gimp/2.2/plug-ins/file-faxg3/file-faxg3
libexec/gimp/2.2/plug-ins/file-fits/file-fits
libexec/gimp/2.2/plug-ins/file-fli/file-fli
@ -336,11 +336,12 @@ libexec/gimp/2.2/plug-ins/file-jpeg/file-jpeg
%%LIBMNG%%libexec/gimp/2.2/plug-ins/file-mng/file-mng
libexec/gimp/2.2/plug-ins/file-pat/file-pat
libexec/gimp/2.2/plug-ins/file-pcx/file-pcx
%%POPPLER%%libexec/gimp/2.2/plug-ins/file-pdf-load/file-pdf-load
libexec/gimp/2.2/plug-ins/file-pdf-load/file-pdf-load
libexec/gimp/2.2/plug-ins/file-pdf-save/file-pdf-save
libexec/gimp/2.2/plug-ins/file-pix/file-pix
libexec/gimp/2.2/plug-ins/file-png/file-png
libexec/gimp/2.2/plug-ins/file-pnm/file-pnm
%%GHOSTSCRIPT%%libexec/gimp/2.2/plug-ins/file-ps/file-ps
libexec/gimp/2.2/plug-ins/file-psd/file-psd
libexec/gimp/2.2/plug-ins/file-psp/file-psp
libexec/gimp/2.2/plug-ins/file-raw-data/file-raw-data
@ -351,7 +352,7 @@ libexec/gimp/2.2/plug-ins/file-sunras/file-sunras
libexec/gimp/2.2/plug-ins/file-svg/file-svg
libexec/gimp/2.2/plug-ins/file-tga/file-tga
libexec/gimp/2.2/plug-ins/file-tiff/file-tiff
libexec/gimp/2.2/plug-ins/file-webp/file-webp
%%WEBP%%libexec/gimp/2.2/plug-ins/file-webp/file-webp
%%WMF%%libexec/gimp/2.2/plug-ins/file-wmf/file-wmf
libexec/gimp/2.2/plug-ins/file-xbm/file-xbm
libexec/gimp/2.2/plug-ins/file-xmc/file-xmc
@ -370,7 +371,7 @@ libexec/gimp/2.2/plug-ins/gradient-map/gradient-map
libexec/gimp/2.2/plug-ins/grid/grid
libexec/gimp/2.2/plug-ins/guillotine/guillotine
libexec/gimp/2.2/plug-ins/help/help
%%HELPBROWSER%%libexec/gimp/2.2/plug-ins/help-browser
%%HELPBROWSER%%libexec/gimp/2.2/plug-ins/help-browser/help-browser
libexec/gimp/2.2/plug-ins/hot/hot
libexec/gimp/2.2/plug-ins/ifs-compose/ifs-compose
libexec/gimp/2.2/plug-ins/imagemap/imagemap
@ -406,6 +407,7 @@ libexec/gimp/2.2/plug-ins/van-gogh-lic/van-gogh-lic
libexec/gimp/2.2/plug-ins/warp/warp
libexec/gimp/2.2/plug-ins/wavelet-decompose/wavelet-decompose
libexec/gimp/2.2/plug-ins/web-browser/web-browser
%%HELPBROWSER%%libexec/gimp/2.2/plug-ins/web-page/web-page
man/man1/gimp-2.10.1.gz
man/man1/gimp.1.gz
man/man1/gimptool-2.0.1.gz

View file

@ -2,7 +2,6 @@
# $FreeBSD$
PORTNAME= gimp
PORTREVISION= 0
PORTEPOCH= 0
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
PKGNAMESUFFIX=