Update to 0.8.1: with PDF support
This commit is contained in:
parent
89a45fdd13
commit
079e741f43
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=278256
6 changed files with 33 additions and 32 deletions
|
@ -6,22 +6,24 @@
|
|||
#
|
||||
|
||||
PORTNAME= qcomicbook
|
||||
PORTVERSION= 0.6.0
|
||||
PORTVERSION= 0.8.1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://qcomicbook.linux-projects.net/releases/
|
||||
|
||||
MAINTAINER= lioux@FreeBSD.org
|
||||
COMMENT= QT-based comic book archive viewer
|
||||
|
||||
BUILD_DEPENDS= lrelease-qt4:${PORTSDIR}/devel/qt4-linguist
|
||||
RUN_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
|
||||
unrar:${PORTSDIR}/archivers/unrar
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
BUILD_DEPENDS= lrelease-qt4:${PORTSDIR}/devel/qt4-linguist
|
||||
LIB_DEPENDS= poppler-qt4.3:${PORTSDIR}/graphics/poppler-qt4
|
||||
RUN_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
|
||||
unrar:${PORTSDIR}/archivers/unrar
|
||||
|
||||
USE_QT_VER= 4
|
||||
QT_COMPONENTS= corelib gui moc_build qmake_build rcc_build uic_build
|
||||
QT_COMPONENTS= corelib gui moc_build qmake_build rcc_build uic_build \
|
||||
xml
|
||||
USE_CMAKE= yes
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
||||
|
@ -29,14 +31,21 @@ PLIST_FILES= \
|
|||
${DESKTOPDIR:S,^${PREFIX}/,,}/${PORTNAME}.desktop \
|
||||
bin/qcomicbook \
|
||||
share/pixmaps/qcomicbook.png \
|
||||
share/qcomicbook/i18n/qcomicbook_cs_CZ.qm \
|
||||
share/qcomicbook/i18n/qcomicbook_de_DE.qm \
|
||||
share/qcomicbook/i18n/qcomicbook_es_ES.qm \
|
||||
share/qcomicbook/i18n/qcomicbook_it_IT.qm \
|
||||
share/qcomicbook/i18n/qcomicbook_fi_FI.qm \
|
||||
share/qcomicbook/i18n/qcomicbook_fr_FR.qm \
|
||||
share/qcomicbook/i18n/qcomicbook_fr_CA.qm \
|
||||
share/qcomicbook/i18n/qcomicbook_ko_KR.qm \
|
||||
share/qcomicbook/i18n/qcomicbook_nl_NL.qm \
|
||||
share/qcomicbook/i18n/qcomicbook_pl_PL.qm \
|
||||
share/qcomicbook/i18n/qcomicbook_pt_BR.qm \
|
||||
share/qcomicbook/i18n/qcomicbook_uk_UA.qm
|
||||
share/qcomicbook/i18n/qcomicbook_ru_RU.qm \
|
||||
share/qcomicbook/i18n/qcomicbook_uk_UA.qm \
|
||||
share/qcomicbook/i18n/qcomicbook_zh_CN.qm
|
||||
|
||||
#
|
||||
PLIST_DIRS= share/qcomicbook/i18n \
|
||||
share/qcomicbook
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (qcomicbook-0.6.0.tar.gz) = cb0be8c1311789138e29a8e042159a4ed753fbf930f3d27acbdc6f2ca679840d
|
||||
SIZE (qcomicbook-0.6.0.tar.gz) = 618346
|
||||
SHA256 (qcomicbook-0.8.1.tar.gz) = 1f9f8d8d49571da507a57ec69a59338fe9d268784758fd232842a4b0c3d3124e
|
||||
SIZE (qcomicbook-0.8.1.tar.gz) = 716588
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- ./help/qcomicbook.1.orig 2009-01-06 01:06:54.000000000 -0200
|
||||
+++ ./help/qcomicbook.1 2009-01-06 01:07:40.000000000 -0200
|
||||
@@ -10,7 +10,7 @@
|
||||
QComicBook is a viewer for comic book archives containing jpeg/png/xpm/gif images, which aims at convenience and simplicity.
|
||||
.PP
|
||||
Features include:
|
||||
- \- automatic decompression of zip (cbz), rar (cbr), ace (cba), targzipped (cbg) and tarbzip2ped (cbb) archives
|
||||
+ \- automatic decompression of zip (cbz), rar (cbr), ace (cba), 7-Zip (cb7), targzipped (cbg) and tarbzip2ped (cbb) archives
|
||||
\- full\-screen mode
|
||||
\- two\-pages viewing
|
||||
\- page scaling
|
11
graphics/qcomicbook/files/patch-src__CMakeLists.txt
Normal file
11
graphics/qcomicbook/files/patch-src__CMakeLists.txt
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/CMakeLists.txt.orig 2011-07-08 07:18:50.000000000 -0300
|
||||
+++ src/CMakeLists.txt 2011-07-24 15:33:02.000000000 -0300
|
||||
@@ -116,6 +116,8 @@
|
||||
QT4_WRAP_UI(qcomicbook_ui_src ${qcomicbook_ui})
|
||||
###QT4_ADD_TRANSLATION(qcomicbook_qm ../lang/pl_PL.ts)
|
||||
|
||||
+link_directories(${POPPLER_LIBDIR})
|
||||
+
|
||||
ADD_EXECUTABLE(qcomicbook ${qcomicbook_src} ${qcomicbook_moc_src} ${qcomicbook_ui_src} ${qcomicbook_res})
|
||||
ADD_DEPENDENCIES(qcomicbook translations)
|
||||
TARGET_LINK_LIBRARIES(qcomicbook ${QT_LIBRARIES})
|
|
@ -1,10 +0,0 @@
|
|||
--- src/P7zipArchiverStrategy.cpp.orig 2010-06-13 09:48:03.000000000 -0300
|
||||
+++ src/P7zipArchiverStrategy.cpp 2010-06-13 09:48:10.000000000 -0300
|
||||
@@ -28,6 +28,7 @@
|
||||
void P7zipArchiverStrategy::configure()
|
||||
{
|
||||
addExtension(".7z");
|
||||
+ addExtension(".cb7");
|
||||
setExecutables("7z", "7zr");
|
||||
|
||||
if (which("7z") != QString::null)
|
|
@ -1,5 +1,6 @@
|
|||
QComicBook is a viewer for comic book archives containing jpeg/png
|
||||
images, which aims at convenience and simplicity. Features include:
|
||||
QComicBook is a viewer for comic book archives (.cbr, .cbz and
|
||||
alike) containing jpeg/png/xpm/gif/bmp images, which aims at speed,
|
||||
convenience and ease of use. Features include:
|
||||
|
||||
* automatic handling of archives
|
||||
* full-screen mode
|
||||
|
@ -8,6 +9,7 @@ images, which aims at convenience and simplicity. Features include:
|
|||
* page scaling (fit to window witdth/height, whole page)
|
||||
* mouse or keyboard navigation, whatever you prefer
|
||||
* bookmarks
|
||||
* PDF support
|
||||
* and more...
|
||||
|
||||
WWW: http://qcomicbook.linux-projects.net/
|
||||
|
|
Loading…
Reference in a new issue