Add newsboat, a fork of newsbeuter, a console RSS reader
PR: 223290 Submitted by: mt@markoturk.info
This commit is contained in:
parent
726eb11fa2
commit
07dc729c52
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=454114
7 changed files with 103 additions and 0 deletions
|
@ -536,6 +536,7 @@
|
|||
SUBDIR += netstiff
|
||||
SUBDIR += netsurf
|
||||
SUBDIR += newsbeuter
|
||||
SUBDIR += newsboat
|
||||
SUBDIR += nextcloud
|
||||
SUBDIR += nghttp2
|
||||
SUBDIR += nginx
|
||||
|
|
49
www/newsboat/Makefile
Normal file
49
www/newsboat/Makefile
Normal file
|
@ -0,0 +1,49 @@
|
|||
# Created by: arved
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= newsboat
|
||||
PORTVERSION= 2.10.1
|
||||
CATEGORIES= www
|
||||
|
||||
MAINTAINER= mt@markoturk.info
|
||||
COMMENT= RSS feed reader for the text console
|
||||
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
LIB_DEPENDS= libstfl.so:devel/stfl \
|
||||
libcurl.so:ftp/curl \
|
||||
libjson-c.so:devel/json-c
|
||||
|
||||
OPTIONS_DEFINE= PODCAST
|
||||
OPTIONS_DEFAULT=PODCAST
|
||||
OPTIONS_SUB= yes
|
||||
PODCAST_DESC= Podcast client (podbeuter)
|
||||
|
||||
USE_GITHUB= yes
|
||||
DISTVERSIONPREFIX= r
|
||||
USES= compiler:c++11-lib gettext gmake iconv:translit ncurses perl5 \
|
||||
pkgconfig sqlite shebangfix ssl
|
||||
USE_CXXSTD= gnu++11
|
||||
USE_PERL5= build
|
||||
SHEBANG_FILES= txt2h.pl
|
||||
USE_GNOME= libxml2
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e "s,share/man,man,; \
|
||||
/^prefix/s|=.*|=${PREFIX}|; /^CXX=/d; \
|
||||
s|/usr/local|${LOCALBASE}|" \
|
||||
${WRKSRC}/Makefile
|
||||
${REINPLACE_CMD} -e 's,<ncursesw/ncurses.h>,<ncurses.h>,' \
|
||||
${WRKSRC}/src/controller.cpp ${WRKSRC}/src/view.cpp
|
||||
${REINPLACE_CMD} -e 's,fail "ncursesw",true,; s,fail "libcrypto",true,' \
|
||||
${WRKSRC}/config.sh
|
||||
${REINPLACE_CMD} -e 's|-liconv|${ICONV_LIB} -lcrypto -lncursesw|;s|-Werror||' \
|
||||
${WRKSRC}/Makefile
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*boat
|
||||
|
||||
.include <bsd.port.post.mk>
|
3
www/newsboat/distinfo
Normal file
3
www/newsboat/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1510573019
|
||||
SHA256 (newsboat-newsboat-r2.10.1_GH0.tar.gz) = 82d5e3e2a6dab845aac0bf72580f46c2756375d49214905a627284e5bc32e327
|
||||
SIZE (newsboat-newsboat-r2.10.1_GH0.tar.gz) = 500250
|
13
www/newsboat/files/patch-include-matcher.h
Normal file
13
www/newsboat/files/patch-include-matcher.h
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- include/matcher.h.orig 2014-02-02 16:00:13.000000000 +0100
|
||||
+++ include/matcher.h 2014-02-02 16:00:19.000000000 +0100
|
||||
@@ -3,6 +3,10 @@
|
||||
|
||||
#include <FilterParser.h>
|
||||
|
||||
+#ifdef _LIBCPP_VERSION
|
||||
+namespace std { namespace tr1 = std; }
|
||||
+#endif
|
||||
+
|
||||
namespace newsbeuter {
|
||||
|
||||
class matchable {
|
13
www/newsboat/files/patch-rss-rsspp_internatl.h
Normal file
13
www/newsboat/files/patch-rss-rsspp_internatl.h
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- rss/rsspp_internal.h.orig 2014-02-02 15:53:54.000000000 +0100
|
||||
+++ rss/rsspp_internal.h 2014-02-02 15:52:36.000000000 +0100
|
||||
@@ -9,6 +9,10 @@
|
||||
#include <rsspp.h>
|
||||
#include <tr1/memory>
|
||||
|
||||
+#ifdef _LIBCPP_VERSION
|
||||
+namespace std { namespace tr1 = std; }
|
||||
+#endif
|
||||
+
|
||||
#define CONTENT_URI "http://purl.org/rss/1.0/modules/content/"
|
||||
#define RDF_URI "http://www.w3.org/1999/02/22-rdf-syntax-ns#"
|
||||
#define ITUNES_URI "http://www.itunes.com/dtds/podcast-1.0.dtd"
|
3
www/newsboat/pkg-descr
Normal file
3
www/newsboat/pkg-descr
Normal file
|
@ -0,0 +1,3 @@
|
|||
Newsbeuter is an RSS feed reader for the text console.
|
||||
|
||||
WWW: http://newsbeuter.org/
|
21
www/newsboat/pkg-plist
Normal file
21
www/newsboat/pkg-plist
Normal file
|
@ -0,0 +1,21 @@
|
|||
bin/newsboat
|
||||
%%PODCAST%%bin/podboat
|
||||
share/locale/ca/LC_MESSAGES/newsboat.mo
|
||||
share/locale/de/LC_MESSAGES/newsboat.mo
|
||||
share/locale/es/LC_MESSAGES/newsboat.mo
|
||||
share/locale/es_ES/LC_MESSAGES/newsboat.mo
|
||||
share/locale/fr/LC_MESSAGES/newsboat.mo
|
||||
share/locale/hu/LC_MESSAGES/newsboat.mo
|
||||
share/locale/it/LC_MESSAGES/newsboat.mo
|
||||
share/locale/ja/LC_MESSAGES/newsboat.mo
|
||||
share/locale/nb/LC_MESSAGES/newsboat.mo
|
||||
share/locale/nl/LC_MESSAGES/newsboat.mo
|
||||
share/locale/pl/LC_MESSAGES/newsboat.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/newsboat.mo
|
||||
share/locale/ru/LC_MESSAGES/newsboat.mo
|
||||
share/locale/sv/LC_MESSAGES/newsboat.mo
|
||||
share/locale/tr/LC_MESSAGES/newsboat.mo
|
||||
share/locale/uk/LC_MESSAGES/newsboat.mo
|
||||
share/locale/zh/LC_MESSAGES/newsboat.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/newsboat.mo
|
||||
share/doc/newsboat/examples/config
|
Loading…
Reference in a new issue