- Update to 18.12.1
- Fix portlint warning - Add a message about known build problem via pre-everything target when ejabberd is already installed. [1] PR: 234123
This commit is contained in:
parent
04e0d19257
commit
07ddabfbcf
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=488608
6 changed files with 31 additions and 21 deletions
|
@ -1,7 +1,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ejabberd
|
||||
PORTVERSION= 18.12
|
||||
PORTVERSION= 18.12.1
|
||||
CATEGORIES= net-im
|
||||
|
||||
MAINTAINER= ashish@FreeBSD.org
|
||||
|
@ -18,11 +18,12 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
|
|||
libpng.so:graphics/png \
|
||||
libwebp.so:graphics/webp
|
||||
|
||||
USES= cpe gmake pkgconfig shebangfix ssl jpeg autoreconf:build
|
||||
|
||||
USERS= ejabberd
|
||||
GROUPS= ${USERS}
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USES= cpe gmake pkgconfig shebangfix ssl jpeg autoreconf:build
|
||||
USE_RC_SUBR= ${PORTNAME}
|
||||
NOPRECIOUSMAKEVARS= yes
|
||||
CPE_VENDOR= process-one
|
||||
|
@ -116,7 +117,7 @@ RIAKC_VER= 2.5.3
|
|||
SQLITE3_VER= 1.1.6
|
||||
STRINGPREP_VER= 1.0.14
|
||||
STUN_VER= 1.0.26
|
||||
XMPP_VER= 1.2.7
|
||||
XMPP_VER= 1.2.8
|
||||
|
||||
OPTIONS_SUB= yes
|
||||
RIAK_DESC= Riak database support
|
||||
|
@ -155,6 +156,14 @@ ICONV_USES= iconv:wchar_t
|
|||
ICONV_LDFLAGS= ${ICONV_LIB}
|
||||
DOCS_MAKE_ARGS_OFF= NOPORTDOCS=yes
|
||||
|
||||
pre-everything::
|
||||
@if pkg query %n-%v net-im/ejabberd; then \
|
||||
${ECHO_MSG} needs to be uninstalled, before this port build could proceed. ; \
|
||||
${ECHO_MSG} For details: https://github.com/processone/ejabberd/issues/2194 ; \
|
||||
${ECHO_MSG} Sorry for the inconvenience. ; \
|
||||
exit 1; \
|
||||
fi
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's,^convert,${LOCALBASE}/bin/convert,' ${WRKSRC}/tools/captcha.sh
|
||||
@${REINPLACE_CMD} -e 's,%%PORTVERSION%%,${PORTVERSION},' ${WRKSRC}/configure.ac
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
TIMESTAMP = 1544595554
|
||||
SHA256 (processone-ejabberd-18.12_GH0.tar.gz) = 9a9ca33dd2d8dc580ae10765449d71201dea6b3c7ca86f4710f5046545e0b271
|
||||
SIZE (processone-ejabberd-18.12_GH0.tar.gz) = 1779381
|
||||
TIMESTAMP = 1545907645
|
||||
SHA256 (processone-ejabberd-18.12.1_GH0.tar.gz) = 7646d6acd3c0b94e4ed5e1d1c61a32bb4026b90a752942b7f80157d1fa014a97
|
||||
SIZE (processone-ejabberd-18.12.1_GH0.tar.gz) = 1781813
|
||||
SHA256 (erlang-lager-lager-3.6.7_GH0.tar.gz) = 74af1b94f87882128e584c25162a497ccffc1f255840db2c69fc4f9c20c523cb
|
||||
SIZE (erlang-lager-lager-3.6.7_GH0.tar.gz) = 266527
|
||||
SHA256 (processone-p1_utils-1.0.13_GH0.tar.gz) = 8f21fc0472c314572ebb066d624cb5463cf5b016e18b7fd7dca9dca2a4589382
|
||||
|
@ -13,8 +13,8 @@ SHA256 (processone-stringprep-1.0.14_GH0.tar.gz) = 32245561f84b03b9024c8768ad2ac
|
|||
SIZE (processone-stringprep-1.0.14_GH0.tar.gz) = 95662
|
||||
SHA256 (processone-fast_xml-1.1.34_GH0.tar.gz) = 8615f77a1448e297af25f85261b6e4a84952af797da2e317c8ec71fe2fe779ac
|
||||
SIZE (processone-fast_xml-1.1.34_GH0.tar.gz) = 93530
|
||||
SHA256 (processone-xmpp-1.2.7_GH0.tar.gz) = 18225169e4550e9b11d9da98c65a51771ed710cab8ea51b62380563ed818e7fe
|
||||
SIZE (processone-xmpp-1.2.7_GH0.tar.gz) = 460260
|
||||
SHA256 (processone-xmpp-1.2.8_GH0.tar.gz) = 75c12a71153905ca53d7b732fb5d0589cf0dc3d045d1f8d343023db42f94c688
|
||||
SIZE (processone-xmpp-1.2.8_GH0.tar.gz) = 460500
|
||||
SHA256 (processone-fast_yaml-1.0.17_GH0.tar.gz) = d2675ec9b2f64eba6c3437597e3abe3bfaae2172560784456a2763d1d1a50b08
|
||||
SIZE (processone-fast_yaml-1.0.17_GH0.tar.gz) = 49925
|
||||
SHA256 (davisp-jiffy-0.14.8_GH0.tar.gz) = 7d1054c475c82c626de3ad57201a7fc51da38667c8a7502149eb751edc6b601d
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- Makefile.in.orig 2017-11-20 12:14:44 UTC
|
||||
--- Makefile.in.orig 2018-12-21 09:44:15 UTC
|
||||
+++ Makefile.in
|
||||
@@ -21,7 +21,7 @@ SBINDIR = $(DESTDIR)@sbindir@
|
||||
LIBDIR = $(DESTDIR)@libdir@
|
||||
|
@ -9,8 +9,8 @@
|
|||
|
||||
# /share/doc/ejabberd
|
||||
PACKAGE_TARNAME = @PACKAGE_TARNAME@
|
||||
@@ -59,10 +59,10 @@ JSDIR = $(PRIVDIR)/js
|
||||
SQLDIR = $(PRIVDIR)/sql
|
||||
@@ -62,10 +62,10 @@ SQLDIR = $(PRIVDIR)/sql
|
||||
LUADIR = $(PRIVDIR)/lua
|
||||
|
||||
# /var/lib/ejabberd/
|
||||
-SPOOLDIR = $(DESTDIR)@localstatedir@/lib/ejabberd
|
||||
|
@ -23,7 +23,7 @@
|
|||
|
||||
# /var/lib/ejabberd/.erlang.cookie
|
||||
COOKIEFILE = $(SPOOLDIR)/.erlang.cookie
|
||||
@@ -123,7 +123,7 @@ JOIN_PATHS=$(if $(wordlist 2,1000,$(1)),
|
||||
@@ -132,7 +132,7 @@ JOIN_PATHS=$(if $(wordlist 2,1000,$(1)),$(firstword $(
|
||||
VERSIONED_DEP=$(if $(DEP_$(1)_VERSION),$(DEP_$(1)_VERSION),$(1))
|
||||
|
||||
ELIXIR_TO_DEST=$(LIBDIR) $(call VERSIONED_DEP,$(word 2,$(1))) $(wordlist 5,1000,$(1))
|
||||
|
@ -32,7 +32,7 @@
|
|||
MAIN_TO_DEST=$(LIBDIR) $(call VERSIONED_DEP,ejabberd) $(1)
|
||||
TO_DEST_SINGLE=$(if $(subst XdepsX,,X$(word 1,$(1))X),$(call MAIN_TO_DEST,$(1)),$(if $(subst XlibX,,X$(word 3,$(1))X),$(call DEPS_TO_DEST,$(1)),$(call ELIXIR_TO_DEST,$(1))))
|
||||
TO_DEST=$(foreach path,$(1),$(call JOIN_PATHS,$(call TO_DEST_SINGLE,$(subst /, ,$(path)))))
|
||||
@@ -183,9 +183,7 @@ install: all copy-files
|
||||
@@ -202,9 +202,7 @@ install: all copy-files
|
||||
#
|
||||
# Configuration files
|
||||
$(INSTALL) -d -m 750 $(G_USER) $(ETCDIR)
|
||||
|
@ -43,7 +43,7 @@
|
|||
$(SED) -e "s*{{rootdir}}*@prefix@*g" \
|
||||
-e "s*{{installuser}}*@INSTALLUSER@*g" \
|
||||
-e "s*{{bindir}}*@bindir@*g" \
|
||||
@@ -194,16 +192,15 @@ install: all copy-files
|
||||
@@ -213,16 +211,15 @@ install: all copy-files
|
||||
-e "s*{{localstatedir}}*@localstatedir@*g" \
|
||||
-e "s*{{docdir}}*@docdir@*g" \
|
||||
-e "s*{{erl}}*@ERL@*g" \
|
||||
|
@ -64,7 +64,7 @@
|
|||
# Elixir binaries
|
||||
[ -d $(BINDIR) ] || $(INSTALL) -d -m 755 $(BINDIR)
|
||||
[ -f deps/elixir/bin/iex ] && $(INSTALL) -m 550 $(G_USER) deps/elixir/bin/iex $(BINDIR)/iex || true
|
||||
@@ -238,11 +235,13 @@ install: all copy-files
|
||||
@@ -257,11 +254,13 @@ install: all copy-files
|
||||
chmod -R 750 $(LOGDIR)
|
||||
#
|
||||
# Documentation
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- configure.ac.orig 2018-04-25 10:30:00 UTC
|
||||
--- configure.ac.orig 2018-12-21 09:44:15 UTC
|
||||
+++ configure.ac
|
||||
@@ -2,7 +2,7 @@
|
||||
# Process this file with autoconf to produce a configure script.
|
||||
|
||||
AC_PREREQ(2.53)
|
||||
-AC_INIT(ejabberd, m4_esyscmd([echo `git describe --tags 2>/dev/null || echo 0.0` | sed 's/-g.*//;s/-/./' | tr -d '\012']), [ejabberd@process-one.net], [ejabberd])
|
||||
+AC_INIT(ejabberd, %%PORTVERSION%%, [ejabberd@process-one.net], [ejabberd])
|
||||
REQUIRE_ERLANG_MIN="6.4 (Erlang/OTP 17.5)"
|
||||
+AC_INIT(ejabberd, 18.12.1, [ejabberd@process-one.net], [ejabberd])
|
||||
REQUIRE_ERLANG_MIN="8.0 (Erlang/OTP 19.0)"
|
||||
REQUIRE_ERLANG_MAX="100.0.0 (No Max)"
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- ejabberdctl.template.orig 2017-12-14 20:47:43 UTC
|
||||
--- ejabberdctl.template.orig 2018-12-27 10:21:03 UTC
|
||||
+++ ejabberdctl.template
|
||||
@@ -58,8 +58,8 @@ done
|
||||
@@ -56,8 +56,8 @@ done
|
||||
|
||||
# define ejabberd variables if not already defined from the command line
|
||||
: "${ETC_DIR:="{{sysconfdir}}/ejabberd"}"
|
||||
|
@ -11,7 +11,7 @@
|
|||
: "${EJABBERD_CONFIG_PATH:="$ETC_DIR/ejabberd.yml"}"
|
||||
: "${EJABBERDCTL_CONFIG_PATH:="$ETC_DIR/ejabberdctl.cfg"}"
|
||||
[ -f "$EJABBERDCTL_CONFIG_PATH" ] && . "$EJABBERDCTL_CONFIG_PATH"
|
||||
@@ -79,7 +79,8 @@ if [ -n "$INET_DIST_INTERFACE" ] ; then
|
||||
@@ -77,7 +77,8 @@ if [ -n "$INET_DIST_INTERFACE" ] ; then
|
||||
ERLANG_OPTS="$ERLANG_OPTS -kernel inet_dist_use_interface $INET_DIST_INTERFACE2"
|
||||
fi
|
||||
fi
|
||||
|
|
|
@ -247,6 +247,7 @@
|
|||
%%EJABBERD_LIBDIR%%/%%PORTNAME%%-%%PORTVERSION%%/include/%%PORTNAME%%_router.hrl
|
||||
%%EJABBERD_LIBDIR%%/%%PORTNAME%%-%%PORTVERSION%%/include/%%PORTNAME%%_sm.hrl
|
||||
%%EJABBERD_LIBDIR%%/%%PORTNAME%%-%%PORTVERSION%%/include/%%PORTNAME%%_sql_pt.hrl
|
||||
%%EJABBERD_LIBDIR%%/%%PORTNAME%%-%%PORTVERSION%%/include/%%PORTNAME%%_stacktrace.hrl
|
||||
%%EJABBERD_LIBDIR%%/%%PORTNAME%%-%%PORTVERSION%%/include/%%PORTNAME%%_web_admin.hrl
|
||||
%%EJABBERD_LIBDIR%%/%%PORTNAME%%-%%PORTVERSION%%/include/eldap.hrl
|
||||
%%EJABBERD_LIBDIR%%/%%PORTNAME%%-%%PORTVERSION%%/include/http_bind.hrl
|
||||
|
|
Loading…
Reference in a new issue