The libdisasm library provides basic disassembly of Intel x86
instructions from a binary stream. The intent is to provide an easy to use disassembler which can be called from any application; the disassembly can be produced in AT&T syntax and Intel syntax, as well as in an intermediate format which includes detailed instruction and operand type information. WWW: http://bastard.sourceforge.net/libdisasm.html PR: ports/108067 Submitted by: Lutz Boehne <lboehne at damogran.de>
This commit is contained in:
parent
b2320580f5
commit
07e3dedf97
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=182713
6 changed files with 109 additions and 0 deletions
|
@ -519,6 +519,7 @@
|
|||
SUBDIR += libdasm
|
||||
SUBDIR += libdfui
|
||||
SUBDIR += libdict
|
||||
SUBDIR += libdisasm
|
||||
SUBDIR += libdlmalloc
|
||||
SUBDIR += libdnsres
|
||||
SUBDIR += libds
|
||||
|
|
57
devel/libdisasm/Makefile
Normal file
57
devel/libdisasm/Makefile
Normal file
|
@ -0,0 +1,57 @@
|
|||
# New ports collection makefile for: libdisasm
|
||||
# Date created: 18 January 2006
|
||||
# Whom: Lutz Boehne <lboehne@damogran.de>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libdisasm
|
||||
PORTVERSION= 0.21
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= bastard
|
||||
DISTNAME= libdisasm-0.21-pre3
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= lboehne@damogran.de
|
||||
COMMENT= The Bastard Disassembly Environment x86 disassembler library
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
USE_GMAKE= yes
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's, make, gmake,' ${WRKSRC}/Makefile
|
||||
.if ${OSVERSION} < 500000
|
||||
${REINPLACE_CMD} -e 's, -Wno-strict-aliasing,,' ${WRKSRC}/libdisasm/Makefile
|
||||
.endif
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
DOCSDIR= ${DATADIR}/doc
|
||||
DOCS= libdisasm.txt
|
||||
.endif
|
||||
|
||||
MAN3= x86_disasm.3 x86_format_insn.3 x86_init.3
|
||||
MAN7= libdisasm.7
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/libdisasm/libdisasm.so ${PREFIX}/lib
|
||||
${INSTALL_DATA} ${WRKSRC}/libdisasm/libdisasm.a ${PREFIX}/lib
|
||||
${INSTALL_DATA} ${WRKSRC}/libdisasm/libdis.h ${PREFIX}/include
|
||||
${MKDIR} ${PREFIX}/share/${PORTNAME}/data
|
||||
${INSTALL_DATA} ${WRKSRC}/libdisasm/ia32_opcode.dat ${DATADIR}/data
|
||||
.if !defined(NOPORTDOCS)
|
||||
.for i in ${DOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/${i} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
.for i in ${MAN3}
|
||||
${INSTALL_MAN} ${WRKSRC}/man/${i} ${PREFIX}/man/man3
|
||||
.endfor
|
||||
.for i in ${MAN7}
|
||||
${INSTALL_MAN} ${WRKSRC}/man/${i} ${PREFIX}/man/man7
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.post.mk>
|
3
devel/libdisasm/distinfo
Normal file
3
devel/libdisasm/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (libdisasm-0.21-pre3.tgz) = c3313485ec8cebb7646518a10c3101dc
|
||||
SHA256 (libdisasm-0.21-pre3.tgz) = f56a4a07ee8107815e87af3bd7da6348dea91f16ab40a0d90d5a028ef556be90
|
||||
SIZE (libdisasm-0.21-pre3.tgz) = 198158
|
33
devel/libdisasm/files/patch-Makefile
Normal file
33
devel/libdisasm/files/patch-Makefile
Normal file
|
@ -0,0 +1,33 @@
|
|||
--- Makefile.old Sat Apr 29 02:16:24 2006
|
||||
+++ Makefile Thu Jan 18 01:01:08 2007
|
||||
@@ -48,7 +48,7 @@
|
||||
# ============================================================================
|
||||
# TARGETS
|
||||
|
||||
-all: $(LIBDIS) $(X86DIS) $(TESTDIS) swig-modules
|
||||
+all: $(LIBDIS)
|
||||
dummy: x86dis libdisasm test dist swig-modules install clean
|
||||
|
||||
# ------------------------------------------------------- LIBDIS
|
||||
@@ -86,15 +86,15 @@
|
||||
cd swig && make clean
|
||||
|
||||
# ------------------------------------------------------- INSTALL
|
||||
-install: $(LIBDIS) $(X86DIS)
|
||||
+install: $(LIBDIS)
|
||||
#swig-install
|
||||
# install bindistrib files to INSTALL_LOC
|
||||
cd libdisasm && make install
|
||||
- cd x86dis && make install
|
||||
- cd man && make install
|
||||
- cd doc && make install
|
||||
- cd perl && make install
|
||||
- cd swig && make install
|
||||
+ #cd x86dis && make install
|
||||
+ #cd man && make install
|
||||
+ #cd doc && make install
|
||||
+ #cd perl && make install
|
||||
+ #cd swig && make install
|
||||
|
||||
uninstall:
|
||||
cd libdisasm && make uninstall
|
8
devel/libdisasm/pkg-descr
Normal file
8
devel/libdisasm/pkg-descr
Normal file
|
@ -0,0 +1,8 @@
|
|||
The libdisasm library provides basic disassembly of Intel x86
|
||||
instructions from a binary stream. The intent is to provide an easy to
|
||||
use disassembler which can be called from any application; the
|
||||
disassembly can be produced in AT&T syntax and Intel syntax, as well as
|
||||
in an intermediate format which includes detailed instruction and
|
||||
operand type information.
|
||||
|
||||
WWW: http://bastard.sourceforge.net/libdisasm.html
|
7
devel/libdisasm/pkg-plist
Normal file
7
devel/libdisasm/pkg-plist
Normal file
|
@ -0,0 +1,7 @@
|
|||
include/libdis.h
|
||||
lib/libdisasm.a
|
||||
lib/libdisasm.so
|
||||
%%DATADIR%%/data/ia32_opcode.dat
|
||||
%%DATADIR%%/doc
|
||||
@dirrm %%DATADIR%%/data
|
||||
@dirrm %%DATADIR%%
|
Loading…
Reference in a new issue