Upgrate to 0.97 and plugin support.

PR:		15670, 15671
Submitted by:	maintainer
This commit is contained in:
Munechika SUMIKAWA 1999-12-25 15:45:42 +00:00
parent 6e46c42a7c
commit 0817aa7e2a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=24055
7 changed files with 58 additions and 2 deletions

View file

@ -7,7 +7,7 @@
#
# "?=" and "+=" are for including this Makefile from japanese/jpilot
DISTNAME= jpilot-0.96
DISTNAME= jpilot-0.97
CATEGORIES= palm comms
MASTER_SITES= http://jpilot.linuxbox.com/

View file

@ -1 +1 @@
MD5 (jpilot-0.96.tar.gz) = 02791ca8ecf8801fc190adb2af8f736f
MD5 (jpilot-0.97.tar.gz) = db31cf7de1b7a93add662f295c04def2

View file

@ -0,0 +1,22 @@
--- Makefile.in.orig Sun Dec 12 13:23:05 1999
+++ Makefile.in Fri Dec 24 11:04:06 1999
@@ -22,7 +22,7 @@
GTKLIBS = @GTK_LIBS@
# Targets
-all: jpilot
+all: jpilot libplugin
jpilot: jpilot.o datebook.o address.o todo.o memo.o \
utils.o sync.o prefs.o log.o plugins.o \
@@ -132,8 +132,10 @@
./install-sh -c -m 755 -g bin -o bin empty/AddressDB.pdb $(prefix)/share/jpilot/
./install-sh -c -m 755 -g bin -o bin empty/ToDoDB.pdb $(prefix)/share/jpilot/
./install-sh -c -m 755 -g bin -o bin empty/MemoDB.pdb $(prefix)/share/jpilot/
+ ./install-sh -c -m 644 libplugin.a $(prefix)/lib/
uninstall:
rm $(prefix)/share/jpilot/*
rm $(prefix)/bin/jpilot
rm $(prefix)/jpilot
+ rm $(prefix)/lib/libplugin.a

View file

@ -0,0 +1,11 @@
--- configure.orig Wed Nov 10 09:59:25 1999
+++ configure Fri Dec 24 10:58:01 1999
@@ -951,7 +951,7 @@
echo $ac_n "checking for dlopen""... $ac_c" 1>&6
echo "configure:953: checking for dlopen" >&5
save_LIBS="$LIBS"
- LIBS="$LIBS -ldl"
+ LIBS="$LIBS"
cat > conftest.$ac_ext <<EOF
#line 957 "configure"
#include "confdefs.h"

View file

@ -0,0 +1,11 @@
--- SyncTime/Makefile.in.orig Fri Nov 5 08:35:11 1999
+++ SyncTime/Makefile.in Fri Dec 24 11:01:26 1999
@@ -27,7 +27,7 @@
echo; echo "WARNING - SyncTime is currently broken for PalmOS 3.3"; echo
libsynctime.so: synctime.o libplugin.a
- ld -shared -ldl -o libsynctime.so synctime.o -L. -lplugin
+ ld -shared -o libsynctime.so synctime.o -L. -lplugin
synctime.o: synctime.c libplugin.h
$(CC) $(OPTIONS) $(GTKFLAGS) $(PILOT_FLAGS) -c synctime.c

View file

@ -0,0 +1,11 @@
--- Expense/Makefile.in.orig Wed Nov 3 13:00:42 1999
+++ Expense/Makefile.in Fri Dec 24 11:37:21 1999
@@ -24,7 +24,7 @@
all: libexpense.so
libexpense.so: expense.o libplugin.a
- ld -shared -ldl -o libexpense.so expense.o -L. -lplugin
+ ld -shared -o libexpense.so expense.o -L. -lplugin
expense.o: expense.c libplugin.h
$(CC) $(OPTIONS) $(GTKFLAGS) $(PILOT_FLAGS) -c expense.c

View file

@ -9,5 +9,6 @@ share/jpilot/AddressDB.pdb
share/jpilot/ToDoDB.pdb
share/jpilot/MemoDB.pdb
share/doc/jpilot/plugin.html
lib/libplugin.a
@dirrm share/jpilot
@dirrm share/doc/jpilot