- Fix build for systems without iconv in the base
Reported by: Alan Valentine <alval@alval.net>, Luca Pizzamiglio <luca.pizzamiglio@gmail.com>
This commit is contained in:
parent
b1cbc26f4f
commit
081bf0c6ca
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=389841
2 changed files with 13 additions and 1 deletions
|
@ -12,7 +12,7 @@ LICENSE= LGPL21
|
|||
|
||||
LIB_DEPENDS= libneon.so:${PORTSDIR}/www/neon
|
||||
|
||||
USES= cmake
|
||||
USES= cmake iconv:build
|
||||
USE_GNOME= libxml2
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
|
@ -23,6 +23,8 @@ GH_TAGNAME= release-${PORTVERSION}
|
|||
post-patch:
|
||||
${REINPLACE_CMD} -e '/pkgconfig/s|$${LIB_INSTALL_DIR}|libdata|' \
|
||||
${WRKSRC}/CMakeLists.txt
|
||||
${REINPLACE_CMD} -e 's|%%ICONV_PREFIX%%|${ICONV_PREFIX}|g' \
|
||||
${WRKSRC}/src/CMakeLists.txt
|
||||
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
|
||||
${WRKSRC}/cmake/modules/*.cmake
|
||||
${RM} -f ${WRKSRC}/cmake/modules/FindLibXml2.cmake
|
||||
|
|
10
audio/libmusicbrainz5/files/patch-src_CMakeLists.txt
Normal file
10
audio/libmusicbrainz5/files/patch-src_CMakeLists.txt
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- src/CMakeLists.txt.orig 2015-06-16 13:01:35 UTC
|
||||
+++ src/CMakeLists.txt
|
||||
@@ -5,6 +5,7 @@ INCLUDE_DIRECTORIES(
|
||||
${CMAKE_CURRENT_BINARY_DIR}/../include
|
||||
${NEON_INCLUDE_DIR}
|
||||
${LIBXML2_INCLUDE_DIR}
|
||||
+ %%ICONV_PREFIX%%/include
|
||||
)
|
||||
|
||||
SET(_sources Alias.cc Annotation.cc Artist.cc ArtistCredit.cc Attribute.cc CDStub.cc Collection.cc
|
Loading…
Reference in a new issue